Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 10/06/2005, à 21:20

Express

Probleme avec hdparm ! et lenteur d'execution de videos

Hi tous wink
J'ai un probleme a lecture de video, donc je me suis tourné vers hdparm pour voir si UDMA était activé, apparement,il l'est.
Voici mon /Etc/hdparm.conf :

## New note - you can use straight hdparm commands in this config file
## as well - the set up is ugly, but it keeps backwards compatibility
## Additionally, it should be noted that any blocks that begin with
## the keyword 'command_line' are not run until after the root filesystem
## is mounted.  This is done to avoid running blocks twice.  If you need
## to run hdparm to set parameters for your root disk, please use the
## standard format.

#Samples follow:
#First three are good for devfs systems, fourth one for systems that do
#not use devfs.  The fifth example uses straight hdparm command line
#syntax.  Any of the blocks that use command line syntax must begin with
#the keyword 'command_line', and no attempt is made to validate syntax.
#It is provided for those more comfortable with hdparm syntax.

#/dev/discs/disc0/disc {
#       mult_sect_io = 16
#       write_cache = off
#       spindown_time = 240
#}

#/dev/discs/disc1/disc {
#       mult_sect_io = 32
#       spindown_time = 36
#       write_cache = off
#}

#/dev/cdroms/cdrom0 {
#       dma = on
#       interrupt_unmask = on
#       io32_support = 0
#}

#/dev/hda {
#       mult_sect_io = 16
#       write_cache = off
#       dma = on
#}

#command_line {
#       hdparm -q -m16 -q -W0 -q -d1 /dev/hda
#}

Il me manque mon /dev/hdb, DD ou est installé Linux, Faut-il que je le mette, et faut-il décommenter des ligne pour activer l'UDMA ?
Voici ce que donne un sudo hdparm -i /dev/hdb

/dev/hdb:

 Model=Maxtor 6E040L0, FwRev=NAR61590, SerialNo=E1GVQ3CE
 Config={ Fixed }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=57
 BuffType=DualPortCache, BuffSize=2048kB, MaxMultSect=16, MultSect=off
 CurCHS=4047/16/255, CurSects=16511760, LBA=yes, LBAsects=80293248
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4
 DMA modes:  mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5 udma6
 AdvancedPM=yes: disabled (255) WriteCache=enabled
 Drive conforms to: (null):

 * signifies the current active mode

Et sudo  hdparm -i /dev/hda

/dev/hda:

 Model=Maxtor 6Y080L0, FwRev=YAR41BW0, SerialNo=Y21X9R7E
 Config={ Fixed }
 RawCHS=16383/16/63, TrkSize=0, SectSize=0, ECCbytes=57
 BuffType=DualPortCache, BuffSize=2048kB, MaxMultSect=16, MultSect=off
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=160086528
 IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4
 DMA modes:  mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5 udma6
 AdvancedPM=yes: disabled (255) WriteCache=enabled
 Drive conforms to: (null):

 * signifies the current active mode

Que dois-je donc faire dans le /etc/hdparm.conf ?
Merci de votre aide . wink

Hors ligne

#2 Le 11/06/2005, à 10:56

Express

Re : Probleme avec hdparm ! et lenteur d'execution de videos

personne n'a une titelol idée ?

Hors ligne

#3 Le 30/06/2005, à 23:24

fredo001z

Re : Probleme avec hdparm ! et lenteur d'execution de videos

hdparm -d /dev/hdb pour voir si le DMA est activer.

Ensuite tu fait ceci :

sudo hdparm -d 1 /dev/hdb

puis tu refais : hdparm -d /dev/hdb
et là tu vois que le DMA est ON


Mais dans le hdparm.conf je sais pas ce que l'on doit mettre pour automatiser cette ligne de commande au démarrage

Hors ligne

Haut de page ↑