Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 18/06/2011, à 11:44

noetmi

problème de démarrage

bonjour à tous
tout se passait bien jusque là .. et ..

j'ai un ordi portable avec ubuntu 10
aujourd'hui en l'allumant plus rien .. j'a l'écran noir avec des tas de trucs écrits ...
je vous mets ce qui est écrit vers la fin ... si jamais vous comprenez ce qui se passe

busybox v1.15.3 ( ubuntu 1:1.15.3-1ubuntu5 ) built in shell ( ash )
enter help for a list of built-in commands

(initramfs ) [ 2.738547] scsi 6:0:0:0: Direct-access   Generic- multi-card
1.00 PQ: 0 ANSI: 0 CCS
[ 2.739240 ] sd 6:0:0:0: attached scsi generic sg2 type 0
[ 2.740892] sd 6:0:0:0: [sdb] attached SCSI removable disk


voilà, j'éspère que vous pourrez m'aider à redemarrer mon ordi, et surtout j'éspère que je ne perdrais pas toutes mes données ( j'ai mes photos, mes documents , pleins de choses dessus ... et pourtant je grave régulièrement mes données ... mais pas depuis un mois, et y'a pleins de choses que j'ai rajouté sur mon ordi depuis un mois  : (

merci d'avance à tous

Dernière modification par slasher-fun (Le 18/06/2011, à 11:49)

Hors ligne

#2 Le 18/06/2011, à 12:08

dedesurfeur

Re : problème de démarrage

Commence par un

whoami

voir si t'es en root ou si t'es un des utilisateurs.
Ensuite un

pwd

voir ou t'es.
Si ces deux trucs donnent rien pas grave.
Ensuite ben regarde le help. Dis nous ce qu'il te dit. T'as quoi comme config? Pour boot tu utilises quoi? Le bios ou un utilitaire de boot tiers?


Ubuntu sur mac powerpc.
A l'ancienne ;)

Hors ligne

#3 Le 18/06/2011, à 12:22

noetmi

Re : problème de démarrage

ok
alors pour le whoami ça me donne ça
/bin/sh : whoami : not found

pour le pwd, ça donne rien non plus, j'ai une ligne noire, vide qui apparait en dessous quand je fais entrée

après je m'y connait pas beaucoup, alors peut être que je ne le tapes pas de la bonne façon ...

j'ai (initramfs) qui apparait, et après ça je peux taper , et je fais entrée pour valider

je viens de faire "help" et ça donne ça

built-in commands :
[alias break cd chdir command continue echo eval exec exit export false getopts hash help let local printf pwd read readonly return set shift source test times trap true type ulimit umask unalias unset wait [ [[ ash awk basename cat chmod chroot chvt clear cmp cp cut deallocvt df dnsdomainname du dumpkmap echo egrep env expr false fbset fdflush fgrep find grep gunzip gzip hostname ifconfig ip kill ln loadfont loadkmap ls mkdir mkifo mknod mkswap mktemp more mount mv openvt pidof printf ps pwd readlink reset rm rmdir sed setkeycodes sh sleep sort stat static-sh stty sync tail tee test touch tr true tty umount uname uniq wc wget yes zcat

voilà je comprends absolument pas tout ce charabia ... est ce que ça te parle ???

Pour boot tu utilises quoi? Le bios ou un utilitaire de boot tiers?
là je peux pas te répondre ... il me semble que j'ai F11 pour le bios ... enfin je ne suis pas sure des termes ...
dis moi comment je peux trouver ça ...

Hors ligne

#4 Le 18/06/2011, à 14:34

dedesurfeur

Re : problème de démarrage

vi c'est tout simplement une liste des commandes que t'as a des dispositions. Et yen a pas mal et surtout ya toutes celles de base.
Le boot c'est le moment ou tu choisis quel système d'exploitation tu vas utiliser. Moi par exemple j'utilise yaboot. C'est un tout petit programme qui agit avant même le système d'exploitation. Mais des fois le bios s'en charge très bien et pas besoin de plus. T'as que linux sur ton PC ou t'as aussi windows?

si tu fais

cat /etc/fstab

il dit quoi?
normalement tu devrais voir une colonne type avec un truc "swap" et un autre "ext>un nombre<" le reste on s'en fout. Ce qui faut c'est savoir sur quel partition est ubuntu.

ps : si tu veux verifier que tous tes fichiers sont la tu peux utiliser la commande cd pour te promener sur ton DD et la commande ls pour lister les fichiers. Ex si tu veux voir si tes photos sont toujours la tu fais cd /home/"ton nom d'utilisateur"/Images puis ls.


Ubuntu sur mac powerpc.
A l'ancienne ;)

Hors ligne

#5 Le 20/06/2011, à 19:34

noetmi

Re : problème de démarrage

salut
j'ai aussi windows sur l'ordi ... je pense que c'est le bios qui s'occupe de ça ... en fait quand j'allume l'ordi j'ai un écran noir avec ubuntu et windows, je peux donc faire le choix à ce moment là ...

et à l'heure actuelle windows fonctionne sur l'ordi et pas ubuntu

pour le cat /etc/fstab : il me dit : no such file or diretory
et si je tape la même chose mais espace après cat : il me dit : not found

pour voir si mes photos sont là, j'ai tapé cd /home/"ton nom d'utilisateur"/Images ( bien sur j'ai mis mon nom d'uitilisateur perso )
j'ai fait entrée, puis ls et entrée : et j'ai not found
j'ai essayé ensuite cd /home/"ton nom d'utilisateur"/Images espace ls : not found
puis cd /home/"ton nom d'utilisateur"/Images/ls et not found ...

c'est mauvais signe ???

Hors ligne

#6 Le 20/06/2011, à 20:36

pode

Re : problème de démarrage

noetmi a écrit :

je vous mets ce qui est écrit vers la fin ... si jamais vous comprenez ce qui se passe

Quand il y a un problème, il vaut mieux afficher les premiers messages d'erreur. Ce sont ceux qui sont les plus proches de la cause du problème.

noetmi a écrit :

busybox v1.15.3 ( ubuntu 1:1.15.3-1ubuntu5 ) built in shell ( ash )
enter help for a list of built-in commands

busybox, c'est une sorte de mini OS utilisé pour faire des développements pour des systèmes embarqués...
Tu n'as pas installé quelque chose dernièrement ?

On dirait donc que tu bootes sur busybox
Il faudrait regarder ce que tu as dans tes entrées grub, à l'aide d'un CD rescue

Dernière modification par pode (Le 20/06/2011, à 20:37)

Hors ligne

#7 Le 20/06/2011, à 20:45

noetmi

Re : problème de démarrage

je ne sais, quel type de chose aurais je pu installer dernièrement ?
désolée je suis pas très douée dans tout ça ..

du coup ce que tu viens de me répondre, c'est du charabia pour moi ...

tu dis : Il faudrait regarder ce que tu as dans tes entrées grub, à l'aide d'un CD rescue
là je suis perdue ... que dois je faire pour arriver à ça ??

Hors ligne

#8 Le 20/06/2011, à 21:08

pode

Re : problème de démarrage

Sur un ordinateur avec Linux d'installé, le démarrage s'effectue de la façon suivante :
- Lancement du BIOS
- Le BIOS passe la main à un bootloader ; dans la très grande majorité des cas, il s'agit de grub (sur Ubuntu, grub version 2 depuis la version 9.10 d'Ubuntu)
- grub va lancer le chargement du noyau Linux
Cf. Grub 2

noetmi a écrit :

tu dis : Il faudrait regarder ce que tu as dans tes entrées grub, à l'aide d'un CD rescue
là je suis perdue ... que dois je faire pour arriver à ça ??

La configuration de grub se trouve dans le fichier /boot/grub/grub.cfg
Je pense, mais peut-être que je me trompe, que c'est cette configuration qui est erronée.

Le problème, c'est que je ne suis pas sûr que tu puisses actuellement accéder à ce fichier pour voir ce qu'il y a dedans.
Est-ce que tu y arrives ?

Si non, pour pouvoir y accéder, il faut prendre un live CD (par exemple). Une fois qu'on a booté sur le live CD, à l'aide de certaines commandes, on peut arriver à accéder à la partition qui contient le fichier /boot/grub/grub.cfg, faire des correctifs, ...
Mais c'est clair que, quand on ne connaît pas, c'est un peu touchy.

Hors ligne

#9 Le 20/06/2011, à 21:22

Sciensous

Re : problème de démarrage

avant de modifier quoique ce soit, mettre un live cd linux (ubuntu de préf wink ) et voir si les partitions sont toujours là !

généralement ce genre de console arrive quand le grub n'a pas trouvé la partition linux indiquée dans la config grub (uuid changée ou autre)

c'est réparable simplement avec un live-cd

à préciser:
la version ubuntu (edit: ok je n'avais pas vu--> 10)

pas de mise à jour récente ?

Dernière modification par Sciensous (Le 20/06/2011, à 21:23)

Hors ligne

#10 Le 20/06/2011, à 21:29

pode

Re : problème de démarrage

pode a écrit :

La configuration de grub se trouve dans le fichier /boot/grub/grub.cfg
Je pense, mais peut-être que je me trompe, que c'est cette configuration qui est erronée.

Il y a aussi une autre possibilité (plus ou moins liée) : le problème peut venir de l'image (*) chargée par grub.
Pour une raison x ou y, cette image lance busybox.

(*) : Cette image correspond à un système Linux minimal (cf. initrd). Une fois chargé, il va à son tour lancer le processus init, qui est le processus père de tous les autres processus Linux.

Hors ligne

#11 Le 21/06/2011, à 08:58

noetmi

Re : problème de démarrage

ok, alors procédons par étape ..
j'ai le live cd ubuntu 10.10

je l'ai mis dans mon ordi et j'ai le choix entre tester ubuntu avec le live cd, sans rien changer sur mon ordi ... ou installer ubuntu sur l'ordi ...
avant toute manip, je préfères vous demander ce que je dois faire maintenant ...
si je lance l'installation, j'imagine que j'aurais à un moment donné les différentes partitions existant sur mon ordi .. mais je n'ose pas le faire de peur de lancer un processus qui supprimerai tous mes dossiers ...

dites moi ce que dois faire maintenant ...

Hors ligne

#12 Le 21/06/2011, à 09:12

malbo

Re : problème de démarrage

A partir de maintenant, tu démarres sur le liveCD Ubuntu en choisissant toujours "tester" sans rien changer (et jamais jamais en choisissant "installer"). Tant que tu n'auras pu sauvegarder sur un disque dur externe les données précieuses dont tu as parlé dans le post #1, c'est ce choix "tester". Je préfère t'indiquer dès à présent la commande à utiliser quand tu en seras à cette étape de sauvegarde sur un disque dur externe. En effet, il faudra avoir des pouvoirs administrateur pour réaliser cette activité sans entrave et ça se fera depuis la session liveCD (choix "tester" comme toujours) et tapant cette commande dans un terminal (pour ouvrir un terminal quand tu es sur le bureau Ubuntu, tu enfonces ces 3 touches Ctrl+Alt+T) :

gksudo nautilus

Une fois que ces doc précieux seront à l'abri sur un disque dur externe, moi je suis dispo pour t'aider à réparer ou à réinstaller Ubuntu.

Dernière modification par malbo (Le 21/06/2011, à 09:14)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#13 Le 21/06/2011, à 09:41

noetmi

Re : problème de démarrage

ok, je suis donc en mode test de ubuntu à partir du live cd

j'ai taper ce que tu m'as indiqué dans un terminal

après je ne sais pas trop comment retrouver mes docs qui étaient présents sur ubuntu ... en fait j'ai accés aux doc présents actuellement sur windows mais je ne trouve pas ceux de ubuntu

Hors ligne

#14 Le 21/06/2011, à 10:08

noetmi

Re : problème de démarrage

en fait j'ai les deux partitions du disque dur qui apparaissent :
celui de 60 GO de windows : partition dans laquelle je peux consulter les documents

celle de 86 GO dédiée à ubuntu et que je ne peux pas consulter
quand je veux l'ouvrir ça me dit
unable to mount location
dbus error org.gtk.private.remotevolumemonitor.failed:
an operation is already pending

Hors ligne

#15 Le 21/06/2011, à 10:39

Sciensous

Re : problème de démarrage

ça ne me parait pas bon du tout ça sad

apparemment il ne plus lire ta partition... surement il va falloir essayer une recup de donneés avec photorec mais là je ne suis pas de bon conseil neutral

Hors ligne

#16 Le 21/06/2011, à 10:42

noetmi

Re : problème de démarrage

rhaa !!! ça commence à me faire fliper tout ça ... si je ne peux pas récupérer mes données je suis dans la mouiz totale ...
bon alors j'attends des conseils d'autres personnes qui pourront me dire comment tenter de récupérer mes données ...
: (

Hors ligne

#17 Le 21/06/2011, à 11:24

malbo

Re : problème de démarrage

Il peut s'agir d'un pb du système de fichiers qui a besoin d'une réparation. j'explique dans ce post comment faire pour ça : http://forum.ubuntu-fr.org/viewtopic.php?id=419893

Dernière modification par malbo (Le 21/06/2011, à 11:25)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#18 Le 21/06/2011, à 12:07

noetmi

Re : problème de démarrage

malbo
j'ai fait ce que tu as proposé dans le post en lien, et dès le début du check ça s'est arrété et ça dit
an error occured while applying the operations
see the details for more information
important
if you want support, you need to provide the saved details !
see http://gparted.sourceforge.net/larry/ti … etails.htm for more information

que dois je faire ?

Hors ligne

#19 Le 21/06/2011, à 12:20

malbo

Re : problème de démarrage

Oui, et c'est quoi les détails (poste une copie d'écran en suivant ces consignes (Balise image) : http://doc.ubuntu-fr.org/tutoriel/howto … ne_reponse


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#20 Le 21/06/2011, à 12:20

jean_bruder

Re : problème de démarrage

D'une manière générale, une bonne pratique de base lorsqu'il est question de récupération de données, est de ne jamais travailler directement sur la source : toujours créer une image du disque afin de pouvoir ensuite seulement en extraire les données. Une fois qu'une mauvaise manipulation est réalisée sur la source, c'est encore plus compliqué de récupérer quoi que ce soit ...

Et si le mal persiste, faire appel à Rémy, qui doit forcement traîner quelque part sur ce forum quoi qu'également assez pris par les RMLL 2011 ...).


:: Jean ::

Hors ligne

#21 Le 21/06/2011, à 12:23

malbo

Re : problème de démarrage

Tu as raison jean_bruder. Pour demander de l'aide pour la récupération de données, noetmi ce serait utile que tu postes dans cette discussion : http://forum.ubuntu-fr.org/viewtopic.php?id=447877


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#22 Le 21/06/2011, à 12:51

noetmi

Re : problème de démarrage

malbo, j'ai ça

GParted 0.6.2

Libparted 2.3
Check and repair file system (ext4) on /dev/sda5  00:00:06    ( ERROR )
        
calibrate /dev/sda5  00:00:00    ( SUCCESS )
        
path: /dev/sda5
start: 117147648
end: 285941759
size: 168794112 (80.49 GiB)
check file system on /dev/sda5 for errors and (if possible) fix them  00:00:06    ( ERROR )
        
e2fsck -f -y -v /dev/sda5
        
Système de fichier monté ou ouvert en mode exclusif par un autre
programme ?
e2fsck 1.41.12 (17-May-2010)
e2fsck: Device or resource busy lors de la tentative d'ouverture de /dev/sda5


Jean bruder ... qu'est qu'une image de disque ??? je suis désolée vous tentez d'aider une novice en la matière .. mais une novice fermement décidée à y arriver : )

Hors ligne

#23 Le 21/06/2011, à 15:07

Sciensous

Re : problème de démarrage

en live cd, peut mettre le resultat de :

mount | grep sd

et

fdisk -l 

(en sudo si rien ne s'affiche)

Hors ligne

#24 Le 21/06/2011, à 15:20

noetmi

Re : problème de démarrage

pour mount | grep sd j'ai ça :

ubuntu@ubuntu:~$ mount | grep sd
/dev/sda1 on /media/A4FA998AFA99597E type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096,default_permissions)
ubuntu@ubuntu:~$

et pour fdisk l ça donne

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x7e08de9b

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        7292    58571966    7  HPFS/NTFS
/dev/sda2            7293       19458    97716225    5  Extended
/dev/sda5            7293       17800    84397056   83  Linux
/dev/sda6           17800       19458    13318144   82  Linux swap / Solaris
ubuntu@ubuntu:~$ ^C
ubuntu@ubuntu:~$

est ce que ça aide ?

Hors ligne

#25 Le 21/06/2011, à 21:11

Sciensous

Re : problème de démarrage

oui ça confirme 2 choses:

ton linux est sur /dev/sda5
il n'y a pas de home séparé (=sépare le système des données personnelles, au cas où... ce qui n'est malheureusement pas ton cas)
le live-cd monte automatiquement les partitions qu'il trouve:
sda1=windows
et sda5: il essaye en boucle et c'est pour ça que le e2fsck ne marche pas

reste à attendre un peu que:
1) je teste de mon coté
2) quelqu'un connaisse mieux ce comportement que moi et réponde

Hors ligne

Haut de page ↑