Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 02/10/2006, à 09:08

illmonkey06

Macbook pro le son fonctionne mais pas dans le casque

Bonjour tout le monde!!

J'ai finalement réussi à installer xubuntu sur mon mac! Il reste cependant un problème... Le son...

J'ai principalement suivi ce tutorial pour l'installation : http://ubuntuforums.org/showthread.php?t=198453

Pour la procédure d'installation du son j'ai recompilé les sources alsa et j'ai pu avoir le son dans mes haut-parleurs! Mais quand je branche le casque le son reste sur les haut-parleur quelqu'un aurait pas une idée?

Merci!

#2 Le 18/02/2009, à 15:02

asheenlevrai

Re : Macbook pro le son fonctionne mais pas dans le casque

j'ai un probleme similaire avec mon Macbbok sous ubuntu 8.10. Le son est là (bien qu'un peu faible), mais si je branche un casque le son des HP s'arrête sans qu'aucun son ne sorte du casque (évidement j'ai testé le casque ;-)  )

Dernière modification par asheenlevrai (Le 18/02/2009, à 15:03)

Hors ligne

#3 Le 27/12/2009, à 22:56

Binoutz

Re : Macbook pro le son fonctionne mais pas dans le casque

Bonjour à toutes et à tous,

je me permet de remettre ce sujet au goût du jour...

après avoir suivi quelques "tutos" qui faisaient marcher le son pour le casque pour des laptop (ASIO et Dell), je me suis dis que pour macbook ça devait être autre chose

http://forum.ubuntu-fr.org/viewtopic.php?id=190869

voici le tuto que j'ai suivi, sans succès apparent...

si quelqu'un peut nous (me) filer des tuyaux, ça serait avec un plaisir non dissimulé que j'accepterai big_smile merci d'avance

pour info ma config: Macbook (pas pro!!), Ubuntu 9.10 Karmic

Dernière modification par Binoutz (Le 27/12/2009, à 22:57)

Hors ligne

#4 Le 28/12/2009, à 09:44

asheenlevrai

Re : Macbook pro le son fonctionne mais pas dans le casque

j'avais trouvé une solution qui fonctionnait sous 9.04 (en cherchant à régler le "problème" du volume un peu bas sur mon Macbook 2,1). Par contre lors de la MAJ vers 9.10 les problèmes (volume + sortie casque) sont revenus.... Malheureusement je n'arrive plus à mettre la main sur ce post...

je continue à chercher...

bonne chance

-a-

Hors ligne

#5 Le 29/12/2009, à 11:41

asheenlevrai

Re : Macbook pro le son fonctionne mais pas dans le casque

voilà le lien de la solution que j'avais trouvé pour 9.04:
https://help.ubuntu.com/community/MacBook2-1/Jaunty

le paragraphe d'intérêt:

Sound works out-of-the-box, provided by the snd_hda_intel driver. However, the volume settings may need to be adjusted, since the default settings usually produce a low-volume output.

(for Ubuntu) Open Volume Control by clicking on the speaker icon and then clicking on Volume Control. Click on Preferences, check the box next to Surround, and then unmute the Surround slider.

(for kubuntu) Open KMix by clicking on the speaker icon and then selecting Mixer. Then, unmute the Surround slider.

This will make the speaker sound louder and will enable earphone sound (which is mute otherwise).

malheureusement sous 9.10 il ne me semble pas que "sourdine" soit activé... et de toute façon il n'y a plus de "surround" dans les préférences du son...

Ensuite j'ai trouvé ca:
(http://lillesvin.net/archives/255)

"I had a weird issue with sound working fine with the internal speakers, but once I connected my headphones or stereo to the output jack, I got nothing. At first I thought I was going to have to recompile a bunch of kernel modules, find a virgin to sacrifice and perhaps give away my first-born, but it turned out to be simpler than that. I installed the package gnome-alsamixer and unmuted all channels and everything was fine. Maybe the devs could make sure that all channels are unmuted on install?"

j'ai donc installé le paquet gnome-alsamixer via synaptic (en cherchant "gnome-alsa", je ne sais pas pourquoi il ne le trouvait pas si je mettais plus de lettres)... puis comme rien n'avait changé... j'ai lancé "à la main" en tapant:

gksudo gnome-alsamixer

----
EDIT: en fait je n'avais pas besoin de passer par le terminal, en effet j'aurais pu le lancer en allant dans:
menu principal->son et video->Mixeur ASLSA GNOME
----
j'ai enlevé tout les "muet" et depuis j'ai du son dans les casques :-D

dites moi si ca vous aide...

bonne chance

-a-

Dernière modification par asheenlevrai (Le 02/01/2010, à 12:39)

Hors ligne

#6 Le 02/01/2010, à 10:31

Binoutz

Re : Macbook pro le son fonctionne mais pas dans le casque

Bonjour asheenlevrai,

devant les divers souci que je rencontrais, j'ai préféré installé un snow léopard.

je te remercie pour tes recherches ainsi que ta solution qui j'espère aideront d'autres utilisateurs.

Merci encore et à bientôt!

Hors ligne

#7 Le 02/01/2010, à 10:51

asheenlevrai

Re : Macbook pro le son fonctionne mais pas dans le casque

http://refit.sourceforge.net/
;-)

Hors ligne

#8 Le 07/01/2010, à 01:00

elvikingo

Re : Macbook pro le son fonctionne mais pas dans le casque

Excellent merci asheenlevrai ça a résolu mon problème (pas de son dans le casque sur un macbook première génération avec Karmic). smile
J'avais eu le même soucis sous Hardy que j'avais résolu car l'interface alsamixer était intégrée dans les préférences du son. Sous Karmic il fallait donc installer alsamixerGnome soi-même...

Hors ligne

#9 Le 11/02/2010, à 09:25

asheenlevrai

Re : Macbook pro le son fonctionne mais pas dans le casque

content d'avoir pu t'aider :-)

Hors ligne

#10 Le 22/02/2010, à 06:58

naks63

Re : Macbook pro le son fonctionne mais pas dans le casque

Bonsoir a tous / toutes (oui bonsoir car je suis aux USA..)

Je me permet de poursuivre le topic des problèmes de son. J'ai un macbook 6.1 et j'ai installé en dual boot avec MAC OSX la distribution Ubuntu Karmic 9.10. J'ai pu résoudre les problèmes de luminosité, wifi...mais comme vous vous en doutez je n'ai pas de son!

J'ai installé alsamixer (même désinstallé et réinstallé, car après pas mal de bidouilles on ne sait jamais) comme préconisé dans d'autres postes (dont celui-ci) j'ai également effectué les manips expliquées dans

http://fluoblog.wordpress.com/2008/01/13/resolution-des-problemes-de-son-sous-ubuntu/

puis vérifié que tous les "channels" Master/PCM ne sont pas muets mais rien n'y fait, je n'ai pas de son ni dans les hauts parleurs ni dans les écouteurs. J'ai essayé avec divers fichiers audio et video et même sur internet.

Après avoir essayé pas mal de trucs différents je fais donc appel a vous donc si quelqu'un a une idée ou une hypothèse pour résoudre ce problème, je lui en serait très reconnaissant. Merci

Naks

Edit 1:32am

Finalement j'ai du son dans les écouteurs mais pas dans les hauts parleurs du macbook.
J'ai réglé mon problème en installant le backports-module-alsa 2.6.31-19 Generic car c'est celui qui correspond a mon noyau.
Donc son dans les écouteurs mais pas dans les hauts parleurs, ca avance, ca avance!!

Edit 1:38am

En fait après avoir re-vérifier les hauts-parleurs, j'ai du son en fait mais a la limite de l'audible pourtant j'ai mis le volume a fond...mystère


Edit 1:43am

Bon bah tout marche c'est cool
J'ai tapé dans le terminal "alsamixer" ca ouvre une espèce de fenêtre avec tous les contrôles de volumes possibles et en bidouilant les curseurs j'ai pu avoir du son dans les hauts-parleurs!!
Pour sauvegarder les réglages

sudo alsactl store 0

0 est le numéro de la carte son, mais c'est expliqué dans le lien que j'ai rappelé ci-dessus

Bon bah mon problème est réglé, c'était un peu un post inutile en fait puisque je me suis répondu tout seul, et par rapport a ce qui avait déjà été dis ca n'apporte pas grand chose...

Bonne journée à toutes et à tous

Naks

Dernière modification par naks63 (Le 22/02/2010, à 07:48)

Hors ligne

#11 Le 22/02/2010, à 09:35

asheenlevrai

Re : Macbook pro le son fonctionne mais pas dans le casque

c'est toujours bien de partager ses expériences... qui sait, ça pourra aider qqn dans le futur.
merci de ta participation :-)

-a-

Hors ligne

#12 Le 25/05/2010, à 15:19

juli3n

Re : Macbook pro le son fonctionne mais pas dans le casque

naks63 a écrit :

Bonsoir a tous / toutes (oui bonsoir car je suis aux USA..)

Je me permet de poursuivre le topic des problèmes de son. J'ai un macbook 6.1 et j'ai installé en dual boot avec MAC OSX la distribution Ubuntu Karmic 9.10. J'ai pu résoudre les problèmes de luminosité, wifi...mais comme vous vous en doutez je n'ai pas de son!

J'ai installé alsamixer (même désinstallé et réinstallé, car après pas mal de bidouilles on ne sait jamais) comme préconisé dans d'autres postes (dont celui-ci) j'ai également effectué les manips expliquées dans

http://fluoblog.wordpress.com/2008/01/13/resolution-des-problemes-de-son-sous-ubuntu/

puis vérifié que tous les "channels" Master/PCM ne sont pas muets mais rien n'y fait, je n'ai pas de son ni dans les hauts parleurs ni dans les écouteurs. J'ai essayé avec divers fichiers audio et video et même sur internet.

Après avoir essayé pas mal de trucs différents je fais donc appel a vous donc si quelqu'un a une idée ou une hypothèse pour résoudre ce problème, je lui en serait très reconnaissant. Merci

Naks

Edit 1:32am

Finalement j'ai du son dans les écouteurs mais pas dans les hauts parleurs du macbook.
J'ai réglé mon problème en installant le backports-module-alsa 2.6.31-19 Generic car c'est celui qui correspond a mon noyau.
Donc son dans les écouteurs mais pas dans les hauts parleurs, ca avance, ca avance!!

Edit 1:38am

En fait après avoir re-vérifier les hauts-parleurs, j'ai du son en fait mais a la limite de l'audible pourtant j'ai mis le volume a fond...mystère


Edit 1:43am

Bon bah tout marche c'est cool
J'ai tapé dans le terminal "alsamixer" ca ouvre une espèce de fenêtre avec tous les contrôles de volumes possibles et en bidouilant les curseurs j'ai pu avoir du son dans les hauts-parleurs!!
Pour sauvegarder les réglages

sudo alsactl store 0

0 est le numéro de la carte son, mais c'est expliqué dans le lien que j'ai rappelé ci-dessus

Bon bah mon problème est réglé, c'était un peu un post inutile en fait puisque je me suis répondu tout seul, et par rapport a ce qui avait déjà été dis ca n'apporte pas grand chose...

Bonne journée à toutes et à tous

Naks

j'ai crée une page dans la documentation, dédié à ce portable , si tu veut bien m'aider à la compléter  : http://doc.ubuntu-fr.org/macbook_6.1

Dernière modification par juli3n (Le 25/05/2010, à 15:20)

Hors ligne

#13 Le 25/05/2010, à 18:02

asheenlevrai

Re : Macbook pro le son fonctionne mais pas dans le casque

un petit lien pour t'aider:
https://help.ubuntu.com/community/MacBookModels

Hors ligne

#14 Le 09/09/2011, à 10:05

gazporc

Re : Macbook pro le son fonctionne mais pas dans le casque

+1, personnellement je suis sur Macbook de 2007 avec refit ubuntu 10.04, j'avais aussi un problème de son que je n'arrivais pas à régler.

J'ai donc installé gnome-alsamixer (et non alsamixer seul) et décoché "sourdine".... Simplement.

Cependant j'ai toujours une lumière rouge dans la prise jack, mystère smile

Merci.


Macbook 13"3 sous GNU/Linux, pourquoi pas?

Hors ligne

Haut de page ↑