Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 10/07/2005, à 22:57

SlrWebDesign

[Résolu] Affichage WXGA nVidia

Bonjour, Il ya quelques mois j'ai copié le contenu d'un fichier xorg.conf depuis un forum vers mon pc, et les pilotes nVidia marchaient parfaitement sur mon Compaq Pressario R3000. Comme un C****** j'ai tout éffacé sans garder de copie. Ca fait des jours que j'essaie de reconfigurer xorg pour utiliser les pilotes.

Mon affichage se fait en 1280x800, avec 2 fois le contenu de l'écran en hauteur, avec comme j'ai put le lire sur ce forum : une bande de pixels aléatoires entre deux. Je pense pourtant avoir parcouru tous les topics en rapport sur ce forum, mais rien de bon.

Par pitié, un peu d'aide !

Mon fichier xorg.conf

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
#   cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
#   sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
#   sudo dpkg-reconfigure xserver-xorg

Section "Files"
	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"
        # paths to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"type1"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr-latin9"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
EndSection
Section "InputDevice"
        Identifier      "Synaptics Touchpad"
        Driver          "synaptics"
        Option          "SendCoreEvents"        "true"
        Option          "Device"                "/dev/psaux"
        Option          "Protocol"              "auto-dev"
        Option		"HorizScrollDelta"	"0"
EndSection

Section "Device"
	Identifier	"NVIDIA Corporation NV17 [GeForce4 420 Mac 32M/GeForce 440 Go 64M]"
	Driver		"nvidia"
	BusID		"PCI:1:0:0"
EndSection

Section "Monitor"
	Identifier	"Écran générique"
	Option		"DPMS"
    HorizSync 30-70
    VertRefresh 55-85
    DisplaySize 330 205
    ModeLine "1280x800" 87.09 1280 1336 1616 1728 800 802 814 840 # 60Hz
EndSection




# Added by GAG
# Reference: http://cmb.phys.cwru.edu/kisner/linux/compaq-r3000/XF86Config-4
Section "Modes"
    # Here is the optimal mode: 1280x800 @ 60.0Hz
    Identifier "16:10"
    # 1280x800 @ 60.00Hz (GTF) hsyn: 49.68kHz; pclk: 83.46Mhz
    ModeLine "1280x800" 83.5 1280 1344 1480 1680 800 801 804 828
EndSection



Section "Screen"
	Identifier	"Default Screen"
	Device		"NVIDIA Corporation NV17 [GeForce4 420 Mac 32M/GeForce 440 Go 64M]"
	Monitor		"Écran générique"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x800"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x800"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	InputDevice	"Synaptics Touchpad"
EndSection

Section "DRI"
	Mode	0666
EndSection

Hors ligne

#2 Le 11/07/2005, à 22:00

Darktux

Re : [Résolu] Affichage WXGA nVidia

Essayes juste ça pour voir, c'est ce qui fonctionne pour moi pour avoir une utilisation normale de mon écran en 1280x800:
rajoutes dans /etc/modules à la suite de nvidia NVreg_Mobile=0.
Pour l'avoir testé sur plusieurs distrib, notamment Mandriva Fedora et Ubuntu, cela fonctionne.
J'ai lû dans le readme de nvidia que la détection des dalles lcd des laptop pouvaient poser pb. Théoriquement, pas besoin de tripatouiller son xorg.conf...
neutral:):o:D;):lol:

Hors ligne

#3 Le 12/07/2005, à 01:13

SlrWebDesign

Re : [Résolu] Affichage WXGA nVidia

Au contraire !!!
La ligne de configuration dont tu parles n'a pas d'effet sur ma config.
J'ai fini par trouver la bonne configuration de mon xorg.conf :

Section "Modes"
        Identifier "16:10"
       # 1280x800 @ 60.00Hz (GTF) hsync: 49.68kHz; pclk: 83.46MHz
       ModeLine "1280x800" 83.5 1280 1344 1480 1680 800 801 804 828 -HSync -VSync
EndSection

Section "Device"
	Identifier	"NVIDIA Corporation NV17 [GeForce4 420 Mac 32M/GeForce 440 Go 64M]
	BusID		"PCI:1:0:0"
   	  Driver          "nvidia"
       Option          "NvAgp"                 "3"
       Option          "NoLogo"                "1"
       Option          "UseEdidFreqs"          "1"
       Option          "DPMS"
       Option          "FlatPanelProperties"   "Scaling = aspect-scaled"
EndSection

Section "Monitor"
	Identifier	"Écran générique"
	 UseModes        "16:10"
       HorizSync       30-90
       VertRefresh     50-75
       Option          "IgnoreEDID"            "true"
#       Option          "UseEdidFreqs"          "0"
       Option          "FlatPanelProperties"   "Scaling = aspect-scaled"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"NVIDIA Corporation NV17 [GeForce4 420 Mac 32M/GeForce 440 Go 64M]"
	Monitor		"Écran générique"
	DefaultDepth	24
       DefaultDepth    24
       SubSection "Display"
               Depth           24
               Modes           "1280x800"
       Virtual 1280 800
       EndSubSection
EndSection

A savoir pour qui rencontre le même problème, mon PC est un Compaq Presario R3000 - Athlon 64 - Geforce 4 440 Go - Ecran widescreen wxga 1280x800

Hors ligne

#4 Le 15/07/2005, à 07:47

Clamp

Re : [Résolu] Affichage WXGA nVidia

Tu as trouvé exactement ce que je cherchais : un ModeLine pour le 1280x800 qui tourne sur portable. Fonctionne comme un charme avec mon portable Asus A6K (GeForce 6200 Go).
Je n'ai pas eu besoin des lignes sur le EDID pour mapart.
Merci du tuyau.

#5 Le 18/07/2005, à 16:11

Kiraa

Re : [Résolu] Affichage WXGA nVidia

Idem pour moi , ce mode fonctionne parfaitement (Asus aspire 1520,gforce FX 5200)
merci

#6 Le 01/10/2005, à 20:04

spawn16

Re : [Résolu] Affichage WXGA nVidia

je veux jouer à act of war sur mon presario r3000 avec ma carte grafique nvidia ge force 4 440 go 64 mo cela ne fontionne pas alors que la config demander est nvidia 3 ou supérieure(les ge force 4mx ou intel extreme graficis family ne sont pas compatibles) peut t'on m'aider. Est-ce ma carte ou un manque de drivers?

Haut de page ↑