Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 05/07/2005, à 19:58

Necro

[Résolu]Cedega+WoW = Plus de vent que sous Win ?

Bonjour a tous !!

Je viens d'installer Cedega, sous linux, et WoW sous XP... et je me suis dis, pkoi pas lancé le WoW de XP sous Ubuntu... Jusque la rien d'impossible, après quelque galère d'affichage, le jeu se lance impec, je résous le prob de click droit comme précédement expliqué dans ce forum.

Je rajoute ceci a la fin de mon fichier de config dans ~/.transgaming/

[AppDefaultsWoW.exeDllOverrides]

"cfgmgr32" = "native"

[AppDefaults\\WoW.exe\\d3dgl]

"AnisotropicTextureFiltering" = "Y"
"VertexShaderMode" = "Hardware"
"VertexShaders" = "Y"
"PixelShaders" = "N"
"PixelShadersLevel" = "1.3"
"ClipSpaceFix" = "Y"
"FixedProgram" = "No"


[AppDefaults\\WoW.exe\\Version]

"Windows" = "win98"

[AppDefaults\\WoW.exe\\x11drv]

"Managed" = "Y"
"Desktop" = "1024x768"
"UseDGA" = "N"
"UseXShm" = "Y"
"DXGrab" = "N"
"UseXVidMode" = "Y"
"UseXRandR" = "Y"

[AppDefaults\\WoW.exe\\WinMM]

"Drivers" = "winealsa.drv"
"WaveMapper" = "msacm.drv"
"MidiMapper" = "midimap.drv"

[AppDefaults\\WoW.exe\\wineoss]

"UseMMap" = "N"
"FullDuplex" = "N"
;; Specify a mapping for what digital audio devices to use
;"dsp0" = "/dev/dsp0"
;"mixer0" = "/dev/mixer0"


[AppDefaults\\WoW.exe\\winealsa]

"UseMMap" = "Y"
"pcm0" = "hw"
"ctl0" = "hw"

[AppDefaults\\WoW.exe\\memory]
"MemoryLayoutOverride" = "0x10000000"

Je killall esd avant de lancé le tout...

Je rentre dans le jeu, tout va bien...sauf...que de manière irrégulière et successive, le son sature complétement, gros souffle dans les enceintes, et puis hop ça se calme les musiques d'ambiances normales reviennent comme si de rien n'était...

Si vous voyez un une solution ça... a oui j'ai également essayer de changer sortie par defaut dans Système>>>Préférences>>> Selecteur de système Multimédia... rien n'y fait !

J'ai donc un Dual Boot : XP / Ubuntu, la carte son est intégré a la carte mère Chip VIA sur une Abit KD7A.

Je précise  que le son fonctionne très bien dans Totem et dans Rythmbox... et que les volumes ont bien été vérfiés...

Merci d'avance pour vos lumières...

Dernière modification par Necro (Le 20/07/2005, à 13:45)

Hors ligne

#2 Le 11/07/2005, à 00:42

Necro

Re : [Résolu]Cedega+WoW = Plus de vent que sous Win ?

UP ?  personne n'a d'idée ?

Hors ligne

#3 Le 11/07/2005, à 00:52

Wipe

Re : [Résolu]Cedega+WoW = Plus de vent que sous Win ?

Je ne sais pas trop t'aidé mais sur le forum ou je traine souvent, quelqu'un à fait un post concernant WOW pour Linux, je te laisse aller y jeter un oeil : http://forums.jeuxonline.info/showthread.php?t=443731


Linux c'est bien !
Mais avec Ubuntu, c'est encore mieux ! :)

Hors ligne

#4 Le 11/07/2005, à 00:56

threexone

Re : [Résolu]Cedega+WoW = Plus de vent que sous Win ?

salut,

je n'ai pas ce souci avec cedega et WoW. J'ai une carte son extérieure à celle de la carte mère (soundblaster 512 PCI). Ceci explique peut-être cela. J'ai exactement le même fichier config.
Piurquoi fais tu un "kill esd" avant de démarrer le jeu ? As-tu essayé sans le faire ? Perso je ne le fais pas.

As-tu remarquer que ce phénomène se repoduisait sur d'autres jeux ? Je pense à des jeux autres que par cedega (Enemy Territory ou Nexuiz par exemple).

Hors ligne

#5 Le 15/07/2005, à 23:10

Necro

Re : [Résolu]Cedega+WoW = Plus de vent que sous Win ?

Bien, alors la seule solution envisageable par rapport a mon problème expliquée dans ce tuto serait d'avoir mes drivers audio compiler avec le noyau et non pas en modules...

1/ Comment savoir sous quelle forme son mes drivers ? (Modules ou Compilés ?)
2/ Comment désactiver le modules ?
3/ Comment compiler le kernel avec les drivers audio ?
4/ Est il judicieux de garder le mm noyau ou de prendre la dernière version stable ?

Merci pour vos conseils, je rappelles que mon audio est intégré a la carte mère et qu'il se nomme : VT8233/A/8235/8237 AC97 Audio dans le Gestionnaire de périphérique d'Ubuntu.

encore merci !

Hors ligne

#6 Le 17/07/2005, à 15:05

Necro

Re : [Résolu]Cedega+WoW = Plus de vent que sous Win ?

J'ai essayer avec ou sans le killall esd pour WoW ...rien n'y fait...

J'ai installer Unreal Tournament 2004 et le son est impec !

La seule solution comme je l'ai dis plus haut, ça serai de compiler mes drivers avec le noyau et non pas en module... mais je ne sais absolument pas comment m'y prendre...

Deja comment vérifier si mes drivers sont en modules ou pas ?

Hors ligne

#7 Le 19/07/2005, à 18:30

Necro

Re : [Résolu]Cedega+WoW = Plus de vent que sous Win ?

Bien que personne ne puisse m'aider, voici un autre essai que j'ai fait :

J'ai installé Call of Duty sous windows, et l'ai lancé avec Cedega sous Ubuntu...

Et la miracle... aucun problème de son... c'est à ne rien y comprendre 0_o

Hors ligne

#8 Le 20/07/2005, à 13:45

Necro

Re : [Résolu]Cedega+WoW = Plus de vent que sous Win ?

Bon j'ai résolu le problème... en lançant le jeu avec Point2play le problème disparait...
Mon monologue aidera surement les autres personnes dans mon cas... (merci a Wipe et a threexone)

Hors ligne

#9 Le 20/07/2005, à 16:17

threexone

Re : [Résolu]Cedega+WoW = Plus de vent que sous Win ?

Heureux que ton souci soit résolu. Lancer les jeux par P2P arrange parfois le problème, mais je ne sait pas pourquoi ... Je le considère plus comme un GUI pour cedega qu'autre chose, mais il doit tout de même y avoir quelquechose en plus.:)

Hors ligne

#10 Le 20/07/2005, à 16:37

Necro

Re : [Résolu]Cedega+WoW = Plus de vent que sous Win ?

En fait il rajoute des trucs en plus dans les fichiers de config pr lancer le jeu... j'ai essayer de comparer les fichiers et j'ai pas trouver... enfin la je viens de jouer 2h d'affiler sans prob d'audio ! c nikel !

Hors ligne

#11 Le 25/08/2005, à 15:32

Styner

Re : [Résolu]Cedega+WoW = Plus de vent que sous Win ?

Salut Necro,

J' ai le même problème que toi !!! Le seul hic c'est que je ne sais pas lancer WoW par Point to Play. Comment fais-tu ???

@++

Hors ligne

  • Accueil
  • » Forum
  • » Jeux
  • » [Résolu]Cedega+WoW = Plus de vent que sous Win ?

Haut de page ↑