Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.04 LTS
Ubuntu-fr propose des clés USB de Ubuntu et toutes ses « saveurs » ainsi qu'un magnifique t-shirt pour cette toute nouvelle version d'Ubuntu !

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 24/07/2005, à 17:43

LR

[Résolu] glxgears marche plus

Salut,

J'essaie depuis quelques temps de faire marcher Enemy Territory et pour ça je me suis tapé plein de tests, des tutos etc car j'ai toujours la même erreur liée à la 3D.

Maintenant, j'ai l'impression que la 3D (Direct Rendering) de ma carte fonctionne car je n'ai pas d'erreur dans Xorg.0.log mais ET toujours pas et depuis plusieurs jours (après un de mes nombreux essai), glxgears ne fonctionne plus :

lilian@lilian:~$ glxgears
glxgears: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

J'ai pas mal cherché sur le net et ça m'a conduit à essayer ça :

lilian@lilian:~$ ldd /usr/X11R6/bin/glxgears
        libGL.so.1 => not found
        libXp.so.6 => /usr/X11R6/lib/libXp.so.6 (0x0000002a9566c000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x0000002a95774000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x0000002a95885000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x0000002a95a63000)
        libm.so.6 => /lib/libm.so.6 (0x0000002a95b78000)
        libc.so.6 => /lib/libc.so.6 (0x0000002a95cfe000)
        libdl.so.2 => /lib/libdl.so.2 (0x0000002a95f3d000)
        /lib64/ld-linux-x86-64.so.2 => /lib64/ld-linux-x86-64.so.2 (0x0000002a95556000)

Pourtant, il me semble que ce fichier existe bel et bien :

lilian@lilian:~$ locate libGL.so.1
/usr/lib/libGL.so.1
/usr/X11R6/lib/libGL.so.1
/usr/X11R6/lib/FGL.renamed.libGL.so.1.2
/usr/X11R6/lib/libGL.so.1.2
/usr/X11R6/lib32/FGL.renamed.libGL.so.1.2
/usr/X11R6/lib32/libGL.so.1.2
/usr/X11R6/lib32/libGL.so.1
/usr/lib32/libGL.so.1
/usr/lib32/libGL.so.1.2

Je me doute bien que glxgears n'est pas un élément capital de mon système mais le fait qu'il ne fonctionne pas n'est pas fait pour me rassurer. Et comme glxinfos me donne le même message d'erreur, je ne peux pas vérifier l'état de la 3D sur mon système...

Est-ce que je peux réinstaller qqch pour régler ça ? Est-ce libGL.so.1 manque dans un certain dossier ?

Merci d'avance
Lilian

Hors ligne

#2 Le 25/07/2005, à 13:07

LR

Re : [Résolu] glxgears marche plus

J'ai réinstallé xlibmesa-gl via synaptic et maintenant glxgears marche à nouveau.

Lilian

Hors ligne