Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 12/07/2005, à 14:43

patoche

Probleme pour installer les drivers ATI propriétaires

Salut,

quand je veux installer xorg-driver-fglrx avec synaptic suivant le tutorial me renvoie une erreur :

E: /var/cache/apt/archives/xorg-driver-fglrx_6.8.0-8.8.25-0ubuntu11_i386.deb:  le sous-processus pre-installation script a retourné une erreur de sortie d'état 2

??

Et puis ca aussi : si je tape glxgears :

Xlib:  extension "GLX" missing on display ":0.0".
glxgears: Error: couldn't get an RGB, Double-buffered visual.

????

Pouvez vous m'aider svp ?!

Hors ligne

#2 Le 12/07/2005, à 15:18

sbrunner

Re : Probleme pour installer les drivers ATI propriétaires

Hello !

Le log complet dit quoi ?

CU
Sté

Hors ligne

#3 Le 12/07/2005, à 15:23

patoche

Re : Probleme pour installer les drivers ATI propriétaires

Salut,

j'ai copié tout ce qu'il y a. Synaptic télécharge de paquet et tente d'installer puis ca renvoir l'erreur.

Hors ligne

#4 Le 12/07/2005, à 16:50

sbrunner

Re : Probleme pour installer les drivers ATI propriétaires

Et si tu essaye

apt-get install xorg-driver-fglrx

le cela dit quoi ? roll

Hors ligne

#5 Le 13/07/2005, à 16:42

patoche

Re : Probleme pour installer les drivers ATI propriétaires

ben je recopie ce que j'ai déjà mis :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Les NOUVEAUX paquets suivants seront installés :
  xorg-driver-fglrx
0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0o/3185ko dans les archives.
Après dépaquetage, 10,2Mo d'espace disque supplémentaires seront utilisés.

Preconfiguring packages ...
(Lecture de la base de données... 93928 fichiers et répertoires déjà installés.)Dépaquetage de xorg-driver-fglrx (à partir de .../xorg-driver-fglrx_6.8.0-8.8.25-0ubuntu11_i386.deb) ...
dpkg-divert: `diversion of /usr/lib/libGL.so.1 to /usr/lib/fglrx/libGL.so.1.xlibmesa by xorg-driver-fglrx' clashes with `diversion of /usr/lib/libGL.so.1 to /usr/lib/nvidia/libGL.so.1.xlibmesa by nvidia-glx'
dpkg : erreur de traitement de /var/cache/apt/archives/xorg-driver-fglrx_6.8.0-8.8.25-0ubuntu11_i386.deb (--unpack) :
le sous-processus pre-installation script a retourné une erreur de sortie d'état 2
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/xorg-driver-fglrx_6.8.0-8.8.25-0ubuntu11_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hors ligne

#6 Le 13/07/2005, à 17:10

sbrunner

Re : Probleme pour installer les drivers ATI propriétaires

Appartement il y a un conflit avec le driver de nvidia roll

Essaye :

apt-get --purge remove nvidia-glx
apt-get install xorg-driver-fglrx

CU
Sté

Hors ligne

#7 Le 13/07/2005, à 18:07

patoche

Re : Probleme pour installer les drivers ATI propriétaires

idem :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Les paquets suivants seront ENLEVÉS :
  nvidia-glx*
0 mis à jour, 0 nouvellement installés, 1 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 0o dans les archives.
Après dépaquetage, 9986ko d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? O
(Lecture de la base de données... 93927 fichiers et répertoires déjà installés.)Suppression de nvidia-glx ...
dpkg-divert: rename involves overwriting `/usr/X11R6/lib/libGL.so.1' with
  different file `/usr/X11R6/lib/nvidia/libGL.so.1.xlibmesa', not allowed
dpkg : erreur de traitement de nvidia-glx (--purge) :
le sous-processus post-removal script a retourné une erreur de sortie d'état 2
Des erreurs ont été rencontrées pendant l'exécution :
nvidia-glx
E: Sub-process /usr/bin/dpkg returned an error code (1)

?? sad

Hors ligne

#8 Le 13/07/2005, à 22:31

patoche

Re : Probleme pour installer les drivers ATI propriétaires

re,

il n'y aurait pas moyen de forcer la désinstallation de nvidia-glx ?

merci de votre aide...

Hors ligne

#9 Le 14/07/2005, à 08:22

sbrunner

Re : Probleme pour installer les drivers ATI propriétaires

dpkg-divert --list

te retourne quoi ?

Hors ligne

#10 Le 14/07/2005, à 13:02

patoche

Re : Probleme pour installer les drivers ATI propriétaires

diversion of /sbin/depmod to /sbin/depmod.modutils by module-init-tools
diversion of /usr/share/man/man8/depmod.8.gz to /usr/share/man/man8/depmod.modut ils.8.gz by module-init-tools
diversion of /usr/share/man/fr/man8/depmod.8.gz to /usr/share/man/fr/man8/depmod .modutils.8.gz by module-init-tools
diversion of /sbin/insmod to /sbin/insmod.modutils by module-init-tools
diversion of /usr/share/man/man8/insmod.8.gz to /usr/share/man/man8/insmod.modut ils.8.gz by module-init-tools
diversion of /usr/share/man/fr/man8/insmod.8.gz to /usr/share/man/fr/man8/insmod .modutils.8.gz by module-init-tools
diversion of /sbin/update-modules to /sbin/update-modules.modutils by module-ini t-tools
diversion of /usr/share/man/man8/update-modules.8.gz to /usr/share/man/man8/upda te-modules.modutils.8.gz by module-init-tools
diversion of /usr/share/man/fr/man8/update-modules.8.gz to /usr/share/man/fr/man 8/update-modules.modutils.8.gz by module-init-tools
diversion of /sbin/modinfo to /sbin/modinfo.modutils by module-init-tools
diversion of /usr/share/man/man8/modinfo.8.gz to /usr/share/man/man8/modinfo.mod utils.8.gz by module-init-tools
diversion of /usr/share/man/fr/man8/modinfo.8.gz to /usr/share/man/fr/man8/modin fo.modutils.8.gz by module-init-tools
diversion of /sbin/kallsyms to /sbin/kallsyms.modutils by module-init-tools
diversion of /usr/share/man/man8/kallsyms.8.gz to /usr/share/man/man8/kallsyms.m odutils.8.gz by module-init-tools
diversion of /usr/share/man/fr/man8/kallsyms.8.gz to /usr/share/man/fr/man8/kall syms.modutils.8.gz by module-init-tools
diversion of /sbin/ksyms to /sbin/ksyms.modutils by module-init-tools
diversion of /usr/share/man/man8/ksyms.8.gz to /usr/share/man/man8/ksyms.modutil s.8.gz by module-init-tools
diversion of /usr/share/man/fr/man8/ksyms.8.gz to /usr/share/man/fr/man8/ksyms.m odutils.8.gz by module-init-tools
diversion of /sbin/lsmod to /sbin/lsmod.Lmodutils by module-init-tools
diversion of /usr/share/man/man8/lsmod.8.gz to /usr/share/man/man8/lsmod.modutil s.8.gz by module-init-tools
diversion of /usr/share/man/fr/man8/lsmod.8.gz to /usr/share/man/fr/man8/lsmod.m odutils.8.gz by module-init-tools
diversion of /sbin/modprobe to /sbin/modprobe.Lmodutils by module-init-tools
diversion of /usr/share/man/man8/modprobe.8.gz to /usr/share/man/man8/modprobe.m odutils.8.gz by module-init-tools
diversion of /usr/share/man/fr/man8/modprobe.8.gz to /usr/share/man/fr/man8/modp robe.modutils.8.gz by module-init-tools
diversion of /sbin/rmmod to /sbin/rmmod.Lmodutils by module-init-tools
diversion of /usr/share/man/man8/rmmod.8.gz to /usr/share/man/man8/rmmod.modutil s.8.gz by module-init-tools
diversion of /usr/share/man/fr/man8/rmmod.8.gz to /usr/share/man/fr/man8/rmmod.m odutils.8.gz by module-init-tools
diversion of /usr/share/man/man5/modules.5.gz to /usr/share/man/man5/modules.mod utils.5.gz by module-init-tools
diversion of /usr/share/man/fr/man5/modules.5.gz to /usr/share/man/fr/man5/modul es.modutils.5.gz by module-init-tools
diversion of /usr/lib/postfix/lmtp to /usr/lib/postfix/lmtp.postfix by postfix-t ls
diversion of /usr/lib/postfix/smtp to /usr/lib/postfix/smtp.postfix by postfix-t ls
diversion of /usr/lib/postfix/smtpd to /usr/lib/postfix/smtpd.postfix by postfix -tls
diversion of /usr/bin/locate to /usr/bin/locate.notslocate by slocate
diversion of /usr/bin/updatedb to /usr/bin/updatedb.notslocate by slocate
diversion of /usr/share/man/man1/locate.1.gz to /usr/share/man/man1/locate.notsl ocate.1.gz by slocate
diversion of /usr/share/man/man1/updatedb.1.gz to /usr/share/man/man1/updatedb.n otslocate.1.gz by slocate
diversion of /etc/cron.daily/find to /etc/cron.daily/find.notslocate by slocate
local diversion of /usr/share/pixmaps/mozilla-firefox.png to /usr/share/pixmaps/ mozilla-firefox.png.distrib
local diversion of /usr/share/pixmaps/mozilla-firefox.xpm to /usr/share/pixmaps/ mozilla-firefox.xpm.distrib
local diversion of /usr/lib/mozilla-firefox/icons/default.xpm to /usr/lib/mozill a-firefox/icons/default.xpm.distrib
local diversion of /usr/lib/mozilla-firefox/chrome/icons/default/default.xpm to /usr/lib/mozilla-firefox/chrome/icons/default/default.xpm.distrib
local diversion of /usr/lib/mozilla-firefox/icons/document.png to /usr/lib/mozil la-firefox/icons/document.png.distrib
local diversion of /usr/share/pixmaps/mozilla-thunderbird.xpm to /usr/share/pixm aps/mozilla-thunderbird.xpm.distrib
local diversion of /usr/share/pixmaps/mozilla-thunderbird-menu.xpm to /usr/share /pixmaps/mozilla-thunderbird-menu.xpm.distrib
local diversion of /usr/lib/mozilla-thunderbird/chrome/icons/default/mozilla-thu nderbird.xpm to /usr/lib/mozilla-thunderbird/chrome/icons/default/mozilla-thunde rbird.xpm.distrib
local diversion of /usr/lib/mozilla-thunderbird/chrome/icons/default/messengerWi ndow16.xpm to /usr/lib/mozilla-thunderbird/chrome/icons/default/messengerWindow1 6.xpm.distrib
local diversion of /usr/lib/mozilla-thunderbird/chrome/icons/default/messengerWi ndow.xpm to /usr/lib/mozilla-thunderbird/chrome/icons/default/messengerWindow.xp m.distrib
local diversion of /usr/share/pixmaps/mozilla-thunderbird-pm-menu.xpm to /usr/sh are/pixmaps/mozilla-thunderbird-pm-menu.xpm.distrib
local diversion of /usr/lib/mozilla-thunderbird/chrome/icons/default/default.xpm  to /usr/lib/mozilla-thunderbird/chrome/icons/default/default.xpm.distrib
diversion of /usr/X11R6/lib/libGL.so.1 to /usr/X11R6/lib/nvidia/libGL.so.1.xlibm esa by nvidia-glx
diversion of /usr/X11R6/lib/libGL.so.1.2 to /usr/X11R6/lib/nvidia/libGL.so.1.2.x libmesa by nvidia-glx
diversion of /usr/X11R6/lib/modules/extensions/libGLcore.a to /usr/X11R6/lib/nvi dia/libGLcore.a.xlibmesa by nvidia-glx
diversion of /usr/X11R6/lib/modules/extensions/libglx.a to /usr/X11R6/lib/nvidia /libglx.a.xlibmesa by nvidia-glx
diversion of /usr/lib/libGL.so.1 to /usr/lib/fglrx/libGL.so.1.xlibmesa by xorg-d river-fglrx
diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/libGL.so.1.2.xlibmesa by xo rg-driver-fglrx

Oui apparemment y a encore des traces de nvidia la dedans....

Hors ligne

#11 Le 14/07/2005, à 19:27

sbrunner

Re : Probleme pour installer les drivers ATI propriétaires

patoche a écrit :

re,

il n'y aurait pas moyen de forcer la désinstallation de nvidia-glx ?

merci de votre aide...

Le moyen le plus radical est (mais pas infaible)

dpkg --force-all nvidia-glx

pour le 'dpkg-divert --list' cela me parais cohérent par apport au résultat que j'ai cool

Hors ligne

#12 Le 15/07/2005, à 00:11

patoche

Re : Probleme pour installer les drivers ATI propriétaires

pour le 'dpkg-divert --list' cela me parais cohérent par apport au résultat que j'ai

A bon c'est cohérent meme s'il y a encore du nvidia alors que je tente d'installer les pilotes ATI ?!

dpkg --force-all nvidia-glx

dpkg: requiert une option d'action

Taper dpkg --help pour une obtenir une aide sur l'installation et la désinstallation des paquets [*] ;
Utiliser dselect pour gérer le paquets de manière plus conviviale ;
Taper dpkg -Dhelp pour une obtenir une liste des valeurs drapeaux de débogage ;
Taper dpkg --force-help pour consulter la liste des options de forçage ;
Taper dpkg-deb --help pour une obtenir une aide sur la manipulation des fichiers *.deb ;
Taper dpkg --licence pour voir la licence copyright et l'absence de garantie (GNU GPL) [*].

Les options marquées d'un [*] affichent beaucoup d'informations - tubez-les à travers « less » ou « more » !

Hors ligne

#13 Le 15/07/2005, à 10:51

sbrunner

Re : Probleme pour installer les drivers ATI propriétaires

J'ai oublier le -r =>

dpkg -r --force-all nvidia-glx

Hors ligne

#14 Le 15/07/2005, à 14:37

patoche

Re : Probleme pour installer les drivers ATI propriétaires

(Lecture de la base de données... 95610 fichiers et répertoires déjà installés.)Suppression de nvidia-glx ...
dpkg-divert: mismatch on divert-to
  when removing `diversion of /usr/lib/libGL.so.1 to /usr/lib/nvidia/libGL.so.1.xlibmesa by nvidia-glx'
  found `diversion of /usr/lib/libGL.so.1 to /usr/lib/fglrx/libGL.so.1.xlibmesa by xorg-driver-fglrx'
dpkg : erreur de traitement de nvidia-glx (--remove) :
le sous-processus post-removal script a retourné une erreur de sortie d'état 2
Des erreurs ont été rencontrées pendant l'exécution :
nvidia-glx

rrrrrrrrrrrrrhhhhh !! mad

Hors ligne

#15 Le 15/07/2005, à 17:16

sbrunner

Re : Probleme pour installer les drivers ATI propriétaires

patoche a écrit :

rrrrrrrrrrrrrhhhhh !! mad

rrrrrrrrrrrrrhhhhh je n'y comprend riens sad

Hors ligne

#16 Le 20/07/2005, à 10:47

patoche

Re : Probleme pour installer les drivers ATI propriétaires

Ah ben alors je fais quoi ?

HELP ! Y a pas moyen de nettoyer les anciens drivers ?

Hors ligne

#17 Le 20/07/2005, à 10:55

SkeRoy

Re : Probleme pour installer les drivers ATI propriétaires

nvidia se lance dans le /etc/modules ? Si oui essaie voir de le virer, de redémarrer, et de le désinstaller...

ICI ils parlent de base corrompue... regarde une fois aussi leurs solutions
http://linuxfr.org/forums/15/8509.html

Dernière modification par SkeRoy (Le 20/07/2005, à 10:57)


== Debian Lenny == {Linux User #422949}

Hors ligne

#18 Le 20/07/2005, à 17:18

patoche

Re : Probleme pour installer les drivers ATI propriétaires

Non il n'y a pas trace de nvidia dans etc/modules

Hors ligne

#19 Le 21/07/2005, à 13:43

alexmic

Re : Probleme pour installer les drivers ATI propriétaires

t'es sur que t'es pas tout simplement en root quand tu lances glxgears?

essaie en user...


OMG Lawl pwnd rofl... Plaît-il?

Hors ligne

#20 Le 25/07/2005, à 14:42

patoche

Re : Probleme pour installer les drivers ATI propriétaires

non je ne suis pas en root.

Help, comment puis-je installer les drivers de ma ATI, ca me gave !

Hors ligne

#21 Le 30/07/2005, à 19:05

Audere

Re : Probleme pour installer les drivers ATI propriétaires

Ayant eu un probleme similaire, essaies:

apt-get remove fglrx-control
apt-get remove nvidia-glx
apt-get install xorg-driver-fglrx
apt-get install fglrx-control

Le fait que je sois en root n'a pas du changer grand chose.