Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 02/08/2005, à 19:35

kerito

[résolu] ect/fstab il est ou le problème

Désolé. je suis dislexique de la moindre ligne de commande à taper au clavier. Et du coup je n'arrive pas a trouver pourquoi ma ubuntu ne monte pas certaines partition hmm

mon ect/fstab:

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda12      /               ext3    defaults,errors=remount-ro 0       1
/dev/hda13      /home           ext3    defaults        0       2
/dev/hda5       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 ro,user,noauto  0       0
/dev/hda11      /mnt/stockport1     vfat    user,auto,uid=100 ,iocharset=utf
/dev/hda9       /mnt/stockport      ext3    defaults        0       0

mon fdisk -l :

Disque /dev/hda: 100.0 Go, 100030242816 octets
255 têtes, 63 secteurs/piste, 12161 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/hda1   *           1         637     5116671    7  HPFS/NTFS
/dev/hda2             638       12161    92566530    f  W95 Etendu (LBA)
/dev/hda5             638         840     1630566   82  Linux swap / Solaris
/dev/hda6             841        1477     5116671   83  Linux
/dev/hda7            2117        2378     2104483+  83  Linux
/dev/hda8            2379        3015     5116671    7  HPFS/NTFS
/dev/hda9            3016        4289    10233373+  83  Linux
/dev/hda10           4290       10026    46082421    7  HPFS/NTFS
/dev/hda11          10027       12161    17149356    b  W95 FAT32
/dev/hda12           1478        2052     4618656   83  Linux
/dev/hda13           2053        2116      514048+  83  Linux

Les entrées de la table de partitions ne sont pas dans l'ordre du disque.

J'ai mis  les  lignes /dev/hda11et /dev/hda9.

Dernière modification par kerito (Le 03/08/2005, à 00:30)

Hors ligne

#2 Le 02/08/2005, à 19:48

Elerosse

Re : [résolu] ect/fstab il est ou le problème

Hello, je ne comprends pas la question ? si c'est Ubuntu monte-elle toute seule les partitions ? c'est non tu dois les monter à la main comme tu as fait pour hda9 & hda11

Hors ligne

#3 Le 02/08/2005, à 19:48

cep

Re : [résolu] ect/fstab il est ou le problème

LA ligne concernant hda11 est incomplette.
par exemple :

/dev/hda11      /mnt/stockport1    vfat  defaults,user,rw,iocharset=utf8,uid=1000,gid=1000  0  0


Mais pour ton problème, quel est le message d'erreur ?
sudo mount -a

Dernière modification par cep (Le 02/08/2005, à 19:51)

Hors ligne

#4 Le 02/08/2005, à 19:53

kerito

Re : [résolu] ect/fstab il est ou le problème

désolé de pas etre clair smile
Quels sont mes erreurs dans mes lignes?

root@kub:/home/kerito # mount -a
[mntent]: ligne 9 dans /etc/fstab est erroné
mount: le point de montage /mnt/stockport n'existe pas

et aussi :

[mntent]: line 9 in /etc/fstab is bad
mount: can't find /dev/hda11 in /etc/fstab or /etc/mtab

Hors ligne

#5 Le 02/08/2005, à 19:54

kerito

Re : [résolu] ect/fstab il est ou le problème

et ubuntu ne monte pas ces  partitions et j'aimerais les ajoutés

Hors ligne

#6 Le 02/08/2005, à 19:57

Elerosse

Re : [résolu] ect/fstab il est ou le problème

sudo mkdir /mnt/stockport, pour créer le répertoire smile

Hors ligne

#7 Le 02/08/2005, à 19:57

cep

Re : [résolu] ect/fstab il est ou le problème

Ok.
Alors il faut créer le point de montage stockport et aussi stockport1 si aucun n'existe.

Pour créer les deux en une commande :

sudo -p mkdir /mnt/stockport/stockport1

et pour hda11, tu peux modifier /etc/fstab avec la ligne que je t'indique plus haut :

/dev/hda11      /mnt/stockport1    vfat  defaults,user,rw,iocharset=utf8,uid=1000,gid=1000  0  0

Hors ligne

#8 Le 02/08/2005, à 20:00

kerito

Re : [résolu] ect/fstab il est ou le problème

je test smile

Hors ligne

#9 Le 02/08/2005, à 20:21

kerito

Re : [résolu] ect/fstab il est ou le problème

heu, j'ai réussit a planter l'ordi. j'ai plus accées a ma session graphiquement big_smile

Hors ligne

#10 Le 02/08/2005, à 20:28

kerito

Re : [résolu] ect/fstab il est ou le problème

je réinstal ou y'a un moyen d'acceder a mon ect/fstab pour enlever les mauvaises lignes ?

Hors ligne

#11 Le 02/08/2005, à 20:34

Donk

Re : [résolu] ect/fstab il est ou le problème

en mode texte:
sudoedit /etc/fstab

Hors ligne

#12 Le 02/08/2005, à 20:46

kerito

Re : [résolu] ect/fstab il est ou le problème

mici donk. je me retrouve dans un truc tous noir en mode texte et un fichier vierge situé dans var/tmp/fstab.XXODg3Yb

ca va me filer des boutons se truc je sent

Hors ligne

#13 Le 02/08/2005, à 20:58

cep

Re : [résolu] ect/fstab il est ou le problème

Qu'as-tu fait avec ton fstab ?

Il faut que tu rétablisses le fstab pour qu'il ressemble à ceci :

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda12      /               ext3    defaults,errors=remount-ro 0       1
/dev/hda13      /home           ext3    defaults        0       2
/dev/hda5       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 ro,user,noauto  0       0
/dev/hda11      /mnt/stockport1    vfat  defaults,user,rw,iocharset=utf8,uid=1000,gid=1000  0  0
/dev/hda9       /mnt/stockport      ext3    defaults        0       0

Tu me dis si tu arrives à quelque chose.
Sinon, le plus simple sera d'utiliser un live cd

Si tu n'as pas de live on prendra un shell de secours.
Mais pour éviter de recommencer des erreurs de manipulations, il serait préférable que tu utilises un live cd et procéder par copier / coller.

Dernière modification par cep (Le 02/08/2005, à 21:06)

Hors ligne

#14 Le 02/08/2005, à 21:19

kerito

Re : [résolu] ect/fstab il est ou le problème

bon, j'avoue.
j'ai rentré une 3° ligne:
/dev/hda13 /partage ext3 defauts 0 0
et reboot
puis plantage
je lance mandrakemove

Hors ligne

#15 Le 02/08/2005, à 21:33

kerito

Re : [résolu] ect/fstab il est ou le problème

Je réinstal. enlever mes lignes dans ect/fstab ne suffit pas.
je reprendrais mes aventures dans fstab aprés.
Merci Elerosse, Cep et donk de m'aider et à tous ceux qui mon lut.

Hors ligne

#16 Le 02/08/2005, à 21:36

cep

Re : [résolu] ect/fstab il est ou le problème

Mais non, tu n'as pas besoin de réinstaller.
Tu as fait une grosse blague, ton hda13 est ton /home.

Grrrrrrrrr, ce genre de truc est à décourager d'aider sur les forums.
Tu peux te vanter de m'avoir fait prendre la rogne avec ces plaisanteries.

Encore une fois, il est inutile de réinstaller pour si peu !!!!

Hors ligne

#17 Le 02/08/2005, à 22:08

kerito

Re : [résolu] ect/fstab il est ou le problème

Pas fait exprés. je réinstal justement pour éviter de m'enfoncer dans mes bétises et avoir un seul problème.

Dernière modification par kerito (Le 02/08/2005, à 22:09)

Hors ligne

#18 Le 02/08/2005, à 22:17

cep

Re : [résolu] ect/fstab il est ou le problème

Bah, ce sont des choses qui arrivent. le fichier fstab est un élément sensible.
J'aurais du te le préciser.
Bonne réinstallation.
Cordialement.
cep

Hors ligne

#19 Le 03/08/2005, à 00:07

kerito

Re : [résolu] ect/fstab il est ou le problème

Ca fonctionne. j'ai suivi vos conseils à la lettre est hasard c'est bon. Merci d'avoir guidé le pauvre aveugle obtu que je suis jusqu'à la solution.

pour info mon fichier fstab final:

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda12      /               ext3    defaults,errors=remount-ro 0       1
/dev/hda13      /home           ext3    defaults        0       2
/dev/hda5       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   udf,iso9660 ro,user,noauto  0       0
/dev/hda11      /mnt/stockport1    vfat  defaults,user,rw,iocharset=utf8,uid=1000,gid=1000  0  0
/dev/hda9       /mnt/stockport      ext3    defaults        0       0
/dev/hda1    /mnt/log    ntfs    ro,user,auto,gid=100,umask=002      0    0
/dev/hda10    /mnt/stockport2    ntfs    ro,user,auto,gid=100,umask=002      0    0
utiliser la commande mkdir pour créer un fichier dans /mnt et relancer avec la commande sudo mount -a qui évite le reboot.

Merci beaucoup.
un ubuntien heureux

Hors ligne

Haut de page ↑