Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 16/09/2011, à 02:08

alefriedx

ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

Bonsoir,

je rencontre qq soucis à faire marcher correctement mon laptop, qui contient deux CG (une intel intégrée et une ATI).
le kernel de 11.04 intégre bien switcheroo, mais il semble qu'il ne démarre qu'une fois sur deux, enfin quand il veux quoi ...

ça se manifeste par un dossier /sys/kernel/debug qui ne contient pas de répertoire ./vgaswitcheroo, pourtant nécéssaire pour faire marcher des scripts permettant de switcher entre les deux cartes.

le tuto qui marche bien dans les versions d'avant (si j'ai bien compris)
http://doc.ubuntu-fr.org/vga_switcheroo?s[]=vga&s[]=switcheroo

Mon post précédent, concernant les problèmes d'affichage :
http://forum.ubuntu-fr.org/viewtopic.php?id=637091

Un lien vers un gars qui propose des modifs interessantes pour ces problèmes (sa manip, à base de apci_call ne fonctionne pas chez moi, le bus n'est pas dans la liste du test_off.sh ?)
http://www.plugngeek.net/ubuntu-1104-su … timeline-x

et enfin la source ou un script pour switcher de carte avec switcheroo est proposé :
http://asusm51ta-with-linux.blogspot.com/

Voila, j'espère que ça pourra en aider certains dans la mm situation que moi (c'était pire il y a qq heures, avec des boots aléatoire et tout le tintouin).
Il me reste que je ne peux pas faire le switch correctement, car switcheroo n'est pas actif à chaque démarrage, pour une raison qui m'échappe... Je dirais que ce module du kernel n'est pas chargé systématiquement, est ce que quelqu'un saurait comment charger switcheroo à chaque démarrage ?

Merci pour vos réponses !

(ce site est une mine d'or, merci pour tous ces supers tutos et forums bien dynamiques, vive le monde libre !)

Hors ligne

#2 Le 16/09/2011, à 14:11

alefriedx

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

personne ne connait switcheroo ?

Hors ligne

#3 Le 16/09/2011, à 14:23

chibbata

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

salut
switchroo ne fonctionne pas avec ubuntu 11.04
installes un kernel 2.6.35
telecharges ces 3 paquets
http://kernel.ubuntu.com/~kernel-ppa/ma … 2_i386.deb
http://kernel.ubuntu.com/~kernel-ppa/ma … 12_all.deb
http://kernel.ubuntu.com/~kernel-ppa/ma … 2_i386.deb

dans un terminal

cd /chemin vers le dossier contenant ces 3 fichiers
sudo dpkg -i linux-*.deb

redemarre avec le kernel 2.6.35
et essaye switchroo

Dernière modification par chibbata (Le 16/09/2011, à 14:28)

Hors ligne

#4 Le 16/09/2011, à 14:35

alefriedx

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

j'ai un kernel 2.6.38-11, et quand je fais

grep -i switcheroo /boot/config-2.6.38-11-generic-pae

il me répond

CONFIG_VGA SWITCHEROO=y

Je me disais donc que c'était ok niveau kernel ... En plus, je l'ai déja vu fonctionner hier soir !

mais je vais essayer ta manip, merci !

Hors ligne

#5 Le 16/09/2011, à 14:38

chibbata

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

un lien pour un script switchroo http://asusm51ta-with-linux.blogspot.com/

Hors ligne

#6 Le 16/09/2011, à 14:52

alefriedx

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

Hum, pas mieux avec le kernel 2.6.35 :

> Je ne peux pas démarrer une session unity (que je trouve pas mal, finallement)
> /sys/kernel/debug ne contient pas de dossier switcheroo, alors que
grep -i switcheroo /boot/config-2.6.35-...-generic-pae
me retourne bien
CONFIG_VGA SWITCHEROO=y

quand je fais un locate switcheroo, je vois bien les fichiers headers dans les deux kernels ...

je concluerais bien en disant que le kernel 2.6.38 est ok, mais que switcheroo n'est pas chargé, ou pas compilé ... ?

Hors ligne

#7 Le 16/09/2011, à 14:55

alefriedx

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

oui, j'avais trouvé ce lien ...

Il faut que je recompile le kernel en incluant switcheroo ? Comment je peux faire ça ?

Hors ligne

#8 Le 16/09/2011, à 15:02

chibbata

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

post le resultat de la commande

cat /sys/kernel/debug/vgaswitcheroo/switch

ou

sudo -s
cat /sys/kernel/debug/vgaswitcheroo/switch

Dernière modification par chibbata (Le 16/09/2011, à 15:04)

Hors ligne

#9 Le 16/09/2011, à 15:22

alefriedx

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

chibbata a écrit :

post le resultat de la commande

cat /sys/kernel/debug/vgaswitcheroo/switch

ou

sudo -s
cat /sys/kernel/debug/vgaswitcheroo/switch

ce dossier n'existe pas, c'est bien mon soucis ...

Hors ligne

#10 Le 16/09/2011, à 15:34

chibbata

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

sudo -s
mount -t debugfs none /sys/kernel/debug

si pas d'erreurs,post

cat /sys/kernel/debug/vgaswitcheroo/switch

Dernière modification par chibbata (Le 16/09/2011, à 15:34)

Hors ligne

#11 Le 16/09/2011, à 15:47

alefriedx

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

root@tool:~# mount -t debugfs none /sys/kernel/debug
mount: none est déjà monté ou /sys/kernel/debug est occup

j'essaie de le démonter et de le remonter:

root@tool:~# umount /sys/kernel/debug 
root@tool:~# mount -t debugfs none /sys/kernel/debug
root@tool:~# cd /sys/kernel/debug/
bdi/       bluetooth/ dri/       extfrag/   hid/       ieee80211/ kprobes/   mce/       mmc0/      pktcdvd/   regulator/ tracing/   usb/       x86/  

pareil !

Hors ligne

#12 Le 16/09/2011, à 15:50

chibbata

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

post le resultat

modinfo vga_switcheroo

ou

modinfo vgaswitcheroo

Hors ligne

#13 Le 16/09/2011, à 15:57

alefriedx

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

root@tool:~# modinfo vgaswitcheroo
ERROR: modinfo: could not find module vgaswitcheroo
root@tool:~# modinfo vga_switcheroo
ERROR: modinfo: could not find module vga_switcheroo

Je crois que j'ai trouvé un truc à https://help.ubuntu.com/community/HybridGraphics
il y est dit : "The vga_switcheroo mechanism will only be active when the kernel is booted with either the "modeset=1" kernel option, and/or the "nomodeset" option being absent. "
or, j'ai manipé pour avoir modeset=0, afin d'éviter les écrans noirs empêchant le boot ... je vais essayer de revenir à modeset =1, ça devrait aider un peu ...

Hors ligne

#14 Le 16/09/2011, à 16:23

alefriedx

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

ok,
donc, en modifiant /etc/default/grub avec
GRUB_CMDLINE_LINUX_DEFAULT=”radeon.modeset=1 acpi_osi_linux”

j'ai le boot bloqué à : "no ipv6 router present"

donc : avec modeset=0 : ca boote mais vga switcheroo n'est pas chargé
modeset=1 : ca ne boote pas.

oyé, quelle affaire !

Hors ligne

#15 Le 16/09/2011, à 16:27

alefriedx

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

en modifiant encore /etc/default/grub pour avoir :
GRUB_CMDLINE_LINUX_DEFAULT=”ipv6.disable=1 radeon.modeset=1 acpi_osi_linux”

je reste bloqué de la même manière, même si le message "no ipv6 router" n'apparait plus : il semble donc, que ça n'ait rien à voir ...

d'autres idées pour charger switcheroo, sans que le boote ne se bloque ?

Hors ligne

#16 Le 16/09/2011, à 16:28

chibbata

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

tu as essayé en ne mettant pas de modeset
la bonne instruction c'est :
nomodeset ou rien

radeon.modeset=0 ou 1 n'est plus utiliser sur les dernieres versions de ubuntu

Dernière modification par chibbata (Le 16/09/2011, à 16:28)

Hors ligne

#17 Le 16/09/2011, à 16:32

chibbata

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

install le dernier pack de firmwares,possible que la carte ati ne soit pas bien reconnue
http://nl.archive.ubuntu.com/ubuntu/poo … 60_all.deb

fais aussi

sudo update-pciids

met a jours les drivers libres

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get upgrade

redemarres le pc

Dernière modification par chibbata (Le 16/09/2011, à 16:37)

Hors ligne

#18 Le 16/09/2011, à 16:33

alefriedx

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

ok, j'essaie, mais il semble que ces options changent tout de même quelquechose smile
edit après manips :

petit résumé :
> nomodeset : ça booote avec une interface graphique crado (pas de vgaswitcheroo)
> rien du tout : ca ne boote pas souvent (quand ça marche vgaswitcheroo est là)
> radeon.modeset=0 : ca boote avec unity, pas de vgaswitcheroo
> radeon.modeset=1 : comme avec rien du tout.

Dernière modification par alefriedx (Le 16/09/2011, à 16:45)

Hors ligne

#19 Le 16/09/2011, à 16:55

chibbata

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

tu as fait les manips de mon post au dessus
etant donné que ta carte graphique ati est recente,le probleme peut venir de la non reconnaissance de celle çi ainsi que le driver libre qui ne la reconnait pas

en plus d'aprés des tests le gpu intel est equivalent en performance au gpu ati,donc tu gagnerais rien a switché sur la ati

Dernière modification par chibbata (Le 16/09/2011, à 17:08)

Hors ligne

#20 Le 16/09/2011, à 17:11

alefriedx

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

mise à jour des firmwares, j'ai eu un bon espoir vu que ça a rébooté une fois, avec vgaswitcheroo activé.
Malheureusement, ça n'a pas rebooté une seconde fois ... je suis sur que ça se joue à pas grand chose !!!

remis en radeon.modeset=0, ça remarche.

d'autres idées ? je désespere un peu ... il y aurait peut-être un demande à faire pour donner ces infos aux développeurs, et demander d'améliorer le supprt du switch de CG ...

merci pour le coup de main chibbata, j'apprécie vraiment smile

Hors ligne

#21 Le 16/09/2011, à 17:14

alefriedx

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

ouais, j'ai bien compris que l'ati ne m'apporterait pas grand chose sous ubuntu, mais je souhaiterai l'ETEINDRE, afin de gagner en autonomie et que l'ordi ne ventile pas en permanence  !

eteindre la ati, c'est possible autrement qu'avec vgaswitcheroo ?

j'ai essayé la methode proposée ici : http://asusm51ta-with-linux.blogspot.com/
mais aucune methode du ./test_off.sh n'a réussi : j'ai donc posté un bug report avec toutes les infos auprès des développeurs ici : http://linux-hybrid-graphics.blogspot.c … onoff.html

voilou, toujours preneur de bonnes idées !

Hors ligne

#22 Le 16/09/2011, à 17:18

chibbata

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

post le resultat de

lsmod

Hors ligne

#23 Le 16/09/2011, à 18:57

alefriedx

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

arnaud@tool:~$ lsmod
Module                  Size  Used by
cryptd                 19801  0 
aes_i586               16956  2 
aes_generic            38023  1 aes_i586
ath3k                  12625  0 
parport_pc             32111  0 
ppdev                  12849  0 
snd_hda_codec_hdmi     27535  1 
snd_hda_codec_idt      60537  1 
rfcomm                 38125  8 
binfmt_misc            13213  1 
sco                    17827  2 
bnep                   17785  2 
l2cap                  48656  16 rfcomm,bnep
arc4                   12473  2 
snd_hda_intel          28209  2 
snd_hda_codec          90901  3 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel
snd_hwdep              13274  1 snd_hda_codec
snd_pcm                80042  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
radeon                925094  0 
snd_seq_midi           13132  0 
ath9k                 103669  0 
snd_rawmidi            25269  1 snd_seq_midi
snd_seq_midi_event     14475  1 snd_seq_midi
snd_seq                51291  2 snd_seq_midi,snd_seq_midi_event
i915                  451068  3 
snd_timer              28659  2 snd_pcm,snd_seq
hp_wmi                 13418  0 
mac80211              257001  1 ath9k
snd_seq_device         14110  3 snd_seq_midi,snd_rawmidi,snd_seq
sparse_keymap          13666  1 hp_wmi
uvcvideo               66851  0 
hp_accel               21632  0 
psmouse                59039  0 
serio_raw              12990  0 
btusb                  18160  2 
ttm                    65184  1 radeon
bluetooth              65493  9 rfcomm,sco,bnep,l2cap,btusb
videodev               75143  1 uvcvideo
joydev                 17322  0 
lis3lv02d              19285  1 hp_accel
snd                    55295  14 snd_hda_codec_hdmi,snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
ath9k_common           13611  1 ath9k
ath9k_hw              300328  2 ath9k,ath9k_common
input_polldev          13735  1 lis3lv02d
ath                    19141  2 ath9k,ath9k_hw
cfg80211              156212  3 ath9k,mac80211,ath
drm_kms_helper         40745  2 radeon,i915
drm                   184164  6 radeon,ttm,i915,drm_kms_helper
soundcore              12600  1 snd
snd_page_alloc         14073  2 snd_hda_intel,snd_pcm
i2c_algo_bit           13184  2 radeon,i915
video                  18951  1 i915
jmb38x_ms              17364  0 
memstick               15816  1 jmb38x_ms
lp                     13349  0 
parport                36746  3 parport_pc,ppdev,lp
usbhid                 41704  0 
hid                    77084  1 usbhid
r8169                  46630  0 
ahci                   21591  3 
libahci                25548  1 ahci
sdhci_pci              13623  0 
sdhci                  22720  1 sdhci_pci
btrfs                 527388  0 
zlib_deflate           26594  1 btrfs
libcrc32c              12543  1 btrfs

Hors ligne

#24 Le 16/09/2011, à 19:32

chibbata

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

tu as les 2 drivers intel et ati qui sont en fonctionnement
blacklist radeon pour l'empecher de se charger au demarrage

sudo -s
echo "blacklist radeon" >> /etc/modprobe.d/blacklist.conf

redemarres le pc
tu n'as plus besoin de radeon.modeset dans le grub
tu peux mettre aussi gpu discrete sur disabled dans le bios

Dernière modification par chibbata (Le 16/09/2011, à 19:45)

Hors ligne

#25 Le 16/09/2011, à 20:23

alefriedx

Re : ubuntu 11.04 : switcheroo n'est disponible qu'une fois sur deux

ah oui, le lsmod ne me parle plus de radeon.
je suivrai ça de près, mais je ne vois pas de gain sur la durée de vie de la batterie pour l'instant (en même temps, une batterie neuve a besoin de rodage). Est elle réellement éteinte électriquement ? comment puis je le vérifier ?

Comment est ce que je peux la rallumer , si jamais j'en ai besoin ?

merci, c'est déja ça de pris, en attendant qu'un switch à chaud, voire un switch automatique soit développé. Ca ça sera cool !

Hors ligne

Haut de page ↑