Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 06/08/2005, à 17:00

Shoobidoowap7

Xampp + SPIP

Bonjour,

Ce sont 2 soucis en 1 apparemment...

- J'ai installé Xampp à partir de ce tuto : http://ubuntu.ttoine.net/xampp/installerxampp.html
Tout s'est déroulé comme il fallait. smile Sur le navigateur tout est bon.

C'est après que je suis paumé ! sad

Je comptais mettre SPIP et mes dossiers (qui sont pour l'instant sur free) dans le dossier :

/opt/lampp/var/www

mais je n'ai pas de www dans [var] ?! Je les mets où alors, sinon est-ce que je dois y créer un www ???

- Et après, si j'essaie de suivre ceci : http://www.euskalug.org/article.php3?id_article=69

Dès ici :


root@shoobundoo : # mysql -u root -p

Ca m'affiche :

mysql: command not found


Enfin, comment je fais pour y accéder d'un ordinateur distant puisque d'un PC de mon Rézo je n'y arrive même pas en tapant : http://IP/xampp ??

(J'arrive correctement à me connecter par Putty, mais comme je ne sais pas où il faut que j'aille, ben j'ai l'air fin ! )

Alors, ben, je suis un peu désemparé, si vous pous pouvez m'aidez.
smile

Dernière modification par Shoobidoowap7 (Le 06/08/2005, à 17:09)

Hors ligne

#2 Le 06/08/2005, à 21:43

AlexandreP

Re : Xampp + SPIP

Le répertoire web est /opt/lampp/htdocs.  Il faut donc placer tes fichiers dans ce répertoire.  Autrement, il faudra modifier la configuration de Apache.


«La capacité d'apprendre est un don; La faculté d'apprendre est un talent; La volonté d'apprendre est un choix.» -Frank Herbert
93,8% des gens sont capables d'inventer des statistiques sans fournir d'études à l'appui.

Hors ligne

#3 Le 07/08/2005, à 02:02

Shoobidoowap7

Re : Xampp + SPIP

AlexandreP a écrit :

Le répertoire web est /opt/lampp/htdocs.  Merci. hmm Je ne sais pas pq dans ma tête htdocs était un fichier alors que ce chemin est bien indiqué. neutral


Il faut donc placer tes fichiers dans ce répertoire.  Autrement, il faudra modifier la configuration de Apache. Euh... C-à-d ?

Pour Spip : J'ai vu qu'il est dans Synaptic (mais en 1.7 au lieu de 1.8) mais que ni Xampp ni Lampp n'y apparaissent.
Je suppose qu'il faut donc que je charge manuellement SPIP et que je l'installe manuellement aussi ?

Dernière modification par Shoobidoowap7 (Le 07/08/2005, à 02:23)

Hors ligne

#4 Le 08/08/2005, à 03:15

AlexandreP

Re : Xampp + SPIP

Peut-être que le paquet Synaptic va dépendre aussi des paquets d'Apache, de PHP, de MySQL, etc.

Shoobidoowap7 a écrit :
AlexandreP a écrit :

Il faut donc placer tes fichiers dans ce répertoire.  Autrement, il faudra modifier la configuration de Apache.

Euh... C-à-d ?

Modifier directement le fichier de configuration /opt/lampp/etc/httpd.conf pour changer la valeur de DocumentRoot vers le chemin vers le répertoire web.

#
# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "/opt/lampp/htdocs"

«La capacité d'apprendre est un don; La faculté d'apprendre est un talent; La volonté d'apprendre est un choix.» -Frank Herbert
93,8% des gens sont capables d'inventer des statistiques sans fournir d'études à l'appui.

Hors ligne

#5 Le 08/08/2005, à 09:59

Shoobidoowap7

Re : Xampp + SPIP

C'est... presque... fonctionnel. smile

J'ai installé SPIP dans /opt/lampp/spip-v1-8-1. L'installation se lance correctement mais je l'ai arrêté en cours de route pcq j'avais déjà eu lamême chose avec EasyPHP :

A un moment donné, il me demande de choisir une table ou de la créer. Sauf qu'au bout, c'est comme si je recommençais tout le site.

Je ramène donc le site entier de mon ftp de chez free au même endroit avec comme dossier spip. Forcément, en le lançant, il ne trouve rien (err. 404).
Je modifie le chemin indiqué dans /.../spip/inc_connect.php3 pour que spip_connect_db pointe aussi sur "localhost" et là il me dit : "site en construction". Si je le fais pointer sur la table test, ça ouvre une belle page d'accueil de mon site... mais tout vide ou ... tout neuf quoi.

Donc, là je ne sais pas ce qu'il faut que je change :

soit dans lampp pour que la table soit enregistrée correctement sans en créer une neuve ;

soit dans un fichier de spip lui-même pour qu'il s'intègre correctement dans lampp.

smile

Hors ligne

#6 Le 08/08/2005, à 15:43

AlexandreP

Re : Xampp + SPIP

Je ne saurais dire, je n'utilise pas Spip.  Mais tu parles de 'tables', je présume donc que tu parles de tables MySQL.  As-tu effectué une exportation de ta base de données chez ton hébergeur et l'as-tu importée dans ton serveur local ?


«La capacité d'apprendre est un don; La faculté d'apprendre est un talent; La volonté d'apprendre est un choix.» -Frank Herbert
93,8% des gens sont capables d'inventer des statistiques sans fournir d'études à l'appui.

Hors ligne

#7 Le 08/08/2005, à 16:06

Shoobidoowap7

Re : Xampp + SPIP

1- Ben SPIP nécessitant APache-PHP-Mysql, il n'aurait pas pu fonctionner si je ne l'avais activé sur free.

Et là, avant de DL tout le contenu, j'ai installé SPIP et il "s'actionne" bien dans Lampp - mais pour la création d'un nouveau site. Du reste, maintenant quand je tape http://localhost, la page me demande le choix entre : apache, spip-v1-8-1 et spip (mon-site).

apache lance sur Xampp
spip-v1-8-1 lance sur la création d'un nouveau site
spip (mon-site) lance sur une toute nouvelle page d'accueil/index (puisque j'ai modifié inc_connect.php3).

En fait, ce qui serait bien c'est que Xampp prenne en compte cette table sans effectuer de création. Comme je suis loin d'être un as de la manipulation d'Apache, je ne sais pas trop ce qu'il faut que je lui dise...
ou à mon spip : quand il t'appelle , va sur la bonne page d'accueil.

2- Je ne sais pas ce tu appelles "exporter une table" ... (chui désolé hmm ). Moi j'ai juste ramené tout ce que j'ai chargé sur free : spip et les documents composants le site.

smile

Dernière modification par Shoobidoowap7 (Le 08/08/2005, à 16:09)

Hors ligne

#8 Le 08/08/2005, à 16:25

DecIRC

Re : Xampp + SPIP

Dans spip, tu as backup base ?
Tu fais cela, tu le télécharges, tu installe un spip tout nouveau chez toi comme pour un nouveau site, quand c'est ok, tu y place le backup que tu as fait, tu l'importes et tu auras un clone de ton site (après avoir placé aussi toutes les images)

cEd

Hors ligne

#9 Le 08/08/2005, à 16:58

Shoobidoowap7

Re : Xampp + SPIP

nan... sad je ne vois ni backup, ni save.

En revanche, dans l'administration du site (en ligne), il y a un fichier de Sauvegarde :

ecrire/data/dump.xml.gz.

Mais ça veut dire que j'ai déjà pu l'ouvrir puisque c'est un bouton qui appelle ce fichier... non ?

Hors ligne

Haut de page ↑