Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 11/08/2005, à 13:01

bris

httpd.conf vide ???

après avoir suivi le wiki sur l'installation de apache2, php4 et my sql (avec phpmy admin). Mon php n'est pas interprété... pour phpinfo.php il me retourne :

Warning: Unknown(/home/brice/public_html/phpinfo.php): failed to open stream: Permission denied in Unknown on line 0

Warning: (null)(): Failed opening '/home/bris/public_html/phpinfo.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0

J'ai pas mal cherché sur le forum mais module.conf est vide et mon httpd.conf est quasiment vide (5 lignes commentée)...
J'ai aussi décommenté les 2 lignes suivantes dans apache2.conf mais rien n'y fait...

AddType application/x-httpd-php .php .php3 .phtml
AddType application/x-httpd-php-source .phps

Je ne comprens vraiment pas pourquoi çà ne marche pas.... hmm aidez moi !!! smile


un vaut mieu que deux ! CQFD

Hors ligne

#2 Le 11/08/2005, à 15:29

thiebo

Re : httpd.conf vide ???

A priori ton erreur signifie que tu devrais faire un chmod 777 sur le document .php que tu veux ouvrir avec ton navigateur.

as-tu installé tous les packages :

mysql-common mysql-server mysql-client

php5 php5-cgi php5-cli php5-common php5-dev php5-fcgi php5-gd php5-mysql
php5-mysqli php5-pear

apache2 apache2-common apache2-doc apache2-mpm-prefork apache2-utils
libapache2-mod-auth-mysql libapache2-mod-php5


puis dans php.ini il faut décommenter la ligne

extension=mysql.so

Sinon ton httpd.conf est bref, mais c'est normal parce que si tu as apache2, ce n'est pas dans httpd.conf qu'il faut regarder : SURTOUT N'Y TOUCHE PAS.

Chuis un peu au boulot là et pas à la maison ce soir, mais si tu as toujours le problème demain, je t'indiquerai exactement quel est le fichier à regarder, et quel pourrait être son contenu.


je m'amuse comme je peux

Hors ligne

#3 Le 11/08/2005, à 15:47

farf

Re : httpd.conf vide ???

A priori c'est un problème de droits sur le répertoire contenant tes scripts php.

Vérifie le user:group et applique un chown

Hors ligne

#4 Le 11/08/2005, à 16:14

bris

Re : httpd.conf vide ???

J'y avais déjà pensé mais j'avais déjà fait :
chmod 777 -r /home/bris/
et
chmod 777 -r /var/www/
çà ne change rien
hmm


un vaut mieu que deux ! CQFD

Hors ligne

#5 Le 11/08/2005, à 16:56

farf

Re : httpd.conf vide ???

et un chown, t'as tenté un chown ?:rolleyes:

Hors ligne

#6 Le 12/08/2005, à 01:33

thiebo

Re : httpd.conf vide ???

chmod 777 -r /home/bris/
et
chmod 777 -r /var/www/

et chmod -R 777 /home/bris ??


je m'amuse comme je peux

Hors ligne

#7 Le 12/08/2005, à 01:40

kedare

Re : httpd.conf vide ???

L'erreur que tu a vien de php et pas d'apache
vu que les erreur WARNING sont indiquer par php , tu n'aurais pas du modifier httpd.conf si non c'est etrange que les erreur dans les fichier soit a la ligne 0 .....

Hors ligne

#8 Le 12/08/2005, à 09:56

bris

Re : httpd.conf vide ???

chmod -R 777, oui c'était çà qu'il fallait faire!!! çà marche nickel maintenant, merci thiebo wink qui sait pourquoi j'avais fait chmod 777 -r , le truc c'est que la console ne m'envoyait aucun message d'erreur!!!

Dernière modification par bris (Le 12/08/2005, à 15:30)


un vaut mieu que deux ! CQFD

Hors ligne

Haut de page ↑