Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 16/10/2011, à 18:04

zolar

(RÉSOLU) Retrouver le bureau Xfce par défaut

Bonjour smile
J'ai installé depuis peu Xfce voulant essayer autre chose qu'Unity...
En faisant une maladresse j'ai supprimé dans un premier la barre d'outil en haut puis la petite en bas, en voulant remettre par défaut j'ai effacé le dossier .config du home, au redémarrage je retrouve bien un bureau avec les barres mais systématiquement avec ces 2 messages qui se suivent dans des boîtes de dialogue :

Aucune instance de xfce4-panel n'a été trouvée

Voulez-vous démarrer le tableau de bord ? Si oui, veillez à ce que la session soit sauvegardée lors de la déconnexion, de la manière que le tableau de bord soit relancé à la prochaine ouverture de session.

Annuler  Exécuter.

je fais Exécuter...

Modification du tableau de bord interdit

Le tableau de bord est exécuté en mode restreint, vous ne pouvez apporter des modifications en tant qu'utilisateur régulier.

Fermer.

Donc sur ce second message je ne comprends pas bien puisque la configuration est dans le home, pourquoi est-il exécuté en mode restreint?
A noter que quand je redémarre j'ai bien coché "Enregistrer la session pour les prochaines connexions"

Merci de votre aide

Dernière modification par zolar (Le 18/10/2011, à 17:51)


1 PC avec Kubuntu 14.04
1 PC avec Ubuntu 14.04
EeeePC 1000h : Ubuntu 14.04 + XFCE

Hors ligne

#2 Le 16/10/2011, à 18:20

The Uploader

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

salut

tu as vérifié les permissions du dossier ~/.config, au cas où ?

ls -l ~/.config

Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS. Attention au bug de USB Creator ! Il vaut mieux graver Xubuntu sur un CD ou DVD.
--
Archlinux/KDE sur ASUS N56VV, Mes PKGBUILDs sur l'AUR

Hors ligne

#3 Le 16/10/2011, à 20:30

zolar

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Merci Uploader de t’intéresser à mon problème!

Donc voici le résultat de la commande...

sellig63@sellig63-laptop:~$ ls -l ~/.config
total 44
drwx------ 2 sellig63 sellig63 4096 2011-10-16 16:31 autostart
drwx------ 2 sellig63 sellig63 4096 2011-10-16 18:07 dconf
drwxr-xr-x 3 sellig63 sellig63 4096 2011-10-16 16:44 gnome-disk-utility
drwxr-xr-x 3 sellig63 sellig63 4096 2011-10-16 16:44 gnome-session
drwxr-xr-x 2 sellig63 sellig63 4096 2011-10-16 16:44 nautilus
drwx------ 2 sellig63 sellig63 4096 2011-10-16 16:55 Thunar
drwx------ 2 sellig63 sellig63 4096 2011-10-16 16:31 ubuntuone
drwx------ 2 sellig63 sellig63 4096 2011-10-16 16:32 update-notifier
-rw------- 1 sellig63 sellig63  639 2011-10-16 16:31 user-dirs.dirs
-rw-rw-r-- 1 sellig63 sellig63    5 2011-10-16 16:31 user-dirs.locale
drwxrwxr-x 6 sellig63 sellig63 4096 2011-10-16 16:58 xfce4

1 PC avec Kubuntu 14.04
1 PC avec Ubuntu 14.04
EeeePC 1000h : Ubuntu 14.04 + XFCE

Hors ligne

#4 Le 16/10/2011, à 20:44

The Uploader

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

D'après cette page, tu dois ajouter une nouvelle entrée dans menu Xfce => paramètres => gestionnaire de paramètres => Session & Démarrage => Démarrage automatique :

Nom : panel
commande : xfce4-panel
commentaire : (rien)

Et ça devrait éviter le message comme quoi aucune instance du panel n'a été trouvé, malgré le fait qu'il soit normalement sauvegardé avec la session, et le message sur le "mode restreint".

Dernière modification par The Uploader (Le 16/10/2011, à 20:46)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS. Attention au bug de USB Creator ! Il vaut mieux graver Xubuntu sur un CD ou DVD.
--
Archlinux/KDE sur ASUS N56VV, Mes PKGBUILDs sur l'AUR

Hors ligne

#5 Le 16/10/2011, à 21:01

zolar

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Malgré ton astuce Uploader j'ai toujours les deux messages l'un après l'autre.
Sinon après j'ai bien les barres de tâche sur le bureau mais à mon avis il ne sauvegarde aucune session en se déconnectant et les messages à chaque fois, c'est assez ennuyeux...


1 PC avec Kubuntu 14.04
1 PC avec Ubuntu 14.04
EeeePC 1000h : Ubuntu 14.04 + XFCE

Hors ligne

#6 Le 16/10/2011, à 21:08

The Uploader

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Ben en fait il te manque un dossier ~/.config/xfce4-session on dirait.

mkdir ~/.config/xfce4-session

c'est peut-être aussi simple que ça.

(tu devrais aussi avoir un dossier ~/.config/xfce4/panel)

Aussi :

ps aux | grep xfce4-session

devrait te donner quelque chose comme :

max       1140  0.0  0.2 178560 11904 tty2     Sl   12:13   0:02 xfce4-session

c'est le gestionnaire de session de xfce. Evidemment, il doit être actif parmi les processus en cours d'exécution.

Dernière modification par The Uploader (Le 16/10/2011, à 21:12)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS. Attention au bug de USB Creator ! Il vaut mieux graver Xubuntu sur un CD ou DVD.
--
Archlinux/KDE sur ASUS N56VV, Mes PKGBUILDs sur l'AUR

Hors ligne

#7 Le 16/10/2011, à 21:21

zolar

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Voilà le résultat de la commande

sellig63  1489  0.0  0.7  31720  7156 ?        Sl   21:09   0:00 xfce4-session
sellig63  1941  0.0  0.0   5684   804 pts/1    S+   21:19   0:00 grep xfce4-session

1 PC avec Kubuntu 14.04
1 PC avec Ubuntu 14.04
EeeePC 1000h : Ubuntu 14.04 + XFCE

Hors ligne

#8 Le 16/10/2011, à 21:23

The Uploader

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Ok, tu as les trois dossiers :

~/.config/xfce4-session
~/.config/xfce4/panel
~/.cache/sessions

avec les droits qui vont bien ?

Dernière modification par The Uploader (Le 16/10/2011, à 21:26)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS. Attention au bug de USB Creator ! Il vaut mieux graver Xubuntu sur un CD ou DVD.
--
Archlinux/KDE sur ASUS N56VV, Mes PKGBUILDs sur l'AUR

Hors ligne

#9 Le 16/10/2011, à 21:47

zolar

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Voici les droits, tel quel ça n'a pas fonctionné.

drwx------ 2 sellig63 sellig63 4096 2011-10-16 20:51 xfce4-session
drwxrwxrwx 6 sellig63 sellig63 4096 2011-10-16 16:58 panel
drwx------ 2 sellig63 sellig63  4096 2011-10-16 21:38 sessions

1 PC avec Kubuntu 14.04
1 PC avec Ubuntu 14.04
EeeePC 1000h : Ubuntu 14.04 + XFCE

Hors ligne

#10 Le 16/10/2011, à 22:10

The Uploader

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Chez moi j'ai ça qui est différent :

drwxr-xr-x 3 max max  12K Sep 21 19:23 sessions
drwxr-xr-x 4 max  max  4.0K Oct 16 22:03 panel

donc les deux commandes suivantes :

chmod 755 ~/.cache/sessions
chmod 755 ~/.config/xfce4/panel

devrait enlever ces différences chez toi.

A voir si ça résoud le problème..

Dernière modification par The Uploader (Le 16/10/2011, à 22:13)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS. Attention au bug de USB Creator ! Il vaut mieux graver Xubuntu sur un CD ou DVD.
--
Archlinux/KDE sur ASUS N56VV, Mes PKGBUILDs sur l'AUR

Hors ligne

#11 Le 17/10/2011, à 08:04

zolar

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Toujours pareil...
Là je vais être absent toute la journée, merci en tout cas Uploader.


1 PC avec Kubuntu 14.04
1 PC avec Ubuntu 14.04
EeeePC 1000h : Ubuntu 14.04 + XFCE

Hors ligne

#12 Le 17/10/2011, à 09:40

zolar

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Je pense que je vais désinstaller complètement Xfce et effacer les fichiers de config, puis réinstaller, on verra bien...
J'attends ce soir car je n'ai pas le Netbook avec moi.


1 PC avec Kubuntu 14.04
1 PC avec Ubuntu 14.04
EeeePC 1000h : Ubuntu 14.04 + XFCE

Hors ligne

#13 Le 17/10/2011, à 09:42

The Uploader

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Ben j'étais sur le point de demander de l'aide à la ML xfce, et/ou d'ailler voir les sources du panel..

Mais ouais, un bon vieux "sudo apt-get purge" suivi d'un "install" pourrait réparer l'install de Xfce.


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS. Attention au bug de USB Creator ! Il vaut mieux graver Xubuntu sur un CD ou DVD.
--
Archlinux/KDE sur ASUS N56VV, Mes PKGBUILDs sur l'AUR

Hors ligne

#14 Le 17/10/2011, à 18:27

zolar

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Alors j'ai fait une suppression complète (donc avec la config) de tous les paquets xfce4-*** , réinstallé le tout, toujours le même problème au démarrage, ce truc doit me coller aux baskets, c'est pas possible! en attendant je repasse sous gnome classique...

Aussi attention, quand on démarre un autre bureau graphique et que l'on a ajouté xfce4-panel dans "sessions & demarrages" ça crée des effets bizarres, xfce s'affichant en doublon avec l'autre bureau ;-)


1 PC avec Kubuntu 14.04
1 PC avec Ubuntu 14.04
EeeePC 1000h : Ubuntu 14.04 + XFCE

Hors ligne

#15 Le 17/10/2011, à 18:36

The Uploader

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Ouais, mélanger les bureaux n'est jamais une bonne idée.. hmm

Bon, un petit mail à la ml xfce s'impose, car là je suis vraiment à court d'idées.


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS. Attention au bug de USB Creator ! Il vaut mieux graver Xubuntu sur un CD ou DVD.
--
Archlinux/KDE sur ASUS N56VV, Mes PKGBUILDs sur l'AUR

Hors ligne

#16 Le 17/10/2011, à 20:39

mr_pouit

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

zolar a écrit :
Modification du tableau de bord interdit

Le tableau de bord est exécuté en mode restreint, vous ne pouvez apporter des modifications en tant qu'utilisateur régulier.

Fermer.

Normalement, ce message apparaît quand on utilise le panel en mode Kiosk (e.g. une borne publique), et qu'on a verrouillé des paramètres pour qu'un utilisateur ne puisse pas les modifier.

Vérifie que les configs par défaut ($HOME/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml, /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml, /etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml, etc.). En bref, pour tous les dossiers listés dans la variable d'environnement $XDG_CONFIG_DIRS, vérifie que $dossier/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml et $dossier/xfce4/panel/default.xml ne contiennent pas l'attribut "locked".

Ou plus simple, tu peux ouvrir l'éditeur de paramètres, et regarder si la case "Verrouillé" est cochée.


N'hésitez pas à venir sur #ubuntu-fr-devel et #u-classroom (FreeNode) !
Ma page perso -- Mon blog

Hors ligne

#17 Le 17/10/2011, à 20:41

The Uploader

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Merci mr_pouit. big_smile


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS. Attention au bug de USB Creator ! Il vaut mieux graver Xubuntu sur un CD ou DVD.
--
Archlinux/KDE sur ASUS N56VV, Mes PKGBUILDs sur l'AUR

Hors ligne

#18 Le 17/10/2011, à 21:51

zolar

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Merci mr_pouit pour ton aide smile

Alors déjà /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml n'existe pas sur mon ordi.
/etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml, etc. non plus mais cela doit être normal puisque au départ j'ai installé Ubuntu normal et rajouté Xfce4 ensuite.

Je vais créer donc un fichier xfce4-panel.xml pour voir...


1 PC avec Kubuntu 14.04
1 PC avec Ubuntu 14.04
EeeePC 1000h : Ubuntu 14.04 + XFCE

Hors ligne

#19 Le 17/10/2011, à 22:31

zolar

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Rien de nouveau...
Sinon que pensez-vous de mon dossier ~/.cache/sessions ?

-rw------- 1 sellig63 sellig63    0 2011-10-17 21:57 Thunar-23d62c69f-0686-4c95-9e51-28cca7543a03
-rw------- 1 sellig63 sellig63    0 2011-10-16 00:03 Thunar-2aedde4d9-c8b4-4ea7-b06e-3aad64c661e4
-rw-rw-r-- 1 sellig63 sellig63 2902 2011-10-17 21:57 xfce4-session-sellig63-laptop:0
-rw-rw-r-- 1 sellig63 sellig63 2902 2011-10-17 18:18 xfce4-session-sellig63-laptop:0.bak
-rw------- 1 sellig63 sellig63    0 2011-10-17 21:57 xfwm4-2c099e9fa-19c6-4ac1-9282-7321eef38841.state

1 PC avec Kubuntu 14.04
1 PC avec Ubuntu 14.04
EeeePC 1000h : Ubuntu 14.04 + XFCE

Hors ligne

#20 Le 18/10/2011, à 09:29

zolar

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Ce matin j'ai démarré en console puis tapé xfce4-panel et voici le message:

xfce4-panel: Failed to connect to session manager: Echec de connexion au gestionnaire de session : SESSION_MANAGER environment variable not defined
xfce4-panel: No window manager registred on screen 0. To start the panel without this check, run with --disable-wm-check

1 PC avec Kubuntu 14.04
1 PC avec Ubuntu 14.04
EeeePC 1000h : Ubuntu 14.04 + XFCE

Hors ligne

#21 Le 18/10/2011, à 11:53

The Uploader

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Dans une xubuntu 11.10 virtualisé, voici la valeur de SESSION_MANAGER :

> $SESSION_MANAGER
local/max-vbox:@/tmp/.ICE-unix/1525,unix/max-vbox:/tmp/.ICE-unix/1525

vraiment bizarre qu'elle ne soit pas définie.. faudrait faire un :

export SESSION_MANAGER="local/max-vbox:@/tmp/.ICE-unix/1525,unix/max-vbox:/tmp/.ICE-unix/1525"

pour la définir avant que xfce4-panel ne se lance... Mais je sais pas trop comment, si ce n'est dans "démarrage automatique" en redémarrant le panel (xfce4-panel -r) :

Nom : export & panel
Commande : exec export SESSION_MANAGER="local/$HOSTNAME:@/tmp/.ICE-unix/1525,unix/$HOSTNAME:/tmp/.ICE-unix/1525" xfce4-panel -r
Commentaire : (rien)

Mais j'ai l'impression que ce n'est qu'un palliatif à un problème plus complexe.

Dernière modification par The Uploader (Le 18/10/2011, à 12:00)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS. Attention au bug de USB Creator ! Il vaut mieux graver Xubuntu sur un CD ou DVD.
--
Archlinux/KDE sur ASUS N56VV, Mes PKGBUILDs sur l'AUR

Hors ligne

#22 Le 18/10/2011, à 14:25

mr_pouit

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

zolar a écrit :

Alors déjà /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml n'existe pas sur mon ordi.
/etc/xdg/xdg-xubuntu/xfce4/xfconf/xfce-perchannel-xml/xfce4-panel.xml, etc. non plus mais cela doit être normal puisque au départ j'ai installé Ubuntu normal et rajouté Xfce4 ensuite.

Je vais créer donc un fichier xfce4-panel.xml pour voir...

Non non, c'est normal donc, il ne faut pas les créer, s'ils existent dans /etc/xdg ça va poser des problèmes. ;-)

$SESSION_MANAGER est mise par le gestionnaire de sessions, donc remplir sa valeur manuellement avec ce qu'a donné The_Uploader ne marchera pas, vu qu'il n'y aura rien à cet emplacement.

Tu devrais essayer de repartir avec un profil un peu plus propre pour de bon : quitte la session Xfce, et supprime $HOME/.cache/xfce4-session* et $HOME/.config/xfce*. Si après ça il ne recrée pas la config par défaut au prochain lancement de ta session, tu as un autre problème ailleurs.

Et au passage, tu ne devrais pas cocher "Enregistrer la session pour les prochaines connexions", ça va te créer encore plus de problèmes (ex : si tu laisses une appli ouverte à la fermeture de session, elle va se réouvrir les prochaines fois ; si une application plante juste avant la fermeture de session, elle ne sera pas relancée les prochaines sessions...)


N'hésitez pas à venir sur #ubuntu-fr-devel et #u-classroom (FreeNode) !
Ma page perso -- Mon blog

Hors ligne

#23 Le 18/10/2011, à 14:32

zolar

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Merci mr_pouit smile , j'essaierai la manip ce soir, là je suis au boulot et n'ai pas mon netbook avec moi.


1 PC avec Kubuntu 14.04
1 PC avec Ubuntu 14.04
EeeePC 1000h : Ubuntu 14.04 + XFCE

Hors ligne

#24 Le 18/10/2011, à 17:50

zolar

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Yahooo! plus de messages au démarrage big_smile

En fait après plusieurs essais de suppression de répertoires ou fichiers, ça a été concluant en supprimant les 2 fichiers xfce4* et le xfwm4* de HOME/.cache/sessions.
Et effectivement le fait de ne pas décocher "Enregistrer la session pour les prochaines connexions" a dû aider aussi, il devait tourner en boucle.
Un grand merci à tous deux, Uploader et mr_pouit smile


1 PC avec Kubuntu 14.04
1 PC avec Ubuntu 14.04
EeeePC 1000h : Ubuntu 14.04 + XFCE

Hors ligne

#25 Le 08/04/2013, à 18:03

Optiplaste

Re : (RÉSOLU) Retrouver le bureau Xfce par défaut

Bonjour,
J'ai eu le même problème sur Debian, et en supprimant les 2 fichiers du cache tout est rentré dans l'ordre.
Merci.


Après Xubuntu, toujours utilisateur de Xfce4 sur Debian.
Très bonne série décalée : http://www.levisiteurdufutur.com/accueil.html
Bientôt une saison 3 : http://www.hero-corp.com/

Hors ligne

Haut de page ↑