Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#26 Le 13/08/2005, à 23:12

Aldones

Re : [Résolu] Mount et oui encore ....

cep a écrit :
adrien_85 a écrit :

?

Je suis pas chaud, et c'est un euphémisme, pour ce genre de solution (errors=recover), lorsque la cause du problème a peut-être été trouvée (ici le hidden en premier).
Il vaut mieux commencer par réparer la cause, ce qui devrait être très facile, avant de faire courir un risque aux données.
D'autant qu'il ne semble pas qu'il y ait urgence.
Voilà, c'est mon opinion smile
Cordialement.
cep

Tu as tout à fait raison, j'avais d'ailleurs prévenu qu'il y avait un risque éventuel avec cette méthode.
Maintenant, cela a focntionné, c'est donc du tout bon.
Mais la le problème ne venais pas du HIDDEN, c'est bien la partition NTFS qui était endommagée. ( NTFS-fs error (device hda1): read_ntfs_boot_sector(): Primary boot sector is invalid.)
Enfin cela  a marché, tout va donc pour le mieux dans le meilleur des mondes wink

Hors ligne

#27 Le 13/08/2005, à 23:17

cep

Re : [Résolu] Mount et oui encore ....

Si la partition était endommagée, elle l'est encore. Non ? smile
Et je maintiens que le hidden doit être enlevé avant tout.
Cordialement.
cep

Hors ligne

#28 Le 13/08/2005, à 23:25

Aldones

Re : [Résolu] Mount et oui encore ....

Pas forcemment.
Je ne connais pas exactement la facon dont linux gère le ntfs, je sais juste qu'il a du mal avec l'écriture.
Mais a partir du moment ou l'option erreur=recover a été mise et que la partition n'est pas montée en lecture, alors je pense qu'il a du réparer l'erreur.
Surtout si c'est le secteur de démarrage qui est endommagé, l'erreur n'est pas bien dure à réparer.
Et tu as raison pour le hidden, dans l'ordre des tests pour réparer l'erreur, cela aurait du être fait avant d'essayer de réparer la partition wink

Hors ligne

#29 Le 14/08/2005, à 00:21

cep

Re : [Résolu] Mount et oui encore ....

Alors, comme le poste est résolu, on peut encore ajouter une ou deux choses sans gêner Adrien smile
Le errors=recover a du simplement forcer le mount, sans rien réparer au fond.
En l'espèce la partition est probablement saine, les données initiales ne sont pas corrompues mais, au boot, le système enrégistre un état de la partition. Et l'ordre du mount avec les options indiquées ne correspond pas à ce que le système connait. Pour cela, il refuse de monter. Le résultat serait pratiquement identique si l'erreur portait uniquement sur l'option de codage utf8.
Je pense d'ailleurs que si, maintenant, on redemandait un mount classique, sans "recover", celui-ci n'aboutirait pas. Tu ne crois pas ? Un fdisk sur hda nous donnerait le même résultat qu'auparavant.
Mais, bon comme tu dis, Adrien a pu retrouver ses données smile

Hors ligne

#30 Le 14/08/2005, à 12:22

adrien_85

Re : [Résolu] Mount et oui encore ....

Oui surtout que d'ici 15 jours qd je serais sur d'avoir tout récupérer je vais formatter ce disque donc wink

Hors ligne

Haut de page ↑