Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 06/01/2007, à 20:26

loxol

[RESOLU] GDM n'utilise pas la resolution max d'xorg.conf ?

Bonjour,

J'ai gdm qui se lance en 1280x1024 (à vue d'oeil), alors que dans xorg.conf je suis en 1400x1050 ou 1600x1200, cela le met en overlay (pour ceux qui connaissent roll ) et la plupart des "options" etc sont invisibles [si l'on ne pense pas à faire défiler l'écran avec la souris] ...

Quelqu'un aurait une solution pour forcer gdm à simplement utiliser la résolution la plus élevée et donc à ne pas passer en overlay ?

J'ai ce problème depuis que je suis passé sous dapper et maintenant aussi sous edgy, mais pas avec la 5.10 (je ne me rappelle plus de son nom).
Cela me fait la même chose avec les pilotes NVidia Legacy ou nv.

Dernière modification par loxol (Le 09/01/2007, à 20:41)

Hors ligne

#2 Le 08/01/2007, à 16:32

Doyen

Re : [RESOLU] GDM n'utilise pas la resolution max d'xorg.conf ?

j'irais voir du coté de nvidia xsettings (Applications -> Outil systeme -> Nvidia XSettings) perso, c'est la que je vais regler ma resolution par defaut wink

++

Doyen


Linux a un noyau, Windows a un pépin
Des chercheurs ont reussi a implanter des dents sur des poules, donc on ne peut plus dire quand les poules auront des dents, a la place, utilisont quand Microsoft n'aura plus de bugs. Ca au moins, c'est pas pret d'arriver !

Hors ligne

#3 Le 08/01/2007, à 17:44

loxol

Re : [RESOLU] GDM n'utilise pas la resolution max d'xorg.conf ?

Merci, mais je n'ai pas ce programme et je l'ai cherché dans les paquets sans succès.

Je n'ai que nvidia-settings qui vient du paquet du même nom et qui ne s'affiche pas dans le menu, il faut le lancer à la main.
Mais il n'y a rien dans celui-ci concernant les résolutions ou les fréquences pour ma carte, il y a seulement les réglages du type contraste, luminosité, gamma, etc, qui d'ailleurs sont inutiles puisque inopérants tant que l'on ne lance pas ce logiciel, peut-être un mode de sauvegarde ? Mais bon j'ai déjà ces réglages via xorg.conf.

...

Je viens de passer sur Google et en fait nvidia-xsettings n'est que pour les pilote 1.0-9xxx, donc pour ma UltraTNT2 avec les pilotes Legacy cela ne fonctionne pas.

Mais je crois m'être mal fait comprendre, désolé:

Ce n'est pas la résolution par défaut de mon compte utilisateur que je cherche à changer, celle-là est bonne: à part la fréquence à 70Hz alors que je devrais être en 75Hz, mais c'est le sélecteur de gnome qui n'est pas très fonctionnel d'après ce que j'ai vu.
Dans Système -> Préférences -> Résolution de l'écran.
Il n'y a que 60 et 70 comme choix alors que je devrais avoir aussi 75 au moins et probablement un 82-85.

Mais c'est la résolution de gdm, ou l'écran de login ou l'écran de connexion, je ne sais comment l'appeler tellement cela change de nom en fonction des gens. C'est l'écran où l'on entre ses nom d'utilisateur et mot de passe avant la session.

Cet écran là utilise une résolution qui semble fixe quelle que soit mon xorg.conf et mes choix de résolution maximale. Il semble être en 1280x1024, or comme j'ai une résolution supérieure  dans mon xorg.conf il se met en overlay (comment dire cela en français ? ), ce qui n'est vraiment pas pratique. roll

Sous Breezy Badger je n'avais pas eu ce problème jusqu'à ce que je choisisse d'installer le paquet des thèmes spécifique à Ubuntu pour gdm, par la suite, et depuis, j'ai toujours cette résolution, fixe avec overlay. hmm

Le fait d'enlever ce paquet n'avait rien changé et j'avais signalé cela.

En passant sous Dapper Drake c'était encore là.
En passant sous Edgy Eft c'est encore là.

Alors je me suis dis que peut-être cela était dans gdm.conf mais je n'ai rien trouvé de tel.

Donc ... 'suis perdu ! sad

Dernière modification par loxol (Le 08/01/2007, à 19:49)

Hors ligne

#4 Le 08/01/2007, à 17:56

Doyen

Re : [RESOLU] GDM n'utilise pas la resolution max d'xorg.conf ?

erf, désolé mais alors je ne sais pas t'aider, j'ai jamais eu ce probleme et ai pas l'habitude de configurer l'ecran de connexion ...

++

Doyen


Linux a un noyau, Windows a un pépin
Des chercheurs ont reussi a implanter des dents sur des poules, donc on ne peut plus dire quand les poules auront des dents, a la place, utilisont quand Microsoft n'aura plus de bugs. Ca au moins, c'est pas pret d'arriver !

Hors ligne

#5 Le 08/01/2007, à 18:08

ncd

Re : [RESOLU] GDM n'utilise pas la resolution max d'xorg.conf ?

Bonsoir,

Je pense a une petite chose pour ton problème de résolution gdm :
une fois la session lancée, faire Système > Préférences > Résolution, et cocher l'option  "mettre par  défaut pour cet ordinateur"


\_C<  p4 2.6Ghz  //  Edgy _ nvidia 9746 _ beryl 0.2.0-svn  //  Utilisateur ubuntu  11021

Hors ligne

#6 Le 08/01/2007, à 20:03

loxol

Re : [RESOLU] GDM n'utilise pas la resolution max d'xorg.conf ?

@Doyen: Merci quand même ! smile

@ncd: Je viens de faire l'essai. Non cela ne fonctionne pas, d'ailleurs cela n'a rien changé du tout. hmm
Qu'est-ce qu'elle est sensée faire cette case en fait ? Parce qu'elle ne me demande pas de mot de passe donc je suppose qu'elle ne peut pas changer des fichiers systèmes ... Si ?

Hors ligne

#7 Le 09/01/2007, à 00:52

ncd

Re : [RESOLU] GDM n'utilise pas la resolution max d'xorg.conf ?

Bonsoir,

Désolé, je sais pas ce que fait concrètement cette option roll
J'ai eu le même problème et cela avait marché chez moi.

Autre petite idée, si tu ne te sert jamais de la résolution "1280x1024", supprime la de ton xorg.conf :

sudo dpkg-reconfigure xserver-xorg

Quand tu arrives aux choix des résolutions, utiliser la touche espace.
Du coup gdm sera - en principe - contraint à utiliser une résolution supérieure  comme celle du bureau.

Avant de modifier le fichier /etc/X11/xorg.conf pense à faire une copie au cas ou :

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

Pour restaurer :

sudo cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf

Dernière modification par ncd (Le 09/01/2007, à 00:54)


\_C<  p4 2.6Ghz  //  Edgy _ nvidia 9746 _ beryl 0.2.0-svn  //  Utilisateur ubuntu  11021

Hors ligne

#8 Le 09/01/2007, à 20:40

loxol

Re : [RESOLU] GDM n'utilise pas la resolution max d'xorg.conf ?

Wouaaa ... Tu serais une fille que je te ferais la bise tiens !!! lol

Ton idée m'a permis de trouver la solution systématique: cool
Il faut une seule résolution dans le xorg.conf.
C'est un bug d'xorg spécifique à Ubuntu parceque je ne l'ai pas sous Debian ni sous Slackware.

exemple:
...
Depth 24
Modes "1600x1200" "1024x768" "800x600"
...

Alors xorg, donc gdm, e17, etc, va se lancer avec un écran en (résolution max - 1) 1024x768 sur un fond en (résolution max) 1600x1200. Je parle en résolution, i.e. grandeur numérique et non pas placement dans la ligne.

Voilà. cool

C'est simplement que la personne 1) n'a pas testée sont propre code ou 2) a un écran LCD donc avec une résolution fixe.

Voilà, "RESOLU". big_smile ... mais chiant car on ne peut plus utiliser le changement de résolution dynamique et les jeux n'ont plus qu'une résolution ... Ouais, le mode des LCD bridés va en faire râler plus d'un.

Hors ligne