Contenu | Rechercher | Menus

Annonce

Ubuntu-fr.org recrute toujours de nouveaux modérateurs, avec de l'expérience.

Ubuntu 16.04 LTS
Réservez vos DVD et clé USB Ubuntu-fr (premières livraisons mi-mai)

Si vous avez des soucis pour rester connecté, déconnectez vous et reconnectez vous depuis ce lien en cochant le case
Me connecter automatiquement lors de mes prochaines visites.

M.A.J. en cours du forum possibilité de bug, nous faisons le maximum pour les résoudre au plus vite

#1 Le 19/02/2005, à 16:43

supjeje

Installation de depots et language

bonjour,

voici l'erreur que j'ai lorsque je veux mettre a jour firefox (ou 1 autre appli)  avec Synaptic :

-------------
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "fr_FR:fr:en_GB:en",
        LC_ALL = (unset),
        LANG = "fr"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

Preconfiguring packages ...
(Reading database ... 60904 files and directories currently installed.)
Preparing to replace mozilla-firefox 0.99+1.0PR.1+revertedto0.9.3-0ubuntu3 (using .../mozilla-firefox_0.99+1.0PR.1+revertedto0.9.3-0ubuntu3_amd64.deb) ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "fr_FR:fr:en_GB:en",
        LC_ALL = (unset),
        LANG = "fr"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Unpacking replacement mozilla-firefox ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "fr_FR:fr:en_GB:en",
        LC_ALL = (unset),
        LANG = "fr"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Setting up locales (2.3.2.ds1-13ubuntu2.2) ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "fr_FR:fr:en_GB:en",
        LC_ALL = (unset),
        LANG = "fr"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales...
  fr.ISO-8859-1...cannot open locale definition file `fr': No such file or directory
dpkg: error processing locales (--configure):
subprocess post-installation script returned error exit status 4
dpkg: dependency problems prevent configuration of lsb:
lsb depends on locales; however:
  Package locales is not configured yet.
dpkg: error processing lsb (--configure):
dependency problems - leaving unconfigured
Setting up mozilla-firefox (0.99+1.0PR.1+revertedto0.9.3-0ubuntu3) ...
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "fr_FR:fr:en_GB:en",
        LC_ALL = (unset),
        LANG = "fr"
    are supported and installed on your system.
...

-----------------

donc je suppose que c un probleme du a une mauvaise configuration de langue mais ou la modifee? J'ai le bureau en Fr mais parfois c en Anglais, par exemple j'ai bien "Application" mais au lieu de "Poste de travail " j'ai "Computer" ou encore synaptic est en anglais ...

Merci

Hors ligne

#2 Le 22/02/2005, à 20:45

supjeje

Re : Installation de depots et language

personne n'a une idee? il faut que je reinstalle tout?

Hors ligne

#3 Le 22/02/2005, à 23:39

kil

Re : Installation de depots et language

La gestion des langages a changé dans Hoary.

Il faut installer les packages language-pack-fr et language-pack-fr-update pour activer la localisation...

Dernière modification par kil (Le 22/02/2005, à 23:40)

Hors ligne

#4 Le 23/02/2005, à 21:08

supjeje

Re : Installation de depots et language

ok, merci

dc j'y susi presque, j'ai recup ici :
http://mir1.ovh.net/ubuntu/ubuntu/pool/main/l/

les 2 fichiers suivants:
language-pack-fr-update_20050128_all.deb
language-pack-fr-update_20050128_all.deb

j'ai mis a jour la lib avec ceux ci: libc6_2.3.2.ds1-20ubuntu8_amd64.deb

mais apres  qd j'installe les pack j'ai ce message :

sudo dpkg -i language-pack-fr-update_20050128_all.deb
(Reading database ... 61525 files and directories currently installed.)
Preparing to replace language-pack-fr-update 20050128 (using language-pack-fr-update_20050128_all.deb) ...
Unpacking replacement language-pack-fr-update ...
dpkg: dependency problems prevent configuration of language-pack-fr-update:
language-pack-fr-update depends on language-pack-fr; however:
  Package language-pack-fr is not installed.
dpkg: error processing language-pack-fr-update (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
language-pack-fr-update

en gros, qd j'installe l'un me dit que l'autre n'et pas installer, et inversement, je tourne en rond .... sad

Hors ligne

#5 Le 19/08/2005, à 16:27

Ju.

Re : Installation de depots et language

Pourquoi ne pas utiliser Synapic : http://wiki.ubuntu-fr.org/applications/synaptic et installer le paquet mozilla-firefox-locale-fr-fr pour avoir firefox en francais ?


Have Fun !

Conduite à tenir face aux trolls

Hors ligne