Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 27/11/2011, à 20:41

Ayu

Grub ne se lance pas

Bonsoir,
J'ai installé windows 7 et Xubuntu 11.10 sur un nouveau pc avec cette configuration:
CM: Asus P8H67 B3
Processeur: i5 2500k
DD: 1TO 7200 RPM
RAM: 2x4GO
CG: Gigabyte GeForce GTX 560

Mais je boot toujours sur windows et Grub ne se lance pas

j'ai essayé de réinstaller grub depuis une session live avec

sudo grub-install  /dev/sda

ça me renvoi:

/usr/sbin/grub-probe : erreur : cannot find a device for /boot/grub (is /dev mounted?).

et

sudo fdisk -l

me renvoi:

Attention : identifiant de table de partitions GPT (GUID) détecté sur « /dev/sda » ! L'utilitaire sfdisk ne prend pas GPT en charge. Utilisez GNU Parted.


Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 têtes, 63 secteurs/piste, 121601 cylindres, total 1953525168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x648ad58f

Périphérique Amorce  Début        Fin      Blocs     Id  Système
/dev/sda1               1  1953525167   976762583+  ee  GPT

et

sudo os-prober

me renvoi: (ça ne montre pas windows ? O.o)

/dev/sda4:Ubuntu 11.10 (11.10):Ubuntu:linux

et le script boot_info_script.sh me renvoi:

                  Boot Info Script 0.60    from 17 May 2011


============================= Boot Info Summary: ===============================

 => Grub2 (v1.99) is installed in the MBR of /dev/sda and looks at sector 
    423401960 of the same hard drive for core.img. core.img is at this 
    location and looks for  on this drive.

sda1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  Unknown
    Boot sector info:   No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

sda2: __________________________________________________________________________

    File system:       
    Boot sector type:  -
    Boot sector info:  
    Mounting failed:   mount : type de système de fichiers «  » inconnu

sda3: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows Vista/7
    Boot sector info:   No errors found in the Boot Parameter Block.
    Operating System:  Windows 7
    Boot files:        /Windows/System32/winload.exe

sda4: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info:  
    Operating System:  Ubuntu 11.10
    Boot files:        /boot/grub/grub.cfg /etc/fstab /boot/grub/core.img

sda5: __________________________________________________________________________

    File system:       swap
    Boot sector type:  -
    Boot sector info:  

sda6: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows Vista/7
    Boot sector info:   No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

============================ Drive/Partition Info: =============================

Drive: sda _____________________________________________________________________

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 têtes, 63 secteurs/piste, 121601 cylindres, total 1953525168 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sda1                   1 1,953,525,167 1,953,525,167  ee GPT


GUID Partition Table detected.

Partition    Start Sector    End Sector  # of Sectors System
/dev/sda1           2,048       206,847       204,800 EFI System partition
/dev/sda2         206,848       468,991       262,144 Microsoft Reserved Partition (Windows)
/dev/sda3         468,992   409,602,047   409,133,056 Data partition (Windows/Linux)
/dev/sda4     409,602,048   800,227,048   390,625,001 Data partition (Windows/Linux)
/dev/sda5     800,227,049   817,023,924    16,796,876 Swap partition (Linux)
/dev/sda6     817,025,024 1,953,523,711 1,136,498,688 Data partition (Windows/Linux)

"blkid" output: ________________________________________________________________

Device           UUID                                   TYPE       LABEL

/dev/loop0                                              squashfs   
/dev/sda1        C425-C856                              vfat       
/dev/sda3        04242E1C242E116A                       ntfs       
/dev/sda4        73768a23-3767-4c6c-bb8d-3a2afbb7bda2   ext4       
/dev/sda5        cdfeeba6-3426-4109-a3de-86412dc29a09   swap       
/dev/sda6        505AA4295AA40DB2                       ntfs       Data

================================ Mount points: =================================

Device           Mount_Point              Type       Options

/dev/loop0       /rofs                    squashfs   (ro,noatime)
/dev/sda3        /media/04242E1C242E116A  fuseblk    (rw,nosuid,nodev,allow_other,blksize=4096,default_permissions)
/dev/sda4        /media/73768a23-3767-4c6c-bb8d-3a2afbb7bda2 ext4       (rw,nosuid,nodev,uhelper=udisks)
/dev/sda6        /media/Data              fuseblk    (rw,nosuid,nodev,allow_other,blksize=4096,default_permissions)
/dev/sr0         /cdrom                   iso9660    (ro,noatime)


=========================== sda4/boot/grub/grub.cfg: ===========================

--------------------------------------------------------------------------------
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
set default="0"
if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
  insmod vbe
  insmod vga
  insmod video_bochs
  insmod video_cirrus
}

insmod part_gpt
insmod ext2
set root='(hd0,gpt4)'
search --no-floppy --fs-uuid --set=root 73768a23-3767-4c6c-bb8d-3a2afbb7bda2
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  insmod part_gpt
  insmod ext2
  set root='(hd0,gpt4)'
  search --no-floppy --fs-uuid --set=root 73768a23-3767-4c6c-bb8d-3a2afbb7bda2
  set locale_dir=($root)/boot/grub/locale
  set lang=fr_FR
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
if [ ${recordfail} != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
if [ "$linux_gfx_mode" != "text" ]; then load_video; fi
menuentry 'Ubuntu, avec Linux 3.0.0-12-generic' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    set gfxpayload=$linux_gfx_mode
    insmod gzio
    insmod part_gpt
    insmod ext2
    set root='(hd0,gpt4)'
    search --no-floppy --fs-uuid --set=root 73768a23-3767-4c6c-bb8d-3a2afbb7bda2
    linux    /boot/vmlinuz-3.0.0-12-generic root=UUID=73768a23-3767-4c6c-bb8d-3a2afbb7bda2 ro   quiet splash vt.handoff=7
    initrd    /boot/initrd.img-3.0.0-12-generic
}
menuentry 'Ubuntu, avec Linux 3.0.0-12-generic (mode de dépannage)' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    insmod gzio
    insmod part_gpt
    insmod ext2
    set root='(hd0,gpt4)'
    search --no-floppy --fs-uuid --set=root 73768a23-3767-4c6c-bb8d-3a2afbb7bda2
    echo    'Chargement de Linux 3.0.0-12-generic ...'
    linux    /boot/vmlinuz-3.0.0-12-generic root=UUID=73768a23-3767-4c6c-bb8d-3a2afbb7bda2 ro recovery nomodeset 
    echo    'Chargement du disque mémoire initial ...'
    initrd    /boot/initrd.img-3.0.0-12-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
    insmod part_gpt
    insmod ext2
    set root='(hd0,gpt4)'
    search --no-floppy --fs-uuid --set=root 73768a23-3767-4c6c-bb8d-3a2afbb7bda2
    linux16    /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
    insmod part_gpt
    insmod ext2
    set root='(hd0,gpt4)'
    search --no-floppy --fs-uuid --set=root 73768a23-3767-4c6c-bb8d-3a2afbb7bda2
    linux16    /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
if [ "x${timeout}" != "x-1" ]; then
  if keystatus; then
    if keystatus --shift; then
      set timeout=-1
    else
      set timeout=0
    fi
  else
    if sleep --interruptible 3 ; then
      set timeout=0
    fi
  fi
fi
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###
--------------------------------------------------------------------------------

=============================== sda4/etc/fstab: ================================

--------------------------------------------------------------------------------
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda4 during installation
UUID=73768a23-3767-4c6c-bb8d-3a2afbb7bda2 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=cdfeeba6-3426-4109-a3de-86412dc29a09 none            swap    sw              0       0
--------------------------------------------------------------------------------

=================== sda4: Location of files loaded by Grub: ====================

           GiB - GB             File                                 Fragment(s)

               =                boot/grub/core.img                             1
               =                boot/grub/grub.cfg                             1
               =                boot/initrd.img-3.0.0-12-generic               2
               =                boot/vmlinuz-3.0.0-12-generic                  1
               =                initrd.img                                     2
               =                vmlinuz                                        1

======================== Unknown MBRs/Boot Sectors/etc: ========================

Unknown BootLoader on sda1

00000000  eb 58 90 4d 53 44 4f 53  35 2e 30 00 02 02 fe 19  |.X.MSDOS5.0.....|
00000010  02 00 00 00 00 f8 00 00  3f 00 ff 00 00 08 00 00  |........?.......|
00000020  00 20 03 00 01 03 00 00  00 00 00 00 02 00 00 00  |. ..............|
00000030  01 00 06 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
00000040  80 00 29 56 c8 25 c4 4e  4f 20 4e 41 4d 45 20 20  |..)V.%.NO NAME  |
00000050  20 20 46 41 54 33 32 20  20 20 33 c9 8e d1 bc f4  |  FAT32   3.....|
00000060  7b 8e c1 8e d9 bd 00 7c  88 4e 02 8a 56 40 b4 41  |{......|.N..V@.A|
00000070  bb aa 55 cd 13 72 10 81  fb 55 aa 75 0a f6 c1 01  |..U..r...U.u....|
00000080  74 05 fe 46 02 eb 2d 8a  56 40 b4 08 cd 13 73 05  |t..F..-.V@....s.|
00000090  b9 ff ff 8a f1 66 0f b6  c6 40 66 0f b6 d1 80 e2  |.....f...@f.....|
000000a0  3f f7 e2 86 cd c0 ed 06  41 66 0f b7 c9 66 f7 e1  |?.......Af...f..|
000000b0  66 89 46 f8 83 7e 16 00  75 38 83 7e 2a 00 77 32  |f.F..~..u8.~*.w2|
000000c0  66 8b 46 1c 66 83 c0 0c  bb 00 80 b9 01 00 e8 2b  |f.F.f..........+|
000000d0  00 e9 2c 03 a0 fa 7d b4  7d 8b f0 ac 84 c0 74 17  |..,...}.}.....t.|
000000e0  3c ff 74 09 b4 0e bb 07  00 cd 10 eb ee a0 fb 7d  |<.t............}|
000000f0  eb e5 a0 f9 7d eb e0 98  cd 16 cd 19 66 60 80 7e  |....}.......f`.~|
00000100  02 00 0f 84 20 00 66 6a  00 66 50 06 53 66 68 10  |.... .fj.fP.Sfh.|
00000110  00 01 00 b4 42 8a 56 40  8b f4 cd 13 66 58 66 58  |....B.V@....fXfX|
00000120  66 58 66 58 eb 33 66 3b  46 f8 72 03 f9 eb 2a 66  |fXfX.3f;F.r...*f|
00000130  33 d2 66 0f b7 4e 18 66  f7 f1 fe c2 8a ca 66 8b  |3.f..N.f......f.|
00000140  d0 66 c1 ea 10 f7 76 1a  86 d6 8a 56 40 8a e8 c0  |.f....v....V@...|
00000150  e4 06 0a cc b8 01 02 cd  13 66 61 0f 82 75 ff 81  |.........fa..u..|
00000160  c3 00 02 66 40 49 75 94  c3 42 4f 4f 54 4d 47 52  |...f@Iu..BOOTMGR|
00000170  20 20 20 20 00 00 00 00  00 00 00 00 00 00 00 00  |    ............|
00000180  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
*
000001a0  00 00 00 00 00 00 00 00  00 00 00 00 0d 0a 52 65  |..............Re|
000001b0  74 69 72 65 7a 20 6c 65  20 64 69 73 71 75 65 ff  |tirez le disque.|
000001c0  0d 0a 45 72 72 2e 20 64  69 73 71 75 65 ff 0d 0a  |..Err. disque...|
000001d0  50 72 65 73 73 65 7a 20  75 6e 65 20 74 6f 75 63  |Pressez une touc|
000001e0  68 65 20 70 6f 75 72 20  72 65 64 82 6d 61 72 72  |he pour red.marr|
000001f0  65 72 0d 0a 00 00 00 00  00 ac c0 ce 00 00 55 aa  |er............U.|
00000200


=============================== StdErr Messages: ===============================

unlzma: Decoder error
awk: cmd. line:36: Math support is not compiled in
awk: cmd. line:36: Math support is not compiled in
awk: cmd. line:36: Math support is not compiled in
awk: cmd. line:36: Math support is not compiled in
awk: cmd. line:36: Math support is not compiled in
awk: cmd. line:36: Math support is not compiled in

En attente de votre réponse.
Merci d'avance!

Dernière modification par Ayu (Le 27/11/2011, à 23:05)


Que vous m'aspergiez d’alcool et de nourritures, que vous me crachiez à la figure, ça passe encore, mais il y as des limites !! Je ne tolère pas que l'ont maltraite un ami! - Akagami no Shanks

Hors ligne

#2 Le 28/11/2011, à 04:23

xabilon

Re : Grub ne se lance pas

Salut

Je ne sais pas si c'est le fait que la table de partitions soit en GPT qui fait ça, mais on dirait que le BIOS démarre sur le boot-sector de sda1 plutôt que sur le MBR de sda. Consulte déjà les options de démarrage de ton BIOS.

C'est malheureusement la première fois que j'entends parler de ce type de table de partitions ...


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#3 Le 28/11/2011, à 11:18

malbo

Re : Grub ne se lance pas

Ayu,
Je m'intéresse à UEFI mais je débute dans l'apprentissage et je ne connais pas l'EFI Boot de Asus autrement que par l'intermédiaire de Google. Je viens de lire ça : http://support.asus.com/Search/KDetail. … 19D871&t=2
Je voudrais savoir pratiquement comment tu démarres actuellement sous Windows par rapport à ce qui est décrit dans ce lien : peux-tu aller dans le réglages avancés et vérifier que c'est bien "Windows Boot Manager" qui est en priorité de Boot ?

Edit : je te parle de UEFI parce que ta carte-mère est équipée de UEFI au lieu de BIOS. On trouve des infos sur ton matériel dans cette partie de la documentation anglaise de Ubuntu : https://help.ubuntu.com/community/UEFIB … chitecture
Il y est dit que les carte-mère H67 de Asus utilisent ce type de logiciel UEFI. Par conséquent, toutes les vieilles méthodes utilisées avec le Bios ne sont pas utilisables. En particulier, on n'installe pas Grub dans le MBR comme ça a été fait dans ton disque dur, comme on peut voir dans le résultat que tu as posté :

                 Boot Info Script 0.60    from 17 May 2011


============================= Boot Info Summary: ===============================

 => Grub2 (v1.99) is installed in the MBR of /dev/sda and looks at sector 
    423401960 of the same hard drive for core.img. core.img is at this 
    location and looks for  on this drive.

C'est à dire que Grub2 installé dans le MBR du disque dur comme il est spécifié dans la documentation du site, ça ne marche pas avec une carte-mère UEFI. Pour l'instant tu peux le laisser en place mais le système UEFI ne pourra pas l'exploiter.
Dans un système UEFI, le paramétrage du multi-boot, ça se fait dans la partition EFI (ta partition sda1). Le principe, c'est que dans cette partition, il doit y avoir tous les fichiers nécessaires pour pouvoir démarrer tous les OS du PC. A l'heure actuelle, c'est dans cette partition EFI que se trouve le fichier qui permet de démarrer Win7. Le but du jeu, c'est qu'un fichier permettant de démarrer Ubuntu se trouve également dans cette partition EFI. Et normalement, lors de l'installation de Ubuntu, l'installateur devrait automatiquement créer le dossier et le fichier qui va bien dans la partition EFI. Mais j'ai de gros doutes dans ton cas et dans la discussion dont je donne le lien ci-dessous, il est mentionné l'hypothèse que pour une raison ou une autre, Ubuntu n'ait pas pu détecter le système UEFI et ait malencontreusement fait une installation classique avec grub-pc au lieu de faire l'installation avec grub-efi qui est sensé fabriquer le fichier qui va bien dans la partition EFI. C'est le système bâtard dont il est question dans cette cette discussion : http://ubuntuforums.org/showthread.php?t=1770885
Cammer Pants semble avoir un partitionnement très semblable au tien en ce qui concerne sda1 et sda2, pourtant ce n'est pas la même carte-mère (la sienne est Gigabyte GA-870A-USB3). Dans ce post de la même discussion, srs5694 - qui est spécialiste de ces pb UEFI - donne des explications.

Dernière modification par malbo (Le 28/11/2011, à 13:42)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#4 Le 28/11/2011, à 20:46

Ayu

Re : Grub ne se lance pas

Bonsoir,
Merci pour vos réponses.

malbo a écrit :

peux-tu aller dans le réglages avancés et vérifier que c'est bien "Windows Boot Manager" qui est en priorité de Boot ?

Oui c'est bien ça, pour le reste je comprend pas trop comment régler le problème.

Dernière modification par Ayu (Le 28/11/2011, à 20:48)


Que vous m'aspergiez d’alcool et de nourritures, que vous me crachiez à la figure, ça passe encore, mais il y as des limites !! Je ne tolère pas que l'ont maltraite un ami! - Akagami no Shanks

Hors ligne

#5 Le 28/11/2011, à 21:25

malbo

Re : Grub ne se lance pas

Peux-tu démarrer sur un support live de Ubuntu 11.10, monter la partition sda1 avec l'utilitaire de disque et vérifier si elle contient bien un fichier grubx64.efi dans le chemin  EFI/ubuntu/ (si tu préfères, tu peux aussi  vérifier la chose depuis Windows puisque la partition EFI est visible depuis Windows). Le but du jeu, c'est d'avoir les éléments pour pouvoir booter sur ce fichier .efi par l’intermédiaire de ton Système UEFI. En général, c'est très simple mais il faut avoir quelques directives et le fabricant de ton PC doit pouvoir te donner l'info si tu ne t'en sors pas à l'instinct.
Moi, je l'ai fait dans un PC virtuel (avec VirtualBox) donc avec un système UEFI virtuel et c'est assez simple à condition d'avoir quelques indications. Je me suis aidé de cette doc (§ 4.1 Using Boot Maintenance Menu:) : http://software.intel.com/en-us/article … scripting/
et c'est ce qui m'a permis de créer une nouvelle entrée dans le Boot manager (voir chapitre D : installation de Ubuntu 11.10 depuis la session live ) : http://forum.ubuntu-fr.org/viewtopic.ph … 1#p7189161
il y a vraiment très peu de manipulations à faire.

Dernière modification par malbo (Le 28/11/2011, à 21:38)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#6 Le 29/11/2011, à 00:37

Ayu

Re : Grub ne se lance pas

Je ne retrouve pas le fichier grubx64.efi par contre je peux booter sur linux en choisissant ça dans le bios
il faut à chaque fois que je rentre dans le bios pour choisir mon OS


Que vous m'aspergiez d’alcool et de nourritures, que vous me crachiez à la figure, ça passe encore, mais il y as des limites !! Je ne tolère pas que l'ont maltraite un ami! - Akagami no Shanks

Hors ligne

#7 Le 29/11/2011, à 07:19

malbo

Re : Grub ne se lance pas

Ayu a écrit :

par contre je peux booter sur linux en choisissant ça dans le bios
il faut à chaque fois que je rentre dans le bios pour choisir mon OS

Cette entrée de ton "Bios" qui te permet de booter sur linux, elle a été créée automatiquement par l'installateur de Ubuntu ou bien c'est toi qui a dû la paramétrer à la main (un peu comme j'explique dans mon post précédent) ?
L'entrée pour Win7 dans ton "Bios" est désignée par "Windows Boot Manager". Comment est désignée l'entrée pour Ubuntu ?
Quand tu choisis de démarrer sur Ubuntu, juste avant que Ubuntu démarre, en appuyant rapidement sur la touche Echap tu dois pouvoir faire apparaître le menu Grub. est-ce bien le cas ?

Dernière modification par malbo (Le 29/11/2011, à 07:25)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#8 Le 29/11/2011, à 10:59

Ayu

Re : Grub ne se lance pas

Bonjour,
l'entrée à été crée automatiquement
L'entrée Win8 c'est bien "Windows Boot Manager"
Par contre si je sélectionne un boot sur le DD (SATA: ST31000524AS) depuis le bios (et cela sans grub) Linux se lance

Dernière modification par Ayu (Le 29/11/2011, à 11:02)


Que vous m'aspergiez d’alcool et de nourritures, que vous me crachiez à la figure, ça passe encore, mais il y as des limites !! Je ne tolère pas que l'ont maltraite un ami! - Akagami no Shanks

Hors ligne

#9 Le 29/11/2011, à 11:48

malbo

Re : Grub ne se lance pas

Ayu a écrit :

Par contre si je sélectionne un boot sur le DD (SATA: ST31000524AS) depuis le bios (et cela sans grub) Linux se lance

Arrivé dans Ubuntu, peux-tu ouvrir un terminal et passer cette commande :

dmesg | grep EFI

Chez moi depuis une session Ubuntu dans un système Bios (mon PC Acer), ça donne ça :

dmesg | grep EFI
[    1.241248] EFI Variables Facility v0.08 2004-May-17

Ce qui indique bien que Ubuntu a démarré dans un système Bios

Par contre, si j'ouvre un session Ubuntu dans un système UEFI (dans un PC virtuel par VirtualBox), voici ce que j'obtiens :

dmesg | grep EFI
[    0.000000] EFI v2.10 by VBOX 64
[    0.000000] Kernel-defined memdesc doesn't match the one from EFI!
[    0.000000] EFI: mem00: type=7, attr=0xf, range=[0x0000000000000000-0x00000000000a0000) (0MB)
[    0.000000] EFI: mem01: type=2, attr=0xf, range=[0x0000000000100000-0x000000000056e000) (4MB)
[    0.000000] EFI: mem02: type=7, attr=0xf, range=[0x000000000056e000-0x000000000f9d9000) (244MB)
[    0.000000] EFI: mem03: type=2, attr=0xf, range=[0x000000000f9d9000-0x000000001f000000) (246MB)
[    0.000000] EFI: mem04: type=3, attr=0xf, range=[0x000000001f000000-0x000000001f00e000) (0MB)
[    0.000000] EFI: mem05: type=7, attr=0xf, range=[0x000000001f00e000-0x00000000365ae000) (373MB)
[    0.000000] EFI: mem06: type=2, attr=0xf, range=[0x00000000365ae000-0x00000000372cf000) (13MB)
[    0.000000] EFI: mem07: type=7, attr=0xf, range=[0x00000000372cf000-0x000000003d8bc000) (101MB)
[    0.000000] EFI: mem08: type=4, attr=0xf, range=[0x000000003d8bc000-0x000000003dc9f000) (3MB)
[    0.000000] EFI: mem09: type=7, attr=0xf, range=[0x000000003dc9f000-0x000000003dcb0000) (0MB)
[    0.000000] EFI: mem10: type=4, attr=0xf, range=[0x000000003dcb0000-0x000000003dcca000) (0MB)
[    0.000000] EFI: mem11: type=7, attr=0xf, range=[0x000000003dcca000-0x000000003dcda000) (0MB)
[    0.000000] EFI: mem12: type=4, attr=0xf, range=[0x000000003dcda000-0x000000003dcf6000) (0MB)
[    0.000000] EFI: mem13: type=7, attr=0xf, range=[0x000000003dcf6000-0x000000003dd4d000) (0MB)
[    0.000000] EFI: mem14: type=4, attr=0xf, range=[0x000000003dd4d000-0x000000003de05000) (0MB)
[    0.000000] EFI: mem15: type=7, attr=0xf, range=[0x000000003de05000-0x000000003de50000) (0MB)
[    0.000000] EFI: mem16: type=1, attr=0xf, range=[0x000000003de50000-0x000000003de70000) (0MB)
[    0.000000] EFI: mem17: type=4, attr=0xf, range=[0x000000003de70000-0x000000003de71000) (0MB)
[    0.000000] EFI: mem18: type=7, attr=0xf, range=[0x000000003de71000-0x000000003de95000) (0MB)
[    0.000000] EFI: mem19: type=2, attr=0xf, range=[0x000000003de95000-0x000000003de9b000) (0MB)
[    0.000000] EFI: mem20: type=4, attr=0xf, range=[0x000000003de9b000-0x000000003dea1000) (0MB)
[    0.000000] EFI: mem21: type=7, attr=0xf, range=[0x000000003dea1000-0x000000003dea4000) (0MB)
[    0.000000] EFI: mem22: type=2, attr=0xf, range=[0x000000003dea4000-0x000000003dea7000) (0MB)
[    0.000000] EFI: mem23: type=4, attr=0xf, range=[0x000000003dea7000-0x000000003deb1000) (0MB)
[    0.000000] EFI: mem24: type=2, attr=0xf, range=[0x000000003deb1000-0x000000003deba000) (0MB)
[    0.000000] EFI: mem25: type=7, attr=0xf, range=[0x000000003deba000-0x000000003debb000) (0MB)
[    0.000000] EFI: mem26: type=4, attr=0xf, range=[0x000000003debb000-0x000000003e7e7000) (9MB)
[    0.000000] EFI: mem27: type=3, attr=0xf, range=[0x000000003e7e7000-0x000000003e951000) (1MB)
[    0.000000] EFI: mem28: type=4, attr=0xf, range=[0x000000003e951000-0x000000003e952000) (0MB)
[    0.000000] EFI: mem29: type=3, attr=0xf, range=[0x000000003e952000-0x000000003e9d3000) (0MB)
[    0.000000] EFI: mem30: type=5, attr=0x800000000000000f, range=[0x000000003e9d3000-0x000000003e9f6000) (0MB)
[    0.000000] EFI: mem31: type=3, attr=0xf, range=[0x000000003e9f6000-0x000000003ea20000) (0MB)
[    0.000000] EFI: mem32: type=5, attr=0x800000000000000f, range=[0x000000003ea20000-0x000000003ea35000) (0MB)
[    0.000000] EFI: mem33: type=0, attr=0xf, range=[0x000000003ea35000-0x000000003ea36000) (0MB)
[    0.000000] EFI: mem34: type=4, attr=0xf, range=[0x000000003ea36000-0x000000003eed3000) (4MB)
[    0.000000] EFI: mem35: type=3, attr=0xf, range=[0x000000003eed3000-0x000000003eede000) (0MB)
[    0.000000] EFI: mem36: type=4, attr=0xf, range=[0x000000003eede000-0x000000003f83f000) (9MB)
[    0.000000] EFI: mem37: type=7, attr=0xf, range=[0x000000003f83f000-0x000000003f843000) (0MB)
[    0.000000] EFI: mem38: type=3, attr=0xf, range=[0x000000003f843000-0x000000003f8be000) (0MB)
[    0.000000] EFI: mem39: type=5, attr=0x800000000000000f, range=[0x000000003f8be000-0x000000003f8cc000) (0MB)
[    0.000000] EFI: mem40: type=3, attr=0xf, range=[0x000000003f8cc000-0x000000003f913000) (0MB)
[    0.000000] EFI: mem41: type=5, attr=0x800000000000000f, range=[0x000000003f913000-0x000000003f922000) (0MB)
[    0.000000] EFI: mem42: type=3, attr=0xf, range=[0x000000003f922000-0x000000003f92f000) (0MB)
[    0.000000] EFI: mem43: type=5, attr=0x800000000000000f, range=[0x000000003f92f000-0x000000003f933000) (0MB)
[    0.000000] EFI: mem44: type=5, attr=0x800000000000000f, range=[0x000000003f933000-0x000000003f94f000) (0MB)
[    0.000000] EFI: mem45: type=6, attr=0x800000000000000f, range=[0x000000003f94f000-0x000000003f985000) (0MB)
[    0.000000] EFI: mem46: type=6, attr=0x800000000000000f, range=[0x000000003f985000-0x000000003f99f000) (0MB)
[    0.000000] EFI: mem47: type=9, attr=0xf, range=[0x000000003f99f000-0x000000003f9b5000) (0MB)
[    0.000000] EFI: mem48: type=9, attr=0xf, range=[0x000000003f9b5000-0x000000003f9bb000) (0MB)
[    0.000000] EFI: mem49: type=10, attr=0xf, range=[0x000000003f9bb000-0x000000003f9bc000) (0MB)
[    0.000000] EFI: mem50: type=10, attr=0xf, range=[0x000000003f9bc000-0x000000003f9bf000) (0MB)
[    0.000000] EFI: mem51: type=4, attr=0xf, range=[0x000000003f9bf000-0x000000003fee0000) (5MB)
[    0.000000] EFI: mem52: type=6, attr=0x800000000000000f, range=[0x000000003fee0000-0x000000003ff00000) (0MB)
[    0.666999] fb0: EFI VGA frame buffer device
[    1.083445] EFI Variables Facility v0.08 2004-May-17

Ce grand nombre de ligne, dont plusieurs avec la mention "mem...", c'est caractéristique de Ubuntu démarré dans un système UEFI

Dernière modification par malbo (Le 29/11/2011, à 11:58)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#10 Le 29/11/2011, à 11:55

Ayu

Re : Grub ne se lance pas

ça donne

[     1.237075] EFI Variables Facility v0.08 2004-May-17

Que vous m'aspergiez d’alcool et de nourritures, que vous me crachiez à la figure, ça passe encore, mais il y as des limites !! Je ne tolère pas que l'ont maltraite un ami! - Akagami no Shanks

Hors ligne

#11 Le 29/11/2011, à 12:20

malbo

Re : Grub ne se lance pas

Ayu a écrit :

ça donne

[     1.237075] EFI Variables Facility v0.08 2004-May-17

OK donc quand tu sélectionnes un boot sur le DD (SATA: ST31000524AS) dans ton "Bios", tu démarres bien en mode "Legacy Device" dont il est question dans ce lien sur les vues : http://support.asus.com/Search/KDetail. … 19D871&t=2
C'est à dire que ton "Bios" ce comporte comme un ancien Bios (et non pas comme un sytème UEFI) et il est d'ailleurs vu par Ubuntu comme un Bios (et pas comme un UEFI). Avec ma petite connaissance du domaine, je crois pouvoir dire qu'il n'est pas possible de réussir à obtenir un menu Grub qui pourrait lancer Windows dans ta configuration actuelle de Ubuntu. En effet, Ubuntu s'est installé (que tu l'aies voulu ou non, ça je ne sais pas le dire) en mode Bios donc il est équipé de grub-pc (au lieu de grub-efi si l'installation avait été faite en mode UEFI). Grub-pc n'arrive pas à détecter la présence de ton Windows 7 parce que ta partition Win7 n'est pas équipé des fichiers caractéristiques d'une installation en mode Bios de Windows 7 : on peut voir dans le résultat de ton Boot Info Script, que ta partition sda3 ne comporte pas ces éléments Bootmgr, BCD, etc... qui servent à cette détection. Normal puisque l'équivalent de ces éléments doit être planqué dans la partition EFI.

En bref, je pense que tu es obligé de choisir ton camp :
1ère possibilité : tu mets la priorité de démarrage sur le DD (SATA: ST31000524AS) dans ton "Bios" et tu démarres par défaut sur Ubuntu. Et le jour où tu as besoin d'aller sur Windows, tu passes par ton "Bios" pour choisir de démarrer "Windows Boot Manager".
2ème possibilité : Parce que tu travailles essentiellement sur Windows ou que le PC est à usage familial, tu mets la priorité de démarrage sur "Windows Boot Manager" dans le "Bios" et le jour où tu dois aller sous Ubuntu, tu passes par le "Bios" pour sélectionner le DD (SATA: ST31000524AS

Dernière modification par malbo (Le 29/11/2011, à 12:22)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#12 Le 29/11/2011, à 12:39

Ayu

Re : Grub ne se lance pas

Oui c'est ce que je compte faire pour le moment mais ce n'est pas la bonne solution hmm
en tous cas merci pour ton aide


Que vous m'aspergiez d’alcool et de nourritures, que vous me crachiez à la figure, ça passe encore, mais il y as des limites !! Je ne tolère pas que l'ont maltraite un ami! - Akagami no Shanks

Hors ligne

#13 Le 29/11/2011, à 12:57

malbo

Re : Grub ne se lance pas

Si tu n'attends plus d'aide pour ce problème, peux-tu modifier le titre de ton post #1 pour qu'il devienne :

[Résolu] Grub ne se lance pas

en suivant ces indications ( 5.2 Passer son sujet en [Résolu] ) : http://doc.ubuntu-fr.org/tutoriel/howto … _en_resolu
Si dans l'avenir, tu réussis à avoir un multi-boot Win7/Ubuntu fonctionnel qui soit géré par Grub (je pense que ce serait grâce à une install de Ubuntu faite en UEFI mode mais moi, je ne sais pas comment il faut faire pratiquement pour ça), ce serait sympa de donner des nouvelles et des tuyaux en postant dans la présente discussion ; ça pourra servir à d'autres.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#14 Le 29/11/2011, à 13:01

Ayu

Re : Grub ne se lance pas

Oui mais j'attends toujours une solution ^^' c'est pas encore résolu vous trouvez pas ? tongue


Que vous m'aspergiez d’alcool et de nourritures, que vous me crachiez à la figure, ça passe encore, mais il y as des limites !! Je ne tolère pas que l'ont maltraite un ami! - Akagami no Shanks

Hors ligne

#15 Le 29/11/2011, à 13:26

malbo

Re : Grub ne se lance pas

Ayu,
Comme tu te rends bien compte, je ne sais pas t'aider davantage pour la solution de tes rêves mais je te recommande un chose si tu ne l'as pas déjà faite : prévois de pouvoir réinstaller Windows dans ce PC. Si tu as le DVD d'install de Win7 ou d'autres moyens d'install sur support externe (sur clé USB ou disque dur externe), c'est parfait sinon fait le nécessaire avant d'autres tentatives.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#16 Le 29/11/2011, à 14:00

xabilon

Re : Grub ne se lance pas

Je ne peux que m'incliner ... et penser que le UEFI promet de belles prises de tête sur les forums GNU/Linux.


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#17 Le 29/11/2011, à 19:05

Ayu

Re : Grub ne se lance pas

malbo,
Oui c'est pas grave si je dois réinstaller Win7 c'est un nouveau PC donc j'évite d'y mettre des données tant que j'ai pas regler ce problème


Que vous m'aspergiez d’alcool et de nourritures, que vous me crachiez à la figure, ça passe encore, mais il y as des limites !! Je ne tolère pas que l'ont maltraite un ami! - Akagami no Shanks

Hors ligne

#18 Le 13/12/2011, à 17:18

YannUbuntu

Re : Grub ne se lance pas

Bonjour
avez-vous toujours le probleme?
pouvez-vous svp suivre ce tuto ( http://forum.ubuntu-fr.org/viewtopic.php?id=614071 ) et nous indiquer ici l'URL qui apparaitra ?


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#19 Le 13/12/2011, à 22:51

Ayu

Re : Grub ne se lance pas

Bonsoir,
Oui j'ai toujours le problème (à chaque démarrage je go BIOS pour lancer windows)
Voici le lien http://paste.ubuntu.com/769415/
En attente de votre aide.
Merci d'avance.


Que vous m'aspergiez d’alcool et de nourritures, que vous me crachiez à la figure, ça passe encore, mais il y as des limites !! Je ne tolère pas que l'ont maltraite un ami! - Akagami no Shanks

Hors ligne

#20 Le 14/12/2011, à 00:08

YannUbuntu

Re : Grub ne se lance pas

Merci.
- Pouvez-vous svp vérifier que dans les Options avancées de Boot-Repair, onglet "Emplacement de GRUB", il y a une case (non cochée par défaut) "Partition /boot/efi :" et qu'à sa droite il y a une liste déroulante avec uniquement "sda1" comme choix?
- pouvez-vous booter sur Ubuntu, ouvrir un terminal, et indiquer le retour des commandes suivantes svp :

sudo mount /dev/sda1 /mnt && ls -F /mnt
ls -F /mnt/efi

(liste les fichiers de sda1)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#21 Le 14/12/2011, à 10:23

malbo

Re : Grub ne se lance pas

Effectivement, l'installation s'est enrichie.
Dans le post #1 on avait ça :

sda3: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows Vista/7
    Boot sector info:   No errors found in the Boot Parameter Block.
    Operating System:  Windows 7
    Boot files:        /Windows/System32/winload.exe

A présent, dans le résultat du Boot Info script du post #19, on a ça :

sda3: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Grub2 (v1.99)
    Boot sector info:   Grub2 (v1.99) is installed in the boot sector of sda3 
                       and looks at sector 745534560 of the same hard drive 
                       for core.img. core.img is at this location and looks 
                       for  on this drive. No errors found in the Boot 
                       Parameter Block.
    Operating System:  Windows 7
    Boot files:        /Windows/System32/winload.exe

Grub dans le secteur de boot de la partition système de Windows, c'est pas trop bon...Heureusement que le windows 7 installé est "EFI" (et pas "Bios"), c'est à dire qu'il se fout de ce secteur de Boot parce qu'il utilise les instructions qui sont dans sda1 pour démarrer.

Dernière modification par malbo (Le 14/12/2011, à 10:26)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#22 Le 15/12/2011, à 23:21

Ayu

Re : Grub ne se lance pas

Bonsoir,

Oui y a bien que sda1 dans le menu déroulant.
et pour les commande j'ai ça:

~$ sudo mount /dev/sda1 /mnt && ls -F /mnt
EFI/
~$ ls -F /mnt/efi
Boot/  Microsoft/

Que vous m'aspergiez d’alcool et de nourritures, que vous me crachiez à la figure, ça passe encore, mais il y as des limites !! Je ne tolère pas que l'ont maltraite un ami! - Akagami no Shanks

Hors ligne

#23 Le 16/12/2011, à 01:45

YannUbuntu

Re : Grub ne se lance pas

je peux vous aider à installer grub-efi (qui je l'espère réglera le problème) avec mes maigres connaissances sur le sujet, mais je ne garantis pas le résultat, donc par précaution svp commencez par:
- sauver toutes vos données sur un support externe (disque USB ou DVD)
- m'envoyer une archive TAR.GZ du contenu de la partition sda1 par email (yannubuntu ATT gmail POINT com)
- m'envoyer aussi par mail une archive TAR.GZ du dossier /var/log/clean qui se trouve dans la partition Ubuntu (sda4)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#24 Le 16/12/2011, à 09:32

malbo

Re : Grub ne se lance pas

Ayu,
Pas hasard, je suis tombé sur cette vidéo qui détaille minutieusement la mise à jour du Bios pour ta carte-mère : http://www.dailymotion.com/video/xmyt8x … -asus_tech
Je ne sais pas si cette mise à jour du Bios pourrait améliorer la cohabitation Ubuntu/Win7 dans ton PC, mais il faut y penser.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#25 Le 21/12/2011, à 00:24

jeanmi199

Re : Grub ne se lance pas

@Ayu.
Quand tu as installer windows tu as ou plutôt windows a formater ton disque en GPT au lieu de MBR (voir les options avancée a l'install de win7) ton probleme vien de la et pas de EFI. Les volume GPT sont prévu pour des disques de plus de 2,2To comme tu as un disque de 1To tu peux le formater en MBR. en tout cas dans un premier temps je ne sais pas si apres reformatage du disque en MBR l'EFI ne causera pas de problème (a creuser) mais je n'ai pas le matériel ad'hoc.

Dernière modification par jeanmi199 (Le 21/12/2011, à 00:37)

Hors ligne

Haut de page ↑