Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 19/10/2011, à 13:13

Luke_fr

Impossible d'installer Ubuntu 11.04 ou 11.10

Bonjour à tous,

J'ai un PC Portable Acer eMachine g443 (Processeur AMD E-350 (1,6 GHz) - Chipset graphique AMD Radeon™ HD 6310 Graphics avec 256 Mo) qui avait Linpus d'installé.

J'ai voulu changer et passer à Ubuntu 11.04.

Malheureusement impossible de l'installer :'(

Après le premier petit logo j'ai un écran noir.

J'ai donc installé la version 10.10 et là pas de soucis.

J'ai voulu faire ensuite une mise à jour vers la 11.04 qui s'est bien déroule ... sauf qu'au démarrage -> écran noir :'(

J'avais espoir avec la 11.10 mais j'ai exactement le même problème. sad

Vous pouvez m'aider?

Merci

Dernière modification par slasher-fun (Le 19/10/2011, à 13:30)

Hors ligne

#2 Le 19/10/2011, à 16:25

malbo

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

Si tu démarres ton PC sur un support live (live-USB ou live-CD) de Ubuntu 11.10 et que tu choisisses "Essayer Ubuntu", est-ce que tu arrives bien sur le bureau de Ubuntu ou pas ?
Je te dis ça parce que je crois que ta carte graphique HD 6310 est supportée par le pilote RADEON si j'en crois la liste des cartes supportées  que je vois dans mon fichier /var/log/xorg.log.0 (j'ai une carte ATI et j'utilise le pilote libre RADEON) : je vois "AMD Radeon HD 6310 Graphics" dans la liste donc je pense que ça devrait le faire. Normalement, le pilote libre RADEON qui vient avec Ubuntu 11.10 devrait supporter ta carte.

Dernière modification par malbo (Le 19/10/2011, à 16:26)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#3 Le 19/10/2011, à 20:09

Luke_fr

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

Je viens de tester avec l'option 'essayer ubuntu" j'ai le même problème: écran noir avec un curseur blanc qui clignotte en haut à gauche, puis d'un coup plus du tout d'affichage (alors que le cd continue de tourner).

:'(

Hors ligne

#4 Le 20/10/2011, à 15:54

Luke_fr

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

Pas d'idée? sad

Vais-je devoir rester sous win 7? ... hmm

Hors ligne

#5 Le 20/10/2011, à 17:08

malbo

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

Désolé de ne pouvoir te donner une procédure mais je ne suis pas spécialiste des pb d'affichage.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#6 Le 20/10/2011, à 17:49

Luke_fr

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

Merci d'avoir répondu en tout cas! smile

En espérant que quelqu'un d'autre est une idée car j'aimerai bien rejoindre la communauté ubuntu ... wink

Hors ligne

#7 Le 24/10/2011, à 00:24

Luke_fr

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

sad

Hors ligne

#8 Le 20/11/2011, à 18:49

dj_garfield

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

Je poste peut être un peut tard , mais j'ai eu le même soucis avec mon nouveau portable ACER ASPIRE 7250 équipé de la carte AMD HD 6310 , en effet lorsque j'ai démarré avec le live CD UBUNTU 11.10 je me suis retrouvé avec un écran noir ...

SOLUTION smile> J'ai Raccordé un Ecran sur la sortie VGA du portable et ôh miracle l'affichage se faisait par ici , du coup je suis en train d'installer UBUNTU 11.10 sur ce portable , je repasse poster ici pour vous tenir au courant de l'avancement .


===============================================================
Dj_GarfielD
http://dj_garfield.fts.cx
Ubuntu 11.10 | ACER ASPIRE 7250 / 4Go / HDD 500Go / AMD 6310 256Mo / Crystal View 17,3" => En beta test | Install UBUNTU 11.10

Hors ligne

#9 Le 20/11/2011, à 18:57

Ayral

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

Sans vouloir d'ennuyer, dj_garfield, évites de mettre ton e-mail dans ta signature, ou alors tu aimes les spams. Mets la dans ton profil, où elle n'est vue que par les inscrits.

En ligne

#10 Le 20/11/2011, à 19:04

Korak

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

Bonjour,

Luke_fr a écrit :

J'ai voulu faire ensuite une mise à jour vers la 11.04 qui s'est bien déroule ... sauf qu'au démarrage -> écran noir

En général, ce problème se règle en ajoutant une option d'amorçage.

Essaie, en LiveCD (essayer Ubuntu sans l'installer), une des options. Je commencerais par l'option "nomodeset".

Tant que tu ne sais pas démarrer correctement en LiveCD, inutile d'essayer d'installer.

Quand tu auras défini quelle est la bonne option, retiens-la, puis clique sur l'icône du bureau "Installer Ubuntu".

Ensuite, il suffira de fixer l'option.


OS: Ubuntu 14.04 64 bits + Windows 8.1 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion g7-2335sb: Processeur: AMD A4-4300M APU   Carte graphique: AMD Radeon HD 7420G   Mémoire vive: 6 Go RAM
Je suis Parrain-Linux

En ligne

#11 Le 21/11/2011, à 12:07

gecim21

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

Bonjour tout le monde. j'ai le même problème avec ma machine :
Fabricant Packard Bell
Modèle EasyNote TH36
Type PC à base de x64
Processeur Pentium(R) Dual-Core CPU T4500 @ 2.30GHz, 2300 MHz
Version du BIOS/Date Packard Bell V1.02, 20/05/2010
Version SMBIOS 2.4

Dernière modification par gecim21 (Le 21/11/2011, à 12:08)

Hors ligne

#12 Le 23/11/2011, à 15:59

antho1404

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

Est ce que quelqu'un a trouvé une solution plus pratique et définitive que celle de dj_garfield. J'ai le même problème d'écran noir au démarrage. Tout le reste semble bien fonctionner.

Hors ligne

#13 Le 02/12/2011, à 12:24

Luc Degryse

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

Ayant rencontré des problèmes similaires, sur mon ACER Aspire 7250, avec carte AMD HD 6310, j'ai pas mal cherché.

Je m'en suis sorti en procédant comme suit :
1) installer Ubuntu 11.04 (ou 11.10).
2) au moment de booter la machine, atteindre le menu GRUB (enfoncer la touche SHIFT)
3) Sélectionner le mode de démarrage FAILSAFE (mode sans échec ? en français ?)
4) la résolution n'est pas terrible, c'est entendu, mais permet de démarrrer le navigateur.
5) chercher le driver ati-driver-installer-11-9-x86.x86_64.run
ou aller à la page : 
http://search.4shared.com/search.html?s … x86_64.run
6) télécharger le driver.
7) installer le driver (il me semble que j'ai fait cela en ouvrant la fenêtre Run Application (ALT+F2 )
8) ça peut durer un peu, marquer des pauses, mais en principe, l'installation se termine correctement
9) Rebooter la machine
10) Croiser les doigts pendant le reboot (très important   smile  )


Si tout va bien, la résolution devrait maintenant être 1600 X 900

Dernière modification par Luc Degryse (Le 02/12/2011, à 12:24)

Hors ligne

#14 Le 06/12/2011, à 13:59

Kottow

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

Bonjour à tous,
Pour en revenir au post initial, effectivement la 11.04 ne fonctionne pas sur cette machine sans passer par l'installation des drivers ATI (mentionné ci-dessus).
Une fois le tout configuré, j'ai personnellement rencontré des problèmes de "freeze" soit dès le panneau de connexion, soit à l'utilisation.
Finalement, c'est mon côté sniule, je suis revenu à la 10.10 qui me convient pleinement wink

Hors ligne

#15 Le 11/12/2011, à 13:28

dj_garfield

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

@ Ayral : J'ai Corrigé ma Signature , j'avais zappé de la virer .

Pour en revenir a nos moutons , l'instalaltion de la 11.10 a fonctionné , et pour repondre au post de Kottow , c'est en fait la carte WiFi qui fait freezer le PC , j'ai ce soucis lorsque je demarre l'ordinateur Hors Lan C.A.D. en ne branchant pas de cable reseau a la prise du PC , des lors qu'on le demarre comme cela le mien freeze aussi a la fenetre de connection , par contre avec le PC raccordé en filaire sur mon switch , il demarre normalement ... Je ne parviens pas a savoir pourquoi .
Autre petit soucis d'ordre "affichage" , lorsque j'utilise les outils Libre Office ( texte, calc ... ), il se produit des petits scintillement au niveau de l'affichage mais seulement sur la barre des boutons de ces application comme si une ligne de l'affichage se decalait d'u coté ou de l'autre de l'ecran ... Je suppose un probleme de rafraichissement .. mais la encore je n'ai pas de solution sous la main , ce malgrés les tentative de reglage avec les outils ATI ( Catalyst ), permettant de regler l'affichage .
je vais tenter de resoudre le souci lié au WiFi , car meme lorsque je demarre le PC avec le cable reseau , lorsque je le debranche , il fonctionne tres bien en WiFi puis freeze a nouveau ...
Voici quelques photos , La premiere lors de l'install , obligé donc de raccorder un ecran sur la sortie VGA du protable , et hop on installe le systeme ...
pendant l'install
une Fois installé on peut donc activer les drivers ATI automatiquement detecté par Ubuntu , et au redemarrage plus besoin de l'ecran de secour smile
Installation OK
Un peut de personalisation et hop ca tourne smile Meme si je n'aime pas la configuration Unity ca fontionne bien quand meme smile
3.jpg


===============================================================
Dj_GarfielD
http://dj_garfield.fts.cx
Ubuntu 11.10 | ACER ASPIRE 7250 / 4Go / HDD 500Go / AMD 6310 256Mo / Crystal View 17,3" => En beta test | Install UBUNTU 11.10

Hors ligne

#16 Le 11/12/2011, à 13:41

dj_garfield

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

Je vais egalement tester l'installation du driver dont a parlé "Luc Degryse" , ce qu'il n'a pas mentionné par contre c'est le type d'installation qu'il a faite : avec une version 32 ou 64 bit de Ubuntu ...
Je telecharge actuellement la 64 bit car celle que j'ai installé est la 32 Bit ...
===========
Edit :
En patientant durant le telechargement , j'ai fait un petit test :
- Demarrer branché au LAN smile> OK
- Debrancher le LAN smile> KO ( Freeze )

- Demarrer Branché au LAN , Et déconection du LAN depuis le paneau de configuration des interfaces reseau : OK  smile> Le WiFi Reste connecté et le PC ne Freeze plus ... Deconection du Câble LAN : KO smile> Le Pc tourne gentillement pendant 1 minutes ou deux .. puis Re-freeze ...

La Si quelqun a une explication autre que des petits lutin qui font rien que nous embeter je suis prenneur car je n'ai encore jamais rencontré ce genre de bizarrerie smile

Dernière modification par dj_garfield (Le 11/12/2011, à 14:04)


===============================================================
Dj_GarfielD
http://dj_garfield.fts.cx
Ubuntu 11.10 | ACER ASPIRE 7250 / 4Go / HDD 500Go / AMD 6310 256Mo / Crystal View 17,3" => En beta test | Install UBUNTU 11.10

Hors ligne

#17 Le 13/12/2011, à 13:01

Luc Degryse

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

@ dj_garfield
(mais pas seulement    :-)    )

La version installée est la suivante :
ubuntu-11.04-desktop-i386.iso

Le pilote ati-driver-installer-11-9-x86.x86_64.run
dont question est à conserver précieusement.
En effet, après avoir procédé à l'upgrade vers 11.10, l'écran était de nouveau "noir".
Même procédure au démarrage après upgrade : se connecter en mode sans échec, et réinstaller le driver en question.

J'espère que vous aurez autant de chance que moi, et que cela fonctionnera pour vous également.

Cordialement.


LD

Hors ligne

#18 Le 13/12/2011, à 13:17

Luc Degryse

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

@ dj_garfield  (toujours)

Je rencontre également les problèmes mentionnés concernant le "freeze".
Selon moi, c'est que le WiFi qui pose problème.
J'ai résolu le problème en désactivant les connexions automatiques.
Ni LAN (entendre WIRED), ni WiFi au démarrage.
Je n'active que la connexion WIRED (auto Eth0) une fois la session ouverte.
Mais ce n'est pas encore idéal, car je constate parfois une interaction avec le routeur, qu'il plonge régulièrement dans un état comateux.

Je n'ai pas encore trouvé de solution pour le WiFi.

ACER, contacté, m'a envoyé une réponse laconique "Nous (Le fabricant, ACER) n'avons aucune obligation de fournir des drivers pour UBUNTU ou autres OS Linux".

C'est dommage, car cela fait des années que j'achetais des ACER, précisément parce que ces machines fonctionnaient bien sous LINUX.
Je me tournerai vers LENOVO ou DELL à l'avenir, qui semblent plus soucieux de la communauté LINUX.

Cordialement

LD

Hors ligne

#19 Le 13/12/2011, à 15:35

Luc Degryse

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

Une nouvelle version du driver est disponible :
ati-driver-installer-11-11-x86.x86_64.run

Tout comme la précédente, elle convient aux installations 32 et 64 bits.

Ne l'ayant pas testée, je ne puis certifier qu'elle fonctionne.

Si quelqu'un le souhaite, qu'il m'envoie un mail et je lui donnerai accès à mon serveur FTP sur lequel j'ai chargé une copie de ceux-ci.

Mais comme c'est un serveur "perso"  normalement à usage privé, il est plus lent que les serveurs professionnels.

C'est comme vous voulez...

Bien à vous

LD

Hors ligne

#20 Le 18/12/2011, à 17:59

oliwek

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

Merci pour ces précisions au niveau de l'écran noir (et de l'astuce provisoire d'utiliser un écran externe) et du wifi, j'étais coincé à l'installation de Mint 12 sur un Acer Aspire 7250 (l'ALU est un AMD E450 non encore supporté par les drivers propriétaires de la distribution). Comme c'est pour un débutant sous Linux, j'ai choisi Mint pour la facilité (codecs, flash et compagnie déjà fournis). L'E450 n'est donc même pas proposé pour les pilotes chez AMD, mais j'ai utilisé les derniers Catalyst au moment de l'install (11.12), en ayant choisi l'E350 comme cpu au moment du téléchargement sur le site d'AMD. J'avais d'abord tenté les drivers AMD de la distribution, et j'ai eu une image vraiment crasse, instable, pleine de défauts, et une mention "hardware unsupported" en bas à droite de l'écran. Gros nettoyage et téléchargement des 11.12 directement chez AMD : la mention unsupported a disparu, plus de parties illisibles aux extrémités de l'écran avec des couleurs fantaisistes, mais la stabilité n'est pas encore optimale. Toutefois ça tourne.
edit : pour ceux que ça intéresserait, il est possible de passer pour l'install par un 2ème écran en HDMI (un 23 pouces 1680x1050 dans mon cas a affiché sans problème le liveusb de Mint)
Pour le wifi, ayant lu vos posts, j'ai installé en ethernet, puis configuré le wifi pour se connecter au routeur, ça semblait fonctionner (de manière instable). Mais au premier démarrage sans câble ethernet, gros freeze, écran noir. Je grommelais déjà et jurais de devoir repasser par un liveusb et un 2ème écran, puis de devoir chrooter et réinstaller catalyst... que nenni, un simple câble ethernet, et ça redémarre normalement...ouf.

Reste à trouver un pilote wifi qui ne bloque pas tout donc, sinon la personne sera forcée d'utiliser windows pour avoir un portable... déplaçable sans fil.
Si vous avez des suggestions à ce propos (je n'ai plus le portable sous la main, et n'ai pas noté le chipset wifi...) hmm

edit : je n'ai jamais conseillé ou acheté d'Acer moi-même, et je ne risque pas trop de m'y essayer : quelle carrosserie cheap sur ce modèle, avec des plastics qui fléchissent, un écran qu'il vaut mieux regarder bien en face sous peine de ne plus avoir de couleurs... Mais bon, je suppose que le prix était en rapport (autant selon moi acheter une bonne machine d'occasion, plus performante, avec moins de soucis sous linux à la clé)

Dernière modification par oliwek (Le 19/12/2011, à 16:41)

Hors ligne

#21 Le 18/12/2011, à 18:18

oliwek

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

Luc Degryse a écrit :

@ dj_garfield  (toujours)

Je rencontre également les problèmes mentionnés concernant le "freeze".
Selon moi, c'est que le WiFi qui pose problème.
J'ai résolu le problème en désactivant les connexions automatiques.
Ni LAN (entendre WIRED), ni WiFi au démarrage.
Je n'active que la connexion WIRED (auto Eth0) une fois la session ouverte.
Mais ce n'est pas encore idéal, car je constate parfois une interaction avec le routeur, qu'il plonge régulièrement dans un état comateux.

Je n'ai pas encore trouvé de solution pour le WiFi.

ACER, contacté, m'a envoyé une réponse laconique "Nous (Le fabricant, ACER) n'avons aucune obligation de fournir des drivers pour UBUNTU ou autres OS Linux".

C'est dommage, car cela fait des années que j'achetais des ACER, précisément parce que ces machines fonctionnaient bien sous LINUX.
Je me tournerai vers LENOVO ou DELL à l'avenir, qui semblent plus soucieux de la communauté LINUX.

Cordialement

LD

Luc, tu pourrais regarder quel chipset utilise le wifi? Et donner ce que rapporte..

lsusb

et

lspci | grep -i net

merci


cf http://doc.ubuntu-fr.org/wifi_liste_car … carte_wifi

Dernière modification par oliwek (Le 18/12/2011, à 18:23)

Hors ligne

#22 Le 19/12/2011, à 00:26

Luc Degryse

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

Bonjour, et merci,

Voici donc ce que me donnenet ces 2 commandes :

lsusb

Moi@MaMachine:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 064e:d214 Suyin Corp.
Bus 004 Device 002: ID 046d:c510 Logitech, Inc. Cordless Mouse

Quant à lspci | grep -i net


Moi@MaMachine:~$ lspci | grep -i net
06:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
07:00.0 Ethernet controller: Atheros Communications AR8152 v2.0 Fast Ethernet (rev c1)

Ceci peut aider ?

Bonne semaine
LD

Hors ligne

#23 Le 19/12/2011, à 14:47

oliwek

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

merci, Luc ; allons donc à la recherche de pilotes pour un chipset Atheros AR9285...

edit : une première recherche sur google semble indiquer qu'il est possible d'utiliser cette carte sous backtrack pour faire de l'injection de paquets (pour les mauvais garçons qui crackent les clés WEP de leurs voisins) ; donc il y a probablement de l'espoir pour des pilotes alternatifs, à suivre...
edit : ils n'utilisent pas backtrack, dont les dernières versions sont basées sur ubuntu, mais wifiway 1.0 (je n'ai jamais approché cette distribution)

cf forum sur le hack wifi en espagnol

Atheros AR928X ¶
Chipset:   AR928X 802.11abgn
Supports:   802.11a 802.11b 802.11g 802.11 draft-n
URL:   http://www.atheros-xspan.com/
Interface:   PCI-Express x1
Notes:   Works with ath9k driver in 2.6.27+. Monitor works, injection works, but sensitivity is low, sees one AP in a location where IPW3945 w/IPWRAW driver (in a Lenovo r61) seems 25+...could be due to antenna.

y luego aqui creo que explica como instalar el driver ath9k:
http://linuxwireless.org/en/users/Drive … th9kdriver

http://foro.elhacker.net/wireless_en_li … z1gz6IJia7


Je n'ai plus le portable sous la main, mais le lien donné (http://linuxwireless.org/en/users/Drive … th9kdriver) pourrait aider l'un d'entre vous à tester avec une version récente du pilote ath9k...

Supported Atheros wireless devices

Vendor
    Product     form factor     Atheros Chip
    PCI Product
    PCI Subvendor     PCI Subsystem
Compex     WLM200NX     Mini-PCI     9220     0x0029     0x168c     0x2096
D-Link     DWA-552     PCI     5416     0x0023     0x1186     0x3a6d
D-Link     DWA-556     PCI Express     5418     0x0024     0x1186     0x3a70
D-Link     DWA-645     Cardbus     5416     0x0023     0x07d1     0x3a09
TP-LINK     TL-WN781N     PCI Express     9285     0x002b     0x168c     0x30a1
TP-LINK     TL-WN861N     Mini-PCI     5416     0x0023     0x168c     0x2079
TP-LINK     TL-WN961N     Mini-PCI     5416     0x0023     0x168c     0x2071
Unex     DNMA-83     Mini-PCI     9160     0x0027     0x168c     0x2082
Unex     DNMA-92     Mini-PCI     9220     0x0029     0x168c     0x2096
Unex     DNMA-91     Mini-PCI     9223     0x0029     0x168c     0x2091
Unex     DNXA-92     PCI Express     9280     0x002a     0x168c     0x309a
Unex     DNXA-93     PCI Express     9283     0x002a     0x185f     0x309d
Unex     DNXA-95     PCI Express     9285     0x002b     0x168c     0x30a1

plusieurs cartes basées sur le même chipset (en gras) sont supportées par ce pilote...
Pour bien faire, il faudrait tenter avec une version la plus récente possible (quitte à devoir compiler soi-même si elle n'est pas déjà précompilée pour Debian/Ubuntu)

EDIT : le problème de freezes viendrait d'ailleurs : lire les 2 posts qui suivent ; toutefois le driver ath9k fourni avec Ubuntu/Mint semble lent et instable avec l'Acer, il conviendrait donc de le mettre à jour (voir aussi, comme cité dans le post suivant, http://askubuntu.com/questions/38043/sy … h9k-driver )

Dernière modification par oliwek (Le 19/12/2011, à 16:35)

Hors ligne

#24 Le 19/12/2011, à 15:05

oliwek

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

Lire ceci aussi sur le forum anglais :
http://ubuntuforums.org/showthread.php?t=1840637

il y a une solution expliquée ici : http://ubuntuforums.org/showthread.php?t=1811178

1. Freezing after login (with unplugged network cable). This is caused by wireless driver. Easy fix is to make network boot as a first option in BIOS (hold F2 after reboot). The solution for this was found on:

http://drivard.com/2011/07/20/instal...wireless-card/

-> choisir dans le bios (appelé par F2 au démarrage) comme première option de boot le réseau, plutôt que le disque dur (HDD), puis sauvegarder (F10) avant de quitter.

D'après le post au bas de cette page : http://askubuntu.com/questions/38043/sy … h9k-driver

il convient peut-être de d'abord activer le boot par réseau dans le bios, avant de pouvoir le sélectionner comme première option de boot

edit : malheureusement cette manip' dans le bios semble ne pas fonctionner pour tout le monde d'après ce que je lis plus bas chez les anglophones (visiblement il y a plusieurs modèles de cartes, et donc de chipsets, wifi dans les Aspire, et le fix fonctionnerait plutôt pour des Broadcom)


autre post intéressant et relevant :

Re: Wireless causes system freeze: Atheros AR9285, Ubuntu 11.04 64-bit, Acer Aspire
Okay. When I boot in the 3.0 kernel there isn't anything relevant from that command (just the device-mapper multi-path lines). Here is the output from the 2.6.38 generic kernel:
Code:

steven@zanazabar:~$ dmesg | egrep 'ath|firmware|FW'
[    2.067479] device-mapper: multipath: version 1.2.0 loaded
[    2.067509] device-mapper: multipath round-robin: version 1.0.0 loaded
[   17.982388] ath9k 0000:07:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
[   17.982414] ath9k 0000:07:00.0: setting latency timer to 64
[   18.059138] ath: EEPROM regdomain: 0x65
[   18.059148] ath: EEPROM indicates we should expect a direct regpair map
[   18.059159] ath: Country alpha2 being used: 00
[   18.059163] ath: Regpair used: 0x65
[   18.135916] ieee80211 phy0: Selected rate control algorithm 'ath9k_rate_control'
[   18.137536] Registered led device: ath9k-phy0::radio
[   18.137594] Registered led device: ath9k-phy0::assoc
[   18.137655] Registered led device: ath9k-phy0::tx
[   18.137712] Registered led device: ath9k-phy0::rx

To further explore I booted up into a Fedora 15 live CD. Everything seems smooth. It uses the 2.6.38 kernel as well with this ath9k driver pack. I ran into a problem though when I booted up into the live CD with the ethernet cable plugged in, and then unplugged it while in the session. System froze!

When I ran this dmesg command from the Fedora 15 live CD session there was some more information. There was an error suggesting a bug in the firmware of one of the Atheros devices, but I couldn't tell from the command if it was referring to the wired or wireless device. It referenced atl1c so I think that means the AR8152 firmware had the problem.

Could I have been blaming the wrong component all along? Perhaps there is no issue at all with the AR9285 wireless, and the AR8152 wired component is to blame for all these issues. It would make sense since the problem seems to occur when the cable is not plugged in or at the time the cable is unplugged. Does AR8152 have rotten firmware? If so, if I can't find new firmware to flash to it, will I have a way to disable the component entirely in Linux and just run wireless? Since it is a laptop, that would not be a big deal at all.

-> peut-être le souci vient-il plutôt de la carte réseau ethernet (puisque le freeze n'intervient que quand pas de câble branché au réseau)... Le souci persiste-t-il si on désactive totalement la carte réseau filaire? (basée elle sur le chipset AR8152, et qui utilise le pilote atl1c)


Still trying to run experiments, so I found out this piece. I boot up again into the 3.0 kernel with the ethernet cable plugged in so everything is fine. In the terminal I run the following command:

Code:

sudo modprobe -r atl1c

This disables the "Wired Connection". Now, if I unplug the ethernet cable, the system stays up! I can now use the laptop just without any network connectivity. This is somewhat better than being tethered to the cable...

Dernière modification par oliwek (Le 19/12/2011, à 16:31)

Hors ligne

#25 Le 19/12/2011, à 15:31

oliwek

Re : Impossible d'installer Ubuntu 11.04 ou 11.10

Donc une solution est de supprimer purement et simplement le chargement du pilote de la carte réseau (ethernet) qui cause le problème ; on n'a alors plus que le wifi pour se connecter. Cependant, le fix est réversible. Pour blacklister le chargement du pilote de la carte réseau filaire :


sudo su 
echo "blacklist atl1c" >> /etc/modprobe.d/blacklist.conf 
exit

(une ligne à la fois, ENTER après chaque ligne)


Toutefois, après un redémarrage, si un

lsmod

amène une liste où atl1c est toujours mentionné, alors faire :

gksudo gedit /etc/rc.local

et dans le fichier texte qui s'ouvre, coller :

modprobe -r athl1c

puis sauvegarder, fermer, et redémarrer sans câble ethernet pour tester


edit : le driver est bien, écrit en minuscules, ATL1C et non ATI1C, ne pas faire de typo entre un "l" minuscule et un "i" majuscule wink

Dernière modification par oliwek (Le 19/12/2011, à 15:46)

Hors ligne

Haut de page ↑