Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 21/08/2005, à 00:53

mat_chab

[Résolu] Grub ne s'installe pas...

Salut à tous,

Bon, j'ai bien essayé de faire quelques recherches sur le forum mais j'ai pas vraiment trouvé de solution adaptée, donc je me lance :

J'installe donc Utuntu en multiboot avec Windows XP sur mon PC. Tout se passe bien jusqu'à l'installation de Grub, il s'arrête à 50% et me dit que l'installation a échoué.
Comme je ne sait absolument pas d'où vient le problème, je vais vous donner des infos que j'espère utiles...

Partitions :
1 - ntfs primaire et zone d'amorçage (avec windows xp installé)
2 - ntfs logique
3 - fat32 logique (/windows en point de montage)
4 - ext3 logique (/ en point de montage)
5 - swap logique (de la même taille que ma ram (1024mo))

J'ai un AMD64 3400+ et j'utilise bien sûr la bonne version d'Ubuntu (5.04 pour AMD64) que je viens de télécharger sur ce site.

Pouvez vous m'aider ?
D'avance merci...

Dernière modification par mat_chab (Le 21/08/2005, à 13:40)

Hors ligne

#2 Le 21/08/2005, à 01:22

mythrys

Re : [Résolu] Grub ne s'installe pas...

ben là je vois pas d'ou ca peut venir (je suis pas un pro non plus)
déjà je peut te dire que la version i386 marche très bien sur les amd64

ensuite jsute comme ca t'a vérfié la somme md5 de ton iso du cd d'installation,
et sinon t'a déjà essayé une deuxième installation

(parce moi aussi ubuntu avait foiré à l'install puis j'ai recommencé et là tout allait bien)

Hors ligne

#3 Le 21/08/2005, à 01:29

mat_chab

Re : [Résolu] Grub ne s'installe pas...

Alors dans l'ordre :

Je ne sais absolument pas ce qu'est la somme md5, je suis un débutant en linux moi attention hein^^.

Ensuite oui j'ai essayé plusieurs installations, même avec des versions différentes (autre que celle pour AMD64, c'est dire).

Donc voilà, d'autre suggestions ?

Hors ligne

#4 Le 21/08/2005, à 02:00

Haikai

Re : [Résolu] Grub ne s'installe pas...

Ton problème vient de ce que la partition où est montée / est une partition logique.
Soit tu reformates pour en faire une primaire, soit tu crées une nouvelle partition primaire (50 ou 60 Mo devrait suffire) pour y monter /boot. Mais le mieux c'est encore de monter / sur une partition primaire. Grub ne peut en tous les cas pas être installé sur une partition logique. Voilà.

Dernière modification par Haikai (Le 21/08/2005, à 02:01)

Hors ligne

#5 Le 21/08/2005, à 13:39

mat_chab

Re : [Résolu] Grub ne s'installe pas...

Okay ça marche merci de votre aide...

Hors ligne

#6 Le 26/08/2005, à 21:37

guymauve

Re : [Résolu] Grub ne s'installe pas...

Bonjour,

J'ai également le problème et je ne l'ai pas vu dans la documentation.

Que dois installer en logique et que dois-je installer en primaire ???

Home en primaire

/ en ???

Swap ???

Merci à vous et bonne journée.

#7 Le 26/08/2005, à 21:47

tomtom

Re : [Résolu] Grub ne s'installe pas...

je crois avoir déja écrit ca sur le forum, mais je suis dans un bon jour !
Je vais te dire comment j'ai installé tout ca, ca te donnera un exemple

créer un /boot en primaire, ext2 et valider "Indications d'amorcage"  (en gros, c'est le noyau linux, c pas con de le séparer du reste)
créer une /swap, en primaire, méthode d'utilisation : utiliser comme espace d'échange
créer un /home, en logique, en ReiserFS
créer un /usr, en logique, en ReiserFS  (dossier ou s'installent tous les logiciels, c pas trop con de mettre ca sur une partoche séparée !!!)
créer un /, en logique, en ReiserFS

Hors ligne

Haut de page ↑