Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 22/05/2005, à 00:24

ptitsuissenature

[resolu] ma tablette wacom fonctionne bizarrement :)

Bonjour,
Je tente de faire fonctionner ma tablette... En fait elle est detectée, tout marche a peu près à ce niveau là, sauf je ne sais pas où la parametrer.
Je ne peux utiliser qu'à peine un 1/4 de la surface... elle est déja pas bien grande... smile
Je ne trouve pas non plus quel mode indiquer dans le xorg.conf pour ne pas la mettre en relatif mais en absolu. (euh absolute ca ne marche evidement pas hein).
On peut lire un peu partout que les wacoms ne posent pas de probleme particulier, et, sans remettre en cause votre enthousiame, qu'est ce que vous appeler une tablette qui marche ? Une tablette detectée qui fait bouger le curseur à l'écran ? Ou puis-je m'archarner pour essayer de la faire fonctionner comme je veux ?
Si des gens ont deja installé des wacom, leur avis m'interesse smile
merci, bonui

Dernière modification par ptitsuissenature (Le 23/05/2005, à 23:38)

Hors ligne

#2 Le 22/05/2005, à 09:25

Gzyg

Re : [resolu] ma tablette wacom fonctionne bizarrement :)

Tu peux aller faire un tour dans la section recherche du forum en tapant juste wacom ... tu te sentiras moins seul !
Perso je diffère cet achat jusqu'à ce qu'il existe une solution "SIMPLE" (genre config modem usb , webcam , ...) roll

Bon courage !

à plus

Gzyg

Hors ligne

#3 Le 22/05/2005, à 22:46

ptitsuissenature

Re : [resolu] ma tablette wacom fonctionne bizarrement :)

salut,
oui je crois que je vais abandonner lol
j ai deja cherche un peu partout sur internet, les 3/4 des ressources ont plus l air destine aux problemes materiels, mais rien sur la configuration logicielle.
merci pour ta reponse.
ciao

Hors ligne

#4 Le 23/05/2005, à 04:15

Grenshad

Re : [resolu] ma tablette wacom fonctionne bizarrement :)

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/input/event3"   # USB ONLY
  Option        "Type"          "cursor"
  Option        "KeepShape"     "on"
  Option        "USB"           "on"                  # USB ONLY
#  Option       "TopX"          "0"
#  Option       "TopY"          "0"
#  Option       "BottomX"       "1400"
#  Option       "BottomY"       "1050"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/input/event3"   # USB ONLY
  Option        "Type"          "stylus"
  Option        "Mode"          "Absolute"
  Option        "KeepShape"     "on"
  Option        "USB"           "on"                  # USB ONLY
  Option        "Button1"       "1"
  Option        "Button2"       "2"
  Option        "Button3"       "4"
#  Option       "TopX"          "0"
#  Option       "TopY"          "0"
#  Option       "BottomX"       "1400"
#  Option       "BottomY"       "1050"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/input/event3"   # USB ONLY
  Option        "Type"          "eraser"
  Option        "Mode"          "Absolute"
  Option        "KeepShape"     "on"
  Option        "USB"           "on"                  # USB ONLY
#  Option       "TopX"          "0"
#  Option       "TopY"          "0"
#  Option       "BottomX"       "1400"
#  Option       "BottomY"       "1050"
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
        InputDevice     "cursor"    "SendCoreEvents"
        InputDevice     "stylus"    "SendCoreEvents"
        InputDevice     "eraser"    "SendCoreEvents"
EndSection

Un extrait de mon /etc/X11/xorg.conf pour mon Intuos 2 A4, les options KeepShape permettent de garder une proportion de tablette utilisable pour avoir le même ratio que sur l'écran, Mode Absolute sert donc à choisir le mode absolu (on pointe un point de la tablette qui correspond au memes coordonnées sur l'écran), Type sert a définir de quel outil on parle (le stylet, le côté gomme ou la souris wacom), les Top et Bottom facultatifs permettent de définir la zone active à l'écran,Device sert à pointer vers le matériel (si c'est pas le bon, rien n'est pris en compte).
Sinon j'utilise des tablettes wacom depuis longtemps sous Linux (Mandrake 9.1 jusqu'a aujourd'hui sous Ubuntu Hoary) avec des modèles variés, artpad série, graphire usb, Intuos 2 usb. A part quelques noyaux où le support des tablettes était cassé (Warty par exemple), la plupart du temps il n'y a qu'a rajouter quelques lignes dans le fichier de config de X.

Hors ligne

#5 Le 23/05/2005, à 23:37

ptitsuissenature

Re : [resolu] ma tablette wacom fonctionne bizarrement :)

han
trop un grand merci smile
ca marche trop bien smile

Hors ligne

#6 Le 24/05/2005, à 14:11

Grenshad

Re : [resolu] ma tablette wacom fonctionne bizarrement :)

ça me fait plaisir wink

Hors ligne

#7 Le 30/08/2005, à 07:08

Brice_de_Paris

Re : [resolu] ma tablette wacom fonctionne bizarrement :)

Bonjour,
Petite question de new newbie : Comment on fait pour ajouter ces lignes à mon xorg.conf ?
MErci !

#8 Le 30/08/2005, à 09:28

Mathieu147

Re : [resolu] ma tablette wacom fonctionne bizarrement :)

D'abord faire un backup:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup

comme ça si tu foires tu n'as qu'a faire

sudo cp /etc/X11/xorg.conf.backup /etc/X11/xorg.conf

Ensuite tu fais

sudo gedit /etc/X11/xorg.conf

tu changes ce qu'il faut, t'enregistres, tu fermes, et voilà smile

N'oublie pas de redmérarrer le serveur X pour voir les modifications: ctrl+alt+backspace


Pffff…

Hors ligne

Haut de page ↑