Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 29/08/2005, à 13:49

Maxime Seguin

[Résolu] Probléme d'affichage premier lancement

J'ai installé Ubuntu sur mon mac mini.
Tout se passe bien jusqu'au premier lancement du serveur X où j'obtient ceci:

plantage.jpg

La carte graphique est une ATI Radeon 9200 AGP
J'ai essayé les explications postées sur le forum mais à part planter le serveur X ça n'a pas donné grand chose.
Savez vous ce qu'il faut faire ?

Merci d'avance.

#2 Le 29/08/2005, à 14:38

Nanal

Re : [Résolu] Probléme d'affichage premier lancement

Une solution temporaire consiste à changer les drivers utilisés par Xorg pour l'affichage.

Pour cela tu dois :
-ouvrir un terminal de connexion via les touches crtl+alt+F1

-te logger avec ton login et ton mot de passe

-fermer gdm via la commande : sudo killall gdm (tu devras redonner ton mot de passe)

-éditer le fichier Xorg avec la commande : sudo nano -w /etc/X11/Xorg.conf (ou xorg.conf je ne me souviens plus mais tu peux utiliser l'autocomplétion avec la touche tabulation.) et à la ligne Drivers de la section Device (autrement dit la carte graphique) mettre le driver vesa (ce qui donne Drivers  "vesa")

-tu sauvegardes le tout (crtl+x)

-tu relances gdm via la commande : sudo gdm

Tu devrais avoir accés à un mode graphique basique mais néanmoins utile pour chercher une réponse plus compléte.


Avatar : "the mirror of the sun" by bernie (deviantart.com)

Hors ligne

#3 Le 29/08/2005, à 14:46

LR

Re : [Résolu] Probléme d'affichage premier lancement

Salut, j'ai eu exactement le même problème au premier démarrage. En plus, le clavier ne répondait plus.

J'ai donc du faire reset, démarrer en mode recovery, éditer mon /etc/X11/xorg.conf. Dans la section "Screen", DefaultDepth était à 24 et c'était ça le problème, j'ai mis une résolution plus basse (16 par ex.), lancé gdm et l'affichage est devenu lisible.

A+Lilian

Hors ligne

#4 Le 29/08/2005, à 17:46

Maxime Seguin

Re : [Résolu] Probléme d'affichage premier lancement

Merci pour vos réponses.
Il m'a suffit de changer la valeur de "DefaultDepth"

@+ Maxime

#5 Le 29/08/2005, à 18:46

Maxime Seguin

Re : [Résolu] Probléme d'affichage premier lancement

J'ai maintenant un affichage qui fonctionne.
Je vous écrit d'ailleur de la Ubuntu.
J'ai fait kes mises à jour.

Je suis bloqué en 800*600.
Gnome ne propose pas de résolutions plus élevées et la qualité d'affichage est médiocre (aspet peau d'orange).
La carte graphique ATI 9200 AGP du Mac Mini doit pourtant pouvoir supporter des résolutions plus élevées.

Avez vous une réponse à mon probléme ?

Merci d'avance.

#6 Le 29/08/2005, à 19:13

LR

Re : [Résolu] Probléme d'affichage premier lancement

Je suis désolé, je ne peux pas t'aider plus car je ne me rappelle plus ce que j'ai fait finalement pour avoir un affichage de bonne qualité.

A toutes fins utiles, voici mon xorg.conf.

A+Lilian

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
#   cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
#   sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
#   sudo dpkg-reconfigure xserver-xorg

Section "Files"
	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"
        # paths to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "ServerFlags"
    Option "Xinerama"
EndSection

Section "Module"
	Load	"GLcore"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"type1"
	Load	"v4l"
	Load	"vbe"
EndSection

Section "Extensions"

 Option "RENDER" "Enable" 

EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"FR_ch"
	Option		"XkbOptions"	"fr_CH"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"ZAxisMapping"		"4 5"
EndSection

#Section "Device"
#	Identifier	"ATI Technologies, Inc. Radeon 9200 SE (RV280)"
#	Driver		"radeon"
#	BusID		"PCI:1:0:0"
#	Option		"UseFBDev"		"true"
#	Option "UseInternalAGPGART" "no"
#EndSection
Section "Device"

	Identifier	"ATI Technologies, Inc. Radeon 9200 SE (RV280)"

	Driver      	"radeon"

#	Option      	"AGPMode" "4"

#	Option 		"AGPSize" "64" # default: 8

#    	Option 		"RingSize" "8"

#    	Option 		"BufferSize" "2"

#    	Option 		"EnablePageFlip" "true"

#    	Option 		"EnableDepthMoves" "true"

    	Option 		"RenderAccel" "true"
	BusID		"PCI:1:0:0"


    Option "DDCMode" "on"
    Option "DPMS
    Screen 0

EndSection

Section "Device"

	Identifier	"ATI Technologies, Inc. Radeon 9200 SE (RV280)2"

	Driver      	"radeon"

    	Option 		"RenderAccel" "true"
	BusID		"PCI:1:0:0"


    Option "DDCMode" "on"
    Option "DPMS
    Screen 1

EndSection

Section "Monitor"
	Identifier	"BenQ"
	Option		"DPMS"
	HorizSync	28-64
	VertRefresh	43-60
	Modeline	"1280x800@60" 83.91 1280 1312 1624 1656 800 816 824 841
EndSection

Section "Monitor"
	Identifier	"Sony"
	Option		"DPMS"
	HorizSync	28-64
	VertRefresh	43-60
	#Modeline	"1024x768@75" 83.91 1280 1312 1624 1656 800 816 824 841
	#Modeline 	"1024x768@100" 113.309 1024 1096 1208 1392 768 769 772 814 +hsync +vsync
	#Modeline	"1152x864@75" 108.00   1152 1176 1304 1484 864 873 876 912 +hsync +vsync
	Modeline	"1280x800@60" 83.91 1280 1312 1624 1656 800 816 824 841
EndSection

Section "Screen"
	Identifier	"Screen0"
	Device		"ATI Technologies, Inc. Radeon 9200 SE (RV280)"
	Monitor		"BenQ"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection



Section "Screen"
    Identifier "Screen1"
    Device "ATI Technologies, Inc. Radeon 9200 SE (RV280)2"
    Monitor "Sony"
    DefaultColorDepth 24
    Subsection "Display"
        Depth 24
#        Virtual 1280 1024
        Modes    "1024x768"#1152x864 
    EndSubsection    
EndSection



#Section "ServerLayout"
#	Identifier	"Default Layout"
#	Screen		"Default Screen"
#	InputDevice	"Generic Keyboard"
#	InputDevice	"Configured Mouse"
#EndSection

Section "ServerLayout"
    Identifier "Multihead layout"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
    Screen  "Screen0" 0 0
    Screen  "Screen1" RightOf "Screen0" 
EndSection

Section "DRI"
	Mode	0666
EndSection

Hors ligne

#7 Le 29/08/2005, à 21:32

Maxime Seguin

Re : [Résolu] Probléme d'affichage premier lancement

Merci.
J'ai réussi à passer en 1024x768 en ajoutant des lignes de ton fichier.
Par contre la qualité reste toujours médiocre.
Je me demande si ça n'a pas un rapport avec "DefaultDepth".
SI quelqu'un a une idée, merci d'avance.

@+ Maxime

#8 Le 29/08/2005, à 21:50

Maxime Seguin

Re : [Résolu] Probléme d'affichage premier lancement

Je viens de résoudre le probléme de qualité en remetant la valeur de "DefaultDepth" à 24.
C'est paradoxal car c'est ce qui me causait l'affichage illisible du début, j'avais été obligé de
passer en "DefaultDepth" 8.
Je ne sais donc pas quelle option a permis de remttre la valeur 24.
Tout ce que je sais c'est que ça fonctionne.
Je poste donc mon fichier /etc/X11/xorg.conf qui fonctionne pour mon Mac Mini.
Si ça peut aider quelqu'un d'autre j'en serais ravis.

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
#   cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
#   sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
#   sudo dpkg-reconfigure xserver-xorg

Section "Files"
	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"
        # paths to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"type1"
	Load	"vbe"
EndSection

Section "Extensions"
	Option "RENDER" "Enable"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr"
	Option		"XkbOptions"	"lv3:lwin_switch"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
EndSection

Section "Device"
	Identifier	"ATI Technologies, Inc. Radeon 9200 (RV280)"
	Driver		"radeon"
	BusID		"PCI:0:16:0"
#	Option		"UseFBDev"		"true"
	Option		"RenderAccel"		"true"
	Option		"DDCMode"		"on"
	Option		"DPMS
	
EndSection

Section "Monitor"
	Identifier	"HP 52 Monito"
	Option		"DPMS"
	HorizSync	30-54
	VertRefresh	50-120
	Modeline	"1024x768@75" 83.91 1280 1312 1624 1656 800 816 824 841
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Technologies, Inc. Radeon 9200 (RV280)"
	Monitor		"HP 52 Monito"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1024x768" "960x720" "800x600" "640x480" "640x400"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1024x768" "960x720" "800x600" "640x480" "640x400"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1024x768" "960x960" "960x720" "800x600" "640x480" "640x400"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1024x768" "960x720" "800x600" "640x480" "640x400"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1024x768" "960x720" "800x600" "640x480" "640x400"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1024x768" "960x720" "800x600" "640x480" "640x400"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "DRI"
	Mode	0666
EndSection

Si vous utilisez ce fichier n'ouibliez pas de faire une sauvegarde de l'ancien.
On sait jamais, ça vous évitera les méandres de:

sudo dpkg-reconfigure xserver-xorg

@+ Maxime

#9 Le 29/08/2005, à 23:33

LR

Re : [Résolu] Probléme d'affichage premier lancement

Je pense que ton fichier configurait mal la carte graphique, de sorte qu'elle n'était pas capable de gérer correctement un affichage en 24 millions de couleurs (je crois que c'est ça "Depth").

Ensuite, quand tu l'as modifié, la résolution maximale était supportée.

Enfin c'est comme ça que je le comprend wink

Hors ligne

#10 Le 30/08/2005, à 18:07

Maxime Seguin

Re : [Résolu] Probléme d'affichage premier lancement

Hmm... Oui, ça doit être ça.

Haut de page ↑