Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#26 Le 21/10/2010, à 21:04

ToToF_run

Re : [Résolu] module CM15pro

peut être un :

sudo apt-get install build-essential linux-headers-$(uname -r)

Hors ligne

#27 Le 22/10/2010, à 14:17

Nigoo

Re : [Résolu] module CM15pro

Bonjour,

Merci ToToF_run pour ta réponse. Je viens d'essayer, mais malheureusement toujours pareil ; même erreur ! Si tu as d'autres idées je suis preneur car sans ce driver, je ne peux rien faire et je n'ai vraiment pas envi de passer le PC sur microsoft ça va toujours planter !! smile

Merci d'avance

Amicalement,
Nigoo

Hors ligne

#28 Le 08/11/2010, à 10:59

ashema

Re : [Résolu] module CM15pro

Bonjour, je débute en domotique et en linux. Je suis bloqué après le insmod CM15a.ko. J'utilise une version usb live de ubuntu 10.10 avec une persistance de 200mo (un ubuntu sur une clef bootable, cela me permet de tester)

Pour la compilation du driver, je suis en 32bits, j'ai remplacé le /linux/autoconfig.h par /generated/autoconfig.h pour que cela fonctionne.
J'obtiens bien un cm15a.ko avec plusieurs warnings( la signature de certaines fonctions a changé) mais ça fonctionne

Ensuite quand je fais le dmesg , j'ai  :

usbcore: registered new interface driver cm15a
X10 CM15A USB Driver v0.03

par contre je ne vois rien dans /dev. J'ai essayé de faire rmmod pour supprimer, à nouveau insmod mais cela ne fonctionne pas. Je ne vois toujours rien.

Devrais je recompiler une version sans warning? existe-t-il un moyen de monter correctement le device ?

Merci de m'eclairer ^^

Hors ligne

#29 Le 16/11/2010, à 17:05

cbloo

Re : [Résolu] module CM15pro

un lsusb te donne quoi ?

Lors de ton insmod cm15a.ko pas d'erreur ?


www.coolbytes.fr
Multigaming et entraide informatique
Tw: @cbloo

Hors ligne

#30 Le 25/11/2010, à 17:43

ashema

Re : [Résolu] module CM15pro

quand je fais lsusb, je ne vois à aucun moment mon cm15 dans les device usb possible et quand je fais insmod je n'ai d'erreur.

Hors ligne

#31 Le 06/12/2010, à 22:45

cbloo

Re : [Résolu] module CM15pro

tu as un cm15a dans ton /dev ?

Si oui, fais un chmod 777 dessus.


www.coolbytes.fr
Multigaming et entraide informatique
Tw: @cbloo

Hors ligne

#32 Le 01/04/2011, à 12:36

xunil2003

Re : [Résolu] module CM15pro

Bonjour,

Voila comment j'ai installé mon cm15 Pro Marmitek.

[root@localhost linux-2.6]# make -f Makefile.cm15a                                     
make -C /lib/modules/2.6.31.14-desktop-1mnb/build  SUBDIRS=/home/serveur/iplc/driver/linux-2.6 modules                                                                                   
make[1]: entrant dans le répertoire « /usr/src/linux-2.6.31.14-desktop-1mnb »               
  Building modules, stage 2.                                                                 
  MODPOST 0 modules                                                                         
make[1]: quittant le répertoire « /usr/src/linux-2.6.31.14-desktop-1mnb »
[root@localhost linux-2.6]#

[root@localhost linux-2.6]# make cm15a                                                       
make -C /lib/modules/2.6.31.14-desktop-1mnb/build/ SUBDIRS=/home/serveur/iplc/driver/linux-2.6/cm15a.d modules                                                                           
make[1]: entrant dans le répertoire « /usr/src/linux-2.6.31.14-desktop-1mnb »               
  CC [M]  /home/serveur/iplc/driver/linux-2.6/cm15a.d/cm15a.o                               
/home/serveur/iplc/driver/linux-2.6/cm15a.d/cm15a.c: In function '__check_read_buffer_size':
/home/serveur/iplc/driver/linux-2.6/cm15a.d/cm15a.c:280: attention : return from incompatible pointer type                                                                               
/home/serveur/iplc/driver/linux-2.6/cm15a.d/cm15a.c: In function '__check_write_buffer_size':
/home/serveur/iplc/driver/linux-2.6/cm15a.d/cm15a.c:284: attention : return from incompatible pointer type                                                                               
/home/serveur/iplc/driver/linux-2.6/cm15a.d/cm15a.c: In function 'read':                     
/home/serveur/iplc/driver/linux-2.6/cm15a.d/cm15a.c:692: attention : format '%d' expects type 'int', but argument 3 has type 'size_t'                                                     
/home/serveur/iplc/driver/linux-2.6/cm15a.d/cm15a.c: In function 'interrupt_in_callback':   
/home/serveur/iplc/driver/linux-2.6/cm15a.d/cm15a.c:905: attention : format '%d' expects type 'int', but argument 4 has type 'size_t'                                                     
/home/serveur/iplc/driver/linux-2.6/cm15a.d/cm15a.c:905: attention : format '%d' expects type 'int', but argument 5 has type 'size_t'                                                     
  Building modules, stage 2.                                                                 
  MODPOST 1 modules                                                                         
  CC      /home/serveur/iplc/driver/linux-2.6/cm15a.d/cm15a.mod.o                           
  LD [M]  /home/serveur/iplc/driver/linux-2.6/cm15a.d/cm15a.ko                               
make[1]: quittant le répertoire « /usr/src/linux-2.6.31.14-desktop-1mnb »                   
[root@localhost linux-2.6]#

                   
Je change de repertoire                   

[root@localhost linux-2.6]# cd cm15a.d
[root@localhost cm15a.d]#

j'execute insmod

[root@localhost cm15a.d]# insmod cm15a.ko
[root@localhost cm15a.d]#

Je verifie suis le driver est installer

[root@localhost cm15a.d]# ls /dev/cm*   
/dev/cm15a0
[root@localhost cm15a.d]#

maintenant je test un ordre domotique en perl avec un fichier nommé  : cm15_A2.pl

[serveur@localhost perl_cm15]$ perl cm15_A2.pl
Module cm15a.ko non charge Permission non accordée at cm15_A2.pl line 4.

Cela ne fonctionne pas je chmod mon repertoire /dev

[root@localhost perl_cm15]# chmod 777 -R /dev
[root@localhost perl_cm15]#

Maintenant que mon repertoire /dev est chmodé, je refait un test est la , la lunmiere s'allume, a comme je suis heureux..

[serveur@localhost perl_cm15]$ perl cm15_A2.pl
[serveur@localhost perl_cm15]$

Voila ce qu'il y a dans mon fichier "cm15_A2.pl"

#!/usr/bin/perl -w
use Fcntl;

sysopen( CM15A, "/dev/cm15a0", O_RDWR |O_NOCTTY | O_NONBLOCK ) || die "Module cm15a.ko non charge $!";
syswrite CM15A, pack( "CC", 4, 0x6E ), 2;
sleep 1;        # can be less
syswrite CM15A, pack( "CC", 6, 0x62 ), 2;      # ON
#syswrite CM15A, pack( "CC", 6, 0x63 ), 2;       # OFF
close( CM15A );

Le probleme est que mon driver ne reste pas en memoire, lorsque je l'arrêt ou le redemarre, il faut que je réinstall le driver a chaque fois !

Quand je fait un lsmod voila ce qu'il m'affiche

Module                  Size  Used by                                                        
cm15a                  17696  0

Dans dmesg j'ai ceci :

usb 5-2: New USB device found, idVendor=0bc7, idProduct=0001                                                                                 
usb 5-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0                                                                            
usb 5-2: Product: USB ActiveHome Interface                                                                                                   
usb 5-2: Manufacturer: X10 Wireless Technology Inc                                                                                           
usb 5-2: configuration #1 chosen from 1 choice

Extrait de lsusb

Bus 005 Device 002: ID 0bc7:0001 X10 Wireless Technology, Inc. ActiveHome (ACPI-compliant)

Extrait de  cat

$  cat /proc/bus/usb/devices
T:  Bus=05 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  2 Spd=1.5 MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1     
P:  Vendor=0bc7 ProdID=0001 Rev= 1.00                            
S:  Manufacturer=X10 Wireless Technology Inc                     
S:  Product=USB ActiveHome Interface                             
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=  2mA                           
I:* If#= 0 Alt= 0 #EPs= 2 Cls=00(>ifc ) Sub=00 Prot=00 Driver=cm15a
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=10ms                       
E:  Ad=02(O) Atr=03(Int.) MxPS=   8 Ivl=10ms         

La version de mon kernel

# uname -r
2.6.31.14-desktop-1mnb

J'ai fait une recherche sur google pour avoir les codes de transmission  du cm15 je n'ai rien trouvé bizarement
J'ai besoin des code de A1 à P16
Je sais que pour :
A2 on = 6, 0x62
A2 off = 6, 0x63

Est la ce n'est pas indiquer  pour le on et off, bazarement cela ne corespond pas a ceux indiqué ci dessus ?
A1 0x66
A2 0x6E
A3 0x62
A4 0x6A
A5 0x61
A6 0x69
A7 0x65
A8 0x6D
A9 0x67
A10 0x6F
A11 0x63
A12 0x6B
A13 0x60
A14 0x68
A15 0x64
A16 0x6C

Es-ce que quelqu'un peut m'aider a avoir cette liste de code, connaisez vous un site qui donne la liste ?

Merci d'avance, cordialement. Xunil2003

Dernière modification par xunil2003 (Le 02/04/2011, à 08:41)


- Intel Pentium I7 960 / 12 Go de Ram - 6 HDD de 2 T0 - Kubuntu & Ubuntu 12.04 x64 / Mageia 2 x64 / Windows 7 x64 / Lamp...
- DreamPlug Multi Boot / Marvel 1.22 Ghz / Architecture ARM / 512 Mo Ram / Carte-sd 16 Go class 10 / 5 Watts / Debian Squeeze 2.6.39.4 ----> http://www.newit.co.uk/shop/proddetail. … ream_Multi ----> appellé également plug computer
JE SUIS CHARLIE

Hors ligne

#33 Le 16/07/2011, à 18:19

fgomes

Re : [Résolu] module CM15pro

Nigoo a écrit :

Bonsoir,

Je suis sous la version 10.4 LTS de Ubuntu et quand j'essaye d'installer le driver du CM15 Pro, j'ai l'erreur suivante :

nh@Nigoo-Home-Serveur:~/iplc/driver/linux-2.6/cm15a.d$ sudo make
make -C /lib/modules/2.6.32-25-generic/build  SUBDIRS= modules
make[1]: entrant dans le répertoire « /usr/src/linux-headers-2.6.32-25-generic »
  CHK    include/linux/version.h
  CHK    include/linux/utsrelease.h
  SYMLINK include/asm -> include/asm-x86
make[2]: *** Pas de règle pour fabriquer la cible « kernel/bounds.c », nécessaire pour « kernel/bounds.s ». Arrêt.
make[1]: *** [prepare0] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux-headers-2.6.32-25-generic »
make: *** [default] Erreur 2
nh@Nigoo-Home-Serveur:~/iplc/driver/linux-2.6/cm15a.d$

Si quelqu'un  a une idée et peut éventuellement me donner un coup de pouce se serait sympa. Je continue à chercher de mon côté. smile

Amicalement,
Nigoo.

Bonjour,
Avez vous trouvé une solution pour ce problème ? je suis dessus depuis 2 heures et je bloque complet !
Merci de votre aide ...

Domotiquement,

Hors ligne

#34 Le 09/10/2011, à 08:57

Arnaud80

Re : [Résolu] module CM15pro

Le make doit se faire dans le dossier : ~/iplc/driver/linux-2.6

Hors ligne

#35 Le 04/01/2012, à 12:20

nemo136

Re : [Résolu] module CM15pro

Bonjour, pour ceux qui possèdent ce module et qui ralent de ne pas pouvoir envoyer d'ordres étendus, il existe maintenant une petite appli, mochad, qui fonctionne parfaitement pour le CM15pro, évite d'avoir à insérer des modules noyau et surtout supporte les commandes dim et bright...

Dernière modification par nemo136 (Le 04/01/2012, à 12:20)

Hors ligne

#36 Le 05/01/2012, à 20:22

xunil2003

Re : [Résolu] module CM15pro

Bonjour,

J'ai des questions à vous posez sur le cm15 avec linux.
1/  Comment faite vous pour créer des macros pour le cm15 ?
2/ Comment faite vous pour envoyer les macros dans le cm15 ?

Merci.


- Intel Pentium I7 960 / 12 Go de Ram - 6 HDD de 2 T0 - Kubuntu & Ubuntu 12.04 x64 / Mageia 2 x64 / Windows 7 x64 / Lamp...
- DreamPlug Multi Boot / Marvel 1.22 Ghz / Architecture ARM / 512 Mo Ram / Carte-sd 16 Go class 10 / 5 Watts / Debian Squeeze 2.6.39.4 ----> http://www.newit.co.uk/shop/proddetail. … ream_Multi ----> appellé également plug computer
JE SUIS CHARLIE

Hors ligne

#37 Le 08/01/2012, à 18:16

cbloo

Re : [Résolu] module CM15pro

Salut Xunil,

Qu entends-tu par macro ?

Tu cites plus haut les script en perl. Apres tu n'a plus vraiment de limite, juste ton imagination smile

Avec ces scripts tu peux définir tous les scénario que tu veux.


www.coolbytes.fr
Multigaming et entraide informatique
Tw: @cbloo

Hors ligne

#38 Le 16/04/2012, à 19:14

xunil2003

Re : [Résolu] module CM15pro

Bonjour,

Je ne comprend pas y a rien qui fonctionne.

Mon pilote cm15 est bien installé, je l'ai chmodé  "chmod -R 777 /dev/cm15a0"

root@debian:/home/serveur/x10/perl# ls -alF /dev/cm15*
crw------- 1 root root 180, 252 Apr 16 17:45 /dev/cm15a0
root@debian:/home/serveur/x10/perl#
root@debian:/home/serveur/x10/perl# dmesg | grep cm15
usbcore: registered new interface driver cm15a
root@debian:/home/serveur/x10/perl#

J'ai branché un AM12 sur une prise sur  A4 et avec ce script perl , y a rien qui marche ?

 root@debian:/home/serveur/x10/perl# cat cm15-A4.pl
    #!/usr/bin/perl -w
    use Fcntl;

    sysopen( CM15A, "/dev/cm15a0", O_RDWR |O_NOCTTY | O_NONBLOCK ) || die "Module cm15a.ko non charge $!";
    syswrite CM15A, pack( "CC", 4, 0x6A ), 2;
    sleep 1;        # can be less
    syswrite CM15A, pack( "CC", 6, 0x6A ), 2;      # ON
    #syswrite CM15A, pack( "CC", 6, 0x63 ), 2;       # OFF
    close( CM15A );
root@debian:/home/serveur/x10/perl#
;

Rien ne ce met en marche, pourtant perl exécute correctement le script.

root@debian:/home/serveur/x10/perl# perl cm15-A4.pl
root@debian:/home/serveur/x10/perl#

J'ai installé "cm15ademo" est la le module AM12  ce met en marche et s'arrête comme ceci

root@debian:/home/serveur/x10/perl# cm15 a4 on
root@debian:/home/serveur/x10/perl#
root@debian:/home/serveur/x10/perl# cm15 a4 off
root@debian:/home/serveur/x10/perl#

Comment faite vous avec perl  ? 
Y a un truc que j'ai pas du pigé .
Pouvez vous m'expliquer ou est le problème dans le code de Perl ?

Merci.

Dernière modification par xunil2003 (Le 17/04/2012, à 19:32)


- Intel Pentium I7 960 / 12 Go de Ram - 6 HDD de 2 T0 - Kubuntu & Ubuntu 12.04 x64 / Mageia 2 x64 / Windows 7 x64 / Lamp...
- DreamPlug Multi Boot / Marvel 1.22 Ghz / Architecture ARM / 512 Mo Ram / Carte-sd 16 Go class 10 / 5 Watts / Debian Squeeze 2.6.39.4 ----> http://www.newit.co.uk/shop/proddetail. … ream_Multi ----> appellé également plug computer
JE SUIS CHARLIE

Hors ligne

#39 Le 26/04/2012, à 11:17

GilH94

Re : [Résolu] module CM15pro

Bonjour,

Juste pour info, je commence à traiter le sujet. Je me suis donc fais un fichier récapitulatif des informations glané ci dessous,voici le lien du document => https://docs.google.com/document/d/1tGt … BpyRI/edit

Cdlt,

Hors ligne

#40 Le 20/08/2012, à 19:56

ToToF_run

Re : [Résolu] module CM15pro

Bonsoir,
tiens le site osmium-76.fr c'est le mien smile ça fait plaisir que ça puisse aider smile
Alors pour les warning dans la compile je galère pas mal mais j'ai réussi à modifier pour que ça fonctionne sous des noyaux 3.0 ...
Dès que j'ai un peu plus de temps je fais une MaJ je vous invite à regarder sur site domotique
Sinon pour les problèmes autres faut être un peu plus précis sinon ça va être galère de vous aider.
Par exemple pour xunil2003 je pense que ton problème vient du choix du module que tu veux commander voir page 1 ... et modifier le code Hexa pour choisir le bon module A1 A2 etc...

Hors ligne

#41 Le 21/08/2012, à 15:23

xunil2003

Re : [Résolu] module CM15pro

Bonjour,

J'ai retesté sur A2 avec un AM12 avec le code perl suivant
J'ai modifié le code perl pour qu'il m'affiche à l'ècran quand il est passé en On ou Off avec une pause de 5 secondes entre le On et le Off.

    #!/usr/bin/perl -w
    use Fcntl;
    use strict;
    use warnings;

    #----- Déclaration des variables -----
    my $on = "A2 On";
    my $off = "A2 Off";
    my $temps = "5"; # Pause en secondes

    #----- Vérification du module et activation commande x10 -----
    sysopen( CM15A, "/dev/cm15a0", O_RDWR |O_NOCTTY | O_NONBLOCK ) || die "Module cm15a.ko non charge $!";
    syswrite CM15A, pack( "CC", 6, 0x6A ), 2;      # ON
    print "$on activé \n";

    #----- Mise en attente avec affichage a l'ècran -----
    print "En pause $temps secondes\n";
    sleep $temps ; # pause 
    print "Fin de la pause\n";

    #----- Activation commande x10 -----
    syswrite CM15A, pack( "CC", 6, 0x63 ), 2;       # OFF
    close( CM15A ); 
    print "$off activé \n";
serveur@debian:~/x10/perl$ perl cm15-A2.pl
A2 On activé 
En pause 5 secondes
Fin de la pause
A2 Off activé 
serveur@debian:~/x10/perl$ 

Mais y a tjr rien qui fonctionne,  ça marche pas bizare ???????????

et la ça marche  avec cm15ademo

serveur@debian:~/x10/perl$ cm15 a2 on
serveur@debian:~/x10/perl$ 
serveur@debian:~/x10/perl$ cm15 a2 off
serveur@debian:~/x10/perl$ 

Et la aussi ça marche avec (cm15ademo) cm15a dans perl
J'ai copié et renommé cm15 en cm15a dans /usr/bin pour faire un test.

# cp -v /urr/bin/cm15 /usr/bin/cm15a

Puis je l'ai chmodé en 777

# chmod 777 /usr/bin/cm15a

Détail

serveur@debian:~/x10/perl$ ls -alF /usr/bin/cm15*
-rwsr-sr-x 1 root root 106335  7 avril 23:13 /usr/bin/cm15*
-rwxrwxrwx 1 root root 106335 21 août  17:15 /usr/bin/cm15a*
serveur@debian:~/x10/perl$ 

cm15ademo avec perl

    #!/usr/bin/perl -w
    use Fcntl;
    use strict;
    use warnings;

    #----- Déclaration des variables -----
    my $on = "A2 On";
    my $off = "A2 Off";
    my $temps = "5"; # Pause en secondes

    #----- Vérification du module et activation commande x10 -----
    sysopen( cm15a, "/usr/bin/cm15a", O_RDWR |O_NOCTTY | O_NONBLOCK ) || die "Module cm15a non chargé dans /usr/bin $!";
    system "/usr/bin/cm15 $on";      # ON
    print "$on activé \n";

    #----- Mise en attente avec affichage a l'ècran -----
    print "En pause $temps secondes\n";
    sleep $temps ; # pause 
    print "Fin de la pause\n";

    #----- Activation commande x10 -----
    system "/usr/bin/cm15 $off";       # OFF
    close( cm15a ); 
    print "$off activé \n";

Mais avec  perl et le binaire, rien fonctionne
J'y comprend plus rien ???????????????????????? HELP MAYDAY !

Merci.

Dernière modification par xunil2003 (Le 21/08/2012, à 18:13)


- Intel Pentium I7 960 / 12 Go de Ram - 6 HDD de 2 T0 - Kubuntu & Ubuntu 12.04 x64 / Mageia 2 x64 / Windows 7 x64 / Lamp...
- DreamPlug Multi Boot / Marvel 1.22 Ghz / Architecture ARM / 512 Mo Ram / Carte-sd 16 Go class 10 / 5 Watts / Debian Squeeze 2.6.39.4 ----> http://www.newit.co.uk/shop/proddetail. … ream_Multi ----> appellé également plug computer
JE SUIS CHARLIE

Hors ligne

#42 Le 30/08/2012, à 19:36

ToToF_run

Re : [Résolu] module CM15pro

fais un :

ls /dev/cm*

normalement tu devrais voir :

/dev/cm15a

et c'est cela que tu dois mettre à la place de /usr/bin/cm15a

et pour pas avoir de souci avant de lancer le perl fais un :

sudo chmod 777 /dev/cm15a

Hors ligne

#43 Le 30/08/2012, à 21:07

xunil2003

Re : [Résolu] module CM15pro

Bonjour

Dans /dev j'ai

serveur@debian:~$ ls -alF /dev/cm*
-rwxrwxrwx 1 root root      4 30 août  21:51 /dev/cm15a0*
serveur@debian:~$

cm15a0 a été chmodé 777.

et avec ceci ça marche pas

    #!/usr/bin/perl -w
    use Fcntl;
    use strict;
    use warnings;

    #----- Déclaration des variables -----
    my $on = "A2 On";
    my $off = "A2 Off";
    my $temps = "5"; # Pause en secondes

    #----- Vérification du module et activation commande x10 -----
    #sysopen( CM15A, "/dev/cm15a0", O_RDWR |O_NOCTTY | O_NONBLOCK ) || die "Module cm15a.ko non charge $!";

    #----- Activation commande x10 -----
    syswrite CM15A, pack( "CC", 6, 0x6A ), 2;      # ON
    print "$on activé \n";

    #----- Mise en attente avec affichage a l'ècran -----
    print "En pause $temps secondes\n";
    sleep $temps ; # pause 
    print "Fin de la pause\n";

    #----- Activation commande x10 -----
    syswrite CM15A, pack( "CC", 6, 0x63 ), 2;       # OFF
    close( CM15A ); 
    print "$off activé \n";

Merci.


- Intel Pentium I7 960 / 12 Go de Ram - 6 HDD de 2 T0 - Kubuntu & Ubuntu 12.04 x64 / Mageia 2 x64 / Windows 7 x64 / Lamp...
- DreamPlug Multi Boot / Marvel 1.22 Ghz / Architecture ARM / 512 Mo Ram / Carte-sd 16 Go class 10 / 5 Watts / Debian Squeeze 2.6.39.4 ----> http://www.newit.co.uk/shop/proddetail. … ream_Multi ----> appellé également plug computer
JE SUIS CHARLIE

Hors ligne

#44 Le 31/08/2012, à 18:19

xunil2003

Re : [Résolu] module CM15pro

Bonjour,

Pouvez vous me dire si ceci fonctionne chez vous.

Avec Perl directement dans le terminal

perl -e 'print pack( "CC", 6, 0x6E )'  > /dev/cm15a0

Pouvez vous me dire ègalement si ce code bash fonctionne chez vous que j'ai pondu.
Créer un fichier CM15-A2.sh puis coller ceci dans le fichier.
Pour l'executer : bash CM15-A2.sh

#!/bin/bash

#----- Déclaration des variables -----
    on="A2 On" # Ordre domotique ON
    off="A2 Off"; # Ordre domotique OFF
    temps="5"; # Pause en secondes
    module="cm15a"; # Nom du module

    #----- Vérification du module -----
    lsmod | grep -q $module
    test "$?" -eq 0 && echo "Module $module chargé." || echo "Module $module non chargé."

    #----- Ordre x10 ON -----
    echo -ne "\x6E" > /dev/cm15a0     # ON
    echo -ne "\x06\x6E" > /dev/cm15a0
    echo "$on activé"

    #----- Mise en attente avec affichage a l'ècran -----
    echo "En pause $temps secondes"
    sleep $temps  # pause 
    echo "Fin de la pause"

    #----- Ordre x10 OFF -----
    echo -ne "\x63" > /dev/cm15a0     # OFF
    echo -ne "\x06\x63" > /dev/cm15a0
    echo "$off activé"

Si tout fonctionne chez vous avec le code perl et de bash c'est que j'ai un problème avec l'hexa du module du cm15.
Merci d'avance pour vos rèponses; cdt.

Dernière modification par xunil2003 (Le 31/08/2012, à 19:57)


- Intel Pentium I7 960 / 12 Go de Ram - 6 HDD de 2 T0 - Kubuntu & Ubuntu 12.04 x64 / Mageia 2 x64 / Windows 7 x64 / Lamp...
- DreamPlug Multi Boot / Marvel 1.22 Ghz / Architecture ARM / 512 Mo Ram / Carte-sd 16 Go class 10 / 5 Watts / Debian Squeeze 2.6.39.4 ----> http://www.newit.co.uk/shop/proddetail. … ream_Multi ----> appellé également plug computer
JE SUIS CHARLIE

Hors ligne