Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 15/01/2007, à 01:03

Vangelius

Google earth et celestia ne se lancent pas

Bonjour à tous,
Voila 2 jours que j'ai installé Ubuntu.
Mon pblm:
-Quand je lance google earth le prog reste bloqué sur la fenetre de presentation
-Quand je lance Celestia: une fenetre apparait et disparait aussitot et rien ne se passe.

Par contre, Stellarium fonctionne sans probleme.

je me suis dis que c'était peut etre un probleme de 3D avec ma carte ATI radeon 9200 PRO mais voici le resultat de:

julio@Julio:~$ glxgears -printfps
6949 frames in 5.0 seconds = 1389.788 FPS
9012 frames in 5.0 seconds = 1802.088 FPS
7203 frames in 5.0 seconds = 1440.553 FPS
8340 frames in 5.0 seconds = 1667.840 FPS
8337 frames in 5.0 seconds = 1667.214 FPS
julio@Julio:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON 9200 Series DDR Generic
OpenGL version string: 1.3.1091 (X4.3.0-8.28.8)
julio@Julio:~$ [b]glxinfo | grep render[/b]
direct rendering: Yes
    GLX_ATI_pixel_format_float, GLX_ATI_render_texture
OpenGL renderer string: RADEON 9200 Series DDR Generic
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
	Identifier     "Default Layout"
	Screen      0  "aticonfig-Screen[0]" 0 0
	InputDevice    "Generic Keyboard"
	InputDevice    "Configured Mouse"
	InputDevice    "stylus" "SendCoreEvents"
	InputDevice    "cursor" "SendCoreEvents"
	InputDevice    "eraser" "SendCoreEvents"
EndSection

Section "Files"

	# path to defoma fonts
	FontPath     "/usr/share/X11/fonts/misc"
	FontPath     "/usr/share/X11/fonts/cyrillic"
	FontPath     "/usr/share/X11/fonts/100dpi/:unscaled"
	FontPath     "/usr/share/X11/fonts/75dpi/:unscaled"
	FontPath     "/usr/share/X11/fonts/Type1"
	FontPath     "/usr/share/X11/fonts/100dpi"
	FontPath     "/usr/share/X11/fonts/75dpi"
	FontPath     "/usr/share/fonts/X11/misc"
	FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
	Load  "i2c"
	Load  "bitmap"
	Load  "ddc"
	Load  "dri"
	Load  "extmod"
	Load  "freetype"
	Load  "glx"
	Load  "int10"
	Load  "type1"
	Load  "vbe"
EndSection

Section "InputDevice"
	Identifier  "Generic Keyboard"
	Driver      "kbd"
	Option	    "CoreKeyboard"
	Option	    "XkbRules" "xorg"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "fr"
	Option	    "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
	Identifier  "Configured Mouse"
	Driver      "mouse"
	Option	    "CorePointer"
	Option	    "Device" "/dev/input/mice"
	Option	    "Protocol" "ExplorerPS/2"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "true"
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
	Identifier  "stylus"
	Driver      "wacom"
	Option	    "Device" "/dev/wacom"          # Change to 
	Option	    "Type" "stylus"
	Option	    "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
	Identifier  "eraser"
	Driver      "wacom"
	Option	    "Device" "/dev/wacom"          # Change to 
	Option	    "Type" "eraser"
	Option	    "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"

                                                      # /dev/input/event
                                                      # for USB
	Identifier  "cursor"
	Driver      "wacom"
	Option	    "Device" "/dev/wacom"          # Change to 
	Option	    "Type" "cursor"
	Option	    "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection

Section "Monitor"
	Identifier   "BenQ T903"
	Option	    "DPMS"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "Generic Video Card"
	Driver      "vesa"
	BusID       "PCI:1:0:0"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]"
	Driver      "fglrx"
	Option	    "VideoOverlay" "on"
	Option	    "OpenGLOverlay" "off"
EndSection

Section "Screen"
	Identifier "Default Screen"
	Device     "Generic Video Card"
	Monitor    "BenQ T903"
	DefaultDepth     24
	SubSection "Display"
		Depth     1
		Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
	EndSubSection
	SubSection "Display"
		Depth     4
		Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
	EndSubSection
	SubSection "Display"
		Depth     8
		Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
	EndSubSection
	SubSection "Display"
		Depth     15
		Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
	EndSubSection
	SubSection "Display"
		Depth     16
		Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
	EndSubSection
	SubSection "Display"
		Depth     24
		Modes    "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x350"
	EndSubSection
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]"
	Device     "aticonfig-Device[0]"
	Monitor    "aticonfig-Monitor[0]"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "DRI"
	Mode         0666
EndSection

Section "Extensions"
	Option "Composite" "disable"
EndSection

Vous pensez que c'est plutôt un problème matériel ou une mauvaise installation des logiciels ?

Merci

Hors ligne

#2 Le 15/01/2007, à 01:46

quelqu'un

Re : Google earth et celestia ne se lancent pas

Tu les a installés comment ces logiciels ? les 3 : google earth, stellarium et celestia

Sinon tu peux lancer les programmes qui ne fonctionnent pas à partir d'un terminal, les commandes pour les lancer :
stellarium
googleearth

et noter les erreurs qui apparaissent (si il y en a), ça peut être utile.


DE RE-RE-RETOUR... AHAH !!! Moi, l'Honorable, l'Illustrissime et vénérable, le vrai véritable et unique Quelqu'un, je viens vous montrer le chemin.

Pour s'adresser à ma personne, veuillez commencer votre discours par :
Ô sa Grandeur, son Excellence, Divinité de l'excellence, Dieu des Dieux, Roi de Toutes choses, Ô puissant esprit supérieur, nous t'implorons.

Hors ligne

#3 Le 15/01/2007, à 05:31

BlueTak

Re : Google earth et celestia ne se lancent pas

J'ai une carte ATI radéon 9200 et Google earth plante après l'écran d'initialisation. D'après mes recherches sur internet c'est à cause d'une incompatibilité entre certaines cartes ATI et le logiciel.
J'attends comme toi avec impatience que Google règle cela !:rolleyes:

Hors ligne

#4 Le 15/01/2007, à 08:38

Vangelius

Re : Google earth et celestia ne se lancent pas

Ok BlueTak, donc je laisse tomber pour google earth si c'est incompatible avec ma carte graphique, mais reste Celestia.

J'ai installé celestia-gnome et celestia-common à partir de Synaptic.
Voici ce qui apparait quand je le lance à partir du terminal:

julio@Julio:~$ celestia-gnome
nStars: 112524
Initializing ARB vertex programs . . .
Loading ARB vertex program: shaders/diffuse_arb.vp
Loading ARB vertex program: shaders/specular_arb.vp
Loading ARB vertex program: shaders/haze_arb.vp
Loading ARB vertex program: shaders/bumpdiffuse_arb.vp
Loading ARB vertex program: shaders/bumphaze_arb.vp
Loading ARB vertex program: shaders/shadowtex_arb.vp
Loading ARB vertex program: shaders/diffuse_texoff_arb.vp
Loading ARB vertex program: shaders/rings_arb.vp
Loading ARB vertex program: shaders/ringshadow_arb.vp
Loading ARB vertex program: shaders/night_arb.vp
Loading ARB vertex program: shaders/glossmap_arb.vp
All ARB vertex programs loaded successfully.
render path: 3
Erreur de segmentation

il y a 2 sujets dans le forum ayant rapport avec ce message d'erreur mais apparemment ça n'a pas été résolu:
http://forum.ubuntu-fr.org/viewtopic.php?id=39107
http://forum.ubuntu-fr.org/viewtopic.php?id=26026

PS: je viens d'installer le jeux tremulous, qui fonctionne parfaitement donc ça ne doit pas être à cause d'une mauvaise configuration de ma carte graphique.

Dernière modification par Vangelius (Le 15/01/2007, à 09:31)

Hors ligne

#5 Le 21/03/2007, à 07:31

jiceel

Re : Google earth et celestia ne se lancent pas

Google Earth n'est pas incompatible avec cette carte graphique, mais les drivers Fglrx. J'ai également une 9200, même symptôme, blocage sur l'image de démarrage, j'ai essayé une ancienne version de Google Earth qui avant fonctionnait et pareil également et impossible d'installer Beryl. Puis je me suis décidé a réinstaller les drivers Radeon qui m'avaient déçu il y a presque 1 an et là tout fonctionne à merveille.
Donc avec une ATI 9200, installer les drivers Radeon.

Dernière modification par jiceel (Le 21/03/2007, à 07:32)


Ubuntu 12.04 LTS 64 sur AMD 2x4600 Nvidia 7600GS 3go DDR2

Hors ligne

Haut de page ↑