Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 17/02/2012, à 14:13

bleck

[Résolu] Incompatibilité de kdelibs-data-kde3 Trinity avec KDE4 Lucid

Bonjour,

J'utilisais KDE3-Trinity conjointement à KDE 4, sans problème, avec Lucid 386. En passant la même machine sous Lucid AMD64, je ne parviens plus à installer kdelibs-data-kde3 (Tinity) qui entre conflit avec kdelibs-data 4:3.5.10.dfsg.1-3ubuntu2.10.04.1 . Le conflit semble provenir d'une tentative de remplacement du fichier ksslcalist.

Voici le message d'erreur :

E: /var/cache/apt/archives/kdelibs-data-kde3_4%3a3.5.12-0ubuntu6+r1152788_all.deb: tentative de remplacement de « /etc/kde3/ksslcalist », qui appartient aussi au paquet kdelibs-data 4

Voyez-vous une solution ? Il serait tentant de forcer l'installation au vu le fichier concerné, mais cela risque-t-il de corrompre mon installation KDE4 ?

Tout avis, conseil ou expérience est bienvenu.

Merci d'avance.

Dernière modification par bleck (Le 17/02/2012, à 19:43)

Hors ligne

#2 Le 17/02/2012, à 16:18

xabilon

Re : [Résolu] Incompatibilité de kdelibs-data-kde3 Trinity avec KDE4 Lucid

Salut

Le problème a l'air de dater :
http://www.linuxquestions.org/questions … ynx-830987
Je pense que c'est une mauvaise idée d'avoir KDE-Trinity et KDE4 sur la même installation.

La solution propre est de virer KDE-Trinity ou KDE4 ... je suppose que cette splution ne te convient pas smile

La solution pas propre est de comparer le fichier ksslcalist présent dans le paquet kdelibs-data-kde3 avec le ksslcalist déjà dans /etc/kde3 (donc celui installé par kdelibs-data).
Si ils sont identiques, tu peux simplement supprimer en root le fichier ksslcalist pour laisser kdelibs-data-kde3 installer le sien (ksslcalist concerne les certificats SSL)

Si ils ne le sont pas ... ben il va falloir choisir l'un ou l'autre.


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#3 Le 17/02/2012, à 17:12

bleck

Re : [Résolu] Incompatibilité de kdelibs-data-kde3 Trinity avec KDE4 Lucid

Merci pour ta réponse xabilon,

J'avais trouvé le post que tu indiques mais comme kde-trinity et kde4 vivait bien ensemble sur ma version Lucid 32bits, j'en avais conclu que le problème indiqué dans le post avait été réglé. D'où aussi la précision que je suis sur une version AMD64.

Pour ce qui est de supprimer le fichier fautif (ksscalist), c'est ce que j'ai fait, en pensant faire comme tu le suggères et aviser si le contenu divergeait suivant les versions... Mais il ne suffit pas de supprimer le fichier.

Après suppression du fichier, apt-get refuse toujours d'installer le paquet et affiche le même message d'erreur. Il semble que la vérification se fasse sur la description des paquets et non sur le contenu du système de fichiers. Ce qui parait logique car sinon on ne voit pas comment apt-get pourrait dire quel paquet a installé le fichier... D'où ma question concernant l'installation forcée.

Je ne sais pas si le message d'erreur d'installation fournit la liste des exhaustives de fichiers conflictuels ou s'arrête au premier conflit rencontré. Dans le  premier cas, une installation forcée permettrait de faire comme nous le pensions tous les deux. Dans le second, y a-t-il une commande fournissant la liste exhaustive des conflits potentiels dans l'hypothèse d'installation d'un paquetage donné ? J'avoue ne connaître que superficiellement la famille des commandes apt-* wink

Effectivement, j'ai besoin de Trinity et KDE4, simultanément smile  Les développeurs de Trinity estiment avoir fait les choses proprement pour ce soit possible puisque c'est l'un de leurs objectifs. En écrivant cela, j'en viens à m'interroger sur la propreté du paquet KDE4. Est-il bien normal qu'un paquet KDE4 installe un fichier dans /etc/kde3 ?

Hors ligne

#4 Le 17/02/2012, à 17:39

xabilon

Re : [Résolu] Incompatibilité de kdelibs-data-kde3 Trinity avec KDE4 Lucid

Tu les as comparés avant de le supprimer ?
Bon, au pire, ce sont les certificats qui déconneront ...
Pour forcer l'installation de kdelibs-data-kde3 :

sudo dpkg -i --force-all /var/cache/apt/archives/kdelibs-data-kde3_4%3a3.5.12-0ubuntu6+r1152788_all.deb

Après, pour le fait que kdelibs-data installe un fichier dans /etc/kde3, je suppose que c'est pour des raisons de compatibilité, ces fichiers étant communs à KDE3 et KDE4, mais puisqu'à la base ils étaient dans KDE3 ...
Quant à savoir si le problème viens de Trinity, de KDE4 ou des packageurs des paquets ... j'en sais rien. Lucid a une vieille version de KDE4.
Depuis Kubuntu 11.10 (KDE4.7), kdelibs-data est remplacé par kdelibs5-data, qui installe ksslcalist dans /usr/share/kde4/config, donc plus de conflit.

En revanche, je ne crois pas que le fait d'être en 32bits ou 64 bits y change quelque chose. Les paquets kdelibs-data et kdelibs-data-kde3 sont des paquets "all", donc les mêmes pour les 2 architectures.

Dernière modification par xabilon (Le 17/02/2012, à 17:40)


Pour passer un sujet en résolu : modifiez le premier message et ajoutez [Résolu] au titre.

Hors ligne

#5 Le 17/02/2012, à 18:08

bleck

Re : [Résolu] Incompatibilité de kdelibs-data-kde3 Trinity avec KDE4 Lucid

Je n'ai fait que  déplacer /etc/kde3/ksscalist pour voir si ça permettait d'avancer dans l'installation, sans recourir à l'option "force". Comme ça ne suffit pas, je me suis arrêté.

Avant le lancer une installation "en force", je vais donc aller me documenter pour trouver la commande permettant de  connaître tous les conflits. Ça doit bien exister... Si je ne trouve pas, je ferai à la façon Window$ : avancer les yeux bander, voir "au doigt mouillé" ce que ça donne et s'il y a trop de casse, réinstaller... Mais une machine virtuelle...

Hors ligne

#6 Le 17/02/2012, à 19:40

bleck

Re : [Résolu] Incompatibilité de kdelibs-data-kde3 Trinity avec KDE4 Lucid

xabilon, tes infos m'ont été bien utiles. En manipulant apt-file, je me suis rendu compte que kdelib5-data était installé sur mon système. Du coup, à quoi pouvait bien servir le paquet kdelibs-data 4 ? En cherchant quels paquetage en dépendaient, j'ai vu ksensor. J'en déduis que j'ai malencontreusement installé kdelibs-data 4 en installant cet paquet.

Tout ça ressemble à des paquetages de rétro-compatibilité pour maintenir à flots certaines applications non portées en KDE4 (dont Quanta).

Après suppression du paquetage kdelibs-data 4, les paquetages de Trinity dont j'avais besoin se sont installés sans aucun problème ! big_smile

Tout ça pour quoi ? Pour installer Kpilot et (enfin !) re-synchroniser mon Palm avec les applications PIM de KDE 4.

Hors ligne

  • Accueil
  • » Forum
  • » Archives
  • » [Résolu] Incompatibilité de kdelibs-data-kde3 Trinity avec KDE4 Lucid

Haut de page ↑