Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 19/02/2012, à 20:57

joeypa13

Ordinateur fixe et acpi = off

Bonjour.

J'ai installé Ubuntu 11.10 sur mon ordinateur fixe. Lors de l'installation, pour la faire démarrer, j'ai du cocher l'option acpi=off. A chaque démarrage, je suis aussi obliger de rajouter dans mes ligne de boot l'option acpi=off (je sais que cela peut se faire automatiquement).

Mais se qui me dérange le plus c'est que quand j'éteins mon ordinateur, il reste bloqué sur la ligne "will now halt" et je suis obligé de l'éteindre à la main ( la tour n'est pas à proximité de moi. Je sais c'est une drôle d'installation ^^).

Donc j'ai une version 64 bits de Ubuntu 11.10.

Config :

Motherboard : Asus P8Z68
CPU : Intel Core i5 2500k
GPU : Gainward GTX 560
Power : Corsair GS700

Comment régler se petit inconvénient ?

Merci

Hors ligne

#2 Le 19/02/2012, à 23:26

Guinioul

Re : Ordinateur fixe et acpi = off

salut,

t'as aussi regardé les réglages de l'acpi du bios ?
des fois ça peut venir de là ...

[Edit]
attention il semblerait qu'il ne faille pas utiliser l'option acpioff de manière permanente car elle coupe les ventilos (notamment)!

voir : community.linuxmint.com/tutorial/view/420
[Edit]

Dernière modification par Guinioul (Le 19/02/2012, à 23:56)

Hors ligne

#3 Le 20/02/2012, à 19:57

joeypa13

Re : Ordinateur fixe et acpi = off

Les réglages ACPI bios ? Il fraudait que je change quoi au juste ?

Hors ligne

#4 Le 20/02/2012, à 22:18

Guinioul

Re : Ordinateur fixe et acpi = off

Tu peux regarder dans le menu "power management" du bios . C'est possible que certains trucs soient désactivés ...
Sous Windows ça marchait correctement ?

c'est bizarre qu'ubuntu ne fonctionne que avec noacpi en fait (tu as vérifié que tes ventilos tournent ?) ... Tu as fait comment ton install ? avec une clé ? un cd ?

Hors ligne

#5 Le 20/02/2012, à 22:59

joeypa13

Re : Ordinateur fixe et acpi = off

J'ai fait mon install avec un CD en appuyant sur la touche F12 et ensuite activer l'option acpi=off. Sinon mon ventirad tourne parfaitement mais j'ai d'autres soucis à cause de acpi=off (genre quand j'éteins.) Aucun problème sous Windows 7 (Mais c'est vachement moins fun que Ubuntu Windows XD)

Sinon pour power management sur ma Asus j'ai les nouveau bios EFI en interface graphique (c'est nul...) donc y'as pas cette catégorie.

Hors ligne

#6 Le 21/02/2012, à 11:34

Guinioul

Re : Ordinateur fixe et acpi = off

Il y a peut être (sans doute) un lien entre l'EFI et le fait que tu doive démarrer en acpi=off ...

L'efi gère différemment les composants d'un bios standard . Si je ne dis pas de bêtises l'efi prend la main sur la gestion d’énergie, l'os n'aurait donc apparemment pas à s'en occuper ce qui pourrait expliquer que tu doives démarrer en noacpi .

Apparemment le problème est fréquent :
- http://ubuntulinuxgethelp.com/2012/01/s … -efi-bios/
- http://forum.hardware.fr/hfr/OSAlternat … 2246_1.htm .

L’installation sur un systeme efi nécessite apparemment quelques précautions :
http://forum.ubuntu-fr.org/viewtopic.php?id=757311

Hors ligne

#7 Le 21/02/2012, à 20:32

joeypa13

Re : Ordinateur fixe et acpi = off

Merci de ton lien. Mais quand je boot sur le live CD je suis aussi obligé de mettre l'option acpi=off. Donc je la met et la commande dmesg | grep EFI me retourne que j'ai un bios normal alors que j'ai un EFI ! Comment faire ?

EDIT : Après avoir fouillier dans mon "BIOS", j'ai trouvé que les image de l'ordre de boot, j'avais mon lecteur en double. Un normal et un avec un bandeau UEFI. Je place donc celui avec le bandeau devant, je boot dessus et là, un grub tout bizare qui est grub-efi ! Tout content, je m'enpresse d'appuier entré et de booter sur mon live CD. Et la bam.... Écran noir.... Donc, je reboot, retombe sur grub-efi et là, j'appuie sur "e" et rajoute après quiet splash la fameuse ligne acpi=off . Miracle, sa boot mais toujours sans ACPI.... Là je suis en train d'installer en suivant les indications de ton lien je te tiens au courant quand sa à finis.

EDIT 2 : écran noir au reboot avec écrit :

        error : file not found
        grub rescue>

Demain je tente une réinstallation. je te tiens au courant.

Dernière modification par joeypa13 (Le 22/02/2012, à 01:19)

Hors ligne

#8 Le 22/02/2012, à 18:45

joeypa13

Re : Ordinateur fixe et acpi = off

Bon ben meme apres reinstallation, grub file not found

Comment faire ?

PS desole pour les accent je suis avec un qwerty sur le live CD

Hors ligne

#9 Le 23/02/2012, à 09:40

malbo

Re : Ordinateur fixe et acpi = off

joeypa13,
il va falloir que tu te poses et que tu cherches à comprendre comment fonctionne ton système UEFI/BIOS. Tu as constaté toi-même dans ton post #7 :

EDIT : Après avoir fouillier dans mon "BIOS", j'ai trouvé que les image de l'ordre de boot, j'avais mon lecteur en double. Un normal et un avec un bandeau UEFI.

Il faut comprendre que ton système UEFI/BIOS est capable de démarrer sur n'importe quel lecteur ( lecteur au sens large, c'est à dire liveCD, liveUSB, disque dur) soit en mode UEFI, soit en mode BIOS. A présent que tu as fait le choix d'installer Ubuntu en mode UEFI sur ton disque dur, il faut comprendre que tu dois choisir de démarrer ton PC sur le disque dur en mode UEFI et non pas en mode BIOS : il faut que tu trouves en fouillant dans ton "BIOS" un choix de démarrage sur ton disque dur qui comporte le "bandeau UEFI" comme tu dis. Normalement, tu devrais avoir une touche à presser au démarrage qui te permet d'accéder à un Boot Manager et tu devrais trouver une entrée toute faite "UEFI : UBUNTU" (je ne suis pas sûr que c'est le cas pour ton PC, mais c'est ce que j'ai pu lire sur internet comme )

Edit : si tu n'y arrives pas, peux-tu répondre à cette demande : http://forum.ubuntu-fr.org/viewtopic.php?id=614071
afin que je puisse voir où tu en es

Dernière modification par malbo (Le 23/02/2012, à 09:53)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#10 Le 23/02/2012, à 11:02

joeypa13

Re : Ordinateur fixe et acpi = off

Non mais j'ai compris le fonctionnement du bios EFI. Je boot sur mon disque sur avec le bandeau UEFI  le disqur s'appelle Ubuntu mais la, grub : file not found

Hors ligne

#11 Le 23/02/2012, à 11:44

malbo

Re : Ordinateur fixe et acpi = off

Alors, il faut que tu te documentes sur ton système UEFI/BIOS parce qu'il va falloir que tu rentres toi-même à la mimine les infos dans ton Bios comme je l'ai expliqué dans le paragraphe D de ce post : http://forum.ubuntu-fr.org/viewtopic.ph … 1#p7189161
C'est cette partie :
"Il va falloir faire une petite manip pour pouvoir arriver à démarrer sur le disque dur.
On peut s'appuyer sur le paragraphe "4.1 Using Boot Maintenance Menu" de cette doc : http://software.intel.com/en-us/article … scripting/
ça commence dans le Shell (il y a une ligne Shell> à la fin).
on tape exit (à la suite de Shell>) :
Shell> exit et on valide par Entrée
On sélectionne la ligne "Boot maintenance manager", puis "Boot options", puis "Add boot option"

Le but de la manip, c'est de créer une entrée spéciale (à laquelle tu pourras donner le nom que tu veux) dans le Boot Manager de ton Système UEFI/Bios, et si tu lis bien ta doc de ton système, tu pourras ensuite accéder directement au menu de ton Boot Manager par une certaine touche de ton clavier au démarrage du PC, ce qui te permettra de sélectionner cette entrée spéciale et de démarrer dessus.

Dernière modification par malbo (Le 23/02/2012, à 11:49)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#12 Le 23/02/2012, à 16:26

joeypa13

Re : Ordinateur fixe et acpi = off

Ok merci. Là j'ai réinstaller Ubuntu en mode BIOS (mais acpi=off obligé) parceque je dois faire un truc très important. J'essaierais se que tu me dit quand j'aurais finis merci.

Par contre, juste une question. Je vais être obliger d'appuyer sur une touche pour booter ?
Ah et aussi, je viens d'y penser. Vu que j'ai un dual boot Win 7 / Ubuntu sa change rien ?

Merci

Hors ligne

#13 Le 23/02/2012, à 16:47

malbo

Re : Ordinateur fixe et acpi = off

joeypa13 a écrit :

Je vais être obliger d'appuyer sur une touche pour booter ?

Ce que je veux dire, c'est que pour accéder au Boot Manager, le manuel de ta carte-mère (dans la partie gestion du démarrage) doit te dire sur quelle touche appuyer au démarrage du PC. Mais ça c'est juste pour le début quand tu découvres ton "Bios", après il faudra que tu te bouges pour configurer (dans ton Bios) la priorité de boot sur cette entrée de sorte que ça démarre par défaut sur elle, sans que tu aies besoin d'appuyer sur cette touche.

Dernière modification par malbo (Le 23/02/2012, à 16:49)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#14 Le 24/02/2012, à 20:58

joeypa13

Re : Ordinateur fixe et acpi = off

Bonsoir !

Donc je pense avoir réussi !

En fait, je me suis rendu compte que mon Windows 7 n'étais pas installer en UEFI. J'ai donc voulu installer Win7 en UEFI en me disant que c'était ça qui faisait planter Ubuntu UEFI. Je me lance dans la réinstallation et il me dit qu'il faut des partition GPT. Je boot donc sur GParted et après avoir fait un backup de mes données, je crée une nouvelle table de partition GPT. Ensuite, j'installe Windows 7 en UEFI. J'installe ensuite mon Ubuntu UEFI. Au début de l'installation, écran noir. Je lance donc mon installation en acpi=off. J'arrive sur l'installation, j'installe le tout, je reboot et la miracle de l'informatique, ça marche ! J'arrive à booter sur Ubuntu UEFI sans acpi=off !

Par contre, si j'ai bien compris, mon bios efi prend la place de grub c'est ça ? A chaque fois que je vais vouloir changer de OS je vais devoir changer l'ordre de boot dans mon bios ? Y' as pas un moyen plus pratique ?

Voila ! Sur ce, je vous remercie tous ! Et pour les gens qui lisent ce post, fait attention au bannières UEFI (bios ASUS FZ) et tout d'abord, renseigniez vous sur l'UEFI avant de foncer tête baissée et installer TOUT vos OS en UEFI.


EDIT : FAUSSE JOIE : Windows 7 crash au démarrage

Dernière modification par joeypa13 (Le 24/02/2012, à 21:10)

Hors ligne

#15 Le 25/02/2012, à 07:11

malbo

Re : Ordinateur fixe et acpi = off

Donne des nouvelles. Si tu veux de l'aide, poste le lien vers ton Boot-Info : http://forum.ubuntu-fr.org/viewtopic.php?id=614071


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#16 Le 25/02/2012, à 10:19

joeypa13

Re : Ordinateur fixe et acpi = off

merci encore de ton aide.

Voila le pastbin du boot info http://paste.ubuntu.com/856268/

Au demarrage de boot repair il m as dit qu il detectait un system EFI< Bon signe non ?

encore desoler pour les accent je suis en qwerty

je viens de réessayer mon windows  et il dit : la sélection de démarrage a échoué car un périphérique nécessaire est inaccessible

Dernière modification par joeypa13 (Le 25/02/2012, à 10:24)

Hors ligne

#17 Le 25/02/2012, à 10:43

malbo

Re : Ordinateur fixe et acpi = off

Tu devrais tout réinstaller en séparant bien les partitions pour Windows 7 des partitions pour Ubuntu comme j’explique dans ce doc : http://forum.ubuntu-fr.org/viewtopic.php?id=757311
Pour cela, il faut d'abord installer Win7 en UEFI comme tu as fait en laissant de la place pour Ubuntu ou bien alors, tu fais l'installation "tout automatique" de Win7 (qui va occuper la totalité du disque dur et le partitionner en GPT) et quand c'est fait - et que tu as pu vérifier que Win7 fonctionne - tu réduis la taille de ta partition système de Win7 pour faire de la place à Ubuntu en utilisant la fonction gérer les disques de Win7 lui-même. Puis tu installes Ubuntu en "Installation prudente" comme je l'indique dans le lien.

PS : une précision sur le dual-boot par rapport à une remarque que tu as faite plus haut : si ça fonctionne, je pense qu'il faudra toujours passer par le Boot manager de ton système UEFI/BIOS mais franchement, je ne vois pas la grosse contrainte que ça représente d'appuyer sur une touche au démarrage et de choisir une entrée (Windows ou Ubuntu) pour démarrer dessus.

Dernière modification par malbo (Le 25/02/2012, à 10:52)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#18 Le 25/02/2012, à 16:18

joeypa13

Re : Ordinateur fixe et acpi = off

Merci beaucoup ça marche nickel ! En fait j'avais sauter l'étape d'enlever le flag boot. Du coup Ubuntu a écrasé la partition EFI de windows. Bref maintenant tout marche ! Sinon pour mon histoire de pratique, je pensais que je devais à chaque fois changer mon ordre de boot et de tout redémarrer. Mais en foulliant dans mon bios, j'ai trouvé qu'on pouvait amorcer directement sans reboot.

Bref, merci beaucoup !

Sinon pour passer en résolu c'est moi qui doit le faire ou un admin ou faut pas le faire ?

Hors ligne

#19 Le 25/02/2012, à 18:49

malbo

Re : Ordinateur fixe et acpi = off

joeypa13,
Aurais-tu la gentillesse de poster ton Boot-Info à présent que tout fonctionne bien pour que je puisse m'en servir pour exemple (on a peu de cas de dual-boot en UEFI qui fonctionne sur le forum) ?


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#20 Le 25/02/2012, à 21:03

joeypa13

Re : Ordinateur fixe et acpi = off

ok pas de problèmes. Par contre, j'ai pas de live CD sous la main la. Si je le fait depuis mon Ubuntu normal sa marche ?

EDIT : Voilà le pastbin de mon boot info fait sous Ubuntu normal (pas le live CD) : http://paste.ubuntu.com/856892/

Dernière modification par joeypa13 (Le 25/02/2012, à 21:12)

Hors ligne

#21 Le 26/02/2012, à 08:14

malbo

Re : Ordinateur fixe et acpi = off

Enfin. je vois sur ce forum la première installation réussie d'un dual-boot win7/Ubuntu complètement en UEFI Je vais encadrer ton résultat Boot-Info dans ma chambre mais déjà je le colle ici :

                 Boot Info Script 0.60-git      [23 Feb 2012]


============================= Boot Info Summary: ===============================

 => No boot loader is installed in the MBR of /dev/sda.

sda1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  Windows 7: FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /efi/Boot/bootx64.efi

sda2: __________________________________________________________________________

    File system:       
    Boot sector type:  -
    Boot sector info: 
    Mounting failed:   mount: unknown filesystem type ''

sda3: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows Vista/7: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  Windows 7
    Boot files:        /Windows/System32/winload.exe

sda4: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  FAT16
    Boot sector info:  According to the info in the boot sector, sda4 starts 
                       at sector 0. But according to the info from fdisk, 
                       sda4 starts at sector 493967360. According to the info 
                       in the boot sector, sda4 has 0 sectors.
    Operating System:  
    Boot files:        /efi/ubuntu/grubx64.efi

sda5: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  
    Boot files:        

sda6: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Ubuntu 11.10
    Boot files:        /boot/grub/grub.cfg /etc/fstab

sda7: __________________________________________________________________________

    File system:       swap
    Boot sector type:  -
    Boot sector info: 

sda8: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  
    Boot files:        

sda9: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  
    Boot files:        

============================ Drive/Partition Info: =============================

Drive: sda _____________________________________________________________________

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sda1                   1   976,773,167   976,773,167  ee GPT


GUID Partition Table detected.

Partition    Start Sector    End Sector  # of Sectors System
/dev/sda1           2,048       206,847       204,800 Data partition (Windows/Linux)
/dev/sda2         206,848       468,991       262,144 Microsoft Reserved Partition (Windows)
/dev/sda3         468,992   493,967,359   493,498,368 Data partition (Windows/Linux)
/dev/sda4     493,967,360   494,008,319        40,960 EFI System partition
/dev/sda5     494,008,320   894,008,320   400,000,001 Data partition (Windows/Linux)
/dev/sda6     894,008,321   920,008,321    26,000,001 Data partition (Windows/Linux)
/dev/sda7     920,008,322   937,008,322    17,000,001 Swap partition (Linux)
/dev/sda8     937,008,323   943,008,323     6,000,001 Data partition (Windows/Linux)
/dev/sda9     943,008,324   976,771,995    33,763,672 Data partition (Windows/Linux)

"blkid" output: ________________________________________________________________

Device           UUID                                   TYPE       LABEL

/dev/sda1        6E0F-A508                              vfat       
/dev/sda3        AC9213A7921374D4                       ntfs       
/dev/sda4        D04D-CA8F                              vfat       
/dev/sda5        c4e5c6b5-78fe-4abe-bf32-0c75f29231a4   ext4       
/dev/sda6        36384dd3-04ff-449a-a712-cfc828887942   ext4       
/dev/sda7        02b70e54-ba9a-4a34-a080-904de8819d6a   swap       
/dev/sda8        3c6cf20e-7ed7-44d0-9dc4-92d366237db0   ext4       
/dev/sda9        cba18de7-5cb2-44fa-9d41-e0a4dfd0cadb   ext4       

================================ Mount points: =================================

Device           Mount_Point              Type       Options

/dev/sda4        /boot/efi                vfat       (rw)
/dev/sda5        /home                    ext4       (rw,commit=0)
/dev/sda6        /                        ext4       (rw,errors=remount-ro,commit=0)
/dev/sda8        /var                     ext4       (rw,commit=0)
/dev/sda9        /usr                     ext4       (rw,commit=0)


=========================== sda6/boot/grub/grub.cfg: ===========================

--------------------------------------------------------------------------------
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
set default="0"
if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n "${have_grubenv}" ]; then if [ -z "${boot_once}" ]; then save_env recordfail; fi; fi
}

function load_video {
  insmod efi_gop
  insmod efi_uga
  insmod video_bochs
  insmod video_cirrus
}

insmod part_gpt
insmod ext2
set root='(hd0,gpt9)'
search --no-floppy --fs-uuid --set=root cba18de7-5cb2-44fa-9d41-e0a4dfd0cadb
if loadfont /share/grub/unicode.pf2 ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  insmod part_gpt
  insmod ext2
  set root='(hd0,gpt6)'
  search --no-floppy --fs-uuid --set=root 36384dd3-04ff-449a-a712-cfc828887942
  set locale_dir=($root)/boot/grub/locale
  set lang=fr_FR
  insmod gettext
fi
terminal_output gfxterm
if [ "${recordfail}" = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
if background_color 44,0,30; then
  clear
fi
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
if [ ${recordfail} != 1 ]; then
  if [ -e ${prefix}/gfxblacklist.txt ]; then
    if hwmatch ${prefix}/gfxblacklist.txt 3; then
      if [ ${match} = 0 ]; then
        set linux_gfx_mode=keep
      else
        set linux_gfx_mode=text
      fi
    else
      set linux_gfx_mode=text
    fi
  else
    set linux_gfx_mode=keep
  fi
else
  set linux_gfx_mode=text
fi
export linux_gfx_mode
if [ "$linux_gfx_mode" != "text" ]; then load_video; fi
menuentry 'Ubuntu, avec Linux 3.0.0-12-generic' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    set gfxpayload=$linux_gfx_mode
    insmod gzio
    insmod part_gpt
    insmod ext2
    set root='(hd0,gpt6)'
    search --no-floppy --fs-uuid --set=root 36384dd3-04ff-449a-a712-cfc828887942
    linux    /boot/vmlinuz-3.0.0-12-generic root=UUID=36384dd3-04ff-449a-a712-cfc828887942 ro   quiet splash vt.handoff=7
    initrd    /boot/initrd.img-3.0.0-12-generic
}
menuentry 'Ubuntu, avec Linux 3.0.0-12-generic (mode de dépannage)' --class ubuntu --class gnu-linux --class gnu --class os {
    recordfail
    insmod gzio
    insmod part_gpt
    insmod ext2
    set root='(hd0,gpt6)'
    search --no-floppy --fs-uuid --set=root 36384dd3-04ff-449a-a712-cfc828887942
    echo    'Chargement de Linux 3.0.0-12-generic ...'
    linux    /boot/vmlinuz-3.0.0-12-generic root=UUID=36384dd3-04ff-449a-a712-cfc828887942 ro recovery nomodeset 
    echo    'Chargement du disque mémoire initial ...'
    initrd    /boot/initrd.img-3.0.0-12-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
    insmod part_gpt
    insmod ext2
    set root='(hd0,gpt6)'
    search --no-floppy --fs-uuid --set=root 36384dd3-04ff-449a-a712-cfc828887942
    linux16    /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
    insmod part_gpt
    insmod ext2
    set root='(hd0,gpt6)'
    search --no-floppy --fs-uuid --set=root 36384dd3-04ff-449a-a712-cfc828887942
    linux16    /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
if [ "x${timeout}" != "x-1" ]; then
  if keystatus; then
    if keystatus --shift; then
      set timeout=-1
    else
      set timeout=0
    fi
  else
    if sleep --interruptible 3 ; then
      set timeout=0
    fi
  fi
fi
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###
--------------------------------------------------------------------------------

=============================== sda6/etc/fstab: ================================

--------------------------------------------------------------------------------
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda6 during installation
UUID=36384dd3-04ff-449a-a712-cfc828887942 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda4 during installation
UUID=D04D-CA8F  /boot/efi       vfat    defaults        0       1
# /home was on /dev/sda5 during installation
UUID=c4e5c6b5-78fe-4abe-bf32-0c75f29231a4 /home           ext4    defaults        0       2
# /usr was on /dev/sda9 during installation
UUID=cba18de7-5cb2-44fa-9d41-e0a4dfd0cadb /usr            ext4    defaults        0       2
# /var was on /dev/sda8 during installation
UUID=3c6cf20e-7ed7-44d0-9dc4-92d366237db0 /var            ext4    defaults        0       2
# swap was on /dev/sda7 during installation
UUID=02b70e54-ba9a-4a34-a080-904de8819d6a none            swap    sw              0       0
--------------------------------------------------------------------------------

=================== sda6: Location of files loaded by Grub: ====================

           GiB - GB             File                                 Fragment(s)

 428.431633472 = 460.024963584  boot/grub/grub.cfg                             1
 426.556351185 = 458.011394560  boot/initrd.img-3.0.0-12-generic               2
 428.429398060 = 460.022563328  boot/vmlinuz-3.0.0-12-generic                  1
 426.556351185 = 458.011394560  initrd.img                                     2
 428.429398060 = 460.022563328  vmlinuz                                        1

========= Devices which don't seem to have a corresponding hard drive: =========

sdb sdc sdd sde 

Ah ! putain que c'est beau...
J'ai quelques questions supplémentaires :
1) Pour installer Win7, as-tu laissé faire l'installation automatique et ensuite tu as réduit la taille du disque C: depuis Win7 ou as-tu procédé autrement (peux-tu détailler ?)
2) peux-tu décrire comment tu fais concrètement au démarrage pour que ton PC démarre sous Ubuntu : est-ce que tu appuies sur une touche (laquelle) pour faire apparaître le Boot Manager et sélectionner l'entrée qui va bien ou quoi ? Est-ce qu'elle apparaît bien sous le nom "UEFI:UBUNTU" ou autrement ?
3) mêmes question pour démarrer ton PC sous Win7 : quelles sont les actions concrètes que tu fais (touche pour faire apparaitre le Boot Manager ou quoi ? l'entrée pour Win7 apparait sous quel nom ?)
4) dans le post #11 ci-dessus, je décris une méthode pour rentrer manuellement les entrées dans le Boot Manager. Peux-tu me confirmer que dans ton cas, les entrées pour Win7 et Ubuntu sont bien créées automatiquement et que tu n'as aucunement mis en pratique cette méthode "manuelle" ?
5) tu écris dans le post #14 "J'arrive à booter sur Ubuntu UEFI sans acpi=off". Est-ce que c'est toujours vrai ? Et si c'est toujours vrai, je ne comprends pas en quoi le fait que Ubuntu soit installé en mode EFI (au lieu du mode Bios) a un rapport avec l'option acpi=off. Si quelqu'un sait nous éclairer sur la chose ou nous donner une piste sur le sujet ce serait bien...

Dernière modification par malbo (Le 26/02/2012, à 10:17)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#22 Le 26/02/2012, à 16:44

joeypa13

Re : Ordinateur fixe et acpi = off

Pour répondre à tes questions

1 : Quand tu m'as conseiller de faire une réinstallation totale, j'ai formater tout mon disque dur avec une table de partition GPT. Mon disque dur était donc totalement vide. J'ai ensuite démarrer l’installation de Windows 7 et je l'ai laissé occuper toute la place du disque. J'ai ensuite réduit son espace disque depuis Windows.

2 et 3 : Plutôt que des mots, voilà une vidéo !  http://www.youtube.com/watch?v=LLyVabPN … e=youtu.be

4 : J'ai absolument rien rentrer à la main. Les entrées sont apparues toute seule je confirme.

5 : Je n'ai effectivement plus besoin d' acpi=off. Moi on m'avais parler de quelque chose comme quoi c'était le BIOS EFI qui prenait la place de ACPI.

Sinon, je serais honorer de voir mon boot info dans ta chambre big_smile C'est un peu grâce à toi que j'ai réussi ^^

Hors ligne

#23 Le 26/02/2012, à 21:38

malbo

Re : Ordinateur fixe et acpi = off

Merci pour les réponses.
Super ta vidéo : ça parait facile quand on le voit comme ça. Je vais utiliser ton expérience en donnant un lien vers cette discussion dans mon "Howto_Installation prudente de Ubuntu 11.10 dans un PC UEFI"

Dernière modification par malbo (Le 26/02/2012, à 21:48)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

En ligne

#24 Le 26/02/2012, à 21:42

joeypa13

Re : Ordinateur fixe et acpi = off

J'espère que mon cas aideras d'autres personnes.

Merci beaucoup de ton aide !

Hors ligne

#25 Le 27/02/2012, à 01:10

joeypa13

Re : Ordinateur fixe et acpi = off

Ah ben finalement, acpi=off est toujours obligatoire .... Mon problème originel n'est donc pas résolu. Quelqu'un a une idée ?

Hors ligne

Haut de page ↑