Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 10/10/2006, à 20:12

forficule

ubuntu et sambaedu

bonjour à tous, je travaille sur un réseau sambaedu3/lcs, et je voudrais faire tourner des postes sous ubuntu (xubuntu/fluxbuntu) sur ce réseau.
Comme les machines sont vieillotes, je ne souhaite pas pour l'instant me lancer dans une authentification pam sur le ldap de sambaedu, avec création des homes à chaque connexion etc...
Je suis donc entrain de regarder du côté de montesmb : http://perso.orange.fr/college.claudel. … ntesmb.htm
Mon problème c'est de le mettre à jour pour sambaedu3 : ça c'est fait en éditant le fichier cfg wink
De le faire fonctionner avec ubuntu : c'est fait en passant avec un sudo pour cause de bit suid non placé sur smbmnt (j'ai bon là ?)... Voyez-vous comment régler ce problème de bit suid ?
Ensuite, il ne restera que le problème du home sambaedu à monter dans un dossier K dans le home de l'utilisateur générique élève. Pour l'instant, avec sambaedu3, soit je monte tous les homes de tous les utilisateurs en tant qu'admin, soit je ne monte rien...
Pour les autres partages, c'est parfait, le logiciel marche plutôt bien. Il suffit de régler les deux petits soucis de dépendance avec synaptic (une lib graphique, et smbclient).
Pour info j'ai fait tourner smbmonte sur une xubuntu avec deux comptes, un compte admin (qui peut faire des sudo) et un compte élève (connexion sur ce compte automatique après 10 secondes, merci gdm smile), dans les homes respectifs j'ai créé les dossiers K, P et L pour recevoir les partages montés par montesmb.
Si vous faites des essais ou si vous avez des retours d'expériences. Merci.

Hors ligne

#2 Le 16/10/2006, à 17:32

Lalou

Re : ubuntu et sambaedu

alors l'admin réseau du lycée (develloper se3) nous a monté un script permettant de rejoindre le réseau se3 sans passé par par nfs mais par un autre protocole plus (je sais plus lequel), je suis encore entrain de le tester mais pour l'instant il à l'aire de marcher impécable.

Par contre pour les élève il semble y avoir une histtoire de shell, pour fonctionner il faut que  chaque élève est un shell (enfin chez nous sa marche comme ca), peut être une piste à explorer.

Dernière modification par Lalou (Le 16/10/2006, à 17:34)


Beryl c'est trop fort, stargate aussi
Ubuntu 7.04 Feisty Fawn
Nvidia GeForce 6200 avec turbo cache
Proc: Pentium 4 3GHz avec hyper threading

Hors ligne

#3 Le 16/10/2006, à 21:21

forficule

Re : ubuntu et sambaedu

Je suis impatient que tu me donnes plus d'infos wink
Donner un shell, je pense voir ce que ça veut dire... je suis aussi le thread sur sambaedu / ldap / ubuntu, il y a visiblement aussi des solutions si un serveur ldap existe sur le réseau (c'est le cas avec la solution sambaedu / lcs)...
Dès que j'ai quelques heures devant moi, je regarde un peu ça...

Hors ligne

#4 Le 26/10/2006, à 14:38

forficule

Re : ubuntu et sambaedu

Re bonjour, j'ai fait quelques essais avec pam (comme vu sur ce post http://forum.ubuntu-fr.org/viewtopic.php?id=45576)
J'ai quelques soucis tout de même... voir sur ce post wink
Y a-t-il des nouvelles du programme montesmb ou du script dont parle Lalou ?
Merci

Hors ligne

#5 Le 26/10/2006, à 17:35

EdLeH

Re : ubuntu et sambaedu

Bonjour

peut-être suis je un peu hors sujet, mais j'ai fait un petit programme (python + gtk) pour permettre la connexion des élèves de mon collège.

Notre réseau est géré par un serveur NT4 avec solstice (académie de Bordeaux).

Les postes sont sous Kubuntu.

J'ai installé smb4k (puis réglage des chmod pour smbmnt et smbumount) et ça fonctionne.

C'est une solution que j'ai mise enplace après avoir étudié les sources de montesmb dont tu parles, mais qui ne convenait pas tel quel dans notre situation.

Plus d'explications (même si je n'ai jamais eu le courage/temps de finir l'article) ici :

http://clgdrouyn.fr/Des-postes-Linux-Kubuntu-dans-un.html

Le prog à télécharger est en bas de l'article.

Le fichier à adapter est "smbsolstice.py", dont voici l'extrait le plus important :

    #-- Window1.on_buttonAppliquer_clicked {
    def on_buttonAppliquer_clicked(self, widget, *args):
        # variables utiles :
        LocalUser = os.environ["USER"]
        HomeUser = "/home/" + LocalUser + "/"
        MessageErreur = ""

        # on deconnecte avant tout Okazou :
        Liste = ["smb4k/VERAC/Applics",
                 "smb4k/VERAC/Ubuntu",
                 "T",
                 "R"]
        for dossier in Liste :
            ligne_commande = "smbumount " + HomeUser + dossier
            os.system(ligne_commande)

        # on (re)cree les dossiers Okazou :
        Liste = ["smb4k",
                 "smb4k/VERAC",
                 "smb4k/VERAC/Applics",
                 "smb4k/VERAC/Ubuntu",
                 "T",
                 "R"]
        for dossier in Liste :
            ligne_commande = "mkdir " + HomeUser + dossier
            os.system(ligne_commande)

        # on connecte les dossiers (Applics etc) en tant que 00000  : 
        NetUser = "00000"
        mdp = "000"
        a = self.MonteRessource("VERAC", "Applics", HomeUser, "smb4k/VERAC/Applics", NetUser, mdp)
        if a != "" :
            MessageErreur = MessageErreur + "\r\n"
            MessageErreur = MessageErreur + a
        a = self.MonteRessource("VERAC", "Ubuntu", HomeUser, "smb4k/VERAC/Ubuntu", NetUser, mdp)
        if a != "" :
            MessageErreur = MessageErreur + "\r\n"
            MessageErreur = MessageErreur + a

        # on recupere utilisateur et mot de passe :
        NetUser = self.entryUser.get_text()
        mdp = self.entryMdp.get_text()

        # on connecte le dossier perso dans T :
        a = self.MonteRessource("VERAC", NetUser, HomeUser, "T", NetUser, mdp)
        if a != "" :
            MessageErreur = MessageErreur + "\r\n"
            MessageErreur = MessageErreur + a

        # pour connecter R, il faut trouver la classe :
    	try:
            # on lit la classe dans le dossier perso :
    	    NomFichier = HomeUser + "T/" + NetUser + ".cfg"
    	    file = open(NomFichier, 'r')
    	    for i in range(6) :
    		ligne = file.readline()
    	    file.close()
            # on vire le saut de ligne :
    	    Ress = "ress" + ligne[0:3]
            # on connecte le dossier ressource de la classe dans R :
            a = self.MonteRessource("VERAC", Ress, HomeUser, "R", NetUser, mdp)
            if a != "" :
                MessageErreur = MessageErreur + "\r\n"
                MessageErreur = MessageErreur + a
    	except IOError:
    	    print "Impossible d'ouvrir le fichier"
    	    MessageErreur = MessageErreur + "\r\n"
            MessageErreur = MessageErreur + "Impossible de se connecter à R"
    	except:
    	    print "autre erreur"
    	    MessageErreur = MessageErreur + "\r\n"
            MessageErreur = MessageErreur + "Impossible de se connecter à R"

        # si tout c'est bien passé :
        if MessageErreur == "" :
            self.MsgBoxOK(u"Tout c'est bien passé")
            # on ferme :
            gtk.main_quit()
        # sinon :
        else :
            MessageErreur = MessageErreur + "\r\n" + "\r\n"
            MessageErreur = MessageErreur + u"Recommencer"
            self.MsgBoxProbleme(MessageErreur)
            # on efface les saisies :
            self.entryUser.set_text("")
            self.entryMdp.set_text("")
    #-- Window1.on_buttonAppliquer_clicked }

en espérant que cela puisse servir

O-
Pascal

Hors ligne

#6 Le 27/10/2006, à 20:26

Lalou

Re : ubuntu et sambaedu

j'ai le script pour faire rejoindre ubuntu, il ne me manque plus que l'autorisation de l'admin réseau puis je vous le passe, j'en profiterai pour avoir les instruction exacts pour l'installation, étant en vacance je finirai les test sur les machines à la rentrée mais pour l'instant tout à l'air de fonctionner normalement


Beryl c'est trop fort, stargate aussi
Ubuntu 7.04 Feisty Fawn
Nvidia GeForce 6200 avec turbo cache
Proc: Pentium 4 3GHz avec hyper threading

Hors ligne

#7 Le 06/11/2006, à 21:58

forficule

Re : ubuntu et sambaedu

C'est la rentrée smile ou sad suivant les cas... Alors que devient ce script pour rejoindre un réseau samdaedu3 ?
Je veux bien tester et aider au débugage si besoin... merci.

Hors ligne

#8 Le 06/11/2006, à 22:29

Lalou

Re : ubuntu et sambaedu

je n'ai pas l'admin qui bosse sur sambaedu aujourd'hui je pense peut être demain, normalement devrai pas y avoir de problème quand même


Beryl c'est trop fort, stargate aussi
Ubuntu 7.04 Feisty Fawn
Nvidia GeForce 6200 avec turbo cache
Proc: Pentium 4 3GHz avec hyper threading

Hors ligne

#9 Le 11/11/2006, à 12:14

Lalou

Re : ubuntu et sambaedu

Bon alors le script de config pour les clients à été (ou va être très bientôt) mis en ligne sur le site officiel de sambaedu et pour le script de config serveur il va être intégré dans les prochaines mises à jour de SE3.


Beryl c'est trop fort, stargate aussi
Ubuntu 7.04 Feisty Fawn
Nvidia GeForce 6200 avec turbo cache
Proc: Pentium 4 3GHz avec hyper threading

Hors ligne

#10 Le 11/11/2006, à 16:41

forficule

Re : ubuntu et sambaedu

Excellent ! j'ai hâte de tester tout ça sur le réseau se3 de mon collège... Je surveille donc le site officiel et les maj !
merci.

Hors ligne

#11 Le 30/03/2007, à 20:36

forficule

Re : ubuntu et sambaedu

Bonsoir, j'ai mis le se3 de mon établissement à jour, les scripts pour intégrer un client linux (ubuntu ou sarge) sont maintenant inclus.
Mon soucis c'est de passer la (les ?) locale en iso quelque chose au lieu de l'utf.
J'ai suivi les commandes de la doc ici http://wwdeb.crdp.ac-caen.fr/mediase3/i … ient_Linux
mais je bloque avec locale.
Tout se passe bien, jusqu'au dpkg-reconfigure localconf que je suis à la lettre, avec sélection de la locale fr_FR@euro ISO-8859-15, puis la mise à jour des locales se passe, et quand je vérifie je suis toujours en utf sad
Du coup le script se termine avec le message d'erreur qui m'avertit de changer les locale...
P.S. : je fais cette manip' sur un celeron 600 mhz/64 ram, installé en serveur puis gonflé à la main avec xfce...

Hors ligne

Haut de page ↑