Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 23/02/2012, à 21:43

brulien

Impossible d'installer U11.10 sur Lenovo B570e. Pb UEFI

Bonjour,

Cela fait deux jours que je m'échine à installer Ubuntu 11.10 sur mon nouvel ordi portable, en vain ...

Le probleme, si j'ai bien compris, c'est que les portables récents sont equipé d'un systeme appellé UEFI qui rend plus compliqué le processus de démarrage.

J'ai suivi trois différents tutoriels sans succès.

Celui ci http://forum.ubuntu-fr.org/viewtopic.php?id=757311 n'a eu aucun effet (aucun processus de démarrage détecté)

Celui la non plus http://ubuntuforums.org/showthread.php?t=1867367.

Je n'ai pas pu suivre celui-la http://askubuntu.com/questions/91484/ho … m-efi-uefi (reponse2) jusqu'au bout car cela me retourne une erreur à l'etape 4 quand il faut tapper la commande

grub-probe --target=device /boot/efi/efi/grub/grub.efi

"il" me repond

../grub-probe: error : cannot stat ´/cow´.

Comment faire ?

Merci

Dernière modification par brulien (Le 23/02/2012, à 22:00)

Hors ligne

#2 Le 24/02/2012, à 03:43

david96

Re : Impossible d'installer U11.10 sur Lenovo B570e. Pb UEFI

Cette erreur a été signalée dans le launchpad ubuntu

https://bugs.launchpad.net/ubuntu/+sour … bug/703009

Par contre c'est tout en anglais.

Hors ligne

#3 Le 24/02/2012, à 12:52

brulien

Re : Impossible d'installer U11.10 sur Lenovo B570e. Pb UEFI

Sauf erreur de ma part, ce bug n'a pas l'air d'être le miens puisque je n'ai pas de problème pour installer grub, et que l'erreur ne mentionne pas `aufs` mais `cow` !

Hors ligne

#4 Le 24/02/2012, à 13:34

malbo

Re : Impossible d'installer U11.10 sur Lenovo B570e. Pb UEFI

brulien,
Je comprends que tu aies les nerfs à vif parce que ce n'est pas simple. Pourrais-tu répondre à cette demande et poster le lien vers ton rapport Boot-Info : http://forum.ubuntu-fr.org/viewtopic.php?id=614071
Cette demande, c'est pour voir où tu en es, parce que tu as dû tenter mille choses et j'ai besoin d'un "état des lieux"


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#5 Le 24/02/2012, à 14:44

brulien

Re : Impossible d'installer U11.10 sur Lenovo B570e. Pb UEFI

Merci beaucoup !

Voici le lien du boot-info: http://paste.ubuntu.com/855322/

Hors ligne

#6 Le 24/02/2012, à 16:02

malbo

Re : Impossible d'installer U11.10 sur Lenovo B570e. Pb UEFI

Je ne vois pas d'anomalie dans le résultat de ton Boot-Info.
Depuis une session live, peux-tu passer cette commande (elle va monter la partition EFI dans /mnt ):

sudo mount /dev/sda1 /mnt

puis celle-ci (L minuscule au debut) dans le but de lister le contenu de la partition EFI :

ls /mnt

Elle devrait donner un dossier "EFI" en résultat (il pourrait aussi y avoir autre chose que EFI en résultat mais c'est le dossier EFI qui nous intéresse)
puis cette dernière commande :

ls /mnt/EFI/ubuntu

qui devrait retourner "grubx64.efi" si l'installation de Ubuntu a bien été faite complètement (ce fichier .efi est l'amorceur de Grub). Le système UEFI de ton PC est dressé pour rechercher les fichiers .efi sur un disque dur, ces fichiers .efi étant les amorceurs des systèmes d'exploitation. Si ce fichier grubx64.efi n'existe pas, il faudra le récréer (je te dirai comment).

Edit :  je pense que tu ne vas pas trouver le fichier .efi parce que je viens de lancer un Boot Info sur mon installation EFI et je trouve ceci :

Boot Info Script 0.60-git      [23 Feb 2012]


============================= Boot Info Summary: ===============================

 => No boot loader is installed in the MBR of /dev/sdb.

sdb1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  FAT16
    Boot sector info:  According to the info in the boot sector, sdb1 starts 
                       at sector 0. But according to the info from fdisk, 
                       sdb1 starts at sector 2048. According to the info in 
                       the boot sector, sdb1 has 0 sectors.
    Operating System:  
    Boot files:        /efi/ubuntu/grubx64.efi 

Chez moi il y a bien le fichier grubx64.efi mais pas chez toi puisque dans ton Boot-Info l'emplacement "Boot files" est vide :

sda1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  FAT16
    Boot sector info:  According to the info in the boot sector, sda1 starts 
                       at sector 0. But according to the info from fdisk, 
                       sda1 starts at sector 2048. According to the info in 
                       the boot sector, sda1 has 0 sectors.
    Operating System:  
    Boot files:        

Dernière modification par malbo (Le 24/02/2012, à 16:35)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#7 Le 24/02/2012, à 16:42

brulien

Re : Impossible d'installer U11.10 sur Lenovo B570e. Pb UEFI

Je viens d'appliquer les commandes que tu me suggérais, le fichier grubx64.efi est en place ...

Edit :
Je pensais au départ que cela venais du fait que j'ai appliqué entretemps un boot rescue, mais ce tout dernier boot info ne me donne toujours pas de grubx64.efi ...
dernier boot info : http://paste.ubuntu.com/855412/

Dernière modification par brulien (Le 24/02/2012, à 16:50)

Hors ligne

#8 Le 24/02/2012, à 16:59

malbo

Re : Impossible d'installer U11.10 sur Lenovo B570e. Pb UEFI

Peux-tu reprendre la manip indiquée plus haut pour voir le contenu de la partition EFI et passer cette commande supplémentaire :

ls -l /mnt/EFI/ubuntu/grubx64.efi

Chez moi, elle donne ceci :

ls -l /mnt/EFI/ubuntu/grubx64.efi
-rwxr-xr-x 1 root root 131072 2011-12-28 20:14 /mnt/EFI/ubuntu/grubx64.efi
ubuntu@ubuntu:~$ 

on y voit la taille du fichier qui est de 131072 octets (le tien est peut-être vide ?)

Dernière modification par malbo (Le 24/02/2012, à 17:01)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#9 Le 24/02/2012, à 17:09

brulien

Re : Impossible d'installer U11.10 sur Lenovo B570e. Pb UEFI

Cela me donne la meme chose, à la date de création du fichier près.

Hors ligne

#10 Le 24/02/2012, à 17:17

malbo

Re : Impossible d'installer U11.10 sur Lenovo B570e. Pb UEFI

Si le fichier .efi est là, il faut maintenant configurer ton système UEFI pour lui dire que ce fichier là, c'est l'amorceur de ton Ubuntu. C'est expliqué dans le § 4.1 Using Boot Maintenance Menu de ce doc : http://software.intel.com/en-us/article … scripting/
Il y a dans ton UEFI/BIOS une fonctionnalité qui doit être désignée "Add a boot option" (c'est dans le lien que je viens de te donner) et c'est grâce à cette fonction que tu vas pouvoir créer une entrée pour Ubuntu. Je mets ça en pratique dans "D) installation de Ubuntu 11.10 depuis la session live" de ce tuto : http://forum.ubuntu-fr.org/viewtopic.ph … 1#p7189161
C'est cette partie :

On sélectionne la ligne "Boot maintenance manager", puis "Boot options", puis "Add boot option"
il apparaît un gros pâté (je mets des points parce que j'ai la flemme de tout copier) " NO VOLUME LABEL,....Primary,Slave...1, GPT,.." qui est déjà présélectionné. Il suffit d'appuyer sur Entrée
Il apparait alors :

<EFI>

il faut encore appuyer sur Entrée
Il apparait alors plusieurs lignes. sélectionner la ligne

<ubuntu>

et valider par Entrée
sélectionner dans ce qui s'affiche la ligne :

grubx64.efi

et valider par Entrée
Dans le menu qui apparaît, sélectionner la première ligne :
"Input the description" et valider par Entrée. On doit entrer un titre (moi je tape "oneiric") et on valide
Puis on descend sur la ligne "Commit Changes and exit" et on valide par Entrée, on ressort en appuyant plusieurs fois sur la touche Echap pour revenir sur la ligne Boot Manager : on peut constater que la liste des options contient à présent une ligne supplémentaire (la mienne s'appelle oneiric puisque c'est le nom que j'ai choisi). En sélectionnant cette ligne et en la validant par Entrée, on démarre sur le Ubuntu fraîchement installé.

Ce qui est curieux, c'est que dans certains posts que je trouve sur internet avec l'ami Google, je vois que des systèmes UEFI sont capables de détecter tout seuls les fichiers EFI et de proposer automatiquement une entrée pour y aller (genre "UEFI:UBUNTU" comme dans ce post ) mais il semblerait que dans certains cas, il faille faire le boulot en manuel, comme je l'ai fait dans ce que j'ai collé plus haut, le système UEFI jouant au con, genre "qu'est-ce que je peux te faire ?" mais ne prend pas l'initiative de proposer une entrée correspondant à chaque fichier .efi qu'il détecte sur le disque dur. Il faut dire aussi que tu es loin d'être expert dans l'utilisation de ce système et il est possible que tu n'aies pas encore fait le bon réglage de ton système UEFI pour qu'il prenne ça en charge automatiquement...

Dernière modification par malbo (Le 24/02/2012, à 17:53)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#11 Le 24/02/2012, à 19:56

brulien

Re : Impossible d'installer U11.10 sur Lenovo B570e. Pb UEFI

Impossible de lancer le Boot Maintenance Menu.
Soit c'est Lenovo qui a bloqué cette option, soit c'est une conséquence de la suppression de la première partition quand j'ai tenté ma premiere installation.

Le shell au début ne se lançais pas. Suivant les indications de ce wiki https://wiki.archlinux.org/index.php/Un … UEFI_Shell , j'ai réussi a le lancer, mais la commande exit m'envois sur le menu de démarrage (HD/CD, ...). J'ai donc essayé la commande bcfg, mais cela me dit que cette commande n'exhiste pas.

J'ai donc essayé efibootmgr http://linux.die.net/man/8/efibootmgr dans le live cd Ubuntu,

J'ai tapé exactement ces deux commandes pour tester ces deux .efi installés:

sudo efibootmgr --create --gpt --disk /dev/sda --part 1 --write-signature --label "GRUB A" --loader "\\EFI\\grub\\grub.efi"
sudo efibootmgr --create --gpt --disk /dev/sda --part 1 --write-signature --label "GRUB B" --loader "\\EFI\\ubuntu\\grubx64.efi"

Les commandes ont l'air de fonctionner, car on voit finalement la liste avec les deux GRUB, affublés d'une petite étoile (au meme titre que toutes les lecteurs physiques). J'ai donc redémarré, et rien. Je suis allé dans la configuration BIOS standard, rien n'a été ajouté dans la liste. J'ai donc relancé efibootmgr sur la distro ubuntu, et les deux entrées grub avaient disparu ...

Je me demande si il n'y aurait pas une sécurité supprime les entrées inconnues au redémarrage ?

Hors ligne

#12 Le 25/02/2012, à 07:56

malbo

Re : Impossible d'installer U11.10 sur Lenovo B570e. Pb UEFI

Je ne sais pas ce qui se passe. Pourrais-tu tenter une réinstallation de Ubuntu 11.10 mais en laissant l'installateur faire le partitionnement automatique à l'étape "Allouer de l’espace disque" (option effacer tout le disque pour installer Ubuntu) ? Il n'est pas question de laisser le partitionnement en l'état pour l'avenir : c'est seulement pour voir si l'installation automatique de Ubuntu résout ou pas le problème. N'essaie plus le Shell : quand je lis les posts de ceux qui réussissent, il n'ont rien à faire et l'entrée UEFI:UBUNTU est proposée automatiquement par leur Bios (voir Edit). Configure quand même provisoirement ton système UEFI/BIOS pour qu'il soit en UEFI uniquement (j'ai vu qu'il y avait des possibilités de régler sur "Both", c'est à dire BIOS par défaut sinon UEFI. Si c'est le cas chez toi, passe en "UEFI only" ou l'équivalent pour voir si ça résout ) 
As-tu un lien vers de la doc qui présente le système UEFI/Bios pour ton PC ?
As-tu une section "Boot Override" dans ton UEFI/BIOS comme on voit là pour une carte-mère P8P67 : http://info-coach.fr/pc/hardware/AsusP8 … t_override
Cette fonctionnalité permet de sélectionner une entrée et de démarrer direct dessus. C'est là que tu pourrais trouver une entrée UEFI:UBUNTU proposée.

Edit : par exemple, dans ce post : http://ubuntuforums.org/showpost.php?p= … stcount=36
evil_hog précise : "Follow the instructions to finish installation and reboot your PC. You should see 'ubuntu' in boot order menu in bios or by hitting F12. The installer puts ubuntu at the top of this list, so after reboot you will get to newly installed system."On ne sent pas la sueur là : tout s'est fait automatiquement et l'entrée "ubuntu" apparaît dans un menu (j'imagine) si tu maintiens la touche F12 enfoncée pendant tout le début du démarrage jusqu'à apparition de ce menu.

Dernière modification par malbo (Le 25/02/2012, à 10:08)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#13 Le 27/02/2012, à 09:26

brulien

Re : Impossible d'installer U11.10 sur Lenovo B570e. Pb UEFI

Encore merci Malbo pour ton aide ! Je garde espoir.

Je vais reessayer une installation automatique sachant que je l-ai deja fait et que ca n'a rien regle du tout.

Quant au BIOS, le probleme est que je n'ai acces a aucune option avancee ! Je ne peux ni choisir duquel mode UEFI ou Bios je boot, ni ajouter une entree, ni de section Boot override, ni de Add Boot Option. Jai cherche deja un peu partout sur les forums a savoir s'il y avait une maniere d'avoir acces a un reglage de bios avance sur mon model de Lenovo, et rien ...

Pour en revenir au probleme, je suis de plus en plus persuade que le systeme bloque la possibilite dajouter une entree boot sur le UEFI qui ne soit pas windows ...

Hors ligne

#14 Le 27/02/2012, à 09:37

malbo

Re : Impossible d'installer U11.10 sur Lenovo B570e. Pb UEFI

brulien a écrit :

Pour en revenir au problème, je suis de plus en plus persuadé que le système bloque la possibilité d'ajouter une entrée boot sur le UEFI qui ne soit pas windows ...

Tu veux dire que tu penses que le problème pourrait affecter tous les Lenovo B570e ou bien tu veux dire que tu penses que c'est ton PC seulement qui a ce problème ?
Parce que quand on lit ce post (et la suite de la discussion) : http://ubuntuforums.org/showthread.php?t=1867367
on constate que le blocage auquel tu penses n'existe pas pour le Lenovo B570. Pourquoi ça serait bon pour le modèle 570 et pas bon pour le 570e ?

Dernière modification par malbo (Le 27/02/2012, à 09:43)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#15 Le 27/02/2012, à 10:27

brulien

Re : Impossible d'installer U11.10 sur Lenovo B570e. Pb UEFI

J'ai réussi !

Avant de faire une réinstallation, j'ai voulu tenter quelque chose que je n'avait pas encore put faire. Comme j'avait put réinstaller le shell avec succès suivant les indications suivantes : https://wiki.archlinux.org/index.php/Un … UEFI_Shell , j'ai donc remplacé "sda1//efi/boot/bootx64.efi" par "/efi/ubuntu/ubuntux64.efi", et ça marche !

Merci beaucoup !

En ce qui concerne le blocage, j'en ai aucune idée ...

Hors ligne

#16 Le 27/02/2012, à 11:01

malbo

Re : Impossible d'installer U11.10 sur Lenovo B570e. Pb UEFI

C'est devenu incompréhensible pour moi. Jusqu'au post #10 compris, chez toi comme chez moi, le fichier .efi se nommait grubx64.efi  et se trouvait dans le chemin suivant : /efi/ubuntu/grubx64.efi
A présent, le fichier qui te permet de démarrer Ubuntu se nomme ubuntux64.efi et se trouve dans ce chemin : /efi/ubuntu/ubuntux64.efi
J'arrête donc les frais car je n'arrive pas à suivre et ça me semble bien trop compliqué. Si ton pb est résolu, tu peux modifier le titre de ton post #1 pour qu'il devienne :   

[Résolu] Impossible d'installer U11.10 sur Lenovo B570e. Pb UEFI

en suivant ces indications : http://doc.ubuntu-fr.org/tutoriel/howto … _en_resolu


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

Haut de page ↑