Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 08/03/2012, à 23:58

mouton2002

[Résolu] Touchpad on/off Lubuntu

Bien le bonsoir,
n'ayant pas de raccourcis multimédia pour désactiver le touchpad, je voulais faire un raccourcis clavier. Par exemple dans mon rc :

<keybind key="Super-x">
      <action name="Execute">
          <command>synclient tapButton1=0</command>
      </action>
    </keybind> 

pour désactiver et

<keybind key="Super-y">
      <action name="Execute">
          <command>synclient tapButton1=1</command>
      </action>
    </keybind> 

Pour réactiver.

Serait-il possible d'assigner une seule touche pour que lorsque j'appuie une fois la valeur est 0 est lorsque je re-appuie la valeur est 1 ??

Merci !!

Dernière modification par mouton2002 (Le 04/11/2012, à 16:03)


CrunchBang Statler / Linux Mint 13 Cinnamon sur ordi. fixe - & -  Lubuntu 12.04 / Debian Squeeze en CLI sur EeePC 1005HA

Hors ligne

#2 Le 16/03/2012, à 17:29

mouton2002

Re : [Résolu] Touchpad on/off Lubuntu

Youhou !!!


CrunchBang Statler / Linux Mint 13 Cinnamon sur ordi. fixe - & -  Lubuntu 12.04 / Debian Squeeze en CLI sur EeePC 1005HA

Hors ligne

#3 Le 04/11/2012, à 16:03

mouton2002

Re : [Résolu] Touchpad on/off Lubuntu

Je me réponds histoire de clore le sujet.
J'ai trouvé :
1/ faire un script, par exemple :

#!/bin/bash

#récupération des infos synclient:
PADSTATE=`synclient -l | grep TapButton1 | tr -s " " | cut -d " " -f4`

# toggle on/off tapbutton
if [ $PADSTATE == 0 ]; then
    synclient tapButton1=1
else
    synclient tapButton1=0
fi

2/ Assigner un raccourcis clavier à ce script dans le .rc :

<keybind key="XF86TouchpadToggle">
      <action name="Execute">
           <command>~/.bin/toggletouchpad.sh</command>
      </action>
    </keybind>

Et voila ! smile


CrunchBang Statler / Linux Mint 13 Cinnamon sur ordi. fixe - & -  Lubuntu 12.04 / Debian Squeeze en CLI sur EeePC 1005HA

Hors ligne

#4 Le 11/01/2013, à 13:14

sgourichon

Re : [Résolu] Touchpad on/off Lubuntu

Merci d'avoir partagé. Le script n'est pas spécifique LXDE, il devrait fonctionner quasiment sur tous les bureaux, pourvu qu'on a le pilote et synclient. Pour s'en assurer :

sudo apt-get install xserver-xorg-input-synaptics

En revanche, le script semble n'affecter que la fonctionnalité "clic en touchant", pas les mouvements du pointeur en effleurant (et c'est ça qui me gêne).

Voici une version ajustée :

-sed au lieu de grep+tr+cut (plus robuste par rapport à la présence ou non d'espaces)
-envoie une notification à l'écran si possible pour confirmer l'opération

#!/bin/bash
# Adjusted from http://forum.ubuntu-fr.org/viewtopic.php?id=845811
FEATURE=TouchpadOff

OLDSTATE=$( synclient -l | sed -n "s/^ *$FEATURE *= *\(.*\)/\1/p" )

if [ $OLDSTATE == 0 ]
then
        NEWSTATE=1
        STATEMSG="disabled" # setting "TouchpadOff" to 1 disables Touchpad.
else
        NEWSTATE=0
        STATEMSG="enabled"
fi

synclient $FEATURE=$NEWSTATE

if type -f notify-send >/dev/null
then
        notify-send Touchpad "Touchpad $STATEMSG" &
fi

En bonus ligne de commande pour XFCE équivalente à la configuration XML d'une réponse précédente.

xfconf-query -c xfce4-keyboard-shortcuts -n -p "/commands/custom/XF86TouchpadToggle" -s "touchpad_toggle.sh" -t string

Teste sur Ubuntu 12.10.

Hors ligne

#5 Le 04/10/2013, à 09:05

pem1664

Re : [Résolu] Touchpad on/off Lubuntu

Bonjour merci pour ce script, qui fonctionne nikel quand je le lance en bash mais qui, lorsque j'utilise la touche raccourci donne un problème de droits/permissions..?
J'ai bien fait un chmod +x sur le fichier toggletouchpad.sh et j'ai essayé avec mon utilisateur et l'utilisateur root, rien n'y fait..
Une question aussi, j'ai pas compris a quoi sert la ligne de commande donnée en bonus :

xfconf-query -c xfce4-keyboard-shortcuts -n -p "/commands/custom/XF86TouchpadToggle" -s "touchpad_toggle.sh" -t string

elle évite d'utiliser le script?


Pas de problème sans solutions, mettre [résolu] dans son premier post permet de rechercher plus facilement une solution... ;)

Hors ligne

#6 Le 04/10/2013, à 09:17

mouton2002

Re : [Résolu] Touchpad on/off Lubuntu

@pem1664 : pour le raccourcis, tu peux essayer

chmod 750 ton_fichier

plutôt que chmod +x et me dire ce que ca donne ? Tu es sous quel environnement ? Comment assignes-tu le raccourcis ?
Pour la ligne "bonus" je n'en ai pas la moindre idée big_smile J’espère pour toi que sgourichon passera par là !


CrunchBang Statler / Linux Mint 13 Cinnamon sur ordi. fixe - & -  Lubuntu 12.04 / Debian Squeeze en CLI sur EeePC 1005HA

Hors ligne

#7 Le 04/10/2013, à 09:41

pem1664

Re : [Résolu] Touchpad on/off Lubuntu

Hello mouton2002, merci pour ta réponse, malheureusement ca n'a rien changé.. sad
je suis sous lxde et pour assigner le raccourci j'ai modifié le fichier .config/openbox/lxde-rc.xml
comme ceci :

<keybind key="XF86TouchpadToggle">
      <action name="Execute">
           <command>/home/pem/.bin/toggletouchpad.sh</command>
      </action>    </keybind>

et le fichier toggletouchpad.sh contient le script de sgourichon cité plus haut.
Le script fonctionne impec avec un

bash .bin/toggletouchpad.sh

mais le raccourci donne "permission non accordée" ?
Edit: désolé, j'avais oublié de remodifier l'utilisateur.. donc oui

sudo chmod 750

a bien fonctionné!! merci!
Maintenant pourquoi le chmod +x n'a pas suffit? chmod 750 donne bien le droit a l'utilisateur  en lecture ecriture et exécution et lecture et exécution pour le groupe et rien pour les autres..?

Dernière modification par pem1664 (Le 04/10/2013, à 09:51)


Pas de problème sans solutions, mettre [résolu] dans son premier post permet de rechercher plus facilement une solution... ;)

Hors ligne

Haut de page ↑