Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#151 Le 21/02/2011, à 13:29

keysoftav

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Le but est d'avoir seulement le compte local et tout le reste, des comptes Active Directory donc les droits ne sont gérés à aucun moment sur les clients Linux.

Je ne gère pas de documents personnels, les partages sont gérés par service, ou bien poste de responsable par exemple mais encore une fois, les droits sont gérés sur le serveur donc je n'ai pas besoin de spécifier un groupe en montant les volumes.

Au sujet des scripts, j'ai bien modifié les liens pour les domaines et j'ai bien la ligne pour configurer le domaine par défaut, c'est la même sauf que "AssumeDefaultDomain 1" est sur la ligne suivante, ça expliquerait pourquoi je dois spécifier le domaine ?

Merci pour le script, je vais tester ça.

Hors ligne

#152 Le 21/02/2011, à 13:39

Divad

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

- pour le domaine par défaut, je crois que l'erreur vient de là.
- pour le script précédent, attention, il y avait une coquille que je viens de corriger.

sinon, j'avoue avoir un peu de mal à comprendre ta demande réelle par rapport aux droits et utilisateurs. Ne veux-tu pas faire un topo sur ce que tu as et ce que tu veux ?

Hors ligne

#153 Le 21/02/2011, à 15:51

keysoftav

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

En faite, c'était bien un espace mais ça envoyait le texte à la suite et j'ai re-testé, j'arrive à me connecter sans préciser DOMAIN, peut-être seulement obligatoire pour la 1ère connexion ?

J'ai résolu une partie de mon problème en montant les volumes dans le home de l'utilisateur pour être sûr que rien ne reste connecter après un changement d'utilisateur.
Après, c'était juste des explications sur la gestion de droits, mon seul souci, les droits pour "Autres", j'aimerais qu'il y en ait aucune autorisations sur les partages car je ne sais pas où Ubuntu va chercher ça sur le serveur de données et actuellement, il peut lister tout le contenu.

Hors ligne

#154 Le 08/03/2011, à 22:36

Remaille

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

SADMS (dans les dépôts Ubuntu) permet de faire ce travail.
Quelques liens utiles :

Une dépêche sur linuxFR :
http://linuxfr.org/news/sadms-int%C3%A9 … -directory

La homepage de SADMS :
http://sadms.objectif-libre.com/

Un tutoriel rapide et en français sur le site du groupe linuxedu :
http://linuxedu.ac-toulouse.fr/doku.php?id=projet:sadms

@+
Rémi.

Dernière modification par Remaille (Le 18/03/2011, à 23:04)

Hors ligne

#155 Le 14/03/2011, à 11:37

Divad

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Merci Remaille. je connaissais, mais je ne suis jamais arrivé à des résultats concluant. Peut-être que dans la version actuelle c'est mieux... As-tu testé ?

Hors ligne

#156 Le 16/03/2011, à 13:08

anyoaceo

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Bonjour,

J'ai cherché un peu plus pour les droits sur les homes utilisateurs: RAPPEL: "Un utilisateurs AD peut voir le contenu d'une home d'un autre utilisateur AD".

Test modification du paramétrage dans la base de registre de likewise via les UMASK, aucun effet.
Modification du répertoire racine contenant les homes en 2700 (Exemple), aucun effet lors de la création des homes, elles restent en 777.
Je sais pas trop quoi faire, dans la doc likewise open il ne parle que des Umask et l'on peut mettre n'importe quoi rien ne fonctionne.

Quelqu'un saurait-il si il est possible de lancer un script (en root) après la création d'une home utilisateur par likewise, pour modifier les droits manuellement sur le répertoire ?

Il est bizarre que ca n'inquiete pas grand monde ce problème sur les homes perso qui sont accessibles par tous le monde smile

Sinon j'ai testé SADMS, mais le mapping des partages distant ne fonctionne pas (enfin pas chez moi). Il y a un bug pour Samba, il faut créer un fichier lanceur bidon. Sinon la gestion des droits par défaut sur les homes est OK big_smile. Mais je préfère la solution d'ici smile

@+

Hors ligne

#157 Le 16/03/2011, à 14:15

Divad

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

bonjour anyoaceo,

- concernant, SADMS, pour moi aussi, certaines choses marchaient, d'autres non, et c'est pour cela que j'ai préféré tout reprendre.

Pour le droit des homes, plusieurs points :
- bien utiliser des user="*" dans le fichier de conf et nom des des gid="profs" ou gid="eleves" et bien vérifier les droits sur le serveur AD.
- d'autre part, j'ai verrouillé les postes : un utilisateur, pour quitter sa session, doit obligatoirement éteindre ou redémarrer le poste. ( je pense que l'obligation, de fermer sa session doit marcher aussi, mais pas testé). Dans tous les cas, le multiutlisateur ne fonctionne pas ( idem avec windows). Cela paraît contraignant, mais cela fonctionne très bien dans notre salle des profs et CDI. Et entre deux utilisations, je n'ai plus d'ordinateur qui tourne pour rien.
voici mon script de préparation des postes :

prepa_skel (){
### PARAMETRAGE DU SKELLETTE
# enlève les options d'hibernation
sudo sed -i '/<allow_active/d' /usr/share/polkit-1/actions/org.freedesktop.upower.policy
sudo sed -i '/<allow_inactive/ a\'"<allow_active>no</allow_active>" /usr/share/polkit-1/actions/org.freedesktop.upower.policy
gconftool-2 --type bool --set /apps/indicator-session/suppress_logout_menuitem true

#enlever la liste des utilisateurs à la connexion
gconftool-2 --type bool --set /apps/gdm/simple-greeter/disable_user_list true

## désactiver le menu de deconnexion
gconftool-2 --type bool --set /apps/panel/global/disable_log_out true

## icones à droite
gconftool-2 --set "/apps/metacity/general/button_layout" --type string ":minimize,maximize,close"

#enlever le verouillage de l'écran
gconftool-2 --type bool --set /desktop/gnome/lockdown/disable_lock_screen true
#enlever le verouillage de l'économiseur d'écran

#enlever le user switch
gconftool-2 --type bool --set /desktop/gnome/lockdown/disable_user_switching true

}

Mise à jour du premier post incluant ce message.

Dernière modification par Divad (Le 16/03/2011, à 14:22)

Hors ligne

#158 Le 17/03/2011, à 17:51

Oscour

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Désolé DIVAT, j'ai lâché un peu l'affaire depuis février :

Divad a écrit :

intéressant Oscour !

Petite question hors sujet pour le LTSP: quelle est la taille de ton serveur ( ram, DD du syteme et DD des homes) et le nombre de clients potentiels ?

Mon serveur n'as que 2Go de memoire et un disque dur de 80Go et un proc de 1,8g pour 6 client légers Hp.
Mais ça tourne bien sans que cela soit la folie, je travaille dans un lycée et j'ai montée ces clients pour le CDI. Et j'ai modifié l'apparence du  Bureau pour que les utilisateurs est le moins d'options possible, pas de tableau de bord, pas de menu, le minimum vital dans nautilus, seulement de gros icônes pour accéder aux applications autorisé et à internet, avec en plus un gros lanceur juste pour se déconnecter.

Divad a écrit :

question dans le sujet : est-ce la 10.10 ou le LTSP qui empêche d'utiliser les dossiers partagés windows ?

Je suis donc sous 10.10 et je n'ai plus trop de problèmes pour monter des dossiers sur le bureau de mes clients grâce à tous les personnes qui on participer à ce post (et ailleurs aussi), merci.

Je n'arrivais pas à monter mes dossiers à cause des options dans le fichier pam_mount.conf.xml, j'ai du rajouter ceci : options="dir_mode=0777"   et soudain ma vie c'est éclairé !!!

J'ai encore rajouté ceci pour les accents : options="dir_mode=0777,iocharset=utf8"

Au total ma ligne ressemble à ceci :

<volume user="*" fstype="cifs" server="10.134.10.70" path="%(USER)$" mountpoint="~/Documents/%(USER)/" options="dir_mode=0777,iocharset=utf8" />

Et le répertoire perso de l'élève monte sur son bureau des la connexion.

Ce que je n'arrive pas encore à faire c'est faire monté un répertoire partagé par tous : Ou plutôt si ! J'arrive à le faire monté, mais seulement à un seul élève à la fois, explication :

____ Si un élève se connecte, un dossier partagé nommé "CDI" monte sur son bureau mais si pendant que cet élève est connecté , un autre élève se connecte à son tour le partage ne monte pas.
Il faudra que le premier élevé se déconnecte pour redonner droit de montage à un autre utilisateur (et à un seul)._____________

Je voudrais que ce partage soit accessible par tous et en même temps !!!

Quelqu'un réussi à faire genre de chose ?

Dernière modification par Oscour (Le 17/03/2011, à 23:14)

Hors ligne

#159 Le 17/03/2011, à 17:56

Divad

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

pas le temps de tout lire, mais ça m'a l'air intéressant...
pour la 10.10, quelle méthode as-tu utilisé pour installer tes clients ?
pour ton problème de partage c'est peut-être le dir_mod=0777 qui coince si tu l'appliques aussi au dossier CDI. essaie sans.

Dernière modification par Divad (Le 17/03/2011, à 17:57)

Hors ligne

#160 Le 17/03/2011, à 23:26

Oscour

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Divad a écrit :

pour la 10.10, quelle méthode as-tu utilisé pour installer tes clients ?

Mais la tienne mon neveu, le script qui réside au tout début de ce post, et ça fonctionne très bien.

Divad a écrit :

pour ton problème de partage c'est peut-être le dir_mod=0777 qui coince si tu l'appliques aussi au dossier CDI. essaie sans.

Déjà essayé, de le supprimer mais pas de le modifier et tu viens de me faire TILT !!!

En fouinant un peu j'ai trouvé ceci :

PS: on peut ajouter également dans les options de montage file_mode=0640,dir_mode=0755 ce qui va restreindre l'accès aux comptes en dehors de root, de l'administrateur du réseau, et du groupe tout en laissant tout le monde scanner le dossier monté.
Trouvé ici : http://michel-eudes.net/blog/index.php?q=samba

Je pense que demain je vais creuser par là...

Hors ligne

#161 Le 18/03/2011, à 13:16

Divad

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

ok et bien je réessaierai sur la 10.10, mais mes premiers tests s'étaient avérés négatifs, c'est pour ça... (d'un autre côté, mieux vaut mettre les efforts sur la 11.04 maintenant !)

pour les droits, as-tu bien configuré le partage des dossiers sur le serveur windows. car chez moi, je ne précise rien de particulier au niveau des clients. Tout est dans l'AD : pour le dossier CDI, tout le monde peut consulter, sauf la documentaliste et moi-même qui avons le droit d'écrire dessus. Mais rien de préciser au niveau des clients.

Dernière modification par Divad (Le 18/03/2011, à 13:17)

Hors ligne

#162 Le 18/03/2011, à 14:32

Oscour

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Les droits sur le dossier Windows sont bien configuré : droit en écriture pour moi et la documentaliste et regard juste pour les autres, mais le problème n'est pas là, puisque quand un client se connecte le partage monte bien sur le bureau et l'utilisateur peut consulter sans modifier. si un autre client se connecte en même temps, là le partage ne se montera pas et si le premier client se déconnecte alors à ce moment le partage montera pour le deuxième client.
Voila, les droits sont bien configuré mais ce n'est pas un partage "partageable" , mais que pour un client à la fois !!!

file_mode=0640,dir_mode=0755 n'ont rien donné, à part modifier les droits d'accès en lecture (et pas en écriture puisque les droits Windows font barrage).

J'ai bien trouvé une page sur "comment configurer pam-mount et ses options" mais en anglais et la langue de Shakespeare c'est pas mon fort ! :

http://manpages.ubuntu.com/manpages/jau … onf.5.html

Si je ne précise rien au niveau des clients ça ne marche pas non plus.

je ne sais pas si la solution est de tripatouiller le fichier pam_mount.conf.xml mais puisque sa semble fonctionné chez toi, pourrait tu publier ton fichier pam_mount.conf.xml , ça pourrait peut être m'aider ?

merci

Dernière modification par Oscour (Le 18/03/2011, à 14:33)

Hors ligne

#163 Le 18/03/2011, à 14:51

Divad

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

mon fichier /etc/security/pam_mount.conf.xml une fois tout installé :

regarde peut-être l'avant dernière ligne : <mkmountpoint enable="1" remove="true" />
et si tu le montes dans un dossier comme media ou mnt ?


<?xml version="1.0" encoding="utf-8" ?>
<!DOCTYPE pam_mount SYSTEM "pam_mount.conf.xml.dtd">
<!--
    See pam_mount.conf(5) for a description.
-->

<pam_mount>

        <!-- debug should come before everything else,
        since this file is still processed in a single pass
        from top-to-bottom -->

<debug enable="0" />

        <!-- Volume definitions -->
<volume user="*" fstype="cifs" server="srv-peda" path="classes$" mountpoint="/media/Classes" options="iocharset=utf8"/>
<volume user="*" fstype="cifs" server="srv-peda" path="eleves$" mountpoint="/media/Eleves" options="iocharset=utf8"/>
<volume user="*" fstype="cifs" server="srv-peda" path="cdi$" mountpoint="/media/CDI" options="iocharset=utf8"/>
<volume gid="eleves" fstype="cifs" server="srv-peda" path="eleves$/%(USER)" mountpoint="~/Documents" options="iocharset=utf8"/>
<volume gid="profs" fstype="cifs" server="srv-peda" path="profs$/%(USER)" mountpoint="~/Documents" options="iocharset=utf8"/>


        <!-- pam_mount parameters: General tunables -->

<!--
<luserconf name=".pam_mount.conf.xml" />
-->

<!-- Note that commenting out mntoptions will give you the defaults.
     You will need to explicitly initialize it with the empty string
     to reset the defaults to nothing. -->
<mntoptions allow="nosuid,nodev,loop,encryption,fsck,nonempty,allow_root,allow_other" />
<!--
<mntoptions deny="suid,dev" />
<mntoptions allow="*" />
<mntoptions deny="*" />
-->
<mntoptions require="nosuid,nodev" />
<path>/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin</path>

<logout wait="0" hup="0" term="0" kill="0" />


        <!-- pam_mount parameters: Volume-related -->

<mkmountpoint enable="1" remove="true" />


</pam_mount>

Dernière modification par Divad (Le 18/03/2011, à 14:53)

Hors ligne

#164 Le 18/03/2011, à 23:07

Remaille

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Divad a écrit :

Merci Remaille. je connaissais, mais je ne suis jamais arrivé à des résultats concluant. Peut-être que dans la version actuelle c'est mieux... As-tu testé ?

Oui, nous avons pas mal testé. La version des dépôts de la 10.10 est fonctionnelle sans soucis. Il y a juste un bug non bloquant qui est corrigé dans la toute dernière : enregistrer les réglages dans un fichier (problèmes de droits).

Tu pourras trouver la toute dernière version ici : http://sourceforge.net/projects/sadms/ (2.0.15)

Hors ligne

#165 Le 21/03/2011, à 11:57

Oscour

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Non, non, non, haaarg !!!

non je ne vois pas ! J'ai essayé plein de solutions en me basant sur ton fichier, ça ne monte pas. Sur le bureau en tout cas, par nautilus j'arrive à accéder au dossier CDI mais le montage ne se fait pas sur le bureau pour tout le monde en même temps.

De toute façon je laisse tomber, j'ai trouvé une solution de secours pas très propre, mais ça feras l'affaire tant pis :

J'arrive à monter sur le bureau de l'utilisateur son dossier perso "Mes Documents" et j'ai pointé le point de montage "CDI" directement dans ce dossier. Du coup en ouvrant le dossier "Mes Documents", l'élevé accède au dossier "CDI" en même temps que les autres utilisateurs.

<volume user="*" fstype="cifs" server="10.134.1.251" path="%(USER)$" mountpoint="~/Mes Documents" options="dir_mode=0777,iocharset=utf8" />
<volume  fstype="cifs" server="10.134.1.251" path="cdi$" mountpoint="~/Mes Documents/CDI"  options="file_mode=0640,dir_mode=0750,iocharset=utf8"/>

Voila !!!

Merci Divad

Hors ligne

#166 Le 08/04/2011, à 16:16

Veni

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Bonjour à tous et bravo pour ce topic !
Je m'en suis pas mal servi pour l'utilisation de likewise dans mon entreprise.

depuis récemment lors de mes installations sur des ubuntu 10.10 et likewise open 6, l'utilisateur likewise ne s'affiche pas dans la page de login de Ubuntu.
j'ai trouvé sur le net la solution et je vous la donne,
il suffit de rajouter dans /etc/passwd l'utilisateur :

DOMAIN\user:x:(id):0:Firstname Name,,,:/home/DOMAIN/user:/bin/bash

l'id se récupère tout simplement en tapant id dans la console, c'est l'uid qui nous intéresse

en espérant que ça puisse aider d'autres personnes!

Dernière modification par Veni (Le 08/04/2011, à 16:22)

Hors ligne

#167 Le 11/04/2011, à 09:50

Divad

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

@Oscour : désolé, je n'avais pu vu ton message avant. Fais attention, j'avais aussi fait de tel montage et il s'était trouvé que l'utilisateur avait les droits d'écriture ( et de suppression ) sur le dossier CDI !

@Remaille et Veni : Merci pour vos astuces ! Je pense que maintenant, il va falloir tourner les efforts vers la 11.04. Avec sadms ? voire la 12.04 et bénéficier d'une LTS... ou passer sur des serveurs linux ;-))

Hors ligne

#168 Le 19/04/2011, à 12:26

Oscour

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Divad a écrit :

@Oscour : désolé, je n'avais pu vu ton message avant. Fais attention, j'avais aussi fait de tel montage et il s'était trouvé que l'utilisateur avait les droits d'écriture ( et de suppression ) sur le dossier CDI !

J'ai testé en me connectant avec un login élève et je n'ai pas pu effacer quoi que ce soit dans le dossier CDI. je crois que les droits des dossiers Windows prennent le pas sur les droits d'ubuntu, j'en suis même persuadé !!!

Hors ligne

#169 Le 31/05/2011, à 13:48

Lanstack

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Bonjour,

Nouveau dans le monde linux  Ubuntu 11.04 + AD 2003

J'ai réussi à rejoindre un domaine Windows. Maintenant je souhaiterais monter des partages réseau. Pour cela, il faudrait que je modifie le fichier /etc/security/pam_mount.conf.xml

Je l'ouvre avec gedit, mais le fichier est en lecture seule. Comment faire pour enregistrer les modifications.

Je suis connecté sur Ubuntu avec le compte que j'ai crée lors de l'installation

Dernière modification par Lanstack (Le 31/05/2011, à 13:50)

Hors ligne

#170 Le 31/05/2011, à 14:19

Nasman

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Lanstack a écrit :

Je l'ouvre avec gedit, mais le fichier est en lecture seule. Comment faire pour enregistrer les modifications.

Je suis connecté sur Ubuntu avec le compte que j'ai crée lors de l'installation

Toi tu n'as pas trop potassé les docs
roll

Pour les fichiers systèmes et en mode graphique il faut un gksudo avant le gedit.
Le fichier s'ouvrira avec gedit en mode superutilisateur - tu fais tes modifs et tu enregistres.


PC fixe et portable avec Precise 64 bits

Hors ligne

#171 Le 01/06/2011, à 12:59

Lanstack

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Bonjour,

Finalement j'utilise sudo gedit.
J'ai fait mes modif et mais ca ne fonctionne pas comme je voudrais. Mais est ce que cela est réalisable !!??

J'ai un AD 2003 et je voudrais monter le dossier de l'utilisateur sur Ubuntu. Remarque : Si je vais dans Connexion à un serveur et je parcours jusqu'au dossier de l'utilisateur, je peux rentrer dedans. Je peux modifier un document existant, mais je ne  peux pas en créer de nouveaux.

Je voudrais que le dossier personnel (barre flottante d'icone à gauche pointent sur son dossier perso du serveur ou  alors un raccourci sur le bureau

Voici mon fichier pam_mount.conf.xml
<?xml version="1.0" encoding="utf-8" ?>
<!DOCTYPE pam_mount SYSTEM "pam_mount.conf.xml.dtd">
<!--
    See pam_mount.conf(5) for a description.
-->

<pam_mount>
<cifsmount>mount -t cifs //%(SERVER)/%(VOLUME) %(MNTPT) -o
    "user=%(USER),uid=%(USERUID),gid=%(USERGID)%(before=\",\" OPTIONS)"</cifsmount>

        <!-- Volume definitions -->
<volume user="*" fstype="cifs" server="srv-eleves" path="%(USER)$" mountpoint="~" \
options="rw,username=%(USER),user=%(USER),domain=lyc-lavoisier-53.LOCAL,iocharset=utf8,file_mode=0600, \
dir_mode=0700,setuids,mapchars,nounix,noserverino,nobrl,noperm,soft" />
<volume user="*" fstype="cifs" server="srv-eleves" path="CLASSES" mountpoint="~/CLASSES" \
options="rw,username=%(USER),user=%(USER),domain=lyc-lavoisier-53.LOCAL,iocharset=utf8,file_mode=0751, \
dir_mode=0751,setuids,mapchars,nounix,noserverino,nobrl,noperm,soft" />
<volume user="*" fstype="cifs" server="srv-eleves" path="DOSSUP" mountpoint="~/DOSSUP" \
options="rw,username=%(USER),user=%(USER),domain=lyc-lavoisier-53.LOCAL,iocharset=utf8,file_mode=0751, \
dir_mode=0751,setuids,mapchars,nounix,noserverino,nobrl,noperm,soft" />
<volume user="*" fstype="cifs" server="srv-eleves" path="NETLOGON" mountpoint="/NETLOGON" \
options="ro,username=%(USER),user=%(USER),domain=lyc-lavoisier-53.LOCAL,iocharset=utf8,file_mode=0751, \
dir_mode=0751,setuids,mapchars,nounix,noserverino,nobrl,noperm,soft" />
<volume user="*" fstype="cifs" server="srv-eleves" path="PARCIACA" mountpoint="/PARCIACA" \
options="ro,username=%(USER),user=%(USER),domain=lyc-lavoisier-53.LOCAL,iocharset=utf8,file_mode=0751, \
dir_mode=0751,setuids,mapchars,nounix,noserverino,nobrl,noperm,soft" />

        <!-- pam_mount parameters: General tunables -->

<debug enable="1" />
<!--
<luserconf name=".pam_mount.conf.xml" />
-->
<!-- Note that commenting out mntoptions will give you the defaults.
     You will need to explicitly initialize it with the empty string
     to reset the defaults to nothing. -->
<mntoptions allow="nosuid,nodev,loop,encryption,fsck,nonempty,allow_root,allow_other" />
<!--
<mntoptions deny="suid,dev" />
<mntoptions allow="*" />
<mntoptions deny="*" />
-->
<mntoptions require="nosuid,nodev" />
<path>/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin</path>

<logout wait="0" hup="0" term="0" kill="0" />


        <!-- pam_mount parameters: Volume-related -->

<mkmountpoint enable="1" remove="true" />
<umount>umount -fl %(MNTPT)</umount>
<msg-authpw>Mot de passe : </msg-authpw>
<msg-sessionpw>Mot de passe : </msg-sessionpw>
</pam_mount>

Hors ligne

#172 Le 21/03/2012, à 09:44

racine87

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Bonjour à tous, je me présente, je suis Jeanpy SENGA, je suis en 3ème Graduat en Informatique dans mon TFC, je suis en train de parler du partage des ressources entre 2plates-formes qui sont Windows (avec Windows Server2003 comme système serveur du réseau) et Linux(avec Ubuntu dans sa version 9.04 comme client du réseau).
J’ai configurer du côté serveur: l'active Directory, le serveur DHCP, Le serveur de fichier, et le serveur DNS(où j'ai créé 2utilisateurs ayant les droits d'administrateurs du domaine, d'administrateurs DHCP, d'administrateurs du schéma, d'utilisateurs du domaine, d'administrateurs de l'entreprise et qui seront membres du groupe d'administrateurs) comme prérequis afin de permettre ce partage de ressources; du côté client, je suis coincé vus que j'utilise l’application Virtual Box Version 3.1.2 r56127 pour réaliser cela afin de me permettre de faire la pratique. Je suis bloquer au niveau de l'installation du protocole samba, lorsque je saisi la commande qui me permet d'installer samba: "apt-get install samba" je reçois comme message:

Lecture des informations d'état... Fait
Aucune version du paquet samba n'est disponible, mais il existe dans la base de données. cela signifie en général que le paquet est manquant, qu'i est devenu obsolète ou qu'il n'est disponible que une autre source
cependant les paquets suivants le remplacent!
smbclient samba-common
E: Aucun paquet ne corespond au paquet samba.

Ce qui fait que je suis bloqué à ce niveau.

Ma deuxième préoccupation est celle de savoir comment arriver à introduire ma machine cliente dans le domaine en me connectant par exemple avec le compte utilisateur créé sur le serveur?

Je suis en attente de vos suggestions et réponses afin de me permettre d'évoluer. Merci!

Hors ligne

#173 Le 27/03/2012, à 14:47

mac-gyver31

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

A mon tour je rejoins la discussion.

Même recherche que vous apparemment : Intégrer une station Ubuntu dans une infra Active Directory.

Jusqu'à la V9 d'Ubuntu, j'arrivais à faire les choses suivantes, assez simplement, et même nativement pour certaines :
- depuis Nautilus : afficher la racine de l'AD, la liste des serveurs en double cliquant sur la racine, la liste des ressources partagées en double cliquant sur un serveur, et à faire un montage en double cliquant sur la ressource. Certes, il fallait donner son user et mdp AD, mais ca marchait.
- Connecter Evolution au serveur Exchange en OWA, et accéder aux dossiers mail, agenda, tâches, carnets d'adresse.

Bref, j'étais à deux doigts de pouvoir me passer de windows, et travailler sous ubuntu dans mon entreprise. Il ne me restait plus qu'à trouver le moyen de changer mon mot de passe AD tous les deux mois, contrainte imposé par une stratégie mise en oeuvre par nos administrateurs de l'AD.

J'ai mis beaucoup de temps à y arriver; surtout à cause du peu de temps que je peux y consacrer. Entre temps, j'ai du faire évoluer mon poste maquette vers Ubuntu 10.04.

Maintenant, je sais changer mon mdp, avec kerberos. Mais je n'arrive plus du tout à accéder aux ressources des serveurs windows (qui sont en win 2003 chez moi aussi)

J'ai lu avec attention les 7 pages de cette discussion, essayé beaucoup de choses. Sans succès. J'ai eu l'impression de prendre un film en cours, et de ne rien comprendre pour avoir raté le début
Car souvent : j'installe un package, comme libpam-mount, par exemple. Je fais les corrections indiquées dans les divers fichiers de config. Mais celà ne règle rien. Mon test de référence : navigation sous nautilus, ne marche pas.
Autre exemple : j'ai installé aussi likewise-open. Et la commande domainjoin-cli fonctionne (du moins si j'en crois le message de retour). Sauf que ce message indique qu'il faut rebooter !!! rebooter aprés une connexion, ca n'a pas de sens ! Je ne comprends pas.... A quoi sert likewise ? et libpam_mount, par rapport à samba ? lesquels faut-il  ?

Ce qui m'aiderait, c'est que quelqu'un fasse un petit récap de ce qu'il faut faire, from scratch, dans l'ordre, pour que les ressources bureautiques deviennent accessibles (l'automatisation des montages au démarrage, on verra aprés; Déjà que je comprenne comment ca marche, et comment tous les softs : samba, likewise, libpam, s'articulent. Lequel sert à quoi, etc ...)

Autant avant c'était simple, car tout avait l'air pré-packagé et intégré, autant maintenant, celà m'a l'air d'une usine à gaz !!!

Merci d'avance pour votre aide


Il est temps d'enlever les fenêtres, et de construire un monde ouvert.

Hors ligne

#174 Le 27/03/2012, à 14:52

mac-gyver31

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

Petite correction : mon poste est maintenant en 11.04, et non 10.04


Il est temps d'enlever les fenêtres, et de construire un monde ouvert.

Hors ligne

#175 Le 03/04/2012, à 12:03

Oscour

Re : Client Ubuntu + Active Directory et partage avec Windows serveur 2003

En fait ce post est plutôt tournée vers l'intégration d'un ordi dans un domaine windows 2003 dans le cadre d'un serveur LTSP.

Mais si tu n'installe pas LTSP, le script copié tel quel fonctionne et va monter ton serveur dans l'active directory.

Il te faudra juste modifié les deux lignes en début de script pour indiquer le nom de ton domaine.

Fait peut-être un essai avec un autre serveur vierge et vois ou tu à fait une erreur.

La seule chose qui ne fonctionne pas pour beaucoup de personnes, c'est le montage des dossiers distant sur le bureau avec libpamount.
Sur mon serveur, cela fonctionne une fois sur 30 (et encore) sans savoir pourquoi.
J'ai l'impression d'effleurer la solution du doigt, mais juste de l'effleurer !!!!!!!

Peut-être qu"en remontant ce post, d'autre nous aiderons à trouver la solution.

HELP !!!

Dernière modification par Oscour (Le 03/04/2012, à 12:03)

Hors ligne

Haut de page ↑