Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 02/12/2011, à 13:12

malbo

[résolu] Installation "à côté" de Ubuntu en mode EFI

EDIT le 30 oct 2012 : pour Ubuntu 12.04 et versions suivantes, le problème évoqué et analysé dans cette discussion est réglé. La doc à utiliser en tout temps est la doc du site : http://doc.ubuntu-fr.org/efi

Je viens de faire pas mal d'essais en PC virtuel (VirtualBox) d'installation en multi-boot de plusieurs versions de Ubuntu dans le même disque dur virtuel. Je remarque que l'installation de Ubuntu avec le choix "Installer Ubuntu à côté des autres" conduit systématiquement à l'installation d'une partition EFI associée à la nouvelle installation. Si on installe 3 versions de Ubuntu dans un disque dur (avec ce même choix "installer à côté des autres"), par exemple Ubuntu 11.04, 11.10 et 12.04 alpha, on se retrouve au final avec 3 partitions EFI dans le même disque dur.
Sauf que l'installateur fait bien son boulot malgré tout, c'est à dire qu'il utilise la partition EFI qui est la plus proche du début du disque dur (à part si je fais encore une erreur d'interprétation de son fonctionnement) comme partition EFI "utile". En somme, tout se passe comme si la partie "partitionnement" de l'installateur avait un fonctionnement de bœuf qui consiste à créer une partition EFI "besoin ou pas" et qu'ensuite l'installation "fine" inspectait tout le disque dur pour rechercher l'existence d'une partition EFI préexistante. Et si cette partition est trouvée, c'est dans elle que l'installation de l'amorceur (le fichier grubx64.efi) est réalisée. La partition EFI indésirable créée par le partitionneur est laissée vide. C'est un peu crasseux de laisser traîner des partitions EFI vides après install mais au moins c'est conforme au principe de EFI qui suppose une seule partition EFI utilisée comme c'est expliqué dans ce post de skodabenz : http://ubuntuforums.org/showpost.php?p= … stcount=76
A noter qu'une nouvelle installation entraîne le remplacement du fichier grubx64.efi (amorceur de l'installation précédente) de la partition EFI "utile" par le fichier grubx64.efi de la nouvelle installation. C'est à dire un fonctionnement analogue à ce qui se passe dans une installation automatique de Ubuntu dans un système Bios où l'amorceur Grub de la nouvelle installation écrase l'amorceur Grub de l'ancienne installation dans le MBR.

Dernière modification par malbo (Le 30/10/2012, à 12:53)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#2 Le 04/12/2011, à 10:59

malbo

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

Après avoir bien exploré la chose, je peux confirmer que le choix "Installer Ubuntu à côté des autres" est une grosse daube : http://doc.ubuntu-fr.org/_media/install … .png?w=400
Comme je l'ai signalé dans le post #1, il créé systématiquement une partition EFI (première connerie), mais je confirme qu'il créé systématiquement aussi une partition swap (deuxième connerie), avec la cerise sur le gâteau : à la fin de l'installation, on peut constater que les autres partitions swap existantes sur le disque dur ne sont même pas prises en compte et ajoutées dans le fichier fstab. Ce type d'installation "Installer Ubuntu à côté des autres", complètement autiste, est une vraie nullité, tant pour Ubuntu 11.10 que pour la future Ubuntu 12.04 (dans son état actuel de développement qui est Alpha). Je recommande donc aux novices qui veulent ajouter un autre Ubuntu (par exemple Ubuntu 11.10) à un Ubuntu déjà installé en mode EFI (par exemple 11.04) de prendre systématiquement le choix "Autre chose" à cette étape : http://doc.ubuntu-fr.org/_media/install … .png?w=400.
Si on prend le choix "Autre chose", et à condition qu'une partition swap existe déjà (utilisée par le Ubuntu déjà installé), on seulement besoin de créer une seule partition dans un espace non alloué : la partition racine de la future installation. Et pour le choix du chargeur d'amorçage : http://doc.ubuntu-fr.org/_media/install … .png?w=500
pas la peine de vous fatiguer à définir quelque chose : quoi que vous choisissiez, l'installateur trouvera tout seul la partition EFI existante et y installera son amorceur.
Après installation par ce choix "Autre chose", on se retrouve avec une seule partition ajoutée : la partition racine de la nouvelle installation et on a la joie de constater que toutes les autres partition swap existantes ont été prises en compte et dûment ajoutées dans le fstab. Autrement dit du bon travail comparé au "ni fait ni à faire" qu'on obtient quand on choisit "Installer Ubuntu à côté des autres".
Edit : voilà à quoi ça ressemble l'installation "à côté" de 3 Ubuntu (j'ai installé 3 fois de suite Ubuntu 11.10) :

sudo gdisk -l /dev/sda
GPT fdisk (gdisk) version 0.6.14

Partition table scan:
  MBR: protective
  BSD: not present
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 105027584 sectors, 50.1 GiB
Logical sector size: 512 bytes
Disk identifier (GUID): ADAAE292-2E20-4C7A-A1B1-456A8D65B933
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 105027550
Partitions will be aligned on 1-sector boundaries
Total free space is 0 sectors (0 bytes)

Number  Start (sector)    End (sector)  Size       Code  Name
   1              34           39096   19.1 MiB    EF00  
   2           39097        19277533   9.2 GiB     0700  
   3       102935582       105027550   1021.5 MiB  8200  
   4        19277534        19316596   19.1 MiB    EF00  
   5        19316597        40910432   10.3 GiB    0700  
   6       100841988       102935581   1022.3 MiB  8200  
   7        40910433        40949495   19.1 MiB    EF00  
   8        40949496        98748324   27.6 GiB    0700  
   9        98748325       100841987   1022.3 MiB  8200 

première install : partitions 1,2,3 (EFI,racine,swap)
2ème install "à coté" : partitions 4,5,6
3ème install "à côté" : partitions 7,8,9
J'ai bien envie d'en faire une 4ème mais je crois que vous avez compris. D'accord ça fonctionne mais c'est moche.

Dernière modification par malbo (Le 08/12/2011, à 19:56)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#3 Le 04/12/2011, à 16:51

YannUbuntu

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

Salut malbo
as-tu créé un rapport de bug ?  (je n'ai rien vu à ce sujet sur LP)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#4 Le 04/12/2011, à 18:38

malbo

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

Non, je ne ferai pas de rapport de bug sur le sujet.
Edit : si des Ubunteros ont pu faire des installations réussies (ou non) de Ubuntu en mode UEFI dans un vrai PC (parce que moi, c'est dans un PC virtuel avec le logiciel VirtualBox), ça m'intéresserait qu'ils prennent le temps de poster dans cette discussion pour en dire quelques mots.

Dernière modification par malbo (Le 04/12/2011, à 18:54)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#5 Le 04/12/2011, à 19:17

YannUbuntu

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

malbo a écrit :

Non, je ne ferai pas de rapport de bug sur le sujet.

Meme si je t'aide ? (c'est quoi qui te bloque?)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#6 Le 04/12/2011, à 21:48

malbo

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

Merci pour ton offre, mais je n'ai pas envie de m'impliquer là-dedans.


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#7 Le 05/12/2011, à 11:54

YannUbuntu

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

Je ne te comprends vraiment pas...

Tu passes des heures entières à tester des logiciels libres (et je t'en remercie)... Résultat?
- ça aidera peut-être 2 ou 3 francophones qui tomberont sur ce post par hasard...
- si tu prenais 2 minutes de plus pour faire un rapport de bug ça aiderait des milliers de Linuxiens du monde entier ! smile

Bref je vais tenter de retranscrire ton post en rapport de bug, mais ça sera beaucoup moins efficace/précis que si tu le faisais toi-même.  EDIT: https://bugs.launchpad.net/ubuntu/+sour … bug/900245
Je n'ai pas parlé du SWAP car pour moi ce n'est pas un bug. (il faut que chaque système ait sa SWAP sinon impossible d'hiberner plusieurs systèmes en même temps).

Dernière modification par YannUbuntu (Le 05/12/2011, à 13:37)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#8 Le 10/04/2012, à 12:25

malbo

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

Nouvelle tentative avec Ubuntu 12.04 Beta2. Le but est de voir si les choses ont changé depuis mes essais des post #1 et #2 réalisés alors que Precise était encore au stade Alpha

Après installation de Precise (on va l'appeler Precise_1, j'ai adopté l'installation automatique "effacer le disque et installer Ubuntu") et rétrécissement (avec Gparted) de la partition 2 afin de laisser de la place pour une deuxième installation (on va l'appeler Precise_2), j'obtiens ce partitionnement :

sudo parted -s /dev/sda unit s print
[sudo] password for malbo: 
Modèle: ATA VBOX HARDDISK (scsi)
Disque /dev/sda : 40853504s
Taille des secteurs (logiques/physiques): 512B/512B
Table de partitions : gpt

Numéro  Début      Fin        Taille     Système de fichiers  Nom  Fanions
 1      34s        195346s    195313s    fat32                     démarrage
 2      195347s    12613631s  12418285s  ext4
 3      38759801s  40853470s  2093670s   linux-swap(v1)

Fstab de Precise_1 :
# / was on /dev/sda2 during installation
UUID=ead83516-5f3b-4e44-b398-15110dc6be65 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=A9AD-03EA  /boot/efi       vfat    defaults        0       1
# swap was on /dev/sda3 during installation
UUID=59b7c214-c8c4-4482-aeaf-6cbabbe3b782 none            swap    sw              0       0
_______________________________________________________________
Installation de Precise_2 (c'est exactement le même support d'installation qui est utilisé)
L'installateur affiche "Ubuntu precise est actuellement installé sur cet ordinateur. Que voulez-vous faire ?"
Je prends le premier choix offert : "Installer Ubuntu 12.04 LTS à côté de Ubuntu precise"

Quand l'installation est terminée et fonctionnelle, je peux relever le nouvel état des lieux : 

sudo parted -s /dev/sda unit s print
[sudo] password for malbo: 
Modèle: ATA VBOX HARDDISK (scsi)
Disque /dev/sda : 40853504s
Taille des secteurs (logiques/physiques): 512B/512B
Table de partitions : gpt

Numéro  Début      Fin        Taille     Système de fichiers  Nom  Fanions
 1      34s        195346s    195313s    fat32                     démarrage
 2      195347s    12613631s  12418285s  ext4
 4      12613632s  12808944s  195313s    fat32                     démarrage
 5      12808945s  38759800s  25950856s  ext4
 3      38759801s  40853470s  2093670s   linux-swap(v1)

Fstab de Precise_2 :
# / was on /dev/sda5 during installation
UUID=1925e300-9e7d-41a2-ba0c-0ef537b6cf92 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda4 during installation
UUID=18BF-9A0D  /boot/efi       vfat    defaults        0       1
# swap was on /dev/sda3 during installation
UUID=59b7c214-c8c4-4482-aeaf-6cbabbe3b782 none            swap    sw              0       0

Après mises à jour (longues), j'ai fait un rapport boot-info voir post #12 ci-dessous

Appréciation des résultats :
Les développeurs ont bien fait évoluer le fonctionnement de l'installateur puisqu'il tient compte d'une partition swap préexistante pour éviter d'en recréer une deuxième. Par contre, je m'attendais à ce que l'installateur fasse de même pour la partition EFI, c'est à dire qu'il réutilise la partition existante et bien pas du tout : j'ai une nouvelle partition EFI créée (la partition 4).
Au final, j'ai bien Precise_1 qui est accessible depuis un chargeur d'amorçage de Grub qui se trouve sur la partition 1, et j'ai bien Precise_2 qui est accessible depuis depuis un chargeur d'amorçage de Grub qui se trouve sur la partition 4 
Moi, tout ça me convient.

Dernière modification par malbo (Le 10/04/2012, à 19:01)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#9 Le 10/04/2012, à 13:01

YannUbuntu

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

Est-ce que la 2eme partition est nécessaire au boot? autrement-dit, si tu supprimes la partition sda4, as-tu toujours accès aux 2 OSs ?


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#10 Le 10/04/2012, à 15:48

malbo

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

YannUbuntu a écrit :

Est-ce que la 2eme partition est nécessaire au boot? autrement-dit, si tu supprimes la partition sda4, as-tu toujours accès aux 2 OSs ?

J'espère répondre à ta question en te disant que si je démarre sur Precise_1 et que je passe la commande :

sudo update-grub

il y a mise à jour du grub et après cela je peux accéder aux deux OS en passant par la partition 1. Du coup, la partition 4 n'est plus indispensable. Mais ce n'est pas pour autant que je vais la supprimer parce que je trouve utile d'avoir une partition EFI pour chaque installation. Regarde la partie "REPRÉSENTATION SCHÉMATIQUE DES POSSIBILITÉS MULTI-BOOT BIOS/UEFI" qui se trouve au milieu de ce post : http://forum.ubuntu-fr.org/viewtopic.ph … 1#p7361661
Elle montre l'intérêt à mon avis d'avoir plusieurs chargeurs d'amorçage (un chargeur pour chaque installation) au lieu d'un seul.

Dernière modification par malbo (Le 10/04/2012, à 15:49)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#11 Le 10/04/2012, à 16:36

cep

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

YannUbuntu a écrit :

Est-ce que la 2eme partition est nécessaire au boot? autrement-dit, si tu supprimes la partition sda4, as-tu toujours accès aux 2 OSs ?

Si le disque avec table gpt ne contient pas d'os Microsoft il n'est pas nécessaire d'avoir plusieurs bios boot partitons ou esp :
( http://en.wikipedia.org/wiki/BIOS_Boot_partition )

Voir aussi le suivi de ce bug :
https://bugs.launchpad.net/ubuntu/+sour … bug/769669
ou l'installeur recréait le fs sur l'esp utilisé par windows, lequel utilisait cette partition.

Dernière modification par cep (Le 10/04/2012, à 16:36)

Hors ligne

#12 Le 10/04/2012, à 18:58

malbo

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

J'ai fait un rapport Boot-Info après mise à jour des deux installations du post #8 : http://paste.ubuntu.com/923569/


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#13 Le 10/04/2012, à 21:05

YannUbuntu

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

@cep: d'apres ce que je sais, il n'y a pas besoin de partition BIOS_boot quand on utilise l'EFI, juste une partition EFI.

@malbo: merci. Si tu fais un sudo update-grub dans Precise1 , puis tu renommes sda4/efi/ubuntu/grubx64.efi en sda4/efi/ubuntu/grubx64.efi_old , tu peux toujours démarrer Precise2 ?


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#14 Le 10/04/2012, à 22:55

cep

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

YannUbuntu a écrit :

@cep: d'apres ce que je sais, il n'y a pas besoin de partition BIOS_boot quand on utilise l'EFI, juste une partition EFI.

Si tu avais parcouru l'adresse que j'ai mis en lien tu aurais su ceci : "In the context of GPT on a BIOS-based computer, a BIOS Boot partition is similar in some respects to the EFI System partition, which is used by systems based on EFI." et comme le sujet ici est grub, le concernant on parle couramment de bios boot partition. Je parlais aussi de esp, terme utilisé avec Ms. Windows.

Hors ligne

#15 Le 11/04/2012, à 02:26

YannUbuntu

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

merci cep, j'avais bien lu l'article mais je ne savais pas que certaines personnes parlent couramment de "bios boot partition" pour désigner aussi une esp. (cela me surprend car il y a pas mal de différences.)
Où as-tu lu que "Si le disque avec table gpt ne contient pas d'os Microsoft il n'est pas nécessaire d'avoir plusieurs bios boot partitons ou esp" stp ?


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#16 Le 11/04/2012, à 11:08

malbo

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

J'ai eu un doute et j'ai tout repris à zéro sur un disque virtuel tout neuf en installant en premier Ubuntu 11.10 (il s'est installé dans sda2)  puis une première install de Ubuntu 12.04 qui s'est installé dans sda4, puis une deuxième install de Ubuntu 12.04 qui s'est installé dans sda5.
Le rapport Boot-Info obtenu en final est là : http://paste.ubuntu.com/924543/
Dans cette manip, il y a eu réutilisation de la partition SWAP (sda3) et de la partition EFI (sda1). La première install de Ubuntu 12.04 a placé son chargeur d'amorçage dans sda1 (en écrasant le chargeur de Ubuntu 11.10). La deuxième install de Ubuntu 12.04 a fait de même : elle a placé son chargeur dans sda1 en écrasant le précédent.
En somme, c'est un fonctionnement différent de ce que j'ai obtenu dans la manip du post #8. J'observe d'ailleurs une différence pour la partition EFI : la partition EFI dans la manip du post #8 est en format FAT32 et sa taille est de 100 Mo environ alors que dans cette dernière manip, la partition EFI est en format F16 et sa taille est de 20 Mo environ (c'est l'installateur de Ubuntu 11.10 qui fonctionne de la sorte : il construit toujours une partition EFI de cette taille 20 Mo dans ce format F16). Cette différence concernant la partition EFI n'est peut-être pas la cause du fonctionnement différent de l'installateur de Precise : je signale ce fait simplement.

Dernière modification par malbo (Le 11/04/2012, à 11:21)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#17 Le 11/04/2012, à 14:01

YannUbuntu

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

Intéressant.
A 1ère vue :
- si aucune esp FAT16 détectée, l'installateur de 11.10 crée une esp FAT16 20Mo, alors que celui de 12.04 crée une esp FAT32 100Mo. C'est une bonne chose, car à priori c'est la spec de l'UEFI qui l'exige. (voir Bug #811485)
- l'installateur de 12.04 réutilise une éventuelle esp FAT16 existante, mais pas une esp FAT32. Cela contredit le fix "Never format EFI system partitions that already contain a filesystem" qui a été apporté à partman-efi le 14/03/2012 (voir ici).
Pour faire un rapport de bug à ce sujet, j'ai besoin des fichiers /var/log/installer/syslog et /var/log/installer/partman de l'un des 12.04 qui ont été installés après le 11.10, peux-tu m'envoyer ces fichiers par email stp ?


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#18 Le 11/04/2012, à 16:58

malbo

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

Reprise de la manip du post #8 mais avec un pot de miel : remplacement de sda4, la partition EFI  qui avait été créée par l'installateur automatique de Precise_2 en FAT32 de 100 Mo par une partition FAT16 de 20 Mo confectionnée à la main depuis le liveCD Gparted. Réparation de Précise_2 afin qu'elle puisse monter correctement la nouvelle sda4 et recréer le chargeur d'amorçage sur sda4 (c'est à dire remplacement de l'UUID par le nouvel UUID de sda4 dans le fstab, redémarrage, recréation du chargeur d'amorçage de sda4 par la commande sudo grub-install passée depuis Precise_2. Je décris ça vite fait parce que la procédure pour réparer Precise_2, ce n'est pas l'important dans cette manip). Quand c'est fait, je vérifie que Precise_1 et Precise_2 fonctionnent bien et je réduis la taille de la racine de Precise_2 pour faire de la place en vue de l'installation de Precise_3

Rapport Boot-Info : Etat des lieux avant install de Precise_3 : http://paste.ubuntu.com/924840/

----------------------------------------------------------------
Installation de Precise_3 en installation automatique "à côté" des autres.

Rapport Boot-Info après install de Precise_3 : http://paste.ubuntu.com/924938/

Commentaires :
L'installateur de Precise_3 a refusé d'utiliser la partition EFI sda1 (il n'aime pas quelle soit en FAT32 de 100 Mo) et il est tombé dans le pot de miel : il a utilisé la partition EFI sda4 qui est en FAT16 de 20 Mo pour y installer son chargeur d'amorçage en écrasant le chargeur de Precise_2 qui se trouvait là.
Par contre, je ne sais pas encore exactement ce qui déplaît à l'installateur de Precise dans la partition EFI en FAT32 de 100 Mo : est-ce que le format est déterminant ou bien est-ce la taille de cette partition ? la réponse se trouve dans les post #21 et 22 ci-après

Dernière modification par malbo (Le 12/04/2012, à 16:50)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#19 Le 11/04/2012, à 17:15

YannUbuntu

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

peux-tu m'envoyer les /var/log/installer/syslog et /var/log/installer/partman du Precise_3 stp ? (yannubuntu ATT gmail)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#20 Le 11/04/2012, à 18:55

malbo

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

@YannUbuntu
Je t'ai envoyé deux mails :
1er mail avec les fichiers syslog et partman de l'installation de Precise_2 (on y voit qu'une nouvelle partition EFI - sda4 - a été créée lors de l'installation)
2ème mail  avec les fichiers syslog et partman de l'installation de Precise_3 (pas de création d'une nouvelle partition EFI, réutilisation d'une partition EFI existante)

Dernière modification par malbo (Le 11/04/2012, à 18:57)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#21 Le 12/04/2012, à 08:56

malbo

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

Nouvelle manip sur disque dur virtuel tout neuf.
But : vérifier si la taille de la partition EFI influe sur l'installation (en réponse à mon interrogation de la fin du post #18). Je vais donc faire un partitionnement manuel de la première install de Precise afin d'imposer le format F16 et la taille de la partition EFI

Installation de Precise (on va l'appeler Pangolin_1). L'installation est faite en manuel (choix "Autre chose") parce que je veux créer une partition EFI en FAT16 (au lieu du format FAT32 que j'aurais obtenu si j'avais adopté l'installation automatique). Par contre je prends exprès une grande taille (200 Mo) pour cette partition EFI pour tenter de démontrer que ce n'est pas la taille qui compte mais le format.
Etat des lieux après cette première installation :  http://paste.ubuntu.com/925947/

------------------------------------------------------------
Installation d'un autre Precise (on va l'appeler Pangolin_2) à côté du premier. l'installation est faite en automatique (choix "à côté") et après installation on obtient cet état : http://paste.ubuntu.com/926005/
Le chargeur d'amorçage de Pangolin_2 a remplacé celui de Pangolin_1 dans la partition EFI (sda1)   

Mes Commentaires :
Cette dernière manip et l'expérience des manips des posts #16 et #18 conduisent à penser que l'installateur de Ubuntu 12.04 Beta2 accepte de réutiliser une partition EFI préexistante à condition qu'elle soit dans le format F16, indépendamment de la taille de cette partition (qu'elle fasse 20 Mo ou 200 Mo n'a aucune importance). A ce jour, je n'ai pas pu réussir à faire de même si la partition EFI est dans le format F32 : on dirait que l'installateur automatique de Ubuntu 12.04 Beta2 refuse de réutiliser une partition EFI préexistante qui est dans le format F32.

Dernière modification par malbo (Le 12/04/2012, à 09:02)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#22 Le 12/04/2012, à 16:35

malbo

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

L'estocade : démonstration que l'installateur de Ubuntu 12.04 Beta2 ne sait pas détecter la présence d'une partition EFI si cette dernière est dans le format FAT32

Détail de la manip :
réalisée sur un disque dur virtuel tout neuf
Installation d'un premier Precise (on va appeler Pango_1 cette première install ) faite en manuel (choix "autre chose") après partitionnement réalisé avec Gparted du liveCD. Création d'une partition FAT32 (avec Gparted) de 40 Mo avec le boot (le "flag" pour qu'elle soit vue comme la partition EFI). Sortie de Gparted et lancement de l'installation. A noter que l'installateur (après le choix "Autre chose") ne voit pas que la partition FAT 32 est EFI : je suis obligé de sélectionner la partition FAT32 et de la modifier pour choisir de l'utiliser comme partition EFI. Je veux dire que le fait de lui avoir collé le flag avec Gparted n'a semble-t-il pas suffit.
Après installation, tout marche bien.
Depuis Pango_1, je relève ce Boot-Info : http://paste.ubuntu.com/926210/

------------------------------------------------------------
Installation d'un deuxième Precise (on va l'appeler Pango_2).
1) je choisis "autre chose" et je constate que la partition sda1 n'est pas reconnue par l'installateur comme une partition EFI : en principe, elle devrait directement apparaître avec le type "efi" alors que là, elle est vue comme une simple partition FAT32. Je pense avoir trouvé la cause des soucis : une mauvaise identification par l'installateur de la partition EFI quand cette dernière est dans le format FAT32.
Je décide de quitter l'installation en vue de la relancer en automatique pour bien démontrer qu'elle va merder.
2) je relance l'installation mais cette fois, je choisis "installer à côté" afin que l'installation soit réalisée automatiquement.
Après installation, je constate que ce que je supposais s'est bien produit : l'installateur ne détectant pas que la partition FAT32 comme une partition EFI a créé une nouvelle partition EFI (en sda4) comme on peut voir sur le Boot-Info réalisé après installation :
http://paste.ubuntu.com/926317/

--------------------------------------------------------
Installation d'une troisième Precise (on va l'appeler Pango_3).
depuis le liveCD Ubuntu 12.04 Beta2, je lance Gparted pour faire maigrir la partition sda5 pour dégager de la place pour l'installation de Pango_3. Puis je referme Gparted et je lance l'installateur. A l'étape du partitionnement, je choisis "autre chose" et je constate que la partition sda1 n'est toujours pas reconnue par l'installateur comme une partition EFI. Je la sélectionne et la modifie dans le champ "utiliser comme" pour remplacer le choix présélectionné "Ne pas utiliser cette partition" par "Partition de démarrage EFI", donc l'installateur n'est pas capable de bosser tout seul : il faut qu'on lui dise que cette partition FAT32 est à considérer comme partition EFI alors même que cette partition est bien correctement équipée de ses insignes EFI et est vue comme telle par Gparted
Ensuite, je m'occupe de créer une nouvelle partition racine pour Pango_3 et je lance la suite de l'installation.
Quand l'installation est terminée, je constate que la partition sda1 a bien été utilisée par l'installateur : le chargeur d'amorçage de Pango_3 a bien écrasé celui de Pango_1 dans cette partition EFI sda1. Voici le rapport Boot-Info obtenu après install de Pango_3 : http://paste.ubuntu.com/926460/

Conclusion :
L'installateur de Ubuntu 12.04 est bien défectueux puisque lui-même installe une partition EFI en FAT32 lorsqu'il fait une installation en automatique, mais le malheureux ne sait pas détecter la présence d'une partition EFI en FAT32 préexistante. Comme on l'a vu plus haut (post #21), il sait détecter une partition EFI si elle est dans le format F16 mais il est aveugle si elle est dans le format FAT32.
En l'état actuel - comme c'était le cas il y a 4 mois quand j'ai créé ce fil - l'installation automatique "à côté" n'est pas utilisable : il faut faire le choix "Autre chose" lors de l'installation.

Edit : pour bien tout bétonner, j'ai remonté la manip du post #21 et si je démarre une session live Ubuntu 12.04 Beta2 et que je lance l'installateur depuis cette session live (comme je fais tout le temps pour mes installations), si je choisis "autre chose", là je vois bien que la partition EFI est bien identifiée comme étant du type "efi" (parce qu'elle est dans le format F16)

Dernière modification par malbo (Le 12/04/2012, à 20:52)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#23 Le 28/08/2012, à 17:18

YannUbuntu

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

Est-ce que ce bug existe toujours avec 12.04.1 ?
(à priori oui: https://bugs.launchpad.net/ubuntu/+sour … bug/900245 )

Dernière modification par YannUbuntu (Le 28/08/2012, à 17:20)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#24 Le 09/09/2012, à 16:07

YannUbuntu

Re : [résolu] Installation "à côté" de Ubuntu en mode EFI

On dirait que la détection des partitions EFI par l'installateur a été améliorée depuis Precise:
https://bugs.launchpad.net/ubuntu/+sour … omments/11


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

Haut de page ↑