Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 25/04/2012, à 19:10

horlas34

CDROM non detecté depuis mise à niveau 11.10

Bonsoir ,
J'ai déjà posté mon problème sur le forum "matériel" mais sans avoir de réponse.
Je poste ici mon problème en espérant trouver une solution.

Je n'ai plus accès à mon lecteur CD/DVD depuis la migration vers la version Ubuntu 11.10.
J'ai fait une mise à jour de la version 11.10.
Je ne trouve pas de réponses satisfaisantes ni dans la doc ni dans le forum.
Je colle mon fichier fstab qui apparement peut donner des infos.
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=467507e6-739d-4f9e-95e0-c9be738c270a /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=67a79303-d2bc-4915-a21e-79d48e6a1770 none            swap    sw              0       0

Les infos de l'utilitaire de disk:
j'ai le type du matériel par contre : "aucun media detecté"

Lorsque je fait la commande sudo lshw
j'ai à un moment:
*-cdrom
             description: DVD-RAM writer
             product: DVDRAM GH60N
             vendor: HL-DT-ST
             physical id: 1
             bus info: scsi@1:0.0.0
             logical name: /dev/cdrom
             logical name: /dev/cdrw
             logical name: /dev/dvd
             logical name: /dev/dvdrw
             logical name: /dev/scd0
             logical name: /dev/sr0
             version: UG00
             capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
             configuration: ansiversion=5 status=nodisc

quant j'essaye la commande sudo mount /dev/cdr0
mount : impossible de trouver /dev/cdr0 dans /etc/fstab ou /etc/mtab

Apparemment c'est un problème récurrent dans lors des mises à niveau....mais toujours pas de pistes sérieuses , quelqu'un a une idée!!!;)
Merci de vos lumières.
Cordialement.

Hors ligne

#2 Le 26/04/2012, à 09:56

malbo

Re : CDROM non detecté depuis mise à niveau 11.10

Ton PC étant démarré sous Ubuntu, si tu connectes une clé USB, est-elle montée automatiquement ?
D'autre part, le PC étant démarré sous Ubuntu, si tu introduis un DVD (pas un liveCD Ubuntu mais un film sur DVD) dans ton lecteur optique, est-ce que le montage se fait automatiquement ou non  ?
En fait, dans le cas général et avec un matériel pas trop vieux, il n'y a pas besoin de créer une ligne pour monter les DVD dans le fichier fstab parce que le montage doit se faire automatiquement. C'est pour cela que je t'ai posé ces questions car si le montage automatique ne se fait pas ni pour le DVD ni pour une clé USB, ce pourrait être un problème de limitation de tes droits d'utilisateur. Je veux dire que ce n'est pas toi consciemment qui aurait limité tes droits mais ce pourrait être une anomalie de fonctionnement de Ubuntu suite à la migration + les mises à jour faites après migration.

Edit : pour avancer un peu vers la lumière, je te propose de démarrer ton PC sur une liveUSB de Ubuntu 11.10 (c'est à dire de faire une session live, avec le choix "Essayer" et non pas installer), de faire les mises à jour proposées (si tu veux être puriste mais sinon, tu ne fais pas les mises à jour), puis de vérifier ce qui se passe quand tu introduis un film DVD dans le lecteur optique. S'il est monté automatiquement, tu auras mis en évidence que ton lecteur est géré convenablement par Ubuntu 11.10 quand c'est un Ubuntu "propre" et neuf et tu pourras en déduire que ton Ubuntu "migré" a du plomb dans l'aile.

Dernière modification par malbo (Le 26/04/2012, à 10:03)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#3 Le 26/04/2012, à 20:33

horlas34

Re : CDROM non detecté depuis mise à niveau 11.10

Bonsoir Malbo,

Merci de prendre le temps et de me répondre ainsi.
Je ne sais pas si tu te souviens mais c'est moi qui avais fait une mise à niveau "sauvage" avec écran noir par la suite. J'ai suivi tes conseils sur d'autres posts. J'ai fait une clé LiveUSB, en choisissant l'option "mise à jour" de la version 11.04 vers 11.10 , je m'en suis sortie. Ensuite j'ai mis à jour les "paquets" (je crois qu'on dit comme ça ) avec les commandes : sudo apt-get update et upgrade, ça m'a résolu pas mal de problèmes. Aujourd’hui 'hui après beaucoup de temps passé , je suis à peu près d'équerre sauf cette histoire de CDRom , donc pas prête psychologiquement à me relancer dans une mise à niveau!!!
Pour ce qui est des ports USB , ils fonctionnent.
J'ai essayé de lire un DVD sur mon lecteur : rien , mais rien de rien même pas le moteur se mettant en route. par contre la commande eject fonctionne.
Aurais tu une idée .
Merci encore : ta présence sur le forum m'a beaucoup aidée.
Cordialement.

Hors ligne

#4 Le 26/04/2012, à 20:46

malbo

Re : CDROM non detecté depuis mise à niveau 11.10

malbo a écrit :

Edit : pour avancer un peu vers la lumière, je te propose de démarrer ton PC sur une liveUSB de Ubuntu 11.10 (c'est à dire de faire une session live, avec le choix "Essayer" et non pas installer), de faire les mises à jour proposées (si tu veux être puriste mais sinon, tu ne fais pas les mises à jour), puis de vérifier ce qui se passe quand tu introduis un film DVD dans le lecteur optique. S'il est monté automatiquement, tu auras mis en évidence que ton lecteur est géré convenablement par Ubuntu 11.10 quand c'est un Ubuntu "propre" et neuf et tu pourras en déduire que ton Ubuntu "migré" a du plomb dans l'aile.

Peux-tu essayer cette proposition ?


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#5 Le 26/04/2012, à 21:38

horlas34

Re : CDROM non detecté depuis mise à niveau 11.10

Oui, je vais essayer. Je te donne des nouvelles. Merci.

Hors ligne

#6 Le 27/04/2012, à 18:08

horlas34

Re : CDROM non detecté depuis mise à niveau 11.10

Bonsoir,

J'ai démarré en LiveUSB en choississant "Essayer".
commande eject.
j'ai mis un dvd.
rien.
Par contre je me suis aperçue que en faisant la commande dmesg: j'avais cette section:

[    1.450567]  sda: sda1 sda2 < sda5 >
[    1.450832] sd 2:0:0:0: [sda] Attached SCSI disk
[    1.864069] ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[    1.872182] ata4.00: ATAPI: HL-DT-ST DVDRAM GH60N, UG00, max UDMA/100
[    1.888191] ata4.00: configured for UDMA/100
[    1.896176] scsi 3:0:0:0: CD-ROM            HL-DT-ST DVDRAM GH60N     UG00 PQ: 0 ANSI: 5
[    1.905404] sr0: scsi3-mmc drive: 40x/40x writer dvd-ram cd/rw xa/form2 cdda tray
[    1.905408] cdrom: Uniform CD-ROM driver Revision: 3.20
[    1.905528] sr 3:0:0:0: Attached scsi CD-ROM sr0
[    1.905585] sr 3:0:0:0: Attached scsi generic sg1 type 5
[    2.075761] EXT4-fs (sda1): INFO: recovery required on readonly filesystem
[    2.075766] EXT4-fs (sda1): write access will be enabled during recovery
[    2.168966] EXT4-fs (sda1): recovery complete
[    2.169442] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)


Le CDrom est-il monté?

Merci de votre aide!

Hors ligne

#7 Le 27/04/2012, à 18:27

malbo

Re : CDROM non detecté depuis mise à niveau 11.10

Moi j'ai ça dans mon dmesg pour mon graveur qui fonctionne très bien merci (j'ai enlevé des lignes intermédiaires qui n'avaient pas de rapport avec mon graveur  :

[    2.024063] ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[    2.026616] ata4.00: ATAPI: HL-DT-ST DVDRAM_GSA-H60N, CA01, max UDMA/100
[    2.026620] ata4.00: SB600 AHCI: limiting to 255 sectors per cmd
[    2.030330] ata4.00: SB600 AHCI: limiting to 255 sectors per cmd
[    2.030332] ata4.00: configured for UDMA/100
[    2.145059] scsi 3:0:0:0: CD-ROM            HL-DT-ST DVDRAM_GSA-H60N  CA01 PQ: 0 ANSI: 5
[    2.256062] sr0: scsi3-mmc drive: 40x/40x writer dvd-ram cd/rw xa/form2 cdda tray
[    2.256066] cdrom: Uniform CD-ROM driver Revision: 3.20
[    2.256178] sr 3:0:0:0: Attached scsi CD-ROM sr0
[    2.256241] sr 3:0:0:0: Attached scsi generic sg2 type 5

Cela ressemble fort à ton dmesg et je pense que ton graveur est bien reconnu

Edit : il est possible que ton graveur soit mort.

Dernière modification par malbo (Le 28/04/2012, à 10:19)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#8 Le 30/04/2012, à 10:49

horlas34

Re : CDROM non detecté depuis mise à niveau 11.10

Merci pour  ta réponse,

Peut-être mon cdrom est-il mort, mais très franchement je ne le pense pas car ça coïncide beaucoup trop avec la migration vers 11.10!

Effectivement ton fichier dmesg ressemble au mien,
avec le gestionnaire de disk , j'ai aussi le modèle correspondant inscrit, mais aucun média détecté!

Quels sont les fichiers rattachés au fonctionnement du cdrom?

Mon fichier fstab m'indique ceci

/etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=467507e6-739d-4f9e-95e0-c9be738c270a /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=67a79303-d2bc-4915-a21e-79d48e6a1770 none            swap    sw              0       0

Je m'interroge sur cette ligne:

# / was on /dev/sda1 during installation
UUID=467507e6-739d-4f9e-95e0-c9be738c270a /               ext4    errors=remount-ro 0       1

Pourquoi /dev/sda1 et pas sda0, et ce errors=remount-ro ????

Y-a-t il une erreur d'adressage ou quelque chose comme ça????

Merci encore de vos lumières!

Hors ligne

#9 Le 30/04/2012, à 11:31

malbo

Re : CDROM non detecté depuis mise à niveau 11.10

horlas34 a écrit :

Je m'interroge sur cette ligne:

# / was on /dev/sda1 during installation
UUID=467507e6-739d-4f9e-95e0-c9be738c270a /               ext4    errors=remount-ro 0       1

Pourquoi /dev/sda1 et pas sda0, et ce errors=remount-ro ????

Pour sda1, c'est normal parce que la première partition du disque dur sda est nommée sda1 (sda0 n’existe pas dans la numérotation des partitions)
D'ailleurs cette ligne extraite de ton dmesg du post #6 montre ton partitionnement :

sda: sda1 sda2 < sda5 >

tu as un disque dur (sda) qui contient une partition principale sda1 sur laquelle se trouve la racine de ton Ubuntu et une partition logique sda5 qui est ta partition swap (sda5 se trouve à l'intérieur d'une partition étendue sda2, ce qui est symbolisé par "sda2 < sda5 >"). Donc tout ça est parfaitement normal à mon avis.
Quant à ta question, sur les options de montage en fin de ligne, moi j'ai exactement la même chose que toi dans mon Ubuntu 11.10 : "errors=remount-ro    0    1"
Là encore aucune anomalie à mon avis.

Dernière modification par malbo (Le 30/04/2012, à 11:32)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP et Ubuntu 13.04
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 13.10

Hors ligne

#10 Le 03/05/2012, à 13:46

horlas34

Re : CDROM non detecté depuis mise à niveau 11.10

Ok ! Merci encore de tes explications , je comprend mieux.
Je continue mes investigations quand le temps m'en donne le loisir!
Cordialement.

Dernière modification par horlas34 (Le 03/05/2012, à 13:46)

Hors ligne

#11 Le 04/05/2012, à 19:53

horlas34

Re : CDROM non detecté depuis mise à niveau 11.10

Ok ,
J' ai trouvé la commande suivantre qui peut donner des renseignements.

ls -l /dev/cd*

lrwxrwxrwx 1 root root 3 2012-05-04 15:54 /dev/cdrom -> sr0
lrwxrwxrwx 1 root root 3 2012-05-04 15:54 /dev/cdrw -> sr0

Alors effectivement je devais confondre sr0 et sd0....
Mon cdrom est détecté mais seulement en partie, j'en reviens toujours au utilitaire de disk qui me donne aucun média detecté, la commande Ejecte ne fonctionne évidement pas .
Par contre via un terminal quand je tape "eject" le CD sort.
Y-a-t-il deux niveaux différents de montage et détection du lecteur. Comme un niveau bas (genre Bios ou autre) et un niveau haut plus en rapport avec le système d'exploitation.
Je ne sais pas si m'exprime bien.
Je continue de chercher.
Si vous avez des explications ou des tuyeaux .
Merci d'avance.

Hors ligne

#12 Le 14/10/2012, à 08:07

L_d_v_c@

Re : CDROM non detecté depuis mise à niveau 11.10

Bonjour,
que retourne la commande  wodim -scanbus ?


Debian Asus 1001HA / Ubuntu 12.04 E6600 et K50IE
M.A.O. UbuntuStudio 12.04 sur Tyan S2915E RAID 5
Pourquoi Linux.
Bug -1 : Derrière chaque bogue se cache constamment la faille humaine !

Hors ligne

#13 Le 09/11/2012, à 11:49

ebp1177

Re : CDROM non detecté depuis mise à niveau 11.10

bonjour horlas34,

AS-tu trouver la solution car j'ai exactement le même probleme ke toi suite a la migration sauvage de ubuntu 10.04 à 11.10 ?

Hors ligne

Haut de page ↑