Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#1 Le 30/04/2012, à 14:11

fatpunk2

[RESOLU] DWA-140 ne fonctionne plus depuis MAJ 12.04

Salut à tous
J'ai 2 clés wifi DWA-140 (une "normale" et une b2) sur 2 ordis différents. Je viens de faire les mises à jour de version et là c'est le drame : aucune des 2 ne fonctionne, pas cool. La 140 "build 1" fonctionnait nickel sous la 11.10, juste à brancher et hop, mais là plus rien que dalle...
Je sais que le pilote est le rt2870, j'ai bien fouillé les forums Ubuntu fr et en, mais je trouve rien pour m'aider, les divers tutos n'allant pas pour cette version de noyau...
Quelqu'un pourrait m'aider ? Pliiiiiiiiiiiiz

Dernière modification par fatpunk2 (Le 30/04/2012, à 19:03)

Hors ligne

#2 Le 30/04/2012, à 14:19

chibbata

Re : [RESOLU] DWA-140 ne fonctionne plus depuis MAJ 12.04

salut
post le resultat de

lsmod
nm-tool

Hors ligne

#3 Le 30/04/2012, à 14:46

fatpunk2

Re : [RESOLU] DWA-140 ne fonctionne plus depuis MAJ 12.04

lsmod
Module                  Size  Used by
nls_iso8859_1          12617  2 
nls_cp437              12751  2 
vfat                   17308  2 
fat                    55605  1 vfat
dm_crypt               22528  0 
snd_hda_codec_analog    75395  1 
snd_hda_intel          32765  2 
snd_hda_codec         109562  2 snd_hda_codec_analog,snd_hda_intel
snd_usb_audio         101566  1 
rfcomm                 38139  0 
snd_pcm                80845  3 snd_hda_intel,snd_hda_codec,snd_usb_audio
bnep                   17830  2 
bluetooth             158438  10 rfcomm,bnep
k8temp                 12905  0 
serio_raw              13027  0 
ppdev                  12849  0 
snd_hwdep              13276  2 snd_hda_codec,snd_usb_audio
snd_usbmidi_lib        24603  1 snd_usb_audio
snd_seq_midi           13132  0 
binfmt_misc            17292  1 
snd_rawmidi            25424  2 snd_usbmidi_lib,snd_seq_midi
parport_pc             32114  1 
asus_atk0110           17742  0 
snd_seq_midi_event     14475  1 snd_seq_midi
pwc                    78445  0 
videobuf2_core         28148  1 pwc
snd_seq                51567  2 snd_seq_midi,snd_seq_midi_event
videodev               86588  1 pwc
videobuf2_vmalloc      12707  1 pwc
videobuf2_memops       13070  1 videobuf2_vmalloc
snd_timer              28931  2 snd_pcm,snd_seq
snd_seq_device         14172  3 snd_seq_midi,snd_rawmidi,snd_seq
snd                    62064  17 snd_hda_codec_analog,snd_hda_intel,snd_hda_codec,snd_usb_audio,snd_pcm,snd_hwdep,snd_usbmidi_lib,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
mac_hid                13077  0 
soundcore              14635  1 snd
snd_page_alloc         14115  2 snd_hda_intel,snd_pcm
i2c_nforce2            12906  0 
lp                     17455  0 
parport                40930  3 ppdev,parport_pc,lp
usbhid                 41906  0 
hid                    77367  1 usbhid
usb_storage            39646  2 
uas                    17699  0 
nouveau               708198  3 
ttm                    65344  1 nouveau
drm_kms_helper         45466  1 nouveau
drm                   197692  5 nouveau,ttm,drm_kms_helper
i2c_algo_bit           13199  1 nouveau
mxm_wmi                12859  1 nouveau
wmi                    18744  1 mxm_wmi
forcedeth              58096  0 
video                  19068  1 nouveau
sata_nv                23360  2 
floppy                 60310  0 
pata_amd               13750  0 
nm-tool

NetworkManager Tool

State: connected (global)

- Device: eth0  [Connexion filaire 1] ------------------------------------------
  Type:              Wired
  Driver:            forcedeth
  State:             connected
  Default:           yes
  HW Address:        00:1B:FC:6C:FC:97

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         192.168.1.45
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.1.1

    DNS:             192.168.1.1

et lsub tant que j'y suis :

 lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 008: ID 07d1:3c09 D-Link System DWA-140 RangeBooster N Adapter(rev.B1) [Ralink RT2870]
Bus 001 Device 005: ID 054c:0243 Sony Corp. MicroVault Flash Drive
Bus 002 Device 002: ID 046d:08b2 Logitech, Inc. QuickCam Pro 4000
Bus 002 Device 003: ID 045e:0734 Microsoft Corp. Wireless Optical Desktop 700

Hors ligne

#4 Le 30/04/2012, à 14:47

chibbata

Re : [RESOLU] DWA-140 ne fonctionne plus depuis MAJ 12.04

sudo modprobe rt2800usb

Hors ligne

#5 Le 30/04/2012, à 14:50

fatpunk2

Re : [RESOLU] DWA-140 ne fonctionne plus depuis MAJ 12.04

sudo modprobe rt2800usb
[sudo] password for bertrand: 
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.

Hors ligne

#6 Le 30/04/2012, à 14:51

fatpunk2

Re : [RESOLU] DWA-140 ne fonctionne plus depuis MAJ 12.04

la dernière manip refait fonctionner la rev1, mais pas la b2

Hors ligne

#7 Le 30/04/2012, à 14:52

chibbata

Re : [RESOLU] DWA-140 ne fonctionne plus depuis MAJ 12.04

sudo rmmod ndiswrapper
sudo rmmod rt2800usb
sudo modprobe rt2800usb

Hors ligne

#8 Le 30/04/2012, à 14:57

fatpunk2

Re : [RESOLU] DWA-140 ne fonctionne plus depuis MAJ 12.04

je passe sur l'ordi avec la b2, le temps de brancher un câble ethernet, etc et je te donne ça

Hors ligne

#9 Le 30/04/2012, à 14:58

chibbata

Re : [RESOLU] DWA-140 ne fonctionne plus depuis MAJ 12.04

tu as installé le driver pour la b2 comme expliqué içi http://doc.ubuntu-fr.org/dwa-140#d-link_dwa-140_b2

Hors ligne

#10 Le 30/04/2012, à 15:00

fatpunk2

Re : [RESOLU] DWA-140 ne fonctionne plus depuis MAJ 12.04

bertrand@bertrandPC:~$ sudo rmmod ndiswrapper
[sudo] password for bertrand: 
ERROR: Module ndiswrapper does not exist in /proc/modules
bertrand@bertrandPC:~$ sudo rmmod rt2800usb
ERROR: Module rt2800usb does not exist in /proc/modules
sudo modprobe rt2800usb

ne renvoie rien

Hors ligne

#11 Le 30/04/2012, à 15:01

fatpunk2

Re : [RESOLU] DWA-140 ne fonctionne plus depuis MAJ 12.04

ceci dit y'a un truc qui change entre rev1 et b2 quand on fait lsusb, au lieu de D-link system DWA-140 blablabla, ça donne juste :

Bus 001 Device 012: ID 2001:3c15 D-Link Corp. 

Dernière modification par fatpunk2 (Le 30/04/2012, à 15:03)

Hors ligne

#12 Le 30/04/2012, à 15:05

fatpunk2

Re : [RESOLU] DWA-140 ne fonctionne plus depuis MAJ 12.04

et oui j'ai essayé d'installer le driver pour la b2, malgré cette phrase :

Le driver ci-dessous ne fonctionne pas avec Ubuntu 11.10 Oneiric Ocelot. Cependant, la clé est reconnue nativement dans cette version. Le driver présenté ci-dessous n'est donc à installer que sous Ubuntu 11.04 ou inférieur.

Ceci dit ça bloque a "insérez votre clé et appuyez sur une touche", qui me renvoie ça en boucle...

sudo sh dwa140b2.sh 
Veuillez patienter...
Compilation en cours. Veuillez patienter...
Compilation terminée.
Installation en cours. Veuillez patienter...
Installation terminée !
Veuillez insérer votre clé Wifi.
Appuyer sur une touche pour continuer.
 
Veuillez insérer votre clé Wifi.
Appuyer sur une touche pour continuer.

Veuillez insérer votre clé Wifi.
Appuyer sur une touche pour continuer.

Veuillez insérer votre clé Wifi.
Appuyer sur une touche pour continuer.

Dernière modification par fatpunk2 (Le 30/04/2012, à 15:15)

Hors ligne

#13 Le 30/04/2012, à 16:15

chibbata

Re : [RESOLU] DWA-140 ne fonctionne plus depuis MAJ 12.04

http://www.ralinktech.com/en/04_support … php?sn=501
prend le driver RT8070 /RT3070 /RT3370 /RT5370 /RT5372 USB
clic droit extraire,ça te donne un autre fichier a extraire aussi
ce qui donne au final un dossier nommé 2011_0719_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.3_DPO
ouvres ce dossier et le sous dossier os et enfin le dossier linux
ouvres le fichier config.mk avec un editeur de texte
modifie les lignes suivantes en mettant =y au lieu de =n
# Support Wpa_Supplicant
HAS_WPA_SUPPLICANT=y

# Support Native WpaSupplicant for Network Maganger
HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y

enregistres et ferme l'editeur de texte

sudo apt-get install build-essential
cd ~/Téléchargements/2011_0719_RT3070_RT3370_RT5370_RT5372_Linux_STA_V2.5.0.3_DPO
make
sudo make install

branche ta clé et redemarres le pc

Hors ligne

#14 Le 30/04/2012, à 17:04

fatpunk2

Re : [RESOLU] DWA-140 ne fonctionne plus depuis MAJ 12.04

ok je vais tester ca, là suis pas chez moi... Ceci dit sur le cd fourni avec la clé DWA-140b2, le pilote pour Windows est le rt2870, donc sans vouloir faire le chichiteux t'es sûr de ton coup avec celui que tu me dis de prendre ?

Hors ligne

#15 Le 30/04/2012, à 17:11

chibbata

Re : [RESOLU] DWA-140 ne fonctionne plus depuis MAJ 12.04

le rt5370 est le bon driver pour ton wifi

Hors ligne

#16 Le 30/04/2012, à 17:43

fatpunk2

Re : [RESOLU] DWA-140 ne fonctionne plus depuis MAJ 12.04

bon ben j'ai qu'une chose à dire : big merci ! Vu le nombre de gens que tu dépannes avec leur galères de wifi, tu devrais changer ton pseudo par wifigod ou (god tout court, d'ailleurs..). Imagines que je m'inclines bien bas...
Par contre, m'adressant à dieu, peut-être pourrait-il m'éclairer : pourquoi est-ce qu'il faut ce pilote là alors que le cd dealé avec la clé fournit le rt2870 ??? Je doute que Ralink s'amuse à changer le nom des pilotes en les fournissant aux constructeurs, donc si t'as une idée suis très preneur, même juste une théorie...

Hors ligne

#17 Le 01/05/2012, à 11:58

jbh

Re : [RESOLU] DWA-140 ne fonctionne plus depuis MAJ 12.04

Bonjour
même problème après une mise à jour depuis 10.04 à partir d'un CD Alternate. Ce qui est rageant, c'est que la clef fonctionne très bien en Live CD mais qu'il faille recompiler un driver après install! J'ai fait la mise à jour justement en espérant arrêter de recompiler mon driver à chaque nouveau noyau... bref, c'est raté.

En tout cas, merci pour les indications: çà marche super!

JB


HP p6354 - Intel Core i3 - DDR3 6 Go - HDD 2 To - NVIDIA GeForce G210 512Mo
Ubuntu 12.04 x64 - Linux Registered User # 520938

Hors ligne

  • Accueil
  • » Forum
  • » WiFi
  • » [RESOLU] DWA-140 ne fonctionne plus depuis MAJ 12.04

Haut de page ↑