Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#151 Le 20/04/2012, à 23:35

david96

Re : Gimp 2.8 : "On essaye de faire le 2.8 avant le SOC 2010"

Oui et c'est d'ailleurs le pourquoi de la distribution Fedora :
http://fr.wikipedia.org/wiki/Red_Hat#Le_projet_Fedora

Hors ligne

#152 Le 27/04/2012, à 04:43

Ishimaru Chiaki

Re : Gimp 2.8 : "On essaye de faire le 2.8 avant le SOC 2010"

Finalement, vu que Precise est sorti et que Gimp 2.8 est encore en RC1 et que de plus, un PPA vient d'être mis en ligne, je vais tout simplement devancer ma réinstallation.

Voici l'article annonçant le PPA pour Oneiric et Precise : http://www.dailynux.fr/2012/04/13/insta … ntu-12-04/


Lubuntu 14.04 LTS sur Intel Pentium 4, 2.8GHz, 1 Go de RAM, carte ATI RV100 QY [Radeon 7000/VE]
[Trad] Installer la clé DWA-125 sur Ubuntu 12.04
Grossir son curseur sur Lubuntu 14.04 LTS
Mon fil Twitter

Hors ligne

#153 Le 27/04/2012, à 07:21

Vu

Re : Gimp 2.8 : "On essaye de faire le 2.8 avant le SOC 2010"

PPA ajouté,
Menu -> Fenêtres -> Mode Fenêtres unique


Ubuntu 12.04

Hors ligne

#154 Le 01/05/2012, à 09:53

souen

Re : Gimp 2.8 : "On essaye de faire le 2.8 avant le SOC 2010"

Salut,
j'ai ajouté le PPA pour Preicise pour avoir la 2.8 en bêta. Je voulais vous demander
si avec la mises à jour, cela m'installera la version stable?...
ou je devrai réinstaller le programme?


Tu es programmé, mais tu es libre.
Ubuntu Studio
"Si il n'y a pas de solution, c'est qu'il n'y a pas problème !"
(sagesse Shadok)

Hors ligne

#155 Le 01/05/2012, à 11:16

Vu

Re : Gimp 2.8 : "On essaye de faire le 2.8 avant le SOC 2010"

Je pense que cela installera la version stable.


Ubuntu 12.04

Hors ligne

#156 Le 01/05/2012, à 12:11

souen

Re : Gimp 2.8 : "On essaye de faire le 2.8 avant le SOC 2010"

Ok Vu Merci


Tu es programmé, mais tu es libre.
Ubuntu Studio
"Si il n'y a pas de solution, c'est qu'il n'y a pas problème !"
(sagesse Shadok)

Hors ligne

#158 Le 03/05/2012, à 16:56

souen

Re : Gimp 2.8 : "On essaye de faire le 2.8 avant le SOC 2010"

david96 a écrit :

Yeeessssss!!!! big_smile


Tu es programmé, mais tu es libre.
Ubuntu Studio
"Si il n'y a pas de solution, c'est qu'il n'y a pas problème !"
(sagesse Shadok)

Hors ligne

#159 Le 03/05/2012, à 19:03

compte supprimé

Re : Gimp 2.8 : "On essaye de faire le 2.8 avant le SOC 2010"

Le paquet "gimp-plugin-registry" est incompatible avec gimp 2.8.
Bon, le seul truc qui m'intéressait dedans, c'était liquid rescale. J'ai donc fait des paquets deb 64 bit pour precise, du plugin liquid rescale.
À utiliser à vos risques et périls (fait avec checkinstall), mais ça marche bien sinon. smile

http://dl.free.fr/dPSQSe2kh
http://dl.free.fr/n59IvrkZx

Ils disparaîtrons au bout de 30 jours, donc si quelqu'un veut bien re-hoster...

Sinon, j'ai testé la dernière version de GMI'C (1.5.3 beta) avec la 2.8 : marche impec'.
Mais je n'arrive pas à compiler gimp-resynthetiser. sad

Edit : gimp-paint-studio (pack de brosses, entre autres) marche bien.
À télécharger ici (remplacer mettre les fichiers dans le dossier dézippé ".gimp2.7", dans le dossier .gimp2.8 de votre dossier personnel) :
https://code.google.com/p/gps-gimp-paint-studio/

Edit 2 : j'ai aussi fait un paquet 64 bit pour separate+, l'addon qui permet à gimp de gérer les profils de couleurs (= addon anti-troll "gimp saynul, çagèrepasleCMJN") :
http://dl.free.fr/kP0L0subg

Dernière modification par monsieurweller (Le 03/05/2012, à 20:13)

#160 Le 03/05/2012, à 19:40

compte supprimé

Re : Gimp 2.8 : "On essaye de faire le 2.8 avant le SOC 2010"

Ah ! Je suis arrivé à compiler le plugin "gimp-resynthesizer" !
Un deb (amd64) ici : http://dl.free.fr/vtdzG2emD

J'ai utilisé la branche bit de Ketsuban. Pour compiler, j'ai modifié le fichier "configure.in", pour rajouter cette ligne :

AC_CHECK_LIB(gthread-2.0, g_thread_init)

Ce qui donne :

dnl Process this file with autoconf to produce a configure script.

dnl lkk 2011 Hacked from gimp-plugin-template configure.in
dnl changed name and added PluginScript/Makefile
AC_PREREQ(2.54)

dnl Name your plug-in here
dnl lkk 2011 Changed name and version digits
m4_define([plugin_name], [resynthesizer])

dnl These three define the plug-in version number
m4_define([plugin_major_version], [1])
m4_define([plugin_minor_version], [0])
m4_define([plugin_micro_version], [0])

m4_define([plugin_version],
          [plugin_major_version.plugin_minor_version.plugin_micro_version])

AC_INIT([plugin_name], [plugin_version])

AC_DEFINE(PLUGIN_NAME, PACKAGE_NAME, [Plug-In name])
AC_DEFINE(PLUGIN_VERSION, PACKAGE_VERSION, [Plug-In version])

AC_DEFINE(PLUGIN_MAJOR_VERSION, plugin_major_version, [Plug-In major version])
AC_DEFINE(PLUGIN_MINOR_VERSION, plugin_minor_version, [Plug-In minor version])
AC_DEFINE(PLUGIN_MICRO_VERSION, plugin_micro_version, [Plug-In micro version])

dnl lkk 2011 changed name
AC_CONFIG_SRCDIR([src/resynthesizer.c])
AM_CONFIG_HEADER(config.h)
AC_CHECK_LIB(gthread-2.0, g_thread_init)
AM_INIT_AUTOMAKE(no-define)

AC_ISC_POSIX
AC_PROG_CC
AM_PROG_CC_STDC
AC_HEADER_STDC


ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"

AM_MAINTAINER_MODE


dnl Use -Wall if we have gcc.
changequote(,)dnl
if test "x$GCC" = "xyes"; then
  case " $CFLAGS " in
  *[\ \    ]-Wall[\ \    ]*) ;;
  *) CFLAGS="$CFLAGS -Wall" ;;
  esac
fi
changequote([,])dnl


GIMP_REQUIRED_VERSION=2.2.0

PKG_CHECK_MODULES(GIMP,
  gimp-2.0 >= $GIMP_REQUIRED_VERSION gimpui-2.0 >= $GIMP_REQUIRED_VERSION)

AC_SUBST(GIMP_CFLAGS)
AC_SUBST(GIMP_LIBS)

GIMP_LIBDIR=`$PKG_CONFIG --variable=gimplibdir gimp-2.0`
AC_SUBST(GIMP_LIBDIR)


dnl i18n stuff

dnl lkk 2011 Changed name here
GETTEXT_PACKAGE=resynthesizer
AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE",
                    [The gettext translation domain.])

dnl Add the languages which your application supports here.
ALL_LINGUAS="es ru"

AC_PROG_INTLTOOL
AM_GLIB_GNU_GETTEXT

AC_CHECK_FUNCS(bind_textdomain_codeset)

dnl lkk 2011 I copied this from the main gimp configure.in
dnl where $PACKAGE is gimp and gimp_plugin_version is 2.0
dnl gimpplugindir="$libdir/$PACKAGE/gimp_plugin_version"
gimpplugindir="$libdir/gimp/2.0"
AC_SUBST(gimpplugindir)

LOCALEDIR='${datadir}/locale'
DATADIR='${datadir}/plugin_name'

AC_SUBST(LOCALEDIR)
AC_SUBST(DATADIR)


AC_MSG_CHECKING([if GTK+ is version 2.7.0 or newer])
if $PKG_CONFIG --atleast-version=2.7.0 gtk+-2.0; then
  have_gtk_2_7=yes
else
  have_gtk_2_7=no
fi
AC_MSG_RESULT($have_gtk_2_7)

if test "x$have_gtk_2_7" != "xyes"; then
  CPPFLAGS="$CPPFLAGS -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED"
fi


AC_MSG_CHECKING([if GIMP is version 2.3.0 or newer])
if $PKG_CONFIG --atleast-version=2.3.0 gimp-2.0; then
  have_gimp_2_3=yes
else
  have_gimp_2_3=no
fi
AC_MSG_RESULT($have_gimp_2_3)

if test "x$have_gimp_2_3" != "xyes"; then
  CPPFLAGS="$CPPFLAGS -DGIMP_DISABLE_DEPRECATED"
fi

dnl lkk July 2011
AC_PROG_RANLIB
dnl AC_PROG_LIBTOOL

dnl lkk 2011 Added PluginScripts/Makefile
AC_CONFIG_FILES([
Makefile
src/Makefile
po/Makefile.in
help/Makefile
help/en/Makefile
help/images/Makefile
PluginScripts/Makefile
])

AC_OUTPUT

À faire avant le ./autogen.sh, pour ceux intéressés par la compilation de cet addon.


Voilà voilà. Avec tout ces addons, gimp deviens une sorte de photoshop, mais en mieux, en libre et en gratuit ! smile

Dernière modification par monsieurweller (Le 03/05/2012, à 20:14)

#161 Le 03/05/2012, à 20:10

Spitfire 95

Re : Gimp 2.8 : "On essaye de faire le 2.8 avant le SOC 2010"

Ya plus qu'à forcer la design team de Canonical à passer à Ubuntu et à utiliser GIMP en remplacement de Mac et Adaube Toshop ^^


Trisquel GNU/Linux 6.0 / Fedora 19 & rawhide.
joueur ryzom et wesnoth
Développeur livewallpaper
Membre déserteur et traître de la brigade des S.

Hors ligne

#162 Le 03/05/2012, à 23:02

Vu

Re : Gimp 2.8 : "On essaye de faire le 2.8 avant le SOC 2010"

Pas possible, ils n'auraient plus d'idées et d'inspirations pour l'interface du bureau. tongue

Dernière modification par Vu (Le 03/05/2012, à 23:04)


Ubuntu 12.04

Hors ligne

#163 Le 03/05/2012, à 23:05

Spitfire 95

Re : Gimp 2.8 : "On essaye de faire le 2.8 avant le SOC 2010"

Vu a écrit :

Pas possible, ils n'auraient plus d'idée et d'inspiration pour l'interface du bureau. tongue

Dans ce cas on va faire plus simple. Ubuntu en cli et nano. Après tout, pas besoin de logiciels compliqués pour changer un pixel sur une image (attention, en six mois, ça a pas l'air comme ça mais, c'est super chaud lol), un éditeur de texte, on change le fichier binaire d'une lettre, et le tour est joué lol


Trisquel GNU/Linux 6.0 / Fedora 19 & rawhide.
joueur ryzom et wesnoth
Développeur livewallpaper
Membre déserteur et traître de la brigade des S.

Hors ligne

Haut de page ↑