Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 28/09/2005, à 14:47

jean-francois

Oser faire l'âne pour avoir du son (rien d'audible dans xmms)

Bonjour chers Ubunters


Les explications de Ploum (dont les billets sur le forum Andesi m'ont aussi aidés) sur le son sont instructives.

Voulant m'installer une alarme musicale, j'ai synaptiqué xmms, xmms-alarm et xmms-cdread. Au lancement de xmms, un message d'erreur indiquait un libmikmod.so.2 non trouvé. Synaptic de ibmikmod2 a résolu le problème.
Mais
Il me reste néanmoins un problème fondamental que je n'arrive pas à résoudre seul : 
*  les applis "son" telles que le "lecteur de musique" ou le "lecteur de CD audio" fonctionnent   parfaitement
*  xmms 1.2.10 charge des fichiers wav, mais ne produit pas de son.
*  le message d'erreur est le suivant :

Message: alsa mixer timed out

*

aplay /usr/share/sounds/gnomemeeting/gnomemeeting.wav
-> Playing WAVE '/usr/share/sounds/gnomemeeting/gnomemeeting.wav' : Signed 16 bit Little Endian, Rate 11025 Hz, Mono

*  les modifications recommandées par ploum sur esd.conf sont effectuées
*

lsof /dev/snd/*  
--> 
mixer_app 14005 jf   36u   CHR  116,0      7139 /dev/snd/controlC0

*

lsmod|grep snd -
> 
snd_intel8x0           29984  0
snd_ac97_codec         64608  1 snd_intel8x0
snd_pcm_oss            47652  0
snd_mixer_oss          16768  1 snd_pcm_oss
snd_pcm                84872  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer              23300  1 snd_pcm
snd                    50276  6 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore               9824  1 snd
snd_page_alloc          9604  2 snd_intel8x0,snd_pcm

Quelqu'un aurait-il une piste à m'indiquer, des tests complémentaires à effectuer ?
Merci

Jean-Francois.

PS:
* je suis sous 5.04 Ubuntu Linux : Hoary Hedgehog (que du bonheur)


un homme à vétir en vaut deux

Hors ligne

#2 Le 28/09/2005, à 17:17

AppleCrow

Re : Oser faire l'âne pour avoir du son (rien d'audible dans xmms)

Quelle est la voie de sortie que tu utilises pour le son? Alsa ou ESD?

Parce qu'un problème de mixer alsa veut dire qu'ALSA est occupé.
Et ESD est un démon sonore qui utilise soit OSS soit ALSA pour le son.

Donc essaye de sortir le son via ESD plutot que via ALSA.

#3 Le 28/09/2005, à 17:24

mesmento

Re : Oser faire l'âne pour avoir du son (rien d'audible dans xmms)

Options > préférences > E/S Audio > Plugin de sortie: esd

Hors ligne

#4 Le 28/09/2005, à 20:04

jean-francois

Re : Oser faire l'âne pour avoir du son (rien d'audible dans xmms)

merci pour vos réponses. wink chers Ubunters

En fait, après ré-essai, les  fichiers sons "standards" sont reconnus et joués. Excusez le dérangement hmm

Par contre, c'est la lecture directe des cd par xmms (paquet xmms-cdread 0.14a-11 ) qui ne produit pas de son.

Bon d'accord, gnome-cd lit les cd sans problème, mais quand même par principe j'aimerais que ce soit xmms qui lise mes CD !

Une idée  ?

Jean-Francois


un homme à vétir en vaut deux

Hors ligne

#5 Le 28/09/2005, à 20:44

dawar

Re : Oser faire l'âne pour avoir du son (rien d'audible dans xmms)

Peux être en utilisant "extraction numérique" dans les préférences de cdread (heuu si c'est bien libcdaudio) ?


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadoks)

Hors ligne

#6 Le 29/09/2005, à 22:01

jean-francois

Re : Oser faire l'âne pour avoir du son (rien d'audible dans xmms)

Merci dawar,

j'ai regardé mais n'ai pas trouvé de préférences particulières pour gnome-cd, à moins qu'il y ait quelque chose qui m'ait échappé.


un homme à vétir en vaut deux

Hors ligne

#7 Le 29/09/2005, à 22:40

dawar

Re : Oser faire l'âne pour avoir du son (rien d'audible dans xmms)

Heuu je croyais d'après ton poste que tu voulais lire les CD audio dans xmms...

Il faut savoir que pour les lecteurs cdrom, il y'a deux modes de fonctionnement pour un CD audio :
1) en mode normal, le lecteur assure la conversion numérique->analogique et balance le son direct a la carte son via un cable branché entre les 2. Il faut régler l'entrée CD-in dans alsamixer.
2) en mode extraction, le CD est "ripé" en temps réel pour être lu, tout est numérique et utilise le système de son du logiciel qui se charge de cela, xmms par exemple.


S'il n'y a pas de solution, c'est qu'il n'y a pas de problème (Devise Shadoks)

Hors ligne

#8 Le 30/09/2005, à 09:05

jean-francois

Re : Oser faire l'âne pour avoir du son (rien d'audible dans xmms)

Effectivemnt. Merci pour ces explications éclairantes.

xmms / préférences : libcdaudio.so
  configurer / vérifier le lecteur -> test d'extraction OK, répertoire /cdrom/ OK
 
préférences : E/S audio / Plugin de sortie : libestout.so
Fonctionne parfaitement merci dawar smile

Juste par curiosité : si je sélectionne Alsa en plugin de sorite, xmms se plante (?)

Une révision de http://wiki.ubuntu-fr.org/installation/son donne : 

Par défaut, Hoary utilise le serveur de son de gnome : ESD (appelé parfois esound). Les applications envoient leurs sons à ESD, qui les mixe et envoie le résultat à OSS qui le passe à ALSA.

Est-ce que l'explication pourrait-être que dans le cas de fichiers .wav, la lecture peut s'effectuer temp réel, au contraire de ce qui passe en mode "extraction" qui requiert un temps de traitement plus long n'autorisant pas le passage d'un flux continu, et que de se fait l'intercalage de ESD (libestout.so) devient nécessaire ?

Mais dans ce cas, la modification du tampon de Alsa devrait aboutir à la lecture possible avec Alsa comme plugin de sorite. Or ce n'est pas le cas (peut être n'ai-je pas trouvé la bonne combinaison entre le tampon et la période)

Qu'en pensez-vous ?


un homme à vétir en vaut deux

Hors ligne

Haut de page ↑