Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 29/04/2005, à 18:49

nkdb

apache : ?

Slt,

j'ai installé apache et créé quelque page php.

Un problème : à l'affichage, les accents sont remplacé par des "?" .

Vous en connaissez la cause ?

merci

Hors ligne

#2 Le 29/04/2005, à 19:42

jpaul

Re : apache : ?

essaie de remplacer "é" par é et "è" par è je crois (n'oublie pas le ";" à la fin.


<Mon avatar n'est pas une grenouille><Windows ça pue; Mac c'est trop cher; Linux c'est trop compliqué*, xBSD ça sert à rien><Les modos, on vous aime><Hébergement Web gratos et sympah ;)>
* Mais ça rend beau
[Membre du club des beaux Ubunteros]

Hors ligne

#3 Le 29/04/2005, à 19:43

nkdb

Re : apache : ?

En fait j'amerais ne pas etre obligé de faire ca ! mais plutot trouver le possible config d'apache pour résoudre le problème ...

merci

Hors ligne

#4 Le 29/04/2005, à 19:46

yeffries

Re : apache : ?

Les données transformées proviennent-elles d'une base de données ? Type Mysql ? Si oui, c'est peut-etre dû à la manière "d'uploader" la base de données.
Par exemple, si tu as selectionné "utf-8", mieux vaut utiliser "latin1".

Sinon, peut-etre que ceci peut changer quelque chose :"<meta http-equiv="content-type" content="text/html;charset=iso-8859-1" />"

Dernière modification par yeffries (Le 29/04/2005, à 19:49)

Hors ligne

#5 Le 29/04/2005, à 19:51

nkdb

Re : apache : ?

non, pas de MySQL dans l'affaire ... meme la page "apache2-default" a ce problème ...

Hors ligne

#6 Le 29/04/2005, à 19:53

tigrou

Re : apache : ?

Tu peux aussi rajouter

AddCharset utf-8 html htm php

dans la section <IfModule mod_mime.c> ça devrait marcher je pense...

Hors ligne

#7 Le 29/04/2005, à 19:57

Stemp

Re : apache : ?

ou aller voir le fichier /etc/apache2/conf.d/charset


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#8 Le 29/04/2005, à 20:24

nkdb

Re : apache : ?

> more /etc/apache2/conf.d/charset
AddDefaultCharset UTF-8

=> ca a l'air ok

/etc/apache2/mods-enabled> ls -al
total 8
drwxr-xr-x  2 root root 4096 2005-04-29 21:19 .
drwxr-xr-x  8 root root 4096 2005-04-28 18:10 ..
lrwxrwxrwx  1 root root   36 2005-04-28 18:10 cgi.load -> /etc/apache2/mods-available/cgi.load
lrwxrwxrwx  1 root root   33 2005-04-29 21:19 mime_magic.conf -> ../mods-available/mime_magic.conf
lrwxrwxrwx  1 root root   33 2005-04-29 21:19 mime_magic.load -> ../mods-available/mime_magic.load
lrwxrwxrwx  1 root root   37 2005-04-28 18:10 perl.conf -> /etc/apache2/mods-available/perl.conf
lrwxrwxrwx  1 root root   37 2005-04-28 18:10 perl.load -> /etc/apache2/mods-available/perl.load
lrwxrwxrwx  1 root root   37 2005-04-28 18:10 php4.conf -> /etc/apache2/mods-available/php4.conf
lrwxrwxrwx  1 root root   37 2005-04-28 18:10 php4.load -> /etc/apache2/mods-available/php4.load
lrwxrwxrwx  1 root root   40 2005-04-28 18:10 userdir.conf -> /etc/apache2/mods-available/userdir.conf
lrwxrwxrwx  1 root root   40 2005-04-28 18:10 userdir.load -> /etc/apache2/mods-available/userdir.load

=> Il y a bien les lien "mime_magic".

/etc/apache2/mods-enabled> more mime_magic.conf
<IfModule mod_mime_magic.c>
    MIMEMagicFile /usr/share/misc/file/magic.mime
    AddCharset utf-8 html htm php
</IfModule>

=> toujours le probleme ...

Hors ligne

#9 Le 30/04/2005, à 13:18

nkdb

Re : apache : ?

http://82.232.196.48/~vince/NKDBbudget/fr/

Pour exemple.

Il se trouve que je n'ai pas de module "mime", mais uniquement le "mime_magic" (installation par defaut). Ceci peut il etre la source du probleme ?

Pas de section "<IfModule mod_mime.c>", uniquement "<IfModule mod_mime_magic.c>"

Hors ligne

#10 Le 30/04/2005, à 15:22

nkdb

Re : apache : ?

Problème résolut :

Fichier : /etc/apache2/conf.d/charset

Passer de :

AddDefaultCharset UTF-8

A :

AddDefaultCharset ISO-8859-1

ma question est : pourquoi par défaut est-ce UTF-8 ?

Hors ligne

#11 Le 30/04/2005, à 15:55

Stemp

Re : apache : ?

Parce que par défaut Ubuntu utilise l'encodage utf-8.
C'est le futur standard, et il est étrange que le fait de passer dans un ancien système régle ton problème.
Il est probable que tu as un problème de configuration quelque part.
M'enfin, le plus important étant que ça fonctionne wink


«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#12 Le 01/05/2005, à 00:40

coffee

Re : apache : ?

utf-8 rend ton contenu web (si tu override pas le charset) compatible avec le monde entier (russe, asiatique, arabe, greque, ...)


Nom d'un tupperware habillé en streetware mangeant de la confiture de pouère et qui se dite où est-ce que je suis ouère !
Tiens mon blog
Les blagues sous forme de fausses aides sont susceptible de ban (ex: rm)

Hors ligne

#13 Le 04/09/2005, à 14:03

Michael Witrant

Re : apache : ?

Utiliser AddDefaultCharset n'est pas du tout recommandé :
http://ungwe.org/blog/2004/01/26/22:52/

Je pense qu'il vaut mieux simplement supprimer ce parametre de la config.

#14 Le 04/09/2005, à 16:14

Donk

Re : apache : ?

nkdb a écrit :

Slt,

j'ai installé apache et créé quelque page php.

Un problème : à l'affichage, les accents sont remplacé par des "?" .

Vous en connaissez la cause ?

merci

Le problème vient sûrement du fait que l'entête de tes pages web n'est pas correcte

Hors ligne

#15 Le 05/09/2005, à 07:49

Kitty

Re : apache : ?

Si c'est OK, peux-tu mettre [Résolu] dans le titre en modifiant ton premier post ? Merci ! (et en clarifiant le titre afin de pouvoir aider d'autres personnes)

Hors ligne

#16 Le 01/10/2005, à 13:59

eks

Re : apache : ?

http://forum.ubuntu-fr.org/viewtopic.php?id=10404


eks

Hors ligne

Haut de page ↑