Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 12/09/2005, à 13:43

ObSVuugj

probleme avec enemy territory

j'ai installé enemy territory et quand je le lance, ca fait sa

harkonen@ubuntu:~$ ./et
ET 2.60 linux-i386 Mar 10 2005
----- FS_Startup -----
Current search path:
/home/harkonen/.etwolf/etmain
/home/harkonen/enemy-territory/etmain/pak2.pk3 (22 files)
/home/harkonen/enemy-territory/etmain/pak1.pk3 (10 files)
/home/harkonen/enemy-territory/etmain/pak0.pk3 (3725 files)
/home/harkonen/enemy-territory/etmain/mp_bin.pk3 (6 files)
/home/harkonen/enemy-territory/etmain

----------------------
3763 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
Xlib:  extension "XFree86-DGA" missing on display ":0.0".
Failed to detect XF86DGA Mouse
XFree86-VidModeExtension Activated at 800x600
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
GL_RENDERER: Mesa GLX Indirect


***********************************************************
 You are using software Mesa (no hardware acceleration)!
 Driver DLL used: libGL.so.1
 If this is intentional, add
       "+set r_allowSoftwareGL 1"
 to the command line when starting the game.
***********************************************************
...WARNING: could not set the given mode (4)
Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.2
XFree86-VidModeExtension Activated at 640x480
Received signal 11, exiting...
harkonen@ubuntu:~$ +set r_allowSoftwareGL 1
bash: +set: command not found
harkonen@ubuntu:~$ ./et +set r_allowSoftwareGL 1
ET 2.60 linux-i386 Mar 10 2005
----- FS_Startup -----
Current search path:
/home/harkonen/.etwolf/etmain
/home/harkonen/enemy-territory/etmain/pak2.pk3 (22 files)
/home/harkonen/enemy-territory/etmain/pak1.pk3 (10 files)
/home/harkonen/enemy-territory/etmain/pak0.pk3 (3725 files)
/home/harkonen/enemy-territory/etmain/mp_bin.pk3 (6 files)
/home/harkonen/enemy-territory/etmain

----------------------
3763 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
Xlib:  extension "XFree86-DGA" missing on display ":0.0".
Failed to detect XF86DGA Mouse
XFree86-VidModeExtension Activated at 800x600
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
GL_RENDERER: Mesa GLX Indirect
...using software Mesa (r_allowSoftwareGL==1).
Initializing OpenGL extensions
...GL_S3_s3tc not found
...ignoring GL_EXT_texture_env_add
...using GL_ARB_multitexture
...GL_EXT_compiled_vertex_array not found
...GL_NV_fog_distance not found
... GL_EXT_texture_filter_anisotropic not found
Initializing GLX extensions
... GLX_SGI_swap_control not found
... GLX_SGI_video_sync not found
XF86 Gamma extension initialized

GL_VENDOR: Mesa project: www.mesa3d.org
GL_RENDERER: Mesa GLX Indirect
GL_VERSION: 1.2 (1.5 Mesa 6.2.1)
GL_EXTENSIONS: GL_ARB_imaging GL_ARB_multitexture GL_ARB_texture_border_clamp GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_transpose_matrix GL_EXT_abgr GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_lod_bias
GLX_EXTENSIONS: GLX_EXT_visual_info GLX_EXT_visual_rating GLX_EXT_import_context GLX_ARB_multisample
GL_MAX_TEXTURE_SIZE: 2048
GL_MAX_ACTIVE_TEXTURES_ARB: 8

PIXELFORMAT: color(24-bits) Z(24-bit) stencil(0-bits)
MODE: 4, 800 x 600 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
CPU:
rendering primitives: multiple glArrayElement
texturemode: GL_LINEAR_MIPMAP_NEAREST
picmip: 1
texture bits: 0
multitexture: enabled
compiled vertex arrays: disabled
texenv add: disabled
compressed textures: disabled
anisotropy: 1.0
NV distance fog: disabled
Initializing Shaders
----- finished R_Init -----

------- sound initialization -------
/dev/dsp: Input/output error
Could not mmap /dev/dsp
------------------------------------
Sound memory manager started
Sys_LoadDll(/home/harkonen/.etwolf/etmain/ui.mp.i386.so)...
Sys_LoadDll(/home/harkonen/.etwolf/etmain/ui.mp.i386.so) failed:
"/home/harkonen/.etwolf/etmain/ui.mp.i386.so: cannot open shared object file: No such file or directory"
Sys_LoadDll(/home/harkonen/enemy-territory/etmain/ui.mp.i386.so)... ok
Sys_LoadDll(ui) found **vmMain** at  0x5dbbaf40
Sys_LoadDll(ui) succeeded!
Found high quality video and fast CPU
--- Common Initialization Complete ---
Opening IP socket: localhost:27960
Hostname: localhost.localdomain
Alias: localhost
Alias: ubuntu
IP: 127.0.0.1
Started tty console (use +set ttycon 0 to disable)
execing preset_high.cfg
r_colorbits will be changed upon restarting.
r_depthbits will be changed upon restarting.
r_picmip will be changed upon restarting.
r_mode will be changed upon restarting.
r_texturebits will be changed upon restarting.
RE_Shutdown( 1 )
Hunk_Clear: reset the hunk ok
----- Initializing Renderer ----
-------------------------------
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 6: 1024 768
Using XFree86-VidModeExtension Version 2.2
XFree86-VidModeExtension Activated at 1024x768
Using 4/4/4 Color bits, 24 depth, 0 stencil display.
GL_RENDERER: Mesa GLX Indirect
...using software Mesa (r_allowSoftwareGL==1).
Initializing OpenGL extensions
...GL_S3_s3tc not found
...ignoring GL_EXT_texture_env_add
...using GL_ARB_multitexture
...GL_EXT_compiled_vertex_array not found
...GL_NV_fog_distance not found
... GL_EXT_texture_filter_anisotropic not found
Initializing GLX extensions
... GLX_SGI_swap_control not found
... GLX_SGI_video_sync not found
XF86 Gamma extension initialized

GL_VENDOR: Mesa project: www.mesa3d.org
GL_RENDERER: Mesa GLX Indirect
GL_VERSION: 1.2 (1.5 Mesa 6.2.1)
GL_EXTENSIONS: GL_ARB_imaging GL_ARB_multitexture GL_ARB_texture_border_clamp GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_transpose_matrix GL_EXT_abgr GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_lod_bias
GLX_EXTENSIONS: GLX_EXT_visual_info GLX_EXT_visual_rating GLX_EXT_import_context GLX_ARB_multisample
GL_MAX_TEXTURE_SIZE: 2048
GL_MAX_ACTIVE_TEXTURES_ARB: 8

PIXELFORMAT: color(32-bits) Z(24-bit) stencil(0-bits)
MODE: 6, 1024 x 768 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
CPU:
rendering primitives: multiple glArrayElement
texturemode: GL_LINEAR_MIPMAP_LINEAR
picmip: 0
texture bits: 32
multitexture: enabled
compiled vertex arrays: disabled
texenv add: disabled
compressed textures: disabled
anisotropy: 1.0
NV distance fog: disabled
Initializing Shaders
----- finished R_Init -----
Sys_LoadDll(/home/harkonen/.etwolf/etmain/ui.mp.i386.so)...
Sys_LoadDll(/home/harkonen/.etwolf/etmain/ui.mp.i386.so) failed:
"/home/harkonen/.etwolf/etmain/ui.mp.i386.so: cannot open shared object file: No such file or directory"
Sys_LoadDll(/home/harkonen/enemy-territory/etmain/ui.mp.i386.so)... ok
Sys_LoadDll(ui) found **vmMain** at  0x5dbbaf40
Sys_LoadDll(ui) succeeded!
Resolving etmaster.idsoftware.com
etmaster.idsoftware.com resolved to 192.246.40.60:27951
execing preset_normal_ui.cfg
execing preset_high_ui.cfg
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Shutdown tty console
harkonen@ubuntu:~$ esd
harkonen@ubuntu:~$ ./et
ET 2.60 linux-i386 Mar 10 2005
----- FS_Startup -----
Current search path:
/home/harkonen/.etwolf/etmain
/home/harkonen/enemy-territory/etmain/pak2.pk3 (22 files)
/home/harkonen/enemy-territory/etmain/pak1.pk3 (10 files)
/home/harkonen/enemy-territory/etmain/pak0.pk3 (3725 files)
/home/harkonen/enemy-territory/etmain/mp_bin.pk3 (6 files)
/home/harkonen/enemy-territory/etmain

----------------------
3763 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
Xlib:  extension "XFree86-DGA" missing on display ":0.0".
Failed to detect XF86DGA Mouse
XFree86-VidModeExtension Activated at 800x600
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
GL_RENDERER: Mesa GLX Indirect


***********************************************************
 You are using software Mesa (no hardware acceleration)!
 Driver DLL used: libGL.so.1
 If this is intentional, add
       "+set r_allowSoftwareGL 1"
 to the command line when starting the game.
***********************************************************
...WARNING: could not set the given mode (4)
Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.2
XFree86-VidModeExtension Activated at 640x480
Received signal 11, exiting...

! pourtant j'ai installé les drivers ATI (fglrx)!Et quand je le lance comme ca

./et +set r_allowSoftwareGL 1

C'est SUPER lent.

j'ai entendu qu'il fallais supprimer fglrx.ko? il est ou ce fichier?

Dernière modification par ObSVuugj (Le 26/09/2005, à 16:55)


Bonjour je suis un portail et je suis ici pour vendre des fenetres!

(Hello! I am Gates and I am here to sell Windows)

Hors ligne

#2 Le 12/09/2005, à 16:50

HeadUp

Re : probleme avec enemy territory

You are using software Mesa (no hardware acceleration)

Tu as bien changer le nom du "driver" dans xorg.conf ?


Chuck Norris s'est vu quand il a bu.

Hors ligne

#3 Le 12/09/2005, à 19:02

ObSVuugj

Re : probleme avec enemy territory

oue j'ai mis fglrx a la place de ati


Bonjour je suis un portail et je suis ici pour vendre des fenetres!

(Hello! I am Gates and I am here to sell Windows)

Hors ligne

#4 Le 13/09/2005, à 05:40

Duny

Re : probleme avec enemy territory

le probleme est "simple" en fait il faut ke tu recompile le fichier ".ko"
j'avais eu ce probleme la aussi j'ai fouillé le forum puisque d'autre on deja eu le meme probleme c'est un "bug" du driver proprietaire

#5 Le 13/09/2005, à 15:28

ObSVuugj

Re : probleme avec enemy territory

oue mais C quel fichier .ko ? et comment je le recompile? sinon qq'un n'as pas d'autres réponses plus simples?

Dernière modification par ObSVuugj (Le 26/09/2005, à 16:53)


Bonjour je suis un portail et je suis ici pour vendre des fenetres!

(Hello! I am Gates and I am here to sell Windows)

Hors ligne

#6 Le 26/09/2005, à 16:54

ObSVuugj

Re : probleme avec enemy territory

alors,personne ?


Bonjour je suis un portail et je suis ici pour vendre des fenetres!

(Hello! I am Gates and I am here to sell Windows)

Hors ligne

#7 Le 02/10/2005, à 14:10

ObSVuugj

Re : probleme avec enemy territory

personne ne sait?

PS:je suis sous ubuntu amd64.... C ptet pour sa?


Bonjour je suis un portail et je suis ici pour vendre des fenetres!

(Hello! I am Gates and I am here to sell Windows)

Hors ligne

#8 Le 02/10/2005, à 15:29

Stemp

Re : probleme avec enemy territory

Ton problème ne vient pas de ET mais de ta configuration 3D.
Fait une recherche sur le forum et sur le wiki. Il faut effectivement enlever un fichier fglrx.ko en trop.

locate fglrx.ko

«La violence n'a jamais rien réglé» Gengis Khan 1162-1227
Blog | Crunchbang Linux | Arch Linux

Hors ligne

#9 Le 10/10/2005, à 14:57

ObSVuugj

Re : probleme avec enemy territory

en fait, pk il y est fglrx.ko si il faut l'enlever ?


Bonjour je suis un portail et je suis ici pour vendre des fenetres!

(Hello! I am Gates and I am here to sell Windows)

Hors ligne

#10 Le 10/10/2005, à 15:50

LR

Re : probleme avec enemy territory

Dans le doute tu le renommes : mv fglrx.ko > fglrx.koBAK.

Tiens-nous au courant.

Hors ligne

Haut de page ↑