Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 04/06/2012, à 17:40

Rems29

Dofus et Linux

Bonjour,
J'ai fouiner un peu partout sur les différents forums mais impossible de trouver une solution à mon problème ... J'essaie donc d'installer Dofus sous linux en suivant ce tuto ICI (méthode 1, la méthode 2 ne marche pas non plus ...). Le message d'erreur lors de l'installation : /tmpair.bI1p2B/setup: error while loading shared librairies: libgtk-x11-2.0.so.0: cannot open shared abject file: no such file or directory. Quelqu'un pourrait-il m'aider à résoudre ce problème ? Merci !

Dernière modification par Rems29 (Le 05/06/2012, à 00:05)

Hors ligne

#2 Le 04/06/2012, à 17:56

sergei_ruskof

Re : Dofus et Linux

Salut,le message te dis qu'il te manque libgtk-x11-2.0.so.0,du coup install libgtk2.0-0

Hors ligne

#3 Le 04/06/2012, à 19:28

Rems29

Re : Dofus et Linux

Merci pour cette réponse rapide ! Alors comment installer sa ? "sudo apt-get install libgtk2.0-0" donne sa :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libgtk2.0-0 est déjà la plus récente version disponible.
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libsdl-ttf2.0-0 libunistring0:i386 libsdl-mixer1.2 libgomp1:i386
  libboost-iostreams1.46.1 libmikmod2 libcroco3:i386 libgettextpo0:i386
  libsdl-net1.2 ttf-wqy-zenhei libboost-regex1.46.1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 1 non mis à jour.

Et lorsque je réessaie d'installer Dofus j'ai le même message d'erreur qui apparaît.

Hors ligne

#4 Le 04/06/2012, à 19:55

sergei_ruskof

Re : Dofus et Linux

Il est deja installé.

Essaye en installant libgtk2.0-0-dev on sais jamais.

Je joue pas a Dofus mais j'ai libgtk2.0-0-common ,libgtk2.0-0-bin,libgtk2.0-0-cil,si il ne sont pas installé sur le tiens c'est peut etre l'un d'eux qui te bloque.

Hors ligne

#5 Le 04/06/2012, à 20:06

Rems29

Re : Dofus et Linux

J'ai essayer d'installer ce que tu dis et dans tout les cas je trouve :

sudo apt-get install libgtk2.0-0-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet libgtk2.0-0-dev
E: Impossible de trouver de paquet correspondant à l'expression rationnelle « libgtk2.0-0-dev »

Alors je ne suis pas doué en informatique faut le noter donc du coup Ubuntu et moi en ce qui concerne les installations et tout le bazard je ne comprends pas trop roll

Hors ligne

#6 Le 04/06/2012, à 20:09

sergei_ruskof

Re : Dofus et Linux

Je me suis tromper c'est libgtk2.0-dev

Plutot que de passer par le terminal,je te conseille d'utiliser synaptic,avec une recherche tu trouve les paquets qu'il te faut.

Hors ligne

#7 Le 04/06/2012, à 20:20

Rems29

Re : Dofus et Linux

Je suis passer par Synaptic et le paquet est déjà installé ! J'ai donc refais l'installation de dofus et j'obtiens exactement le même message d'erreur neutral Aurais-tu une autre idée ? Et tout sa pour un jeu roll

Dernière modification par Rems29 (Le 04/06/2012, à 20:21)

Hors ligne

#8 Le 04/06/2012, à 20:26

sergei_ruskof

Re : Dofus et Linux

Tu es en 64 bits?

Si c'est le cas installe libgtk2.0-0:i386

Je suis en 64 bits et viens d'installer le jeux et sa marche,j'ai tout les paquets cité plus haut ainsi que le paquet 32 bits.

Hors ligne

#9 Le 04/06/2012, à 22:51

Rems29

Re : Dofus et Linux

Oui je suis en 64 bits ! J'ai donc installer libgtk2.0-0:i386 mais je me retrouve face à un autre problème lorsque j'installe dofus :

"(setup:2216): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : <<murrine>>
Gtk-Message: Failed to load module <<canberra-gtk-module>>
"

Ensuite une fenêtre s'ouvre automatiquement et me dis :

"L'exécution d'AIR 2.6 32 bits sur les systèmes 64 bits n'a pas été intégralement testée. Néanmoins, AIR 32 bits fonctionnera probablement sur les systèmes 64 bits si les bibliothèques et les packages 32 bits requis sont installés sur ces derniers."

Qu'en penses-tu ?

Hors ligne

#10 Le 04/06/2012, à 23:18

J5012

Re : Dofus et Linux

eviter de suivre un tuto obsolete : le tuto de ccm propose l'install de dofus 1.2.6
le tuto ubuntu explique l'install de dofus 2.0 http://doc.ubuntu-fr.org/dofus

tu as aussi la possibilite de recuperer la grosse archive binaire http://download.dofus.com/zip/linux/ (956mo !!)

Hors ligne

#11 Le 04/06/2012, à 23:22

Rems29

Re : Dofus et Linux

Et une fois avoir télécharger l'archive je la décompresse avec tar -xvzf c'est bien sa ?

Hors ligne

#12 Le 04/06/2012, à 23:33

J5012

Re : Dofus et Linux

pourquoi faire complique ? avec file-roller, simplement clic clic dessus l'archive, au choix, extraire, ou drag and drop ...

Hors ligne

#13 Le 04/06/2012, à 23:41

Rems29

Re : Dofus et Linux

Houla Houla ! Jamais vu sa moi ! Du coup je dois télécharge file roller et faire extraire en cliquant sur l'archive ?

Dernière modification par Rems29 (Le 04/06/2012, à 23:42)

Hors ligne

#14 Le 04/06/2012, à 23:52

J5012

Re : Dofus et Linux

tu n'as donc jamais utilise le desarchiveur graphique de ubuntu en mode standard ? il s'appelle file-roller et est installe avec la ubuntu.

Hors ligne

#15 Le 05/06/2012, à 00:03

Rems29

Re : Dofus et Linux

J'essaie toujours de me débrouiller à partir du terminale ! big_smile
Encore un problème ... J'ai donc télécharge l'archive que tu m'as proposer mais au moment de lancer le jeu ils me disent "Cette application nécessite une version d'Adobe AIR qui est introuvable.
Veuillez télécharger la dernière version de l'exécutable à partir de
http://www.adobe.com/go/getair_fr
ou contacter l'auteur de l'application pour obtenir une mise à jour.
"
Mais lorsque j'arrive sur le site il y a écrit : "Adobe AIR pour Linux n’est plus pris en charge. Pour accéder à d’anciennes versions non prises en charge, consultez les archives AIR.".

Les anciennes versions seront suffisante pour lancer le jeu ? Et si oui où je peux les trouver ?

Hors ligne

#16 Le 05/06/2012, à 02:16

J5012

Re : Dofus et Linux

normalement la grosse archive est un runtime, cad pas besoin d'install, mais ca ne fonctionne que sur les systems 32b (je viens de tester en 64b) ; pour les ubuntu en 64b il faut suivre cette discussion : http://forum.ubuntu-fr.org/viewtopic.php?id=363549
- install de adobeair, de dofus, de ia32-libs pour les 64b pre-precise (a noter chez moi en precise ca ne marche que si je mets effectivement les ia32libs)

Hors ligne

#17 Le 05/06/2012, à 13:40

Rems29

Re : Dofus et Linux

Alors j'essaie d'installer adobeair comme dans le tuto mais a chaque fois la logithèque bug et ça revient à zéro donc au final adobeair n'est pas installer ... N'y a t-il pas un autre moyen pour installer ?

Hors ligne

#18 Le 05/06/2012, à 21:34

Rems29

Re : Dofus et Linux

En faite j'ai réussi je suis passé sous wine pour installer adobeair et il n'y a plus qu'à suivre le tuto sur le site de dofus ! Merci pour vos réponse en tout cas wink

Hors ligne

Haut de page ↑