Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 26/02/2012, à 13:36

PDemong

Comment installer Openshot 1.4.2 sur Oneiric (11.10)

Bonjour,
(ce courriel est une copie de celui que j'ai envoyé sur la liste de LPROD le 12 février 2012)

voici la recette que j'ai du appliquer pour installer Openshot 1.4.2 sur Ubuntu Oneiric (11.10). Des problèmes de dépendances et de fix récent d'une des librairies utilisées (MLT) font que cette installation est un peu plus compliquée à faire sur Oneiric.

Prérequis 1 conseillé (FFmpeg) : Installer la dernière version stable de FFmpeg depuis le dépôt stable de Jon Severinsson :

sudo add-apt-repository ppa:jon-severinsson/ffmpeg
sudo apt-get update
sudo apt-get install ffmpeg

Prérequis 2 obligatoire selon moi (MLT) : Installer la dernière version stable des librairies MLT depuis le dépôt stable d'Olivier Banus :

sudo add-apt-repository ppa:sunab/kdenlive-release
sudo apt-get update
sudo apt-get install libmlt4 libmlt-data libmlt++3 python-mlt3 melt

Installer la dernière version stable (1.4.2) depuis le dépot stable d'Openshot à l'aide des commandes suivantes :

sudo add-apt-repository ppa:jonoomph/openshot-edge
sudo apt-get update
sudo apt-get install openshot openshot-doc

Rendu à cette étape, lancer dans un terminal "openshot" et regarder si cela se lance sans message d'erreur. Si cela se lance, on a terminé.

Le 8 février 2012, j'avais malheureusement 2 messages d'erreur. Voici comment je les ai réglés, mais il est fort possible que vous ne rencontriez plus ce problème dans les prochaines versions disponibles par les PPA ci-dessus.

  • Message d'erreur concernant LADSPA :

No LADSPA plugins were found!
Check your LADSPA_PATH environment variable.

Pour cela j'ai du installer un paquet relié à LDSPA :

sudo apt-get install ladspa-sdk
  • Message d'erreur concernant MLT (mlt_repository_init) :

mlt_repository_init: failed to dlopen /usr/lib/mlt/libmltavformat.so
  (/usr/lib/mlt/libmltavformat.so: symbol ff_cropTbl, version LIBAVCODEC_53 not defined in file libavcodec.so.53 with link time reference)

Detecting formats, codecs, and filters...
Erreur de segmentation

Cela a été corrigé le 8 février dernier dans une nouvelle version de MLT, non encore prise en charge dans le dépôt stable de MLT à ce moment-là. Il faut donc activer temporairement le dépot "expérimental" de MLT via le PPA suivant (risqué, mais cela a bien fonctionné pour moi) :

sudo add-apt-repository ppa:sunab/kdenlive-svn
sudo apt-get update
sudo apt-get upgrade libmlt4 libmlt-data libmlt++3 python-mlt3 melt

Voilà, donc si jamais d'autres veulent installer la dernière version Openshot sur Ubuntu Oneiric, c'est faisable! wink
UN GROS MERCI À OLIVIER GIRARD (alias Cenwen) QUI M'A SUPPORTÉ DANS CHACUNE DES ÉTAPES DE MON INSTALLATION, JUSQU'A LA RÉUSSITE FINALE.

Patrick

Dernière modification par PDemong (Le 26/02/2012, à 22:48)

Hors ligne

#2 Le 09/05/2012, à 07:58

Pacifick_FR42

Re : Comment installer Openshot 1.4.2 sur Oneiric (11.10)

Bonjour,  smile
Avec 12.04 ça ne fonctionne pô sad Il propose de désinstaller un max de paquet, j'utilise aptitude)
Est-ce que tu as une idée ? - Merci wink

Les NOUVEAUX paquets suivants vont être installés :
  gtk2-engines-pixbuf{a} libmlt4{a} openshot python-mlt3{a} 
0 paquets mis à jour, 4 nouvellement installés, 0 à enlever et 3 non mis à jour.
Il est nécessaire de télécharger 20,1 Mo d'archives. Après dépaquetage, 54,0 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 libmlt5 : Est en conflit avec: libmlt4 mais 0.7.6+git20120204-2 doit être installé.
ouverts : 69 ; fermés : 1169 ; reportés : 29 ; en conflit : 72                                                                                   oLes actions suivantes permettront de résoudre ces dépendances :

       Supprimer les paquets suivants :                                        
1)       bluez-alsa:i386                                                       
2)       glib-networking:i386                                                  
3)       gstreamer0.10-fluendo-mp3:i386                                        
4)       gstreamer0.10-plugins-base:i386                                       
5)       gstreamer0.10-plugins-good:i386                                       
6)       gstreamer0.10-x:i386                                                  
7)       gtk2-engines:i386                                                     
8)       gtk2-engines-murrine:i386                                             
9)       gtk2-engines-oxygen:i386                                              
10)      gtk2-engines-pixbuf:i386                                              
11)      gvfs:i386                                                             
12)      gvfs-libs:i386                                                        
13)      ia32-libs                                                             
14)      ia32-libs-multiarch:i386                                              
15)      ibus-gtk:i386                                                         
16)      libaa1:i386                                                           
17)      libacl1:i386                                                          
18)      libao4:i386                                                           
19)      libasn1-8-heimdal:i386                                                
20)      libasound2:i386                                                       
21)      libasound2-plugins:i386                                               
22)      libasyncns0:i386                                                      
23)      libatk1.0-0:i386                                                      
24)      libattr1:i386                                                         
25)      libaudio2:i386                                                        
26)      libaudiofile1:i386                                                    
27)      libavahi-client3:i386                                                 
28)      libavahi-common3:i386                                                 
29)      libavc1394-0:i386                                                     
30)      libbz2-1.0:i386                                                       
31)      libc6:i386                                                            
32)      libcaca0:i386                                                         
33)      libcairo-gobject2:i386                                                
34)      libcairo2:i386                                                        
35)      libcanberra-gtk-module:i386                                           
36)      libcanberra-gtk0:i386                                                 
37)      libcanberra0:i386                                                     
38)      libcap2:i386                                                          
39)      libcapi20-3:i386                                                      
40)      libcdparanoia0:i386                                                   
41)      libcomerr2:i386                                                       
42)      libcroco3:i386                                                        
43)      libcups2:i386                                                         
44)      libcupsimage2:i386                                                    
45)      libcurl3:i386                                                         
46)      libdatrie1:i386                                                       
47)      libdb5.1:i386                                                         
48)      libdbus-1-3:i386                                                      
49)      libdbus-glib-1-2:i386                                                 
50)      libdrm-intel1:i386                                                    
51)      libdrm-nouveau1a:i386                                                 
52)      libdrm-radeon1:i386                                                   
53)      libdrm2:i386                                                          
54)      libdv4:i386                                                           
55)      libelf1:i386                                                          
56)      libesd0:i386                                                          
57)      libexif12:i386                                                        
58)      libexpat1:i386                                                        
59)      libffi6:i386                                                          
60)      libflac8:i386                                                         
61)      libfontconfig1:i386                                                   
62)      libfreetype6:i386                                                     
63)      libgail-common:i386                                                   
64)      libgail18:i386                                                        
65)      libgcc1:i386                                                          
66)      libgconf-2-4:i386                                                     
67)      libgcrypt11:i386                                                      
68)      libgd2-xpm:i386                                                       
69)      libgdbm3:i386                                                         
70)      libgdk-pixbuf2.0-0:i386                                               
71)      libgettextpo0:i386                                                    
72)      libgif4:i386                                                          
73)      libgl1-mesa-dri:i386                                                  
74)      libgl1-mesa-glx:i386                                                  
75)      libglapi-mesa:i386                                                    
76)      libglib2.0-0:i386                                                     
77)      libglu1-mesa:i386                                                     
78)      libgnome-keyring0:i386                                                
79)      libgnutls26:i386                                                      
80)      libgomp1:i386                                                         
81)      libgpg-error0:i386                                                    
82)      libgphoto2-2:i386                                                     
83)      libgphoto2-port0:i386                                                 
84)      libgpm2:i386                                                          
85)      libgssapi-krb5-2:i386                                                 
86)      libgssapi3-heimdal:i386                                               
87)      libgstreamer-plugins-base0.10-0:i386                                  
88)      libgstreamer0.10-0:i386                                               
89)      libgtk2.0-0:i386                                                      
90)      libgudev-1.0-0:i386                                                   
91)      libhcrypto4-heimdal:i386                                              
92)      libheimbase1-heimdal:i386                                             
93)      libheimntlm0-heimdal:i386                                             
94)      libhx509-5-heimdal:i386                                               
95)      libibus-1.0-0:i386                                                    
96)      libice6:i386                                                          
97)      libidn11:i386                                                         
98)      libiec61883-0:i386                                                    
99)      libieee1284-3:i386                                                    
100)     libjack-jackd2-0:i386                                                 
101)     libjasper1:i386                                                       
102)     libjpeg-turbo8:i386                                                   
103)     libjpeg8:i386                                                         
104)     libjson0:i386                                                         
105)     libk5crypto3:i386                                                     
106)     libkeyutils1:i386                                                     
107)     libkrb5-26-heimdal:i386                                               
108)     libkrb5-3:i386                                                        
109)     libkrb5support0:i386                                                  
110)     liblcms1:i386                                                         
111)     libldap-2.4-2:i386                                                    
112)     libllvm3.0:i386                                                       
113)     libltdl7:i386                                                         
114)     libmad0:i386                                                          
115)     libmikmod2:i386                                                       
116)     libmng1:i386                                                          
117)     libmpg123-0:i386                                                      
118)     libmysqlclient18:i386                                                 
119)     libncurses5:i386                                                      
120)     libncursesw5:i386                                                     
121)     libnspr4:i386                                                         
122)     libnss3:i386                                                          
123)     libodbc1:i386                                                         
124)     libogg0:i386                                                          
125)     liboil0.3:i386                                                        
126)     libopenal1:i386                                                       
127)     liborc-0.4-0:i386                                                     
128)     libp11-kit0:i386                                                      
129)     libpango1.0-0:i386                                                    
130)     libpciaccess0:i386                                                    
131)     libpcre3:i386                                                         
132)     libpixman-1-0:i386                                                    
133)     libpng12-0:i386                                                       
134)     libproxy1:i386                                                        
135)     libpulse-mainloop-glib0:i386                                          
136)     libpulse0:i386                                                        
137)     libpulsedsp:i386                                                      
138)     libqt4-dbus:i386                                                      
139)     libqt4-declarative:i386                                               
140)     libqt4-designer:i386                                                  
141)     libqt4-network:i386                                                   
142)     libqt4-opengl:i386                                                    
143)     libqt4-qt3support:i386                                                
144)     libqt4-script:i386                                                    
145)     libqt4-scripttools:i386                                               
146)     libqt4-sql:i386                                                       
147)     libqt4-sql-mysql:i386                                                 
148)     libqt4-svg:i386                                                       
149)     libqt4-test:i386                                                      
150)     libqt4-xml:i386                                                       
151)     libqt4-xmlpatterns:i386                                               
152)     libqtcore4:i386                                                       
153)     libqtgui4:i386                                                        
154)     libqtwebkit4:i386                                                     
155)     libraw1394-11:i386                                                    
156)     libroken18-heimdal:i386                                               
157)     librsvg2-2:i386                                                       
158)     librsvg2-common:i386                                                  
159)     librtmp0:i386                                                         
160)     libsamplerate0:i386                                                   
161)     libsane:i386                                                          
162)     libsasl2-2:i386                                                       
163)     libsasl2-modules:i386                                                 
164)     libsdl-image1.2:i386                                                  
165)     libsdl-mixer1.2:i386                                                  
166)     libsdl-net1.2:i386                                                    
167)     libsdl-ttf2.0-0:i386                                                  
168)     libsdl1.2debian:i386                                                  
169)     libselinux1:i386                                                      
170)     libshout3:i386                                                        
171)     libslang2:i386                                                        
172)     libsm6:i386                                                           
173)     libsndfile1:i386                                                      
174)     libsoup-gnome2.4-1:i386                                               
175)     libsoup2.4-1:i386                                                     
176)     libspeex1:i386                                                        
177)     libspeexdsp1:i386                                                     
178)     libsqlite3-0:i386                                                     
179)     libssl0.9.8:i386                                                      
180)     libssl1.0.0:i386                                                      
181)     libstdc++5:i386                                                       
182)     libstdc++6:i386                                                       
183)     libtag1-vanilla:i386                                                  
184)     libtag1c2a:i386                                                       
185)     libtasn1-3:i386                                                       
186)     libtdb1:i386                                                          
187)     libthai0:i386                                                         
188)     libtheora0:i386                                                       
189)     libtiff4:i386                                                         
190)     libtinfo5:i386                                                        
191)     libudev0:i386                                                         
192)     libunistring0:i386                                                    
193)     libusb-0.1-4:i386                                                     
194)     libuuid1:i386                                                         
195)     libv4l-0:i386                                                         
196)     libv4lconvert0:i386                                                   
197)     libvisual-0.4-0:i386                                                  
198)     libvisual-0.4-plugins:i386                                            
199)     libvorbis0a:i386                                                      
200)     libvorbisenc2:i386                                                    
201)     libvorbisfile3:i386                                                   
202)     libwavpack1:i386                                                      
203)     libwind0-heimdal:i386                                                 
204)     libwrap0:i386                                                         
205)     libx11-6:i386                                                         
206)     libx11-xcb1:i386                                                      
207)     libxau6:i386                                                          
208)     libxaw7:i386                                                          
209)     libxcb-glx0:i386                                                      
210)     libxcb-render0:i386                                                   
211)     libxcb-shm0:i386                                                      
212)     libxcb1:i386                                                          
213)     libxcomposite1:i386                                                   
214)     libxcursor1:i386                                                      
215)     libxdamage1:i386                                                      
216)     libxdmcp6:i386                                                        
217)     libxext6:i386                                                         
218)     libxfixes3:i386                                                       
219)     libxft2:i386                                                          
220)     libxi6:i386                                                           
221)     libxinerama1:i386                                                     
222)     libxml2:i386                                                          
223)     libxmu6:i386                                                          
224)     libxp6:i386                                                           
225)     libxpm4:i386                                                          
226)     libxrandr2:i386                                                       
227)     libxrender1:i386                                                      
228)     libxslt1.1:i386                                                       
229)     libxss1:i386                                                          
230)     libxt6:i386                                                           
231)     libxtst6:i386                                                         
232)     libxv1:i386                                                           
233)     libxxf86vm1:i386                                                      
234)     odbcinst1debian2:i386                                                 
235)     wine                                                                  
236)     wine-gecko1.4:i386                                                    
237)     wine1.4                                                               
238)     wine1.4-amd64                                                         
239)     wine1.4-common                                                        
240)     wine1.4-i386:i386                                                     
241)     xaw3dg:i386                                                           
242)     zlib1g:i386                                                           

       Conserver les paquets suivants dans leur version actuelle :             
243)     libmlt4 [Non installé]                                                
244)     openshot [Non installé]                                               
245)     python-mlt3 [Non installé]                                            

       Laisser les dépendances suivantes non satisfaites :                     
246)     winetricks recommande wine1.4 | wine | cxoffice5 | cxgames5           
247)     wine-gecko1.4 recommande wine1.4-amd64                                
248)     libcanberra-gtk0:i386 recommande libcanberra-gtk-module:i386          
249)     libgphoto2-2:i386 recommande udev:i386 (>= 0.175)                     
250)     libgphoto2-2:i386 recommande libgphoto2-l10n:i386 (>= 2.4.13-1ubuntu1)
251)     libncurses5:i386 recommande libgpm2:i386                              
252)     libncursesw5:i386 recommande libgpm2:i386                             
253)     libslang2:i386 recommande libpng12-0:i386                             
254)     libvisual-0.4-0:i386 recommande libvisual-0.4-plugins:i386            
255)     wine1.4-i386:i386 recommande libfontconfig1:i386 | libfontconfig:i386 
256)     wine1.4-i386:i386 recommande libsane:i386                             
257)     wine-gecko1.4:i386 recommande wine1.4-i386:i386                       
258)     libqt4-dbus:i386 recommande qdbus:i386 (= 4:4.8.1-0ubuntu4.1)         
259)     libqtgui4:i386 recommande libcups2:i386                               


Accepter cette solution ? [Y/n/q/?] 

Dernière modification par Pacifick_FR42 (Le 09/05/2012, à 08:03)


Venez M'écouter !!! : http://www.pacifick-dream.fr/ - N'hésitez pas à me donner votre avis !!! -
Projet OpenSource : radioactif.pcexpert-loire.fr - Autre site : http://www.lheureducrime.com

Hors ligne

#3 Le 15/05/2012, à 10:35

Pacifick_FR42

Re : Comment installer Openshot 1.4.2 sur Oneiric (11.10)

up ? (idem sous 11.10)...


Venez M'écouter !!! : http://www.pacifick-dream.fr/ - N'hésitez pas à me donner votre avis !!! -
Projet OpenSource : radioactif.pcexpert-loire.fr - Autre site : http://www.lheureducrime.com

Hors ligne

#4 Le 15/05/2012, à 13:22

PDemong

Re : Comment installer Openshot 1.4.2 sur Oneiric (11.10)

Bonjour,

honnêtement je ne sais pas quoi te conseiller. Tu as probablement une installation sur mesure qui explique tout ce nettoyage de paquets. Je te propose d'aller exposer ton questionnement directement sur la liste de lprod, où justement je me suis fait aider pour établir la procédure de ce post.

Pour t'y inscrire, voici la procédure : http://www.lprod.org/wiki/doku.php/aide_liste. N'hésite pas à y aller, c'est vraiment une liste intéressante.

Hors ligne

#5 Le 16/05/2012, à 09:01

Pacifick_FR42

Re : Comment installer Openshot 1.4.2 sur Oneiric (11.10)

Merci pour l'info wink


Venez M'écouter !!! : http://www.pacifick-dream.fr/ - N'hésitez pas à me donner votre avis !!! -
Projet OpenSource : radioactif.pcexpert-loire.fr - Autre site : http://www.lheureducrime.com

Hors ligne

#6 Le 06/06/2012, à 07:18

vince06fr

Re : Comment installer Openshot 1.4.2 sur Oneiric (11.10)

Malheureusement ça ne fonctionne plus sous precise, la version de libmlt des dépôts sunab est passée en version5, ce qui rend impossible l'installation de python-mlt3 et donc d'openshot
Solution : purger le dépôt sunab , pour ceux, qui comme moi n'utilisent openshot que pour l’éditeur de titre et kdenlive pour le montage, celà oblige a downgrader kdenlive sad

Enfin ça semble fixer pour la version instable d'openshot :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=668793

Dernière modification par vince06fr (Le 06/06/2012, à 07:24)

Hors ligne

#7 Le 06/06/2012, à 12:14

Pacifick_FR42

Re : Comment installer Openshot 1.4.2 sur Oneiric (11.10)

Bonne nouvelle ! smile


Venez M'écouter !!! : http://www.pacifick-dream.fr/ - N'hésitez pas à me donner votre avis !!! -
Projet OpenSource : radioactif.pcexpert-loire.fr - Autre site : http://www.lheureducrime.com

Hors ligne

#8 Le 06/06/2012, à 19:17

vince06fr

Re : Comment installer Openshot 1.4.2 sur Oneiric (11.10)

Donc, pour installer la dernière version d'openshot en conservant les dépôt sunab pour la dernière version de kdenlive il faut utiliser les dépôts daily d'openshot (attention dépôts instable, donc si vous tenez à la stabilité de votre systeme vous pouvez les désactiver après installation)

$ sudo add-apt-repository ppa:openshot.developers/daily
$ sudo apt-get update
$ sudo apt-get install openshot

Dernière modification par vince06fr (Le 06/06/2012, à 19:18)

Hors ligne

#9 Le 09/07/2012, à 20:06

Kermit

Re : Comment installer Openshot 1.4.2 sur Oneiric (11.10)

@vince06fr
Voici plusieurs jours que j'essayais d'installer openshot sur la 12.04 et que ces problèmes de dépendances me pourrissaient la vie.
Merci pour tes conseils.


Desktop: Linux Mint17/64 bits
Intel core i7 3770k - 3.4Ghz - 8Go ram
Cm Asrock H61M-VG4 / Cg Nvidia GT640 2Go
Portable Amilo 7400M avec wheezy 7.6 32 bits

Hors ligne

#10 Le 04/10/2012, à 12:21

8140david

Re : Comment installer Openshot 1.4.2 sur Oneiric (11.10)

vince06fr a écrit :

Donc, pour installer la dernière version d'openshot en conservant les dépôt sunab pour la dernière version de kdenlive il faut utiliser les dépôts daily d'openshot (attention dépôts instable, donc si vous tenez à la stabilité de votre systeme vous pouvez les désactiver après installation)

$ sudo add-apt-repository ppa:openshot.developers/daily
$ sudo apt-get update
$ sudo apt-get install openshot

Merci mais ca ne marche pas chez moi (Ubuntu 12.04, avec le dernier kdenlive installé):
"Les paquets suivants contiennent des dépendances non satisfaites :
openshot : Dépend: python-mlt5 mais il n'est pas installable ou
                     python-mlt3 mais ne sera pas installé ou
                     python-mlt2 mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état »."
Une idée pour résoudre ce problème ?

Hors ligne

#11 Le 26/04/2013, à 13:25

wilfrid_69

Re : Comment installer Openshot 1.4.2 sur Oneiric (11.10)

Bonjour à tous.

J'ai installé Linux Mint 13 sur ma dernière machine et impossible de lire les fichiers vidéos sur OpenShot.

Je faisais mes montages sans problème avec OpenShot sur la machine précédente avec la même distribution.

Openshot démarre sans erreur mais les fichiers asf, avi, mp4 ... sortent en grisé et ça plante au bout de quelques secondes.

Quelqu'un à une suggestion ?

Hors ligne

#12 Le 27/04/2013, à 12:25

PDemong

Re : Comment installer Openshot 1.4.2 sur Oneiric (11.10)

Bonjour wilfrid_69,
je ne pense pas que ce fil de discussion soit adapté pour poser ta question. Tu devrais selon moi :
- ouvrir un nouveau fil de discussion
- probablement l'ouvrir sur un forum orienté Linux Mint plutôt que celui-ci qui est plus Ubuntu
- t'adresser à la mailing-list d'Openshot. Moi j'utilise celle de LPROD, c'est en français, on y trouve des passionnés de montage vidéo en libre, et des gens connaissant bien Openshot. Pour t'y inscrire, voici la page expliquant comment faire : http://www.lprod.org/wiki/doku.php/aide_liste

Bonne chance,
Patrick

Hors ligne

#13 Le 03/09/2014, à 03:47

kykyou

Re : Comment installer Openshot 1.4.2 sur Oneiric (11.10)

merci vince06fr
je suis sous voyager 12.04 - 64 bit  .....
ta manip fonctionne a merveille ..
pour le titre avec open shot et le montage avec kdenlive ...

udo add-apt-repository ppa:openshot.developers/daily
sudo apt-get update
sudo apt-get install openshot

PS : d ailleurs au passage tout les rendu sont disponible aec open shot !! flv H264 xvid etc etc
alors qu avec kdenlive ca veux pas !! ggggrrrrrr

Dernière modification par kykyou (Le 03/09/2014, à 03:48)

Hors ligne

Haut de page ↑