Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 04/07/2012, à 15:43

jemini

Erreur Grub : fd0 read error, no such disk

Bonjour !

J'ai un serveur installé sous Ubuntu 10.04 qui tourne depuis pas mal de temps.

Le boot est installé en Raid 1 (sda1 et sda2).
la racine et le home sont installées en Raid 5 + LVM2 (sda3, sdb3, sdc3)

Le tout fonctionné correctement jusque là.

par inadvertance, j'ai supprimer mon user du sudoers en le retirant du groupe admin.
Du coup, j'ai bootté sur un liveCD Ubuntu et ne sachant plus exactement comment était organisé les raid et lvm, j'ai utiliser mdadm :

J'ai réassemblé le raid 1 contenant sda1 et sda2 (en fait la partition boot) et je l'ai monté (md1)
Puis j'ai réassemblé le raid 5 contenant sda3, sdb3 et sdc3 (md2)
J'ai utiliser vgscan, vgchange, etc pour pouvoir monter mon lvm sur md2.
Et ainsi, j'ai pu redonner les droits root à mon user.

Le problème, c'est que maintenant, au redémarrage, j'ai le message d'erreur grub suivant :

fd0 read error
no such disk

puis je tombe sur la ligne de commande de grub...

Je ne comprends pas comment, ayant simplement assemblé le raid contenant le boot, j'ai pu «casser» Grub ?!

Merci pour votre aide !

Hors ligne

#2 Le 04/07/2012, à 16:45

abelthorne

Re : Erreur Grub : fd0 read error, no such disk

Si je ne m'abuse, fd0 correspond au lecteur de disquettes. Tu ne l'aurais pas réactivé dans le BIOS par erreur (ou débranché une nappe si tu en as un) ?

Hors ligne

#3 Le 04/07/2012, à 17:00

jemini

Re : Erreur Grub : fd0 read error, no such disk

Merci abelthorne !

Oui, c'est bien ça... J'étais tellement absorbé par la récupération du serveur que je n'ai même pas calculé que fd0 désigne le lecteur de disquette (lecteur de quoi ?) lol
En fait de temps en temps au boot, grub cherche à booter sur fd0 pourtant il me semble que le lecteur de disquette est bien désactiver dans le bios... Dès que je peux (dès que mes users rentrent chez eux), je reboot et je vais faire un tour dans le bios pour vérifier.

Un grand merci !

Hors ligne

Haut de page ↑