Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 20/01/2012, à 16:01

radix

[Résolu] Changement de disposition clavier

Bonjour,

je viens de passer à Lubuntu dont je suis assez content dans l'ensemble,
mais je suis assez embêté car j'utilise actuellement un clavier double français/arabe, et je ne trouve pas de moyen de changer rapidement la disposition du clavier...
Xkeymap ne permet pas d'installer deux claviers à la fois, et le petit indicateur de clavier du panel ne permet pas d'agir sur la disposition utilisée. Pas non plus de petit raccourci clavier configurable et bien pratique comme sous gnome... :-(
Pour le moment, j'en suis réduit à ouvrir un terminal et lancer la commande

setxkbmap ar

pour passer au clavier arabe, et

setxkbmap fr

pour repasser en français.
Quelqu'un/e a-t-il/elle déjà trouvé une solution ?
Ou voyez-vous une petite astuce pour contourner le problème ?

Merci d'avance

Dernière modification par radix (Le 03/02/2012, à 11:47)

Hors ligne

#2 Le 03/02/2012, à 09:24

Uncle_Franek

Re : [Résolu] Changement de disposition clavier

J'ai justement passé des heures sur les forums hier pour trouver la solution. Moi, j'alterne régulièrement avec un raccourci les claviers en français/polonais/hongrois/américain sous Ubuntu, et depuis que j'ai fait passé mon vieux PC sous Lubuntu, plus possible... La commande magique, celle que j'ai trouvé sur tous les forums, c'est ça (j'ai mis pour français et hongrois, je te laisse te débrouiller pour l'arabe) :

setxkbmap -layout "fr,hu" -option "grp:alt_shift_toggle"

Mais malheureusement ça ne tient pas quand tu redémarres. La solution, selon beaucoup de forums, c'était de l'ajouter à la fin du fichier /.bashrc

sudo nano /home/user/.bashrc

Ça peut fonctionner pour toi, mais pour moi ça ne fonctionnait toujours pas. Alors j'ai enfin trouvé quelque part (mais je n'arrive pas à retrouver où) une solution qui a marché pour moi :

sudo leafpad /etc/default/keyboard

et à l'intérieur de ce fichier, remplacer :

XKBMODEL="pc105"
XKBLAYOUT="fr"
XKBVARIANT=","
XKBOPTIONS=""

par :

XKBMODEL="pc105"
XKBLAYOUT="fr,hu"
XKBVARIANT=","
XKBOPTIONS="grp:alt_shift_toggle"

Et là du coup ça devrait marcher, tu peux alterner trankilou avec les touches alt + shift. NB : Je n'ai pas essayé avec plusieurs clavier.

Il peut être utile aussi de rajouter le plugin "Keyboard Layout Switcher" du panel.

PS : c'est la première fois que je réponds sur ce forum ! J'aurais jamais pensé que ça m'arriverait un jour wink

Hors ligne

#3 Le 03/02/2012, à 11:46

radix

Re : [Résolu] Changement de disposition clavier

Merci infiniment Uncle_Franek !
Je n'ai fait que ta dernière manip, celle qui modifie /etc/default/keyboard
puis redémarré mon système, et ça marche du tonnerre !
Je confirme que, associé avec le "Keyboard Layout Switcher" du panel, c'est excellent. Moi je l'avais déjà, mais il ne me servait à rien puisque je n'arrivais pas à switcher !

C'est mon principal problème qui saute. Pour moi, Lubuntu est définitivement adopté !

Dernière modification par radix (Le 03/02/2012, à 11:48)

Hors ligne

#4 Le 11/04/2012, à 15:52

Faris

Re : [Résolu] Changement de disposition clavier

Merci Uncle_Franek ça m'a beaucoup aidé

Hors ligne

#5 Le 28/04/2012, à 15:05

Toupie1923

Re : [Résolu] Changement de disposition clavier

merci aussi!

Hors ligne

#6 Le 07/07/2012, à 13:36

Uncle_Franek

Re : [Résolu] Changement de disposition clavier

Une petite précision. J'ai remarqué qu'avec la solution décrite plus haut par mes soins, le clavier habituel français sous Ubuntu, à savoir, "français alternatif" passe à autre chose (je ne sais pas quoi exactement). Le problème, c'est que moi je l'aime bien, le clavier alternatif. Il permet notamment de faire les jolies ligatures œ et le æ (en utilisant alt gr + o et a), et j'aime bien son emplacement des guillemets français (alt gr+ w et x). Bref. Si vous voulez garder ce clavier en particulier, il faut remplacer les lignes décrites plus haut par :

XKBMODEL="pc105"
XKBLAYOUT="fr,hu"
XKBVARIANT="oss,"
XKBOPTIONS="grp:alt_shift_toggle"

Pour trouver le clavier que vous rechercher (à indiquer dans XKBLAYOUT, après "fr,.....", précédé d'une virgule) :
http://en.wikipedia.org/wiki/List_of_ISO_639-1_codes
Regarder dans la colonne 639-1.

Hors ligne

#7 Le 08/07/2012, à 22:08

thib1984

Re : [Résolu] Changement de disposition clavier

Ayant rencontré le même problème cette semaine, j'ai adopté une autre solution un peu plus artisanale. big_smile

1-creer deux fichier .sh du type suivant, un pour chaque disposition de clavier

#!/bin/bash
setxkbmap fr
#!/bin/bash
setxkbmap ru

2-les rendre executables

3-dans /usr/share/applications/, rajouter deux entrées pointant vers les scripts, en adaptant évidemment les chemins vers les icones, et les exécutables. Ce sont des fichiers *.desktop

[Desktop Entry]
Encoding=UTF-8
Name=ModeFr
Comment=Clavier français
Icon=/home/thib1984/Scripts/modefr.png
Exec=/home/thib1984/Scripts/modefr.sh
Type=Application
Categories=GNOME;GTK;System;

4-barre de lancement d'applications (celle de droite avec les bouton power), j'ai rajouté les raccourcis vers les lanceurs que je venais de créer (menu outils et système pour mon exemple). Ca donne quelque chose comme ca au final.

Clavier double

Un clic sur le drapeau biélorusse, je bascule en clavier russe, un clic sur le drapeau français, je repasse en azerty.

Hors ligne

#8 Le 20/10/2012, à 18:22

nour_al_imen

Re : [Résolu] Changement de disposition clavier

Bonjour,

Merci ça marche pr moi aussi
Mais comment je peux remplacer le raccourci alt+Schift par le bouton "windows démarrer"
Car mon bouton "alt" ne marche pas trèx bien et le bouton windows n'est utile à rien sur Ubuntu


BETTAIEB Imen  -- Ingènieur Informatique et Trainer Accréditée en développement de personnalité
Membre du LoCo Team Ubuntu-Tn (communauté approuvée des utilisateurs de Ubuntu en Tunisie)

Hors ligne

#9 Le 28/01/2013, à 15:05

Uncle_Franek

Re : [Résolu] Changement de disposition clavier

La réponse suivante devrait répondre à nour_al_imen.

Pour changer la disposition du clavier rapidement, je renvoie à mon explication précédente. Seulement, on n'est tributaire des lignes données dans ces descriptions pour les réglages. Ainsi, le problème de nour_al_imen est qu'il veut utiliser la touche super (windows), alors que moi je préfèrerais utiliser les deux majuscules enfoncées à la fois.

Hé bien pour connaître tous les paramètres à indiquer respectivement dans "model", "layout", "variant" et "option", taper dans un terminal :

less /usr/share/X11/xkb/rules/base.lst

et trouvez ce qui vous intéresse dans ce long fichier.
(NB : flèche haut et bas pour naviguer, "q" pour revenir au terminal).

Ainsi, pour nour_al_imen (qui veut alterner grâce à la touche super aka windows), la configuration pour alterner (ici entre français et hongrois) devrait ressembler à ça :

XKBMODEL="pc105"
XKBLAYOUT="fr,hu"
XKBVARIANT="oss,"
XKBOPTIONS="grp:lwin_switch"

Et pour moi (qui veut alterner grâce aux deux shift ensemble) :

XKBMODEL="pc105"
XKBLAYOUT="fr,hu"
XKBVARIANT="oss,"
XKBOPTIONS="grp:shifts_toggle"

Hors ligne

Haut de page ↑