Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 20/08/2005, à 14:08

Link

Re : [Info]Drivers ATi 8.16.20

effectivement il n'utilise pas la bonne version benohite !


(II) fglrx(0): Kernel Module Version Information:
(II) fglrx(0):     Name: fglrx
(II) fglrx(0):     Version: 8.8.25
(II) fglrx(0):     Date: Jan 14 2005
(II) fglrx(0):     Desc: ATI FireGL DRM kernel module
(WW) fglrx(0): Kernel Module version does *not* match driver.
(EE) fglrx(0): incompatible kernel module detected - HW accelerated OpenGL will not work


mais ta commande ne semble pas marcher pour moi, mon kernel est

****@****:~$ uname -r
2.6.10-5-k7


etan donner que je n'etais pas certain du kernel que tu parlais, j'ai fait avec les deux. celui de ma carte graphique

****@****:~$ sudo mv /lib/modules/8.8.25 /kernel/drivers/video/fglrx.ko $HOME
mv: cannot stat `/lib/modules/8.8.25': No such file or directory
mv: cannot stat `/kernel/drivers/video/fglrx.ko': No such file or directory


et le vrai kernel:

****@****:~$ sudo mv /lib/modules/2.6.10-5-k7 /kernel/drivers/video/fglrx.ko $HOME
mv: cannot stat `/lib/modules/2.6.10-5-k7': No such file or directory
mv: cannot stat `/kernel/drivers/video/fglrx.ko': No such file or directory


ca ne semble pas fonctionner ou est-ce que je fait mal ta commande??


p.s.  j'ai verifier et dans /lib/modules  tout ce que j'ai est   fglrx  si ca peut aider.


In a world without walls and fences, who needs Windows and Gates?

Hors ligne

#27 Le 20/08/2005, à 14:33

Tarlak

Re : [Info]Drivers ATi 8.16.20

Apres avoir installer les drivers je me suis retrouver avec un fps a 250 aie ouille, je fais donc ceci ;
NE pas oublier tout d'abord de verifier que les header du kerben sont installés sinon ca ne marchera pas pour moi c'était  kernel-headers-2.6.10-5-686

Ensuite j'ai fait cela (merci benohite)

benohite a écrit :

Pour résoudre le problème, aprés avoir installer:
-> aller dans le répertoire /lib/modules/fglrx/build_mod
-> lancer le script make.sh: sudo .make.sh
-> remonter d'un répertoire (cd ..)
-> lancer le script make_install.sh: sudo ./make_install.sh
-> sudo modprobe fglrx
-> relancer le serveur X via Ctrl+Alt+Backspace (juste au dessu d'entrer)

je fais un glxgears et j'obtiens :

22922 frames in 5.0 seconds = 4584.400 FPS
23791 frames in 5.0 seconds = 4758.200 FPS
23768 frames in 5.0 seconds = 4753.600 FPS
23764 frames in 5.0 seconds = 4752.800 FPS
23787 frames in 5.0 seconds = 4757.400 FPS

ensuite un petit fgl_glxgears

4029 frames in 5.0 seconds = 805.800 FPS
4052 frames in 5.0 seconds = 810.400 FPS
4041 frames in 5.0 seconds = 808.200 FPS
4065 frames in 5.0 seconds = 813.000 FPS

Youpieeee j'ai un super gain de perfomance avant cela j'avais ceci :

glxgears

15393 frames in 5.0 seconds = 3078.600 FPS
17470 frames in 5.0 seconds = 3494.000 FPS
17509 frames in 5.0 seconds = 3501.800 FPS
17509 frames in 5.0 seconds = 3501.800 FPS
17510 frames in 5.0 seconds = 3502.000 FPS

fgl_glxgears

3353 frames in 5.0 seconds = 670.600 FPS
3538 frames in 5.0 seconds = 707.600 FPS
3538 frames in 5.0 seconds = 707.600 FPS
3539 frames in 5.0 seconds = 707.800 FPS
3538 frames in 5.0 seconds = 707.600 FPS

Soit si je ne me plante pas un gain d'environ 30%

Encore merci à tous pour vos réaction rapide qui m'ont permit de regler mon petit soucis rapidement

PS : Ma carte graphique est une Radeon 9800 XT 256 Mo

Dernière modification par Tarlak (Le 20/08/2005, à 14:35)

Hors ligne

#28 Le 20/08/2005, à 17:46

Tixu

Re : [Info]Drivers ATi 8.16.20

ben moi c'est le bordel . ecran noir, l'ordi planté , obligé d'appuyer sur le bouton reset. Et du coup obligé d'utiliser le driver ati pour avoir un affichage . Si quelqu'un a eu les memes problèmes ...
au moment du make j'ai cette erreur
could not find /lib/modules/fglrx/build_mod/2.6.x/.libfglrx_ip.a.GCC3.cmd for /lib/modules/fglrx/build_mod/2.6.x/libfglrx_ip.a.GCC3

Dernière modification par Tixu (Le 20/08/2005, à 17:56)

Hors ligne

#29 Le 20/08/2005, à 18:17

Tarlak

Re : [Info]Drivers ATi 8.16.20

Il faut que tu rajoute GCC 3 si il n'est pas installé avec une petite recherche dans synaptic ca devrait aller

Dernière modification par Tarlak (Le 20/08/2005, à 18:23)

Hors ligne

#30 Le 20/08/2005, à 23:13

Tixu

Re : [Info]Drivers ATi 8.16.20

déjà fait...malheureusement c'st poa la solution...merci quand même smile

Hors ligne

#31 Le 20/08/2005, à 23:17

Tarlak

Re : [Info]Drivers ATi 8.16.20

Et le GCC tout simple il est installé aussi ? de plus as tu les header en rapport avec ton kernel ??

Hors ligne

#32 Le 20/08/2005, à 23:32

Link

Re : [Info]Drivers ATi 8.16.20

est-ce que quelqu'un a une idee pour mon prebleme s.v.p. ?

poste 26


In a world without walls and fences, who needs Windows and Gates?

Hors ligne

#33 Le 21/08/2005, à 10:18

Tarlak

Re : [Info]Drivers ATi 8.16.20

Link a écrit :

est-ce que quelqu'un a une idee pour mon prebleme s.v.p. ?

poste 26

As tu essayer avec la methode de benohite ?? pour moi ca à parfaitement marché je dois dire

Hors ligne

#34 Le 21/08/2005, à 13:04

benohite

Re : [Info]Drivers ATi 8.16.20

@Link: essayes d'installer les paquets linux-headers et linux-restricted-modules, retentes ensuite la compilation du module (cf l'edit de mon 1er post).

@Tchaka: bonne nouvelle, on n'aura pas cherché en vain smile, sinon pour mplayer je ne sais pas d'autant que je ne l'utilise pas, juste une petite suggestion. Modifies ton fichier /etc/X11.xorg.conf comme suit:

Section "Device"
	Identifier	"ATI Technologies, Inc. Radeon 9600 SE (RV350 AQ)"
	Driver		"fglrx"
	Option "UseFastTLS"                 "2"
	BusID		"PCI:1:0:0"
	screen 		0
	VideoRam	128000

Videram: valeur de la mémoire sur ta carte video (ici 128Mo pour ma carte video).
Enuite redémarres le serveur graphique.

Ben

Dernière modification par benohite (Le 21/08/2005, à 13:05)


You are legally entitled and encouraged to copy, share and redistribute this CD for yourself and your friends. Share the spirit of Ubuntu !

Hors ligne

#35 Le 21/08/2005, à 14:45

Romu

Re : [Info]Drivers ATi 8.16.20

@Link : il se peut simplement (c'est ce qui m'est arrivé) que le fglrx.ko ne soit pas copié dans le /kernel/drivers/video.

Pour ma part ça fonctionne sauf que pour mon écran 1600*1050 je suis obligé de laisser les "modes" du xorg.conf à vide sinon il n'exploite pas l'écran...étrange


A tout problème complexe, il existe une solution simple : la mauvaise

Hors ligne

#36 Le 21/08/2005, à 15:25

Tchaka

Re : [Info]Drivers ATi 8.16.20

Slt Benohite,

J'ai effectué ce que tu m'as indiqué plus haut et j'avoue que je suis vraiment bluffé de voir que maintenant j'ai mplayer qui marche niquel. Donc c'est une fois de plus que je te remercier pour ton aide (ca va devenir une habitude tongue), je me demande d'ailleurs comment tu fais pour savoir autant de chose ^^

Donc voila normalement j'ai tout qui fonctionne bien normalement. J'ai testé quake3 et maintenant je n'ai pu de probleme de resolution d'ecran, donc c'est chouette.

@Link -> dsl que ton probleme ne soit pas encore résolu, si tu veux des infos sur certains de mes fichiers de conf, n'hesite pas wink

Bye


EDIT:  Je viens de faire un test de la sortie TV, et j'ai un probleme avec la qualité de l'image. Elle est affiché sur l'ecran de la tv mais il y a des bandes verticales de 2cm de large sur toutes la surface de l'ecran, et l'image a aussi tendance à "sautiller", les couleurs ne sont pas belles (trop pale).

Dernière modification par Tchaka (Le 21/08/2005, à 15:53)


skaara@jabber.anywise.com

Hors ligne

#37 Le 21/08/2005, à 18:09

Link

Re : [Info]Drivers ATi 8.16.20

merci a tout ceux qui essai de m'aider, ces grandement apprecier mais je ne peux pas essayer maintenant tout ce que vous me dite car encore une fois, je vien de lire vos reponse au travail donc je vous en donnerais des nouvelle ce soir apres l'avoir essayer de chez moi. 

merci encore!


In a world without walls and fences, who needs Windows and Gates?

Hors ligne

#38 Le 22/08/2005, à 05:15

Link

Re : [Info]Drivers ATi 8.16.20

Je ne sais pas pourquoi, mais la je vien d'arriver chez moi et je n'ai plus d'interface graphique en demarrant Ubuntu, je suis obliger de le demmarer en safe mode ???  que faire le serveur x ne veut plus du tout demarrer ??


In a world without walls and fences, who needs Windows and Gates?

Hors ligne

#39 Le 22/08/2005, à 05:44

Link

Re : [Info]Drivers ATi 8.16.20

je crois que je vien de trouver l'erreur mais je ne sais pas comment la reparer:

lors du demarage, je voix l'erreur qu'il ne trouve pas mon kernel dans /lib/modules et je vien d'aller verifier et ces vrai, il n'apparait plus. Tout ce que je vois dans /lib/modules ces fglrx mais avant j'avait bien mon kernel qui apparaissait la et je ne sait pas pourquoi ces disparu et comment regler ce probleme ??

j'ai vraiment besoin d'aide s.v.p.


In a world without walls and fences, who needs Windows and Gates?

Hors ligne

#40 Le 22/08/2005, à 08:13

benohite

Re : [Info]Drivers ATi 8.16.20

@Tchaka: je ne sais pas autant de choses que tu te l'imagines, pour le coup c'est un simple coup de bol smile.
En ce qui concerne ta sortie TV je ne peux pas t'aider, je ne sais pas la configurer mais en faisant une recherche sur le forum tu devrais trouver.

@Link: Un configuration ne tombe pas en panne comme ça sans raison, il faudrait nous dire ce que tu as modifier avant que ça t'arrive.
Sinon une solution de secours consiste à changer "fglrx" par "ati" dans ton fichier xorg.conf pour que le serveur graphique redémarre normalement.
As-tu installé les paquet linux-headers et linux-restricted-modules comme je te l'ai indiqué plus haut ?

Ben


You are legally entitled and encouraged to copy, share and redistribute this CD for yourself and your friends. Share the spirit of Ubuntu !

Hors ligne

#41 Le 22/08/2005, à 09:21

CHUCKYCHUCK

Re : [Info]Drivers ATi 8.16.20

salut ! je voulais être bien sur d'un point :
bnohite il faut bien suivre tes instructions après avoir installé les drivers ??
et comment les installe-t-on ?? ( installation personnalisée, générer un package ........ ) merci


Dual Boot Win 7 Pro + Lucid Lynx
Asus G60JX 16'' - Core i5 430M 2.26 Ghz - 4 Go Ram - Geforce GTS 360 M 1GB

Hors ligne

#42 Le 22/08/2005, à 09:36

Tarlak

Re : [Info]Drivers ATi 8.16.20

CHUCKYCHUCK a écrit :

salut ! je voulais être bien sur d'un point :
bnohite il faut bien suivre tes instructions après avoir installé les drivers ??
et comment les installe-t-on ?? ( installation personnalisée, générer un package ........ ) merci

Si tu telercharge le plus gros paquet (qui fait 51 mo) c'est un exectuable tu le lance (avec un sudo devant) et c'st bon ca install pas de soucis ensuite si apres ca ne marche pas (score minable au glxgears) la tu utilise la technique de benohite

Hors ligne

#43 Le 22/08/2005, à 10:25

CHUCKYCHUCK

Re : [Info]Drivers ATi 8.16.20

euh chez moi ca marche pas ........

j'avais déjà les drivers précédents ( 8.14 je crois ) d'installés via ka procédure de Kagou

j'ai installé le nouvo driver a l'aide du gros installeur ( 50 Mo ), en choisissant a chaque fois l'option la + facile lors des différentes étapes proposées par l'installateur
puis sans rebooter ( fallait ??? ) j'ai fait un glxgears ... bon j'ai honte de mon score ...
j'ai alors tenté de suivre la procédure de benohite, mais la 2ème ligne ne marche pas chez moi
sudo .make.sh   moi il me dit un truc du genre commande introuvable ....
par contre sudo ./make.sh marche, mais ya un messeage d'erreur qui dit qu'un truc est incomplet ....

j'ai alors rebooté, retenté tout ca, mais ca marche toujours pas ....  j'ai alors viré les 2 paquets fglrx, puis j'ai   "undo " les modifications faites aux fichiers de conf, modifs indiquées dans le tuto de kagou
et réinstallé le gros drivers, et ben ca marche toujours pas ............;;


lors de l'install vous choississez bien les options "rapides"  ( genre install automatique ) a chaque fois ??? vous avez eu besoin d'executer fglrxconfig ?
ya un moyen de revenir a un système "vierge" au niveau des drivers graphiques ????

merci beaucoup
P.S. sinon peut-être que ubuntu a déjà fabriqués ses propres .deb basés sur ces nouvos drivers ???

Dernière modification par CHUCKYCHUCK (Le 22/08/2005, à 12:07)


Dual Boot Win 7 Pro + Lucid Lynx
Asus G60JX 16'' - Core i5 430M 2.26 Ghz - 4 Go Ram - Geforce GTS 360 M 1GB

Hors ligne

#44 Le 22/08/2005, à 12:41

benohite

Re : [Info]Drivers ATi 8.16.20

sudo .make.sh   moi il me dit un truc du genre commande introuvable ....
par contre sudo ./make.sh marche, mais ya un messeage d'erreur qui dit qu'un truc est incomplet ....

Merci de l'avoir signalé, effectivement il faut bien taper ./make.sh et non .make.sh (oubli corrigé).
Si tu as une erreur post la, ça pourrait aider à résoudre ton problème.

lors de l'install vous choississez bien les options "rapides"  ( genre install automatique ) a chaque fois ???

oui rien de particulier à ce niveau

Ben


You are legally entitled and encouraged to copy, share and redistribute this CD for yourself and your friends. Share the spirit of Ubuntu !

Hors ligne

#45 Le 22/08/2005, à 13:28

Tarlak

Re : [Info]Drivers ATi 8.16.20

@CHUCKYCHUCK si tu nous donne ton message d'erreur ca sera plus facile, personnellement j'avais u un message d'erreur aussi je ne sais plus le quel mais j'ai rajouter les headers de mon kernel, plus le compilateur GCC et la tout nikel

Hors ligne

#46 Le 22/08/2005, à 14:07

Eric P.

Re : [Info]Drivers ATi 8.16.20

benohite a écrit :

Il semble que ce soit toujours le cas, pas d'accélération 3d quand composite est activé

Aïe, dommage sad
Espérons que ce soit prévu quand même par ATI. Faut que leur écrive un petit mail pour savoir si c'est dans leur roadmap...

Eric

Hors ligne

#47 Le 22/08/2005, à 14:39

Link

Re : [Info]Drivers ATi 8.16.20

ok ces bon, j'ai finalement reussi a retablir la situation. Je ne sais vraiment pas pourquoi, mais le repertoir de mon kernel etais dans mon repertoir personnel alors je l'ai seulement deplacer dans /lib/modules et tout est revenu normale ou presque.

je dit ou presque parceque j'ai toujours le probleme de pilote de carte graphique !!

je vais essayer de de-installer ceux que j'ai maintenant et de le re-installer a partir de 0 en suivant ton tuto  benohite


In a world without walls and fences, who needs Windows and Gates?

Hors ligne

#48 Le 22/08/2005, à 15:09

CHUCKYCHUCK

Re : [Info]Drivers ATi 8.16.20

voici le message d'erreur que j'obtiens en tapant sudo ./make.sh

ATI module generator V 2.0
==========================
initializing...
kernel includes at /usr/src/linux/include not found or incomplete
file: /usr/src/linux/include/linux/version.h


je précise que j'ai déjà viré tout mes paquets fglrx dans l'espoir que ca allait faire marcher le nouvo driver installé ( le message d'erreur est bien le même qu'avant )

a vue de nez je dirais que c'est un problème de kernel/header ( je sé pas du tout ce que ca ve dire kernel/header )



benohite dans ton tuto tu précisais aussi de déziper un truc et de mettre un lien, tu pourrais préciser ???
vous avez eu besoin d'exécuter fglrxconfig pour que ca marche ??
j'ai déjà désinstaller les anciens drivers/ réinstaller plusieurs fois les nouvos, vous sauriez comment je peux faire pour "tout remettre à zéro" ??
merci


Dual Boot Win 7 Pro + Lucid Lynx
Asus G60JX 16'' - Core i5 430M 2.26 Ghz - 4 Go Ram - Geforce GTS 360 M 1GB

Hors ligne

#49 Le 22/08/2005, à 15:13

Tarlak

Re : [Info]Drivers ATi 8.16.20

je ne sais pas si ca peut t'aider mais j'ai essayer de faire un petit tuto ici regarde on sait jamais ca peut peut etre t'aider

Hors ligne

#50 Le 22/08/2005, à 15:21

CHUCKYCHUCK

Re : [Info]Drivers ATi 8.16.20

merci

sinon en effet je n'avais pas les prérequis du tuto de benohite smile   ( le header/source, je pensais que cté les même prérequis que le tuto de kagou )

j'essaierai prochainement ( la chuis à l'étranger avec mon portable et la connexion est très variable, desfois 500Ko/s des fois 5 Ko /s ... ; en ce moment précis c'est 5 ... )

sinon même après plein de désinstallation/réinstallation des anciens/nouvos drivers ( voir + haut  ) , vous pensez que ca marchera quand même ???

merci

Dernière modification par CHUCKYCHUCK (Le 22/08/2005, à 15:24)


Dual Boot Win 7 Pro + Lucid Lynx
Asus G60JX 16'' - Core i5 430M 2.26 Ghz - 4 Go Ram - Geforce GTS 360 M 1GB

Hors ligne