Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 25/09/2012, à 10:07

zemat73

[Resolu] Impossible de faire une upgrade avec apt-get

Bonjour,

Je suis sur Ubuntu Server 12.04 en français.

Quand je fais "sudo apt-get update" tout se passe bien.
Par contre quand je fais "sudo apt-get upgrade", voilà ce que j'obtiens :

mkubajek@Emkalaus:~$ sudo apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets suivants ont été conservés :
  linux-generic-pae linux-image-generic-pae
Les paquets suivants seront mis à jour :
  apport bind9-host dbus dnsutils gnupg gpgv isc-dhcp-client isc-dhcp-common libapache2-mod-php5 libbind9-80
  libdbus-1-3 libdns81 libisc83 libisccc80 libisccfg82 libjs-jquery liblwres80 linux-libc-dev php5-cli php5-common
  php5-gd php5-intl php5-ldap php5-mysql php5-sqlite php5-xsl python-apport python-problem-report resolvconf tzdata
30 mis à jour, 0 nouvellement installés, 0 à enlever et 2 non mis à jour.
[b]Failed to exec method /usr/lib/apt/methods/
E: Method  has died unexpectedly!
E: Le sous-processus  a renvoyé un code d'erreur (100)
E: La méthode /usr/lib/apt/methods/ n'a pas démarré correctement[/b]
mkubajek@Emkalaus:~$

Avec "sudo apt-get dist-upgrade" et j'ai la même erreur.
Et en utilisant aptitude c'est quasiment le même message.

J'ai cherché sur les forums mais je n'ai rien trouvé pour l'instant.

Dernière modification par zemat73 (Le 25/09/2012, à 14:06)

Hors ligne

#2 Le 25/09/2012, à 10:15

michel_04

Re : [Resolu] Impossible de faire une upgrade avec apt-get

Bonjour,

Tu peux poster ton sources.list, merci.

cat /etc/apt/sources.list

Edit : Et :

ls /etc/apt/sources.list.d

A+

Dernière modification par michel_04 (Le 25/09/2012, à 10:17)


:D
Comment Poser Les Questions De Manière Intelligente
[url=[modéré : pas d’auto-pub, merci]]l'Almanet doLys de nam1962 et ses amis[/url] - Forum Ubuntu-fr - Documentation Ubuntu

Hors ligne

#3 Le 25/09/2012, à 10:16

Diahovez-Ivan

Re : [Resolu] Impossible de faire une upgrade avec apt-get

Salut,

sudo  apt-get -f dist-upgrade

Profil ...
Asus R700VM-TY092V : Linux Mint (15) 13.04  Mate // Tinkpad T61: Linux Mint (14) 12.10 Xfce
Jeux

Hors ligne

#4 Le 25/09/2012, à 10:32

zemat73

Re : [Resolu] Impossible de faire une upgrade avec apt-get

Bonjour,


@ Diahovez-Ivan

sudo apt-get -f dist-upgrade

ne marche pas, j'ai exactement la même erreur.


@ michel_04

le dossier /etc/apt/sources.list.d est vide

et voici le contenu du fichier /etc/apt/sources.list :

# 

# deb cdrom:[Ubuntu-Server 12.04 LTS _Precise Pangolin_ - Release i386 (20120424.1)]/ precise main restricted

#deb cdrom:[Ubuntu-Server 12.04 LTS _Precise Pangolin_ - Release i386 (20120424.1)]/ precise main restricted

# See [url]http://help.ubuntu.com/community/UpgradeNotes[/url] for how to upgrade to
# newer versions of the distribution.
deb [url]http://fr.archive.ubuntu.com/ubuntu/[/url] precise main restricted
deb-src [url]http://fr.archive.ubuntu.com/ubuntu/[/url] precise main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb [url]http://fr.archive.ubuntu.com/ubuntu/[/url] precise-updates main restricted
deb-src [url]http://fr.archive.ubuntu.com/ubuntu/[/url] precise-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb [url]http://fr.archive.ubuntu.com/ubuntu/[/url] precise universe
deb-src [url]http://fr.archive.ubuntu.com/ubuntu/[/url] precise universe
deb [url]http://fr.archive.ubuntu.com/ubuntu/[/url] precise-updates universe
deb-src [url]http://fr.archive.ubuntu.com/ubuntu/[/url] precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb [url]http://fr.archive.ubuntu.com/ubuntu/[/url] precise multiverse
deb-src [url]http://fr.archive.ubuntu.com/ubuntu/[/url] precise multiverse
deb [url]http://fr.archive.ubuntu.com/ubuntu/[/url] precise-updates multiverse
deb-src [url]http://fr.archive.ubuntu.com/ubuntu/[/url] precise-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb [url]http://fr.archive.ubuntu.com/ubuntu/[/url] precise-backports main restricted universe multiverse
deb-src [url]http://fr.archive.ubuntu.com/ubuntu/[/url] precise-backports main restricted universe multiverse

deb [url]http://security.ubuntu.com/ubuntu[/url] precise-security main restricted
deb-src [url]http://security.ubuntu.com/ubuntu[/url] precise-security main restricted
deb [url]http://security.ubuntu.com/ubuntu[/url] precise-security universe
deb-src [url]http://security.ubuntu.com/ubuntu[/url] precise-security universe
deb [url]http://security.ubuntu.com/ubuntu[/url] precise-security multiverse
deb-src [url]http://security.ubuntu.com/ubuntu[/url] precise-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb [url]http://archive.canonical.com/ubuntu[/url] precise partner
# deb-src [url]http://archive.canonical.com/ubuntu[/url] precise partner

## Uncomment the following two lines to add software from Ubuntu's
## 'extras' repository.
## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
# deb [url]http://extras.ubuntu.com/ubuntu[/url] precise main
# deb-src [url]http://extras.ubuntu.com/ubuntu[/url] precise main

a+
merci

Dernière modification par zemat73 (Le 25/09/2012, à 14:06)

Hors ligne

#5 Le 25/09/2012, à 11:02

michel_04

Re : [Resolu] Impossible de faire une upgrade avec apt-get

Re,

Rien d'anormal.
Essaie :

sudo apt-get clean
sudo apt-get autoclean
sudo apt-get autoremove --purge
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

A+


:D
Comment Poser Les Questions De Manière Intelligente
[url=[modéré : pas d’auto-pub, merci]]l'Almanet doLys de nam1962 et ses amis[/url] - Forum Ubuntu-fr - Documentation Ubuntu

Hors ligne

#6 Le 25/09/2012, à 12:50

zemat73

Re : [Resolu] Impossible de faire une upgrade avec apt-get

Re,

J'ai exécuté dans l'ordre toutes le commandes et j'obtiens toujours la même erreur.
Ci-dessous la trace de l’exécution des commandes :

mkubajek@Emkalaus:~$ sudo apt-get clean
[sudo] password for mkubajek:
mkubajek@Emkalaus:~$ sudo apt-get autoclean
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
mkubajek@Emkalaus:~$ sudo apt-get autoremove --purge
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 32 non mis à jour.
mkubajek@Emkalaus:~$ sudo apt-get update
Ign http://fr.archive.ubuntu.com precise InRelease
Ign http://fr.archive.ubuntu.com precise-updates InRelease
Ign http://fr.archive.ubuntu.com precise-backports InRelease
Ign http://security.ubuntu.com precise-security InRelease
Atteint http://fr.archive.ubuntu.com precise Release.gpg
Atteint http://fr.archive.ubuntu.com precise-updates Release.gpg
Atteint http://fr.archive.ubuntu.com precise-backports Release.gpg
Atteint http://fr.archive.ubuntu.com precise Release
Atteint http://fr.archive.ubuntu.com precise-updates Release
Atteint http://security.ubuntu.com precise-security Release.gpg
Atteint http://fr.archive.ubuntu.com precise-backports Release
Atteint http://security.ubuntu.com precise-security Release
Atteint http://fr.archive.ubuntu.com precise/main Sources
Atteint http://fr.archive.ubuntu.com precise/restricted Sources
Atteint http://fr.archive.ubuntu.com precise/universe Sources
Atteint http://fr.archive.ubuntu.com precise/multiverse Sources
Atteint http://fr.archive.ubuntu.com precise/main i386 Packages
Atteint http://fr.archive.ubuntu.com precise/restricted i386 Packages
Atteint http://fr.archive.ubuntu.com precise/universe i386 Packages
Atteint http://fr.archive.ubuntu.com precise/multiverse i386 Packages
Atteint http://fr.archive.ubuntu.com precise/main TranslationIndex
Atteint http://fr.archive.ubuntu.com precise/multiverse TranslationIndex
Atteint http://fr.archive.ubuntu.com precise/restricted TranslationIndex
Atteint http://fr.archive.ubuntu.com precise/universe TranslationIndex
Atteint http://fr.archive.ubuntu.com precise-updates/main Sources
Atteint http://security.ubuntu.com precise-security/main Sources
Atteint http://fr.archive.ubuntu.com precise-updates/restricted Sources
Atteint http://fr.archive.ubuntu.com precise-updates/universe Sources
Atteint http://security.ubuntu.com precise-security/restricted Sources
Atteint http://fr.archive.ubuntu.com precise-updates/multiverse Sources
Atteint http://security.ubuntu.com precise-security/universe Sources
Atteint http://fr.archive.ubuntu.com precise-updates/main i386 Packages
Atteint http://fr.archive.ubuntu.com precise-updates/restricted i386 Packages
Atteint http://security.ubuntu.com precise-security/multiverse Sources
Atteint http://security.ubuntu.com precise-security/main i386 Packages
Atteint http://fr.archive.ubuntu.com precise-updates/universe i386 Packages
Atteint http://fr.archive.ubuntu.com precise-updates/multiverse i386 Packages
Atteint http://fr.archive.ubuntu.com precise-updates/main TranslationIndex
Atteint http://fr.archive.ubuntu.com precise-updates/multiverse TranslationIndex
Atteint http://fr.archive.ubuntu.com precise-updates/restricted TranslationIndex
Atteint http://fr.archive.ubuntu.com precise-updates/universe TranslationIndex
Atteint http://fr.archive.ubuntu.com precise-backports/main Sources
Atteint http://fr.archive.ubuntu.com precise-backports/restricted Sources
Atteint http://fr.archive.ubuntu.com precise-backports/universe Sources
Atteint http://fr.archive.ubuntu.com precise-backports/multiverse Sources
Atteint http://fr.archive.ubuntu.com precise-backports/main i386 Packages
Atteint http://fr.archive.ubuntu.com precise-backports/restricted i386 Packages
Atteint http://fr.archive.ubuntu.com precise-backports/universe i386 Packages
Atteint http://fr.archive.ubuntu.com precise-backports/multiverse i386 Packages
Atteint http://fr.archive.ubuntu.com precise-backports/main TranslationIndex
Atteint http://fr.archive.ubuntu.com precise-backports/multiverse TranslationIndex
Atteint http://fr.archive.ubuntu.com precise-backports/restricted TranslationIndex
Atteint http://fr.archive.ubuntu.com precise-backports/universe TranslationIndex
Atteint http://fr.archive.ubuntu.com precise/main Translation-fr_FR
Atteint http://fr.archive.ubuntu.com precise/main Translation-fr
Atteint http://fr.archive.ubuntu.com precise/main Translation-en
Atteint http://fr.archive.ubuntu.com precise/multiverse Translation-fr_FR
Atteint http://fr.archive.ubuntu.com precise/multiverse Translation-fr
Atteint http://fr.archive.ubuntu.com precise/multiverse Translation-en
Atteint http://fr.archive.ubuntu.com precise/restricted Translation-fr_FR
Atteint http://fr.archive.ubuntu.com precise/restricted Translation-fr
Atteint http://fr.archive.ubuntu.com precise/restricted Translation-en
Atteint http://fr.archive.ubuntu.com precise/universe Translation-fr_FR
Atteint http://fr.archive.ubuntu.com precise/universe Translation-fr
Atteint http://fr.archive.ubuntu.com precise/universe Translation-en
Atteint http://fr.archive.ubuntu.com precise-updates/main Translation-fr
Atteint http://fr.archive.ubuntu.com precise-updates/main Translation-en
Atteint http://fr.archive.ubuntu.com precise-updates/multiverse Translation-fr
Atteint http://fr.archive.ubuntu.com precise-updates/multiverse Translation-en
Atteint http://fr.archive.ubuntu.com precise-updates/restricted Translation-fr
Atteint http://fr.archive.ubuntu.com precise-updates/restricted Translation-en
Atteint http://fr.archive.ubuntu.com precise-updates/universe Translation-fr
Atteint http://fr.archive.ubuntu.com precise-updates/universe Translation-en
Atteint http://fr.archive.ubuntu.com precise-backports/main Translation-en
Atteint http://fr.archive.ubuntu.com precise-backports/multiverse Translation-en
Atteint http://fr.archive.ubuntu.com precise-backports/restricted Translation-en
Atteint http://fr.archive.ubuntu.com precise-backports/universe Translation-en
Atteint http://security.ubuntu.com precise-security/restricted i386 Packages
Atteint http://security.ubuntu.com precise-security/universe i386 Packages
Atteint http://security.ubuntu.com precise-security/multiverse i386 Packages
Atteint http://security.ubuntu.com precise-security/main TranslationIndex
Atteint http://security.ubuntu.com precise-security/multiverse TranslationIndex
Atteint http://security.ubuntu.com precise-security/restricted TranslationIndex
Atteint http://security.ubuntu.com precise-security/universe TranslationIndex
Atteint http://security.ubuntu.com precise-security/main Translation-en
Atteint http://security.ubuntu.com precise-security/multiverse Translation-en
Atteint http://security.ubuntu.com precise-security/restricted Translation-en
Atteint http://security.ubuntu.com precise-security/universe Translation-en
Lecture des listes de paquets... Fait
mkubajek@Emkalaus:~$ sudo apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets suivants ont été conservés :
  linux-generic-pae linux-image-generic-pae
Les paquets suivants seront mis à jour :
  apport bind9-host dbus dnsutils gnupg gpgv isc-dhcp-client isc-dhcp-common libapache2-mod-php5 libbind9-80
  libdbus-1-3 libdns81 libisc83 libisccc80 libisccfg82 libjs-jquery liblwres80 linux-libc-dev php5-cli php5-common
  php5-gd php5-intl php5-ldap php5-mysql php5-sqlite php5-xsl python-apport python-problem-report resolvconf tzdata
30 mis à jour, 0 nouvellement installés, 0 à enlever et 2 non mis à jour.
Failed to exec method /usr/lib/apt/methods/
E: Method  has died unexpectedly!
E: Le sous-processus  a renvoyé un code d'erreur (100)
E: La méthode /usr/lib/apt/methods/ n'a pas démarré correctement
mkubajek@Emkalaus:~$ sudo apt-get dist-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les NOUVEAUX paquets suivants seront installés :
  linux-image-3.2.0-31-generic-pae
Les paquets suivants seront mis à jour :
  apport bind9-host dbus dnsutils gnupg gpgv isc-dhcp-client isc-dhcp-common libapache2-mod-php5 libbind9-80
  libdbus-1-3 libdns81 libisc83 libisccc80 libisccfg82 libjs-jquery liblwres80 linux-generic-pae
  linux-image-generic-pae linux-libc-dev php5-cli php5-common php5-gd php5-intl php5-ldap php5-mysql php5-sqlite
  php5-xsl python-apport python-problem-report resolvconf tzdata
32 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.
Failed to exec method /usr/lib/apt/methods/
E: Method  has died unexpectedly!
E: Le sous-processus  a renvoyé un code d'erreur (100)
E: La méthode /usr/lib/apt/methods/ n'a pas démarré correctement
mkubajek@Emkalaus:~$

Et ce que ça peut venir du fait que je sois derrière un proxy d'entreprise assez restrictif ?
Ou que ça tourne sur une VirtualBox ?
Mais je ne pense pas car j'ai d'autre VirtualBox avec des Ubuntu et ça s'upgrade sans problèmes.

A+

Hors ligne

#7 Le 25/09/2012, à 13:40

inbox

Re : [Resolu] Impossible de faire une upgrade avec apt-get

Salut,

As-tu essayé de passer la commande suivante ?

sudo dpkg --configure -a

A+


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#8 Le 25/09/2012, à 13:46

michel_04

Re : [Resolu] Impossible de faire une upgrade avec apt-get

Re,

Peut-être ton proxy, mais cette erreur est souvent survenue lors d'erreur dans le sources.list, de paquet incohérent, etc...

Tu peux modifier les lignes de ton sources.list en enlevant les fr. (serveur france), exemple :

deb http://fr.archive.ubuntu.com/ubuntu/ precise main restricted

devient (serveur principal) :

deb http://archive.ubuntu.com/ubuntu/ precise main restricted

Puis :

sudo apt-get remove
sudo apt-get update
sudo apt-get upgrade

A+


:D
Comment Poser Les Questions De Manière Intelligente
[url=[modéré : pas d’auto-pub, merci]]l'Almanet doLys de nam1962 et ses amis[/url] - Forum Ubuntu-fr - Documentation Ubuntu

Hors ligne

#9 Le 25/09/2012, à 14:05

zemat73

Re : [Resolu] Impossible de faire une upgrade avec apt-get

Re,

Je me suis dit que je vais commenter une à une les lignes du fichier

/etc/apt/sources.list

et voir ce que ça fait en lancant

sudo apt-get upgrade

et ça a marché dès la première ligne :

# deb http://fr.archive.ubuntu.com/ubuntu/ precise main restricted

toutes les mises à jour sont passées.

@ inbox
du coup je n'ai pas executé

sudo dpkg --configure -a

Merci à tous pour votre aide,
a+

Hors ligne

#10 Le 25/09/2012, à 14:25

inbox

Re : [Resolu] Impossible de faire une upgrade avec apt-get

Par contre, il faut remettre cette ligne, pour qu'il ne te manque pas de mises à jour, puis refaire un "update" suivi d'un "upgrade".


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#11 Le 25/09/2012, à 14:47

zemat73

Re : [Resolu] Impossible de faire une upgrade avec apt-get

C'est fait.

Merci encore pour vos conseils.

Hors ligne