Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#376 Le 25/01/2008, à 15:56

teet

Re : [E17] Exalt! un network manager

j'ai abandonné, j'ai installé linux mint v.4 et internet fonctionne du premier coup.


manger du castor et vous sauverez un arbre !
ubuntu user 6419

Hors ligne

#377 Le 25/01/2008, à 18:19

Watchwolf

Re : [E17] Exalt! un network manager

bmar a écrit :

'soir,

Je viens de dépanner mon problème de charge excessive depuis la MaJ gràce à l'aide de lut!n, mais je suis trop crevé ce soir pour relancer la compil d'exalt. Je vais essayer de le faire demain soir, mais je serais peut-être obligé de reporter à la semaine prochaine.
Je poste dès que j'ai du nouveau.

Je vais te dire 2 ou3 trucs qui pourront peut être t'aider dans tes tests (et m'aider smile).

quand tu as le message "the name exalt..........." ca veut dire que le daemon n'est pas lancé. Si tu n'as pas ce message au début mais qu'il apparait après une manipulation c'est que le daemon a planté.

Lancer le daemon avec "exalt-daemon --nodaemon" permet d'avoir les msgs dans le terminal ce qui peut être pratique. Sinon ces messages sont dans le fichier /var/log/exaltd.log

Exalt est constitué de 2 applications graphiques: le module et l'application en etk. Quand tu execute exalt dans un terminal tu lance l'application etk. Le module c'est l'icone bleu dans le shelf. Le module execute l'application lorsque tu clique sur une carte ou sur un réseau sans fils. Si cela ne fonctionne pas tu peut configurer dans les propriétés du module le chemin à executer. C'est possible que l'executable exalt ne soit pas dans ton path, il faut alors mettre le chemin complet.

Il pourrait être interessant que tu configure d'abord un réseau filaire et voit si cela fonctionne puis ensuite passer au sans fils.

Si tu veut aller un peu plus loin tu peut utiliser gdb. C'est très utile si une application plante.
Pour l'application etk tu peut faire dans une console: gdb exalt
Pour lancer l'application il faut faire "r"
Une fois que ca a planté (l'application doit se figer mais pas se fermer) tu fait "bt" dans gdb et tu regarde le résultat (et me le donne smile)

Pour le daemon il faut faire: gdb exalt-daemon
et ensuite "r --nodaemon". Puis pareil ensuite "bt" si ca plante.

voila voila smile

Hors ligne

#378 Le 25/01/2008, à 20:48

bmar

Re : [E17] Exalt! un network manager

'soir,

OK, merci pour les explications.
Pour ce soir c'est mort, je ne peux pas m'y mettre et je pars tout le week-end, donc je m'y mettrais en début de semaine prochaine.
Juste une question de plus, est-ce que je dois enlever tout autre network manager pour faire cela ?
J'utilise en ce moment wicd.


Soyez vous-même le changement que vous voulez voir dans le Monde - Gandhi

Hors ligne

#379 Le 26/01/2008, à 21:37

Watchwolf

Re : [E17] Exalt! un network manager

bmar a écrit :

'soir,

OK, merci pour les explications.
Pour ce soir c'est mort, je ne peux pas m'y mettre et je pars tout le week-end, donc je m'y mettrais en début de semaine prochaine.
Juste une question de plus, est-ce que je dois enlever tout autre network manager pour faire cela ?
J'utilise en ce moment wicd.

non tu peut garder networkmanger, ca ne devrait pas poser de pb.

Hors ligne

#380 Le 29/01/2008, à 20:50

bmar

Re : [E17] Exalt! un network manager

Bonsoir,

Voila, je m'y suis remis.
J'ai remis à  jour avec svn, recompilé et fait un premier essai en cà¢blé:
Tout me semble fonctionner correctement, les boutons sont actifs et les adresses correctes.
J'ai eu un plantage de exalt lorsque je suis passé en mode avancé et que j'ai voulu revenir en mode basic, voici le résultat : http://pastebin.com/m1b857c43

J'ai mis les détails auxquels j'ai pensé, si besoin de plus d'info je recommence la manipulation.

La je dois aller coucher les petites, mais je reprends après avec la carte wifi.


Soyez vous-même le changement que vous voulez voir dans le Monde - Gandhi

Hors ligne

#381 Le 29/01/2008, à 22:30

bmar

Re : [E17] Exalt! un network manager

Re...

Bon, la ça se complique !
Dommage que je ne puisse toujours pas faire de screenshot, cela serait plus parlant (et j'aurai moins à  écrire wink ).
Je suis dans la même config que précédemment sauf que ma carte wifi est insérée.
J'ai lancé "gdb exalt-daemon" puis "r --nodaemon" dans un premier terminal
et "gbd exalt" puis "r" dans un second, le tout en sudo.
La fenêtre exalt apparaà®t et m'indique dans le volet des cartes réseaux :
- général
- wifi0 avec une coche verte
- eth1 cablé avec un panneau d'avertissement triangulaire
- eth0 wifi avec une coche verte
Je suis allé sur la carte eth0 pour configurer ma connexion sans fil, mais cette fois aucun réseau sans fil n'apparaà®t dans le tableau. Sous le tableau vide apparaissent les infos de ma connexion actuelle essid +de s caractères bizzards, IP, masque et passerelle, tout est juste. Les boutons "desactive", "mode de cryptage" et "connection mode" sont actifs.
La je ne peux rien faire. Dans les terminaux pas de plantage.
Je suis allé sur la carte wifi0 pour voir si j'avais quelque chose, pas de réseau sans fil visible mais les infos sous le tableau sont différentes : essid affiche mon essid actuel + des caractères bizzards. Le reste est vide. Les mêmes boutons que plus haut sont actifs. Je ne peux rien faire.
J'ai fermé la fenêtre avec la croix et exalt a planté, exalt-daemon n'a pas bougé.

Je ne suis pas convaincu que cette manip ai fait ressortir quelque chose, mais j'ai quand même mis les backtraces ici : http://pastebin.com/d4902956f;

Sans screenshot cela me paraà®t lourd d'expliquer de façon clair et concise, il vaux peut-être mieux que j'attende la mise à  jour pour refaire ??


Soyez vous-même le changement que vous voulez voir dans le Monde - Gandhi

Hors ligne

#382 Le 30/01/2008, à 12:25

Watchwolf

Re : [E17] Exalt! un network manager

C'est normal que ca plante quand on revient en mode basic, c'est connu et ca vient de ETK, pas de Exalt smile

Pour le wifi, tu as bien 2 cartes wifi ou ce n'est pas normal qu'il y en ait 2 ?
La colonne de droite adns la configuration d'une carte wifi (mode de cryptage ...) concerne la configuration que tu veut appliquer, aucunement la configuration actuel (pour cela il y a juste le essid et les adresse en bas).

C'est norlmal qu exalt plante parfois quand il est fermé, c'est connu.

Le problème est que tu n'a pas vu de réseau sans fils, ce n'est pas normal et inhabituel.
- Tu as regardé si le daemon voyait quelque chose ?
- tu a attendu un peu ? dernièrement j'ai fait une modification et le listing des réseaux une première est un peu lent hmm

Hors ligne

#383 Le 30/01/2008, à 12:43

bmar

Re : [E17] Exalt! un network manager

Bonjour,

Pour le wifi, ce n'est pas normal qu'il y en ai 2 car je n'en ai qu'une, habituellement reconnue sous eth0.
Je ne sais pas si le daemon a vu quelque chose, je vais regarder ce que j'ai mis sur pastebin.
Environ 3 minutes se sont écoulées entre le lancement des taches et la fin de l'essai.
Je ferais d'autres essais...


Soyez vous-même le changement que vous voulez voir dans le Monde - Gandhi

Hors ligne

#384 Le 30/01/2008, à 13:40

Watchwolf

Re : [E17] Exalt! un network manager

bmar a écrit :

Bonjour,

Pour le wifi, ce n'est pas normal qu'il y en ai 2 car je n'en ai qu'une, habituellement reconnue sous eth0.
Je ne sais pas si le daemon a vu quelque chose, je vais regarder ce que j'ai mis sur pastebin.
Environ 3 minutes se sont écoulées entre le lancement des taches et la fin de l'essai.
Je ferais d'autres essais...

Utilise "ifconfig -a" et  iwconfig (-a)" pour voir la lsite des cartes detectés par le système, si il t'en détecte 2 c'est que le problème vient d'autre part (du driver peut être ?)
Sinon redemarre le daemon, j'ai remarqué que dans de rare cas une carte wifi peut être detecté comme une carte filaire hmm, sinon je n'ai jamais remarqué 2 cartes wifi mais on ne sait jamais.

Hors ligne

#385 Le 31/01/2008, à 10:26

fredr

Re : [E17] Exalt! un network manager

Salut Watchwolf,

Depuis que j'ai réinstallé Exalt par le CVS j'ai une explosion incontrolée Load_Cycle_count voir ici:http://forum.ubuntu-fr.org/viewtopic.ph … 2#p1501432
C'est sans doute une coà¯ncidence, mais je cherche pq. Penses-tu que Exalt (ou E17) ait pu modifier la gestion d'énergie?

Fred

A part cela, en modifiant le fichier dans dbus-1 Exalt démarre bien et détecte mes réseaux mais ne me connecte à  aucun. WPA et WEP. Mais comme c'est idem aussi bien avec NetworkManager que Wicd et que je suis chaque fois obligé de le configurer en dur dans le fichier interface je pense que ça vient du driver propio de ma carte Intel.


Kubuntu 22.10 avec Plasma - BSPWM ...
L'optimiste pense que nous vivons dans le meilleur des mondes. Et le pessimiste craint que ce ne soit exact.

Hors ligne

#386 Le 18/02/2008, à 21:41

yoyo

Re : [E17] Exalt! un network manager

Bonjour à  tous
Mon problème vient du fait que je ne peux me connecter en wifi via Exalt.

Il repère bien mon réseau mais refuse de prendre mon MdP. Celui-ci est en wep hexadécimal, mais exalt n'accepte que je rentre un MdP qu'en wep ascII et c'est apparemment incompatible (en tout cas, non fonctionnel).
Quand je tente de rentrer le tout en sélectionnant wep (hexadécimal), il m'est tout simplement impossible de valider ma clé. (je ne peux pas utiliser le bouton "apply").

Quelqu'un a une idée ?

Hors ligne

#387 Le 24/02/2008, à 10:25

Watchwolf

Re : [E17] Exalt! un network manager

Tu pense bien à mettre les lettres du mot de passe en majuscules  ?

Hors ligne

#388 Le 24/02/2008, à 10:55

yoyo

Re : [E17] Exalt! un network manager

Bonjour
Et merci pour la réponse, mais j'ai alors un autre problème, mon mdp ne contiens pas de majuscules
J'ai quand même tenté, au cas où, en majuscules, et je peux effectivement utiliser le bouton "apply", seulement, il m'est alors impossible de me connecter.

Un ping me renvoie un "Network is unreachable"

Hors ligne

#389 Le 24/02/2008, à 11:52

Watchwolf

Re : [E17] Exalt! un network manager

une clé hexa contient forcement des majuscules sinon ce n'est pas de l'hexa hmm
Tu configure bien le mode de connection et le mode de securité ?

Sinon tu n'as pas la possibilité de changer le mot de passe du routeur et d'y mettre des majuscules ? (pour tester)

Dernière modification par Watchwolf (Le 24/02/2008, à 11:53)

Hors ligne

#390 Le 24/02/2008, à 13:37

yoyo

Re : [E17] Exalt! un network manager

Bon, je suis repassé en WEP ASCII et j'ai tenté les 4 possibilités
Ad-hoc/open
Ad-hoc/share
managed/open
managed/shared

Sans résultat.

Je vais tenté de changer de mdp ..

Bon, même en mettant chaque lettre en majuscules, rien n'y fait.
Par contre, connecté par cable, ça fonctionne

Dernière modification par yoyo (Le 24/02/2008, à 18:22)

Hors ligne

#391 Le 25/02/2008, à 17:31

zerocopek

Re : [E17] Exalt! un network manager

Bonjour,

je viens d'installer Gos sur un vieux 433 avec comme connexion internet une livebox.
Exalt me récupère bien les réseaux visibles, dont le mien, mais je ne sais pas comment le forcer à se connecter sur ma livebox. Il se connecte sur un réseau sans nom.
Novice en la matière, quelqu'un peut-il m'aider ? Merci

#392 Le 25/02/2008, à 17:51

Watchwolf

Re : [E17] Exalt! un network manager

zerocopek a écrit :

Bonjour,

je viens d'installer Gos sur un vieux 433 avec comme connexion internet une livebox.
Exalt me récupère bien les réseaux visibles, dont le mien, mais je ne sais pas comment le forcer à se connecter sur ma livebox. Il se connecte sur un réseau sans nom.
Novice en la matière, quelqu'un peut-il m'aider ? Merci

Exalt ne se connecte pas sur un réseau par défaut.

Il te suffit dans le module qui t'affiche la liste des réseaux, de cliquer sur celui où tu veut te conneter et dans le logiciel qui apparait de configurer la partie droite. Après Exalt va automatiquement sessayer de se connecter au dernier réseau auquel tu t'es connecté.

Si ca ne marche pas revient ici, il y a quelques problemes mais je n'ai jamais trop compris si c'etit exalt le pb ou le systeme (driver tous cas).

Hors ligne

#393 Le 25/02/2008, à 17:59

zerocopek

Re : [E17] Exalt! un network manager

Merci mais comment connaître le dernier réseau connecté ?

#394 Le 25/02/2008, à 18:20

Watchwolf

Re : [E17] Exalt! un network manager

Exalt sauvegarde la configuration dans /etc/exalt.eet.

Hors ligne

#395 Le 25/02/2008, à 18:20

zerocopek

Re : [E17] Exalt! un network manager

C'est bon ca marche, une histoire de réglage

#396 Le 25/02/2008, à 18:26

Watchwolf

Re : [E17] Exalt! un network manager

oki c'est cool, tu peut me dire quel réglage tu utilise ? (histoire de voir ce qui fonctionne et ce qui peut poser pb)

Hors ligne

#397 Le 12/03/2008, à 19:35

TiteFleur

Re : [E17] Exalt! un network manager

Bonjour,

Est-ce que le mode WEP hexadecimal fonctionne réellement ? Il est dans la liste des cryptages, mais lorsque l'on tape le mot de passe avec ce mode, le bouton ne se dégrise jamais, il est donc impossible de se connecter ou du moins d'essayer wink

Merci
TiteFleur


Ancienne Ubunteros qui continue à traîner sur les forums ;)

Hors ligne

#398 Le 12/03/2008, à 22:50

watchwolf32

Re : [E17] Exalt! un network manager

TiteFleur a écrit :

Bonjour,

Est-ce que le mode WEP hexadecimal fonctionne réellement ? Il est dans la liste des cryptages, mais lorsque l'on tape le mot de passe avec ce mode, le bouton ne se dégrise jamais, il est donc impossible de se connecter ou du moins d'essayer wink

Merci
TiteFleur

Il faut saisir les lettres en majuscules smile

#399 Le 12/03/2008, à 23:04

TiteFleur

Re : [E17] Exalt! un network manager

En effet, c'était tout bête !

Merci beaucoup, beau boulot ;-)


Ancienne Ubunteros qui continue à traîner sur les forums ;)

Hors ligne

#400 Le 12/03/2008, à 23:35

watchwolf32

Re : [E17] Exalt! un network manager

Je suis bien placé pour connaitre ce probleme étant donné que j'ai codé Exalt et qu'une fois j'ai cherché pendant 20 minute spourquoi ca ne fonctionnait (j'était aller cherché dans les sources le pourquoi du comment) lol