Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 02/10/2013, à 19:31

PeuchC

Problème Réseau Machine Virtuelle RESOLU

Bonsoir à tous,

alors voilà sur mon pc physique je tourne sous W8, j'ai donc décidé de mettre en place une machine virtuelle UBUNTU.

Je dois paramétrer l'adresse IP de ma VM en adresse fixe mais le problème est que lorsque je choisis Bridged comme option de connexion dans les paramètres de ma VM je n'ai plus d'accès à internet.

Pour avoir accès à Internet et au réseau depuis ma VM je dois mettre en NAT mais j'obtiens une adresse ne faisant pas du tout partie du pool d'adresse de mon DHCP..

Donc je souhaiterai savoir si quelqu'un aurait une solution à mon problème

Dernière modification par PeuchC (Le 06/11/2013, à 20:57)


Diplômé BTS SIO | Linuxien | Raspberry Pi Power | Développeur | Server Admin

Hors ligne

#2 Le 02/10/2013, à 23:41

tiramiseb

Re : Problème Réseau Machine Virtuelle RESOLU

Salut,

Tout d'abord, ton problème n'est pas nécessairement plus urgent que les problèmes des autres gens sur le forum : pas besoin de le préciser smile

Ensuite, ton message n'est pas clair :
Tu dois paramétrer ta VM avec une IP fixe ou alors en DHCP ?

Si tu mets en mode pont (bridged) et que tu fais une requête DHCP, ça donne quoi ?

Hors ligne

#3 Le 03/10/2013, à 19:43

PeuchC

Re : Problème Réseau Machine Virtuelle RESOLU

Excuses moi pour le URGENT c'était juste que je galére sur le problème depuis lgtps et que hier ca faisait 4h que j'étais dessus donc ca m'avait un peu gonflé.

Lorsque je fais un ifconfig /renew ca me renvoi une interface d'interface


Diplômé BTS SIO | Linuxien | Raspberry Pi Power | Développeur | Server Admin

Hors ligne

#4 Le 03/10/2013, à 19:48

pires57

Re : Problème Réseau Machine Virtuelle RESOLU

Et alors? tu te mets en NAT et tu passes ton adresse en IP fixe en modifiant le fichier de config, il est ou le problème?


Utilisateur d'Archlinux, Ubuntu et Kali Linux
Administrateur système et réseau spécialisé Linux.
LinkedIn

Hors ligne

#5 Le 03/10/2013, à 19:57

PeuchC

Re : Problème Réseau Machine Virtuelle RESOLU

Une erreur d'interface et non pas une interface d'interface comme j'ai écrit


Diplômé BTS SIO | Linuxien | Raspberry Pi Power | Développeur | Server Admin

Hors ligne

#6 Le 03/10/2013, à 20:03

pires57

Re : Problème Réseau Machine Virtuelle RESOLU

Qu'entend tu par "erreur d'interface"? Que cherches tu a faire concrètement?
Dans ton premier post tu parles de DHCP et d'IP fixe, si tu as une IP fixe tu n'as pas besoin d'allez demander l'adresse a un DHCP. Expliques toi.


Utilisateur d'Archlinux, Ubuntu et Kali Linux
Administrateur système et réseau spécialisé Linux.
LinkedIn

Hors ligne

#7 Le 03/10/2013, à 20:19

PeuchC

Re : Problème Réseau Machine Virtuelle RESOLU

Alors en fait, je souhaiterai pouvoir fixer l'adresse IP de ma machine virtuelle pour le serveur WEB installé dessus à des fins de tests.

J'ai regardé dans les paramètres de ma box afin de connaître mon pool d'adresses DHCP pour pouvoir choisir une adresse en faisant partie.

Mon pool d'adressage va de l'adresse 192.168.1.20 à 192.168.1.100

J'ai donc mis le parmametrage de la connexion de la VM en Bridgeg (Replicate Physical Network Connection State) pour que je puisse avoir une adresse IP faisant partie du Pool de ma box et une adresse mac reconnue sur l'interface de ma box pour pouvoir fixer une adresse ip à ma vm.

Problème, lorsque je mets bridge comme mode de connexion je n'ai plus aucunes adresses IP attribué à ma VM et ensuite si je le mets en NAT j'ai une adresse de ce type 191.168.239.128..

Je galère donc bcp pour avoir une ip faisant partie du pool de mon réseau physique


Diplômé BTS SIO | Linuxien | Raspberry Pi Power | Développeur | Server Admin

Hors ligne

#8 Le 03/10/2013, à 21:05

pires57

Re : Problème Réseau Machine Virtuelle RESOLU

PeucHC a écrit :

J'ai regardé dans les paramètres de ma box afin de connaître mon pool d'adresses DHCP pour pouvoir choisir une adresse en faisant partie

on s'en fou un peu du DHCP, l'important c'est qu'il ne vienne pas casser les pieds donc on choisis une adresse dont on n'est sur qu'elle ne sera pas attribué.
Je te donne un exemple:
j'ai un réseau en 192.168.1.X/24
Sur ce réseau j'ai un serveur DHCP qui fourni des adresses ip entre 192.168.1.20 et 192.168.1.100 donc ce que je vait faire, c'est que je prend 192.168.1.101 pour mon serveur et je lui fixe son IP en modifiant le fichier de conf donc

sudo vim /etc/network/interfaces

et ont le modifie pour obtenir quelque chose qui ressemble a cela:

#The loopback network interface
auto lo
iface lo inet loopback

#The primary network interface
auto eth0
iface eth0 inet static
address 192.168.1.101
netmask 255.255.255.0
broadcast 192.168.1.255
gateway 192.168.1.254

puis on redémarre le service

sudo /etc/init.d/networking restart
PeucHC a écrit :

J'ai donc mis le parmametrage de la connexion de la VM en Bridgeg (Replicate Physical Network Connection State) pour que je puisse avoir une adresse IP faisant partie du Pool de ma box et une adresse mac reconnue sur l'interface de ma box pour pouvoir fixer une adresse ip à ma vm.

Jusqu'a preuve du contraire, rien ne t’empêche de le faire en NAT mais en Bridged cela fonctionnera aussi puisqu'avec une config de ce genre tu prendras l'IP défini dans le fichier de conf et non une IP chercher sur un DHCP.

Dernière modification par pires57 (Le 03/10/2013, à 21:13)


Utilisateur d'Archlinux, Ubuntu et Kali Linux
Administrateur système et réseau spécialisé Linux.
LinkedIn

Hors ligne

#9 Le 03/10/2013, à 21:48

PeuchC

Re : Problème Réseau Machine Virtuelle RESOLU

Je viens d'essayer toutes ces configurations mais maintenant je n'ai plus aucunes adresses ip attribué à ma machine virtuelle

Lorsque j'effectue un ifconfig, je me retrouve avec la configuration du local uniquement (localhost..) mais plus rien par rapport à l'interface eth0


Diplômé BTS SIO | Linuxien | Raspberry Pi Power | Développeur | Server Admin

Hors ligne

#10 Le 03/10/2013, à 21:58

pires57

Re : Problème Réseau Machine Virtuelle RESOLU

c'est qu'il y a une erreur dans ton fichier.
lorsque tu as taper la commande

sudo /etc/init.d/networking restart

est ce qu'il t'as mis un "FAIL" ou pas?
peut tu me fournir le résultat de

cat /etc/network/interfaces

Utilisateur d'Archlinux, Ubuntu et Kali Linux
Administrateur système et réseau spécialisé Linux.
LinkedIn

Hors ligne

#11 Le 03/10/2013, à 22:16

PeuchC

Re : Problème Réseau Machine Virtuelle RESOLU

Lorsque je fais un sudo /etc/init.d/networking restart j'obtiens une erreur qui me dit que je peux faire qu'un start ou un truc du genre et juste après la machine plante et je suis obligé de la redémarrer

Et pour le cat /etc/network interfaces j'obtiens ca

# Interfaces (5) file used by ifup (8) and ifdown (8)
auto lo
iface lo inet loopback

#The primary network interface

auto eth0
iface eth0 inet static
adress 192.168.1.101
netmack 255.255.255.0
broadcast 292.168.1.255
gateway 192.168.1.1 

Dernière modification par PeuchC (Le 03/10/2013, à 22:17)


Diplômé BTS SIO | Linuxien | Raspberry Pi Power | Développeur | Server Admin

Hors ligne

#12 Le 03/10/2013, à 22:25

pires57

Re : Problème Réseau Machine Virtuelle RESOLU

broadcast 292.168.1.255

<-- c'est quoi ce truc??

netmack 255.255.255.0

<-- alors la je peut t'assurer qu'il n'appréciera pas du tout. C'est 'netmask'avec un 'S' et pas 'netmack'
ensuite ce que je t'ai donné c'est bien sur un exemple a adapter.
Quel est l'adresse de ton réseau? son masque de sous réseau?


Utilisateur d'Archlinux, Ubuntu et Kali Linux
Administrateur système et réseau spécialisé Linux.
LinkedIn

Hors ligne

#13 Le 03/10/2013, à 22:38

PeuchC

Re : Problème Réseau Machine Virtuelle RESOLU

Ah oui effectivement je crois que je me suis trompéééé ^^

Le masque de sous réseau c'est 255.255.255.0
Et la passerelle par défaut c'est 192.168.1.1


Diplômé BTS SIO | Linuxien | Raspberry Pi Power | Développeur | Server Admin

Hors ligne

#14 Le 03/10/2013, à 22:43

pires57

Re : Problème Réseau Machine Virtuelle RESOLU

#The loopback network interface
auto lo
iface lo inet loopback

#The primary network interface
auto eth0
iface eth0 inet static
address 192.168.1.101
netmask 255.255.255.0
broadcast 192.168.1.255
gateway 192.168.1.1

fait un copier coller, ce sera plus simple puis

sudo /etc/init.d/networking restart

renvois ensuite le resultat de

ifconfig

edit: A et j'oubliais, c'est address avec deux 'd' et pas adress

Dernière modification par pires57 (Le 03/10/2013, à 22:44)


Utilisateur d'Archlinux, Ubuntu et Kali Linux
Administrateur système et réseau spécialisé Linux.
LinkedIn

Hors ligne

#15 Le 03/10/2013, à 22:49

PeuchC

Re : Problème Réseau Machine Virtuelle RESOLU

Je viens de faire un copié collé dans le fichier de configuration mais lorsque je fais un restart j'ai la machine virtuelle qui plante complètement


Diplômé BTS SIO | Linuxien | Raspberry Pi Power | Développeur | Server Admin

Hors ligne

#16 Le 03/10/2013, à 22:51

pires57

Re : Problème Réseau Machine Virtuelle RESOLU

comment cela? plantage du logiciel de virtualisation ou de la vm en elle meme?
je doute fortement que cela provienne de la modification de ce fichier de conf


Utilisateur d'Archlinux, Ubuntu et Kali Linux
Administrateur système et réseau spécialisé Linux.
LinkedIn

Hors ligne

#17 Le 03/10/2013, à 22:53

PeuchC

Re : Problème Réseau Machine Virtuelle RESOLU

C'est la Vm qui plante. Ça me dit que je peux pas faire un restart et j'ai même pas le temps de tout lire que le terminal se ferme et la Vm plante direct


Diplômé BTS SIO | Linuxien | Raspberry Pi Power | Développeur | Server Admin

Hors ligne

#18 Le 03/10/2013, à 22:58

pires57

Re : Problème Réseau Machine Virtuelle RESOLU

redemarre la vm et donne le résultat de

ifconfig

Utilisateur d'Archlinux, Ubuntu et Kali Linux
Administrateur système et réseau spécialisé Linux.
LinkedIn

Hors ligne

#19 Le 03/10/2013, à 23:00

PeuchC

Re : Problème Réseau Machine Virtuelle RESOLU

eth0      Link encap:Ethernet  HWaddr 00:0c:29:43:17:8b  
          inet adr:192.168.1.101  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::20c:29ff:fe43:178b/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:9 erreurs:0 :0 overruns:0 frame:0
          TX packets:62 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:1146 (1.1 KB) Octets transmis:9096 (9.0 KB)
          Interruption:19 Adresse de base:0x2024 

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:225 erreurs:0 :0 overruns:0 frame:0
          TX packets:225 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          Octets reçus:17304 (17.3 KB) Octets transmis:17304 (17.3 KB)

Diplômé BTS SIO | Linuxien | Raspberry Pi Power | Développeur | Server Admin

Hors ligne

#20 Le 03/10/2013, à 23:05

PeuchC

Re : Problème Réseau Machine Virtuelle RESOLU

Donc c'est bon j'ai bien l'adresse 192.168.1.101 d'attribué à ma VM mais je n'ai pas la possibilité d'accéder aux serveurs installés sur cette VM depuis ma machine physique en passant par l'adresse 192.168.1.101 et je ne peux ni pinger de ma machine physique vers la VM ni de la VM vers la machine physique.


Diplômé BTS SIO | Linuxien | Raspberry Pi Power | Développeur | Server Admin

Hors ligne

#21 Le 03/10/2013, à 23:05

pires57

Re : Problème Réseau Machine Virtuelle RESOLU

et bien je pense que tout est ok, que donne

ping 192.168.1.1

edit: ta vm est en pont ou en nat?

Dernière modification par pires57 (Le 03/10/2013, à 23:10)


Utilisateur d'Archlinux, Ubuntu et Kali Linux
Administrateur système et réseau spécialisé Linux.
LinkedIn

Hors ligne

#22 Le 03/10/2013, à 23:12

PeuchC

Re : Problème Réseau Machine Virtuelle RESOLU

clement@ubuntu:~$ ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.101 icmp_seq=1 Destination Host Unreachable
From 192.168.1.101 icmp_seq=2 Destination Host Unreachable
From 192.168.1.101 icmp_seq=3 Destination Host Unreachable

elle est en nat


Diplômé BTS SIO | Linuxien | Raspberry Pi Power | Développeur | Server Admin

Hors ligne

#23 Le 03/10/2013, à 23:13

pires57

Re : Problème Réseau Machine Virtuelle RESOLU

alors passes la en pont


Utilisateur d'Archlinux, Ubuntu et Kali Linux
Administrateur système et réseau spécialisé Linux.
LinkedIn

Hors ligne

#24 Le 03/10/2013, à 23:16

PeuchC

Re : Problème Réseau Machine Virtuelle RESOLU

Avec l'option replicate ?


Diplômé BTS SIO | Linuxien | Raspberry Pi Power | Développeur | Server Admin

Hors ligne

#25 Le 03/10/2013, à 23:21

pires57

Re : Problème Réseau Machine Virtuelle RESOLU

qu'utilisetu pour virtualiser? vmware?
je n'ai jamais essayé avec vmware je ne peut donc pas te dire mais test , cela ne coute rien de changer


Utilisateur d'Archlinux, Ubuntu et Kali Linux
Administrateur système et réseau spécialisé Linux.
LinkedIn

Hors ligne