Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 31/08/2007, à 09:59

jlbiasini

Re : Compiz-fusion lent

pas de troll s'il vous plaît on a un vrai problème et c'est pas faire partir notre discussion en troll qui va le résoudre. Plusieurs personnes m'ont d'ailleurs signalé le même problème sous Debian... Feisty a certes des problèmes de latence sur certains postes mais là c'est un problème bien localisé.

Logique puisque si ça vient pas des drivers je vois pas ce que ça peut être :

Dans mon cas par contre, j'ai remarqué que certains effets sont fluides et d'autres au contraire le sont pas du tout. Le cube par exemple est fluide, sidestick ou dream vont a peut pret, par contre magic lamp est inutilisable smile

exactement pareil...:|

pour continuer d'avancer pouvez vous me dire avec quel drivers vous avez ce problème ?

moi c'est avec les 1.0-9631 (nvidia-glx, installé automatiquement)
et avec les 1.0-10.14.11 (nvidia-legacy, installé par envy)
notez que je n'ai réussi avec envy à installer ni les 9639, ni les 7185

et vous ?

d'autres part qui sait comment on rapporte un bug, j'ai jamais fait ça (avec une tapette, oui je sais smile)?

Dernière modification par jlbiasini (Le 31/08/2007, à 10:22)


Debian Wheezy,  Ubuntu Natty.
ASUS K93SV: CORE I5 / Intel Sandy Bridge - nVidia GT540M - Optimus
Vous avez un bug ? - Déposez un brevet !

Hors ligne

#27 Le 31/08/2007, à 13:52

jlbiasini

Re : Compiz-fusion lent

Bon j'ai posté ici :

http://www.nvnews.net/vbulletin/showthread.php?p=1360861#post1360861

Il y avait déjà un post, et je vous suggère d'aller aussi foutre la merde là bas histoire qu'on sache un peu plus. Entre temps j'ai testé l'affichage 2D d'une vieille TNT2 et ben c'est beaucoup mieux même mon windows en dual boot est beaucoup plus rapide...


Debian Wheezy,  Ubuntu Natty.
ASUS K93SV: CORE I5 / Intel Sandy Bridge - nVidia GT540M - Optimus
Vous avez un bug ? - Déposez un brevet !

Hors ligne

#28 Le 31/08/2007, à 14:13

jeanvalery

Re : Compiz-fusion lent

roooh lala loin de moi l'idée de troller... faut pas en voir partout! je voulais savoir si sk8glad avait aussi une nvidia, et faire remarquer que changer de distrib n'etait pas une soution miracle, du moins pour les gens dans mon cas. Pour ma part j'ai de la debian testing et de l'ubuntu, je vais pas aller troller sur l'une des deux distrib que j'utilise.

mes drivers nvidia sont les derniers dispo sur leur site : 100.14.11

Tres cordialement avec des poils,

jeanvalery


Membre du club des beaux Ubunteros

Hors ligne

#29 Le 31/08/2007, à 15:57

jlbiasini

Re : Compiz-fusion lent

smile ne t'en fait pas le message s'adressait à sk8glad

J'envisage de passer aussi à debian mais ce n'est pas la question.

à plus

Dernière modification par jlbiasini (Le 31/08/2007, à 16:01)


Debian Wheezy,  Ubuntu Natty.
ASUS K93SV: CORE I5 / Intel Sandy Bridge - nVidia GT540M - Optimus
Vous avez un bug ? - Déposez un brevet !

Hors ligne

#30 Le 31/08/2007, à 17:35

sk8glad

Re : Compiz-fusion lent

@ jlbiasini
Pour répondre à ta question j'ai une geforce go7400. Et pour le driver nvidia, il existe un driver patché que tu trouves ici http://grizach.sc18.info/nvpatch/. Au pire tu prends le noyau 2.6.22 qui est dans unstable.
Mais vraiment j'ai constaté la différence sur debian, et aussi sur sabayon et archlinux (que je n'ai pas gardé longtemps).

Hors ligne

#31 Le 31/08/2007, à 22:29

jlbiasini

Re : Compiz-fusion lent

smile Merci !

C'est que je passerai pour un rustre moi !:lol::lol:

edit le script tombe sur une erreur de path de modpost (il le détecte  pas au bon endroit ou alor il faut que j'installe un truc que j'ai pas... je continu de chercher et je vous tient au courant...

Dernière modification par jlbiasini (Le 31/08/2007, à 22:32)


Debian Wheezy,  Ubuntu Natty.
ASUS K93SV: CORE I5 / Intel Sandy Bridge - nVidia GT540M - Optimus
Vous avez un bug ? - Déposez un brevet !

Hors ligne

#32 Le 01/09/2007, à 12:36

jlbiasini

Re : Compiz-fusion lent

Euh... en fait entre les connaissances en anglais et les connaissane en informatique je suis un peu limite là...:rolleyes:

sk8glad, pourrais tu me détailler un peu quel est le problème décrit ? Je n'ai pas très bien compris est-ce que je dois, et peux, installer un nouveau noyau sous ubuntu ? Puis appliquer le patch ?
Si oui, est-ce qu'il existe des dépots fournissants des image déjà compilé pour ubuntu ? (j'ai déjà compilé sous debian mais sous ubuntu, avec tout les patch qu'ils doivent ajouter aux kernels, ça à l'air un peu hasardeux. De plus je suis le spécialiste du kernel panic...:lol::lol:)

Sinon pour ne pas avoir à appliquer un patch il faut direct passer à 2.6.22 c'est ça ?

Pour info, le lien que j'ai indiqué a été rejoint pour un mec qui utilise gusty et qui a le même problème (kernel 2.6.21) on a pas le cul sortie des ronces !!!

edit :

Si oui, est-ce qu'il existe des dépots fournissants des image déjà compilé pour ubuntu ?

si je dois appliquer un patch ça paraît mal barré, 12 :30 ça fait tôt pour dire des conneries...:lol::lol:

Dernière modification par jlbiasini (Le 01/09/2007, à 12:39)


Debian Wheezy,  Ubuntu Natty.
ASUS K93SV: CORE I5 / Intel Sandy Bridge - nVidia GT540M - Optimus
Vous avez un bug ? - Déposez un brevet !

Hors ligne

#33 Le 01/09/2007, à 16:17

sdumasp

Re : Compiz-fusion lent

je ne pense pas... beaucoup de personnes arrivent à faire tourner Beryl ou Compiz-fusion très correctement avec du matériel nVidia et des configs moindres...


Ubuntu Hardy Heron 8.04  Linux 2.6.22-14-generic

Hors ligne

#34 Le 02/09/2007, à 04:38

jlbiasini

Re : Compiz-fusion lent

Bon alors, journée chargée :

Hier soir Ubuntu, ce matin Mandriva, cet aprèm Debian au moins ces conneries me fond voyager...
Et je suis en train d'aprendre précisément les connerie qui m'avait fait  abandonner Debian il y a quelque mois... Genre : "qu'est-ce qu'un module ?" "comment ça s'installe ?" mais en fait je vais aussi pouvoir en profiter sous Ubuntu c'est cool cool

Je me demande s'il ne serait pas possible de faire un fichier /etc/apt/preferences pour avoir tous les depot de etch - lenny - sid - experimental - drapper - feisty - gusty - mephis lol:lol: La putain d'usine à gaz que ça ferait !!!:lol::lol::D:D

Bon revenons à nos mouton : Sous mandrake c'est l'horreur j'ai même une fenêtre qui à fini par s'intégrer totalement à mon wall paper (peut-être le dernier effet metisse lol !!)

Debian, après quatre heure pour configurrer ma connection (euh ! j'ai quand même été un peu boulet je crois...:/ 4 de plus pour comprendre ce qu'est un module et comment installer ceux de nvidia...

Donc avec le kernel 2.6.18-4 c'est pareil qu'ubuntu (en un peu plus fluide évidement... un point pour toi sk8glad)

Bon mais ça on s'en doutait un peu que ça ramerait à peu près pareil... Donc étape suivante installer un noyau 2.6.20 et le corriger avec le drivers patché ... je suis pas prés de dormir moi !!!!


Debian Wheezy,  Ubuntu Natty.
ASUS K93SV: CORE I5 / Intel Sandy Bridge - nVidia GT540M - Optimus
Vous avez un bug ? - Déposez un brevet !

Hors ligne

#35 Le 02/09/2007, à 10:09

did

Re : Compiz-fusion lent

Salut,

sdumasp a écrit :

je ne pense pas... beaucoup de personnes arrivent à faire tourner Beryl ou Compiz-fusion très correctement avec du matériel nVidia et des configs moindres...

Ben en fait je sais pas si c'est lié à Nvidia,  mais j'ai moi aussi le même problème.

J'ai une config (Toshiba A100-110) qui devrait me permettre de largement faire tourner Compiz-fusion :
- Intel Core 2 Duo T7200 2.0 GHz
- 2G DDR2 de RAM
- NVIDIA GeForce Go 7300 512Mo (256 Mo dédiés + 256 Mo TurboCache)

Pourtant, la plupart des effets du plugin animation, sont lents et saccadés.
Les autres effets (cube, flip, expose...) ne posent pas de problème.

Je suis sous Kubuntu Feisty et j'ai installé Compiz-fusion des dépôts Trévino.
J'utilise le driver 100.14.11 installé manuellement à partir du .run (j'ai réessayé les deux versions précédentes sans résultat).

Je précise que j'utilisais Beryl et qu'il n'y avait aucun problème, tout était fluide. J'ai vraiment ressenti une différence lorsque je suis passé à Compiz-fusion.
J'ai aussi essayé de lancer Compiz avec les options --use-copy, --loose-binding, --indirect-rendering, --sm-disable ou --ignore-desktop-hints (séparement ou en combinaison) mais cela ne change rien.

Bon du coup je n'utilise aucune de ces animations (sauf l'avion en papier qui reste fluide) mais c'est vrai que j'aimerais bien trouver une solution.

A+

Dernière modification par did (Le 02/09/2007, à 10:11)

Hors ligne

#36 Le 02/09/2007, à 11:16

jlbiasini

Re : Compiz-fusion lent

Salut !

Apriori on parle pas de la même chose ou alors il y a une solution !

parce que moi j'ai le probleme avec compiz beryl et même metacity puisque ça concerne le rendu 2d à l'intérieur des fenêtre...

Pourrais tu te souvenir de ce que tu as fait entre beryl et l'installation de fusion ?

Dernière modification par jlbiasini (Le 02/09/2007, à 11:17)


Debian Wheezy,  Ubuntu Natty.
ASUS K93SV: CORE I5 / Intel Sandy Bridge - nVidia GT540M - Optimus
Vous avez un bug ? - Déposez un brevet !

Hors ligne

#37 Le 02/09/2007, à 15:34

sdumasp

Re : Compiz-fusion lent

j'ai l'air d'avoir les mêmes symptomes que did...
et c'est vrai que dans ton cas comme dans le mien, on a des configs suffisantes pour tout faire tourner sans problème...
est-ce que tu pourrais détailler les options que tu as utilisées par contre s'il-te-plait? (et puis c'est quoi cet effet de l'avion en papier? big_smile j'ai pas tout essayé!)


Ubuntu Hardy Heron 8.04  Linux 2.6.22-14-generic

Hors ligne

#38 Le 02/09/2007, à 18:16

did

Re : Compiz-fusion lent

jlbiasini a écrit :

Pourrais tu te souvenir de ce que tu as fait entre beryl et l'installation de fusion ?

Ben rien de particulier justement, j'ai désinstallé Beryl puis installé Compiz-Fusion et j'ai pu constater que le second tourne moins bien que le premier.

sdumasp a écrit :

est-ce que tu pourrais détailler les options que tu as utilisées par contre s'il-te-plait? (et puis c'est quoi cet effet de l'avion en papier?  j'ai pas tout essayé!)

Je ne sais pas à quoi correspondent exactement ces options, je les ai trouvées ici et sur le forum anglophone pour les utilisateurs de cartes nvidia. Tu peux les tester sans risque pour voir si ça change quelque chose chez toi, par exemple tu fais :

compiz --replace --use-copy

Tu peux aussi combiner plusieurs options :

compiz --replace --sm-disable --loose-binding --ignore-desktop-hints ccp

L'effet "avion en papier" c'est airplane du plugin animation.

A+

Hors ligne

#39 Le 02/09/2007, à 18:48

sdumasp

Re : Compiz-fusion lent

merci pour les précisions
effectivement ces commandes ne changent pas grand chose aux performances même en tentant différentes combinaisons mais encore faudrait-il savoir leurs effets précis pour chacune.
@ jlbiasini : est-ce un problème de kernel alors?


Ubuntu Hardy Heron 8.04  Linux 2.6.22-14-generic

Hors ligne

#40 Le 03/09/2007, à 00:07

jlbiasini

Re : Compiz-fusion lent

Bon alors la solution Debian + kernel 2.6.21 + drivers nvidia patché ne donne rien pour moi... Peut-être celà marche t'il avec les cartes récentes ? pour moi rien...

Prions pour que les nouveau drivers règle le problème... sad:(:(

Pour ceux qui veulent essayer, le plus dur pour moi a été de configurer mon modem pour avoir une connexion sous débian (quelle merde ce sagem 800!!), sinon vous avez image et headers 2.6.20 et 20 dans les dépots sid...

Vous lancez le .run situé  au site submentionné par sh ./NVIDIA-<patin-couffin>.run

et c'est parti !

Dernière modification par jlbiasini (Le 03/09/2007, à 00:12)


Debian Wheezy,  Ubuntu Natty.
ASUS K93SV: CORE I5 / Intel Sandy Bridge - nVidia GT540M - Optimus
Vous avez un bug ? - Déposez un brevet !

Hors ligne

#41 Le 09/09/2007, à 13:04

jlbiasini

Re : Compiz-fusion lent

De nombreuse personne sont bloqué par ce problème sur le site de nvidia linux

http://www.nvnews.net/vbulletin/showthread.php?p=1360861#post1360861


Debian Wheezy,  Ubuntu Natty.
ASUS K93SV: CORE I5 / Intel Sandy Bridge - nVidia GT540M - Optimus
Vous avez un bug ? - Déposez un brevet !

Hors ligne

#42 Le 14/09/2007, à 18:17

jajaX

Re : Compiz-fusion lent

hello

je me suis lancé dans la nouvelle aventure compiz fusion hier soir. verdict :

- sur mon laptop => ça tourne bien même très bien malgré la carte vidéo (intel 950) intégrée
- sur mon PC fixe => ça rame, ça plante.... j'ai pourtant une G6600 256 Mo... j'ai remis beryl....


@+
jajaX
Asus X93SM-YZ065V sous KDE Neon
ASUS N53SN sous Kubuntu 20.04 Focal Fossa (64 bits) / ACER Aspire 5612 WLMI sous Kubuntu 18.04 Bionic Beaver (32 bits)

Hors ligne

#43 Le 22/09/2007, à 09:26

sdumasp

Re : Compiz-fusion lent

ben on a plus qu'à attendre les prochaines versions de Compiz-fusion qui seront peut-être plus adaptée à nos nVIdia... mais bon ça a l'air de vite se développer je pense pas que ça soit trop long tongue


Ubuntu Hardy Heron 8.04  Linux 2.6.22-14-generic

Hors ligne

#44 Le 22/09/2007, à 09:33

TheKind

Re : Compiz-fusion lent

Bonjour, et moi je viens d'essayer d'installer compiz fusion sur ma fraiche installation d'ubuntu, mais il y a un problème:
Je pense bien avoir suivi parfaitement le tutoriel dans la doc (méthode des dépots trevino), mais quand je lance compiz, il utilise plus de 50% du CPU en permanence... et tout finit par se bloquer.

glxinfo | grep renderding me dit "Yes", et je tourne à 6435 FPS sous glxgears...
Où se situe le problème ???
Merci pour vos réponses.

Hors ligne

#45 Le 24/09/2007, à 12:57

timbolchevik

Re : Compiz-fusion lent

pareil, ma geforce 7100 en prend plein la gueule, alors que Quake 4 tourne à bloc chez moi, que sous beryl tout allait bien, enfin je suis d'accord c'est toujours une beta, mais l'option --loose-binding n'a rien changé chez moi hmm . Va falloir être patients wink

#46 Le 24/09/2007, à 13:19

sirius10

Re : Compiz-fusion lent

Salut
Idem pour moi j ai un pc portable neuf de trois mois qui tourne tres bien Geforece7400 (2Go ram, double couer) et le passage au dernier driver nvidia a été une catastrophe...plantage dans fierefox, ralentissement,.....j 'ai été obligé de reinstallé. Apres la reinstallation, et bien pareil mad  ces nouveaux drivers ont tout plantés, donc ce soir reinstall mais avec les anciens drivers glx smile:)

Bon courage, j espere que nvidia ou l 'equipe compiz (qu il faut encore felicité pour leur taf) feront bientot de nouvelle version plus adaptée....


"Pour ce qui est de l'Avenir, il ne s’agit pas de le prévoir, mais de le rendre possible."     
Antoine de Saint-Exupéry

Hors ligne

#47 Le 25/09/2007, à 20:50

timbolchevik

Re : Compiz-fusion lent

bah j'en veux pas à nvidia, ils font des efforts, ça reste du proprio mais merci de ne pas entrer dans ce troll, si on s'en sert c'est en toute conscience, ceci précisé, j'aurais plutot tendance à remercier nvidia pour ses efforts, bien que je soit sensible aux effort fait par amd recement et donc à la publication des spef' (nvidia je ne leur en voudrais pas pour autant de ne pas publier leurs spef' s'ils restent réactif sous 'nux). Ils ont été les premier à modifier leurs drivers pour notre jolie affichage composite, rien que pour ça... et ont des drivers plus souvent à jour que sous xp par ex, enfin je ne leur en veux pas et pour le moment j'ai confiance.

#48 Le 07/10/2007, à 21:32

Keldath

Re : Compiz-fusion lent

Bonjour/soir,

Je souffre également d'un manque de fluidité avec les effets du Bureau 3D sous Edgy et Feisty (le cube tourne bien, l' "ondulage" des fenêtres aussi, mais ça reste lent lorsqu'on navigue dans les menus, minimise les fenêtres, etc).

Au départ je pensais que ça venait de ma carte graphique (Radeon 9200 PRO), mais j'ai installé une Geforce FX 5200 en pensant résoudre tous mes problèmes de fluidité --> Même soucis.
J'ai pourtant fouillé de long en large, en m'appuyant sur la Doc et les divers topics du forum pour paramétrer correctement ces 2 CG. Le soucis ne viendrait donc pas forcément de la CG... ?
Autre info : glxgears fait monter la charge CPU à 100% sous Metacity, et avec les effets du Bureau 3D activés ça ne dépasse pas les 80%.

Y'aurait-il un rapport avec l'AGP sinon ?
Mon controleur et ma carte gèrent l'AGP, mais malgré mes tentatives d'activation (http://doc.ubuntu-fr.org/materiel/optimisation_nvidia), la commande

cat /proc/driver/nvidia/agp/status

me renvoie

Status:          Disabled

Je continue de chercher... smile

EDIT : J'ai fini par réussir à activer l'AGP, mais le problème reste entier.

Dernière modification par Keldath (Le 08/10/2007, à 19:03)

Hors ligne

#49 Le 09/10/2007, à 19:33

cedric84

Re : Compiz-fusion lent

bonjour,

Depuis la dernière mise à jour de compiz fusion sous feisty....ça marche pas terrible...je peux lancer qu'une seule application....

Ma configuration : AMD Ahtlon 3200+, 1 giga de ram, carte mere Asus M2nPV-VM avec carte graphique Nvidia geforce 6150. Résolution 1280 x 1024 Ecran samsung 21 pouces

Je précise qu'avant ma dernière mise à jour de compiz (hier 08102007), tout marchait nickel. J'utilisai la commande :

compiz --replace --indirect-rendering

Quelqu'un a t il rencontré des problèmes depuis la dernière maj ?

Dans l'attente, obligé de le désactiver....dur dur de s'en séparer !

Dernière modification par cedric84 (Le 09/10/2007, à 19:39)


A Abandonné Win$ en Aout 2007 ! Sous ubuntu depuis Feisty.
Actuellement sous Natty ! Acer extensa 7620.

Hors ligne

#50 Le 10/10/2007, à 19:31

cedric84

Re : Compiz-fusion lent

La solution evoquée sur le wiki consacré à compizfusion ne marche pas chez moi :
http://doc.ubuntu-fr.org/compiz_fusion

Depuis une mise à jour, certains possesseurs de carte Nvidia ont constaté de forts ralentissements, si vous les constatez, lancez compiz avec la commande

compiz --replace  --loose-binding.

Rappel :
jusqu'à présent je démarrai sans probleme compizfusion avec :
compiz --replace --indirect-rendering


J'ai essayé une combinaison des deux
compiz --replace --indirect-rendering --loose-binding
Sans succès....débutant sous linux...

Quelqu'un a t il solutionné ce problème ?


A Abandonné Win$ en Aout 2007 ! Sous ubuntu depuis Feisty.
Actuellement sous Natty ! Acer extensa 7620.

Hors ligne