Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 03/09/2007, à 21:43

vince-60

(Résolu, devenu tuto !)Grub : problème ordre des disques IDE et SATA

Bonjour,

Voila mon problème.
J'ai une carte mère avec 6 ports SATA, et une (seule) nappe IDE (donc pour 2 périphériques).

Je souhaite installer Ubuntu (Feisty) sur le disque IDE (pour avoir un deuxième Ubuntu indépendant dans mon système).
Le boot du liveCD se passe sans soucis, ainsi que l'install. Le disque dur est bien reconnu.
Je peux créer mes partitions sans problème.
A la fin, il me dit qu'il install Grub sur (hd0).

Mais, au reboot et au lancement de grub, il me met une erreur 21 (disque non trouvé).

Je suis pas mal certain qu'il se prend les pieds dans le tapis entre les 6 SATA et l'IDE.
Bien que les disques SATA soient tous débranchés, je pense que mon IDE se retrouve en (hd6) (7eme disque dur).
Seulement, si pendant l'install, à la fin, je précise (hd6) plutôt que (hd0), ça ne marche pas mieux (même erreur).

Alors ma question : comment faire pour installer un Ubuntu sur un disque IDE branché sur une carte mère qui possède des ports SATA ? Quelqu'un a-t-il déjà rencontré le problème ?
EDIT : Y'a-t-il un ordre des disques durs SATA et IDE, même si tous les SATA ne sont pas branchés ?
Dans le bios, j'ai d'abord les 6 SATA (dont 3 à none), puis les périphériques IDE.

Merci à vous tous !
Vince.

******

Précisions :
carte mère ASUS P5B-Deluxe,
Ubuntu Feisty,
Disque IDE en maître,
CDROM en esclave.
Seul doûte : ordre de branchement sur la nappe IDE : disque dur au milieu, puis CDRom en bout de nappe. Peut-être devrais-je essayer d'inverser.

EDIT : Disque dur en maitre en bout de nappe (étiquetée "HDD"), et CDRom au milieu.

Dernière modification par vince-60 (Le 23/09/2007, à 00:47)

Hors ligne

#2 Le 04/09/2007, à 02:12

vince-60

Re : (Résolu, devenu tuto !)Grub : problème ordre des disques IDE et SATA

Alors je vais compléter mon problème.

Je fais des tests en ce moment même, et il se trouve que le disque IDE se place en premier disque, en /dev/sda (oui oui, sda, et non hda).
Mon disque habituel de boot (SATA1) se retrouve en /dev/sdb

Dans mon /boot/grub/device.map, il est spécifié que /dev/sda, c'est hd0, et /dev/sdb, c'est hd1.
Dans mon menu.lst, c'est toujours hd0 qui est censé booter. Donc, le boot devrait se retrouver sur le nouveau disque IDE que j'ai mis, et donc déconner.

Mais non, tout va bien. J'ai bouté sur mon disque habituel SATA1 (théoriquement hd1) comme si de rien n'était.

La notion d'ordre avec des disques IDE et SATA est vraiment bizarre.
Je suis même persuadé que des fois, mon IDE se retrouve à la fin (en /dev/sdd).

Comment pouvons-nous remédier à cette question ?

Hors ligne

#3 Le 04/09/2007, à 03:13

vince-60

Re : (Résolu, devenu tuto !)Grub : problème ordre des disques IDE et SATA

Bon, là, j'ai la confirmation : mon IDE se trouve soit en premier disque (sda), soit en dernier (sdd).
Cependant, ça n'empêche pas mon système de booter. Je me demande comment il sait où se trouve vraiment le hd0.

Hors ligne

#4 Le 04/09/2007, à 17:48

vince-60

Re : (Résolu, devenu tuto !)Grub : problème ordre des disques IDE et SATA

Je continue à me répondre à moi même.

Résumé du démarrage du PC :

- Le BIOS détecte tous les disques (SATA et IDE), et pleins d'autres choses.
Il sait aussi vers quels périphériques donner la main, et dans quel ordre de préférence.

- Le disque dur défini dans la séquence de boot du BIOS (le SATA1) se retrouve donc avec le devoir de booter.
Sur ce disk, il y a grub dans le MBR.
---> Je pense qu'à ce moment là, mon disque IDE n'est plus reconnu/détecté par Grub. Donc, que l'IDE soit déclaré en première place ou en dernière, le SATA1 se retrouve de toute façon en hd0.
Grub lit le menu.lst, où il est écrit de booter sur hd0,1 (pour Ubuntu).
Le démarrage se fait donc sans problème.

- Arrivé sous Ubuntu, mon disque IDE est de nouveau reconnu (par un fdisk -l). Même sous Grub, cette fois, ça marche : un "find /boot/grub/stage1" renvoie comme réponse hd0,0 et hd1,1 (ou hd0,1 et hd3,0 si le disque IDE se retrouve en dernière position).

Donc, toujours mes 2 questions :

* pourquoi l'IDE n'est pas reconnu au moment où il le devrait, empêchant Grub de lancer le démarrage dessus ?
* pourquoi mon disque IDE se retrouve des fois en première place, des fois en dernière ?

Allez, je suis sûr de ne pas être le seul à se poser ces questions psychodébiliques.
Merci smile

Hors ligne

#5 Le 04/09/2007, à 17:56

Compte anonymisé

Re : (Résolu, devenu tuto !)Grub : problème ordre des disques IDE et SATA

Salut

Ce qui serait pas mal c'est de lister qq infos :
Indiquer quel est le disque de boot (si tu changes de disque les infos listées ont toutes les chances de changer aussi).
Déjà le résultat de :
sudo fdisk -l depuis le livecd mais aussi depuis le disque de boot si tu réussis à démarrer ubuntu.
Lister les fichiers :
/boot/grub/menu.lst et
/etc/fstab

@+

#6 Le 06/09/2007, à 19:41

vince-60

Re : (Résolu, devenu tuto !)Grub : problème ordre des disques IDE et SATA

Salut,

J'ai pas mal progressé sur mon problème, et je vais expliquer ce que j'ai fait.
Je vais donner le contenu de ses fichiers après ceci :

Rappel : carte mère Asus P5B-Deluxe.

Sur ma carte mère, j'ai les ports suivants : SATA1, SATA2, ... SATA6. Ainsi qu'un controlleur IDE (un seul).
Les 1, 2, 5, et 6 sont rouges, les 3 et 4 sont noirs (déjà bizarre, fonctions différentes ?)
Les prises ne sont pas alignées dans l'ordre de leur numéros :
SATA5   SATA2   SATA1
SATA6   SATA4   SATA3

Bref.

1ere partie, celle qui ne pose plus de problème

Mes branchements actuels, avec lesquels je vais travailler :
SATA1 : disque1 80Go (WinXP + Ubuntu + swap)
SATA2 : disque2 20Go (Debian + Kubuntu + 10 Go de libres) - disque IDE avec adaptateur ide --> Sata
SATA3 : disque3 180 Go (stockage) - disque IDE avec adaptateur ide --> Sata

Mon grub "principal" est sur le MBR du disque1. Dans son menu.lst, j'ai un choix me permettant d'aller booter sur les différentes partitions du disque2 (entré manuellement après les installes de Debian puis de Kubuntu).
Sur le disque2, j'ai deux partitions, équipée chacune d'elle d'un grub me permettant de booter sur Debian ou Kubuntu. A la fin des installes de ces 2 distribs, j'ai bien sûr bien précisé (dans "advanced options", dernier bouton avant l'installe pour Kunbutu) que je voulais grub sur (hd1,1) (ou (hd1,2)) et non (hd0) qui est le choix par défaut.

Jusqu'à maintenant, la présence du disque3 empêchait le boot correct sur le disque2. Ce disque n'était même pas détecté par le grub du disque1 (error de chargement), ni lors des installes de Debian ou Kubuntu, ni en bootant avec le CDRom "Super Grub disk" (peut-être connaissez-vous, cela permet entre autre d'effacer grub ou de le remettre sur un disque ou une partition. Moi, ca me permet surtout de constater que mon disque est détecté ou pas.)
--> Pour y remédier, j'ai du flasher mon BIOS. J'ai gagné 1 an d'évolution (passage de la version du 29/09/2006 à celle du 14/08/2007).
Là, la présence des 3 disques SATA ne posait plus problème.

MAIS : grub ne voyait pas correctement les disques, pas dans le bon ordre.
Si le disque1 était vu en (hd0) (donc correct), le (hd1) était le disque3, et le (hd2) était le disque2. Alors qu'un "fidsk -l" positionnait correctement les disques.
Si cela n'était pas bloquant en soit, ce manque de logique me consternait.
--> Modification dans le BIOS. J'ai passé en compatibilité "RAID" mon contrôleur SATA. Je n'avais jusqu'à maintenant pas osé, de peur qu'il me flingue mes disques en voulant me construire un raid.
Maintenant, mes 6 contrôleurs SATA ont la possibilité d'être montés en RAID. En fait, ce ne change rien, sauf au boot, "CTRL-i" me propose cette fonctionnalité.
Bonne surprise, "Super Grub Disque" voit mes disques SATA dans le bon ordre !

Détail de mes fichiers en question :

[b]root@vincent-ubuntu:/home/vincent# fdisk -l[/b]

Disque /dev/sda: 80.0 Go, 80026361856 octets
255 têtes, 63 secteurs/piste, 9729 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sda1   *           1        4589    36861111    7  HPFS/NTFS
/dev/sda2            4590        9215    37158345   83  Linux
/dev/sda3            9216        9729     4128705   82  Linux swap / Solaris

Disque /dev/sdb: 20.4 Go, 20404101120 octets
255 têtes, 63 secteurs/piste, 2480 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sdb1               1         608     4883728+  83  Linux
/dev/sdb2             609        1216     4883760   83  Linux

Disque /dev/sdc: 185.2 Go, 185283624960 octets
255 têtes, 63 secteurs/piste, 22526 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets

Périphérique Amorce    Début         Fin      Blocs    Id  Système
/dev/sdc1               1       22526   180940063+  83  Linux

Vous remarquerez qu'il n'y a pas de secteur d'amorce (*) sur le sdb malgrés la présence d'autres distribs bootables. .

menu.lst de mon disque1 (grub dans le mbr)

[b]root@vincent-ubuntu:/home/vincent# more /boot/grub/menu.lst[/b]

# je vous passe les commentaires...
default         0
timeout         10
#hiddenmenu

## ## End Default Options ##

splashimage=/boot/grub/splashimages/hubble.xpm.gz

title           Ubuntu, kernel 2.6.20-16-generic
root            (hd0,1)
kernel          /boot/vmlinuz-2.6.20-16-generic root=UUID=cbfb8fed-0716-427c-8c4e-087e43777155 ro quiet splash loca
le=fr_FR
initrd          /boot/initrd.img-2.6.20-16-generic
quiet
savedefault

title           Ubuntu, kernel 2.6.20-16-generic (recovery mode)
root            (hd0,1)
kernel          /boot/vmlinuz-2.6.20-16-generic root=UUID=cbfb8fed-0716-427c-8c4e-087e43777155 ro single
initrd          /boot/initrd.img-2.6.20-16-generic

title           Ubuntu, kernel 2.6.20-15-generic
root            (hd0,1)
kernel          /boot/vmlinuz-2.6.20-15-generic root=UUID=cbfb8fed-0716-427c-8c4e-087e43777155 ro quiet splash loca
le=fr_FR
initrd          /boot/initrd.img-2.6.20-15-generic
quiet
savedefault

title           Ubuntu, kernel 2.6.20-15-generic (recovery mode)
root            (hd0,1)
kernel          /boot/vmlinuz-2.6.20-15-generic root=UUID=cbfb8fed-0716-427c-8c4e-087e43777155 ro single
initrd          /boot/initrd.img-2.6.20-15-generic

title           Ubuntu, memtest86+
root            (hd0,1)
kernel          /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title           Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title           Microsoft Windows XP Professionnel
root            (hd0,0)
savedefault
makeactive
chainloader     +1


# Debian Etch installé sur /dev/sdb1
title           Debian Etch 4.0 (hd1,0)
root            (hd1,0)
chainloader +1
boot

# Kubuntu installée sur /dev/sdb2
title           Kubuntu 7.04 (hd1,1)
root            (hd1,1)
chainloader +1
boot
menu.lst du disque2, partition1 (Debian) (après montage de la partition dans /mnt)

[b]root@vincent-ubuntu:/home/vincent# more /mnt/boot/grub/menu.lst[/b]

## ## End Default Options ##

title           Debian GNU/Linux, kernel 2.6.18-5-686
root            (hd1,0)
kernel          /boot/vmlinuz-2.6.18-5-686 root=/dev/sdb1 ro 
initrd          /boot/initrd.img-2.6.18-5-686
savedefault

title           Debian GNU/Linux, kernel 2.6.18-5-686 (single-user mode)
root            (hd1,0)
kernel          /boot/vmlinuz-2.6.18-5-686 root=/dev/sdb1 ro single
initrd          /boot/initrd.img-2.6.18-5-686
savedefault

### END DEBIAN AUTOMAGIC KERNELS LIST
menu.lst du disque2, partition2 (Kubuntu) (après montage de la partition dans /mnt)

[b]root@vincent-ubuntu:/home/vincent# more /mnt/boot/grub/menu.lst[/b]

## ## End Default Options ##

title           Ubuntu, kernel 2.6.20-15-generic
root            (hd1,1)
kernel          /boot/vmlinuz-2.6.20-15-generic root=UUID=f743c921-d320-4041-859f-e6a2621704b7 ro quiet splash loca
le=fr_FR
initrd          /boot/initrd.img-2.6.20-15-generic
quiet
savedefault

title           Ubuntu, kernel 2.6.20-15-generic (recovery mode)
root            (hd1,1)
kernel          /boot/vmlinuz-2.6.20-15-generic root=UUID=f743c921-d320-4041-859f-e6a2621704b7 ro single
initrd          /boot/initrd.img-2.6.20-15-generic

title           Ubuntu, memtest86+
root            (hd1,1)
kernel          /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST
Enfin ma fstab qui heureusement ne fonctionne plus avec les sda ou autres sdb, mais avec les ids des disques :

[b]root@vincent-ubuntu:/home/vincent# more /etc/fstab[/b]

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# /dev/sda2
UUID=cbfb8fed-0716-427c-8c4e-087e43777155 /               ext3    defaults,errors=remount-ro 0       1
# /dev/sda1
UUID=B0A86745A86708E4 /media/disquec  ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
# /dev/sdc1
UUID=49ef1862-878b-4b93-a9fa-1eeef8a2bec4 /media/disqued  ext3    defaults        0       0
# /dev/sda3
UUID=6a35caaa-cc32-42e2-8f94-061102d30ed0 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0

Dans cette configuration, tout marche bien (maintenant !)
Donc, je répète :

- Flashage du BIOS
- Configuration des SATA en RAID

2eme partie, celle qui pose toujours des problèmes

Avec la config ci-dessus, j'ai rajouté mon fameux disque IDE.
Celui-ci est maintenant bien détecté par grub. La flashage du BIOS a fait du bien à la puce JMicron (qui s'occupe de gérer tout ca sur ma carte mère).

Cependant, malgrés la configuration RAID de mon contrôleur IDE, mon disque IDE aparaît tantôt en premier (sda), tantôt en dernier (sdd).

Conclusion pour ceux qui ont eu le courage de lire jusqu'ici :

Je pense pouvoir maintenant installer quelquechose sur mon IDE seul et booter dessus.
Mais si d'autres disques SATA sont présents, alors mon IDE n'est pas sûr d'être vu en (hd0), ou en (hd3). Donc boot non assuré.
La question reste en suspens : Pourquoi l'IDE change ainsi de place dans l'ordre des disques durs ?

nb :
disque dur IDE en esclave, milieu de nappe.
CDRom IDE en maître, en bout de nappe.

Voilà, j'espère que mon bref résumé pourra aider des personnes dans le même cas que moi. J'ai parcouru d'autre forums, et vu que je n'étais pas le seul. Et puis c'est très formateur d'avoir tous ces soucis. Quand on en ressort et que ça marche, on se dit vraiment : bon sang, Linux, quand même, c'est quelque chose. Mon pauvre WinXP est tout seul sur sa première partition, et n'est pas très fier de ne pas proposer toutes ces possibilités.
Bon, pis si quelqu'un sait me répondre sur ma dernière question, je suis preneur.

Merci cool

Dernière modification par vince-60 (Le 06/09/2007, à 19:47)

Hors ligne

#7 Le 23/09/2007, à 00:41

vince-60

Re : (Résolu, devenu tuto !)Grub : problème ordre des disques IDE et SATA

Bonjour,

Je profite d'une installation de Debian pour dire ceci :

J'ai encore progressé sur toute cette histoire, concernant ma carte mère capricieuse.

1-Ordre des disques dans Grub (a l'initialisation de la machine).
En fait, cet ordre ne dépend pas du paramètre du BIOS : IDE, AHCI, ou RAID.

C'est directement dans l'un des derniers menus qu'il faut agir. Il y a marqué quelquepart "ordre des disques" (Ben oui, fallait y penser...). C'est bien l'ordre de préférence de démarrage, ordre que l'on retrouve directement avec Grub au démarrage.

Donc, important, bien vérifier ce paramètre du BIOS, et choisir ce que l'on veut.


2-Ordre des disques SATA une fois sous Ubuntu (ou Debian...).

Dans le BIOS, on a trois choix possibles :

IDE : faire passer le contrôleur SATA en contrôleur IDE standard.
Il faut savoir que l'installation de WinXP Pro n'est possible (sans disquette supplémentaire ou CD d'installe transformé) qu'avec ce paramètre.

AHCI : pour Advanced ... Controler ....
Bref, c'est l'IDE avancé. Permet notamment d'agir sur ces disques durs (réduire le bruit au détriment des performances...) Enfin, c'est ce que j'ai compris.

RAID : pour mettre plusieurs disques durs en RAID.

Personnellement, j'étais en IDE.
Avec 4 disques SATA branchés, il y avait une inversion entre SATA2 et SATA3. (Le 2 se retrouvait en sdc et le 3 en sdb). (De plus, l'installe de Debian ne détectait que 2 de mes disques...)
En passant le BIOS en "AHCI", le bon ordre était respecté, et je suis en train d'installer Debian sur mon SATA2.

A noter que je n'ai plus de disque branché sur nappe IDE. Donc, la question reste soulevée...

3-Conclusion

Donc, finalement :
- Flashage du BIOS pour avoir une version récente.
- Configuration SATA en AHCI (si pas de RAID dans votre PC). Linux sera content et mettra les disques à leur place.
- Vérifier l'ordre des disques durs au démarrage. Attention, cet ordre peut changer si on change le paramètre de config SATA. Donc, vérifier en dernier avant de relancer le PC.

Avec ca, on est correct.

Sauf Windows si vous l'avez installé a partir d'un controleur IDE et non AHCI !!
Je vous invite à voir cette procédure pour réparer cette bévue : http://forum.hardware.fr/hfr/Hardware/C … 8242_1.htm
(rechercher ce texte : "Procédure pour installer l'AHCI après installation de Windows")
Prenez soin avant de faire un nouveau profil matériel, au cas ou, et travailler avec... (voir doc sur vmware, tout y est marqué a ce sujet de profil matériel).

Ouf !

Dernière modification par vince-60 (Le 24/09/2007, à 05:43)

Hors ligne