Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 22/10/2007, à 18:18

jjcojax

Faire fonctionner le réseau avec Ubuntu

Bonjour,

J'ai fouillié les tutos et le forum de votre site, mais ne vois pas ce qui coince chez moi ...:(

Je n'arrive pas a faire fonctionner le réseau sur une installation Ubuntu (7.10) (ou 7.04 sur live CD)

Je donne une adresse et masque réseau à mes 2 cartes réseau que le gestionnaire de périphérique semble reconnaître.

il y a:
Une 3c900 (3com combo coax-rj45) (eth0 192.168.0.1)(celle qui m'intéresse d'abord)
Une RTL 8139 (Realtec) (eth1 192.168.100.1) (fait partie de la carte mère)
Un modem ADSL USB (->pour après car il fonctionne + -)

config du réseau via le live CD

Est-il normal d"avoir connexion filaire ?
Si je fais un ping vers mes autres machines (Windows 98, NT4, 2000, XP) pas de réponce.

La machine a les même adresses que sous Windows et avec lui, je peux sans problème communiquer par les 2 cartes réseau

Merci à celui qui peut me faire avancer sous un Linux que je découvre smile

#2 Le 23/10/2007, à 09:17

jjcojax

Re : Faire fonctionner le réseau avec Ubuntu

Bonjour,

Un petit up

et j'apporte de l'info supplémentaire ...

La carte 3com 3c900 combo comporte 2 connexions (Coax et RJ45)

Sous Windows, c'est le réseau en coax qui est branchée sur cette carte et cela fonctionne.

Avec Ubuntu je peux uniquement utiliser la connexion RJ45 de cette carte !

Qu'est ce que je dois faire avaler à Ubuntu pour qu'il communique par la partie coax de cette carte.

Merci

Dernière modification par jjcojax (Le 24/10/2007, à 10:50)

Hors ligne

#3 Le 20/11/2007, à 13:51

jjcojax

Re : Faire fonctionner le réseau avec Ubuntu

Re Bonjour,

Comme je n'arrive pas à faire fonctionner cette carte (3c900 combo) pour le COAX, j'indique ce que j'ai essayé sans succès afin d'avoir une autre piste.

Commande ethtool:

jjcojax@ubuntu-7:~$ sudo ethtool --h
ethtool version 5
Usage:
ethtool DEVNAME Display standard information about device
        ethtool -s|--change DEVNAME     Change generic options
                [ speed 10|100|1000 ]
                [ duplex half|full ]
                [ port tp|aui|bnc|mii|fibre ]
                [ autoneg on|off ]
                [ phyad %%d ]
                [ xcvr internal|external ]
                [ wol p|u|m|b|a|g|s|d... ]
                [ sopass %%x:%%x:%%x:%%x:%%x:%%x ]
                [ msglvl %%d ]

résultats:

jjcojax@ubuntu-7:~$ sudo ethtool -s eth0 port mii -> ok
jjcojax@ubuntu-7:~$ sudo ethtool -s eth0 port bnc -> ce que je veux
Cannot set new settings: Invalid argument
  not setting port

J'ai essayé ifconfig:

SYNOPSIS
       ifconfig [-v] [-a] [-s] [interface]
       ifconfig [-v] interface [aftype] options | address ...
bla-bla
        media type
              Set the physical port or medium type to be used by  the  device.
              Not all devices can change this setting, and those that can vary
              in what values  they  support.   Typical  values  for  type  are
              10base2 (thin Ethernet), 10baseT (twisted-pair 10Mbps Ethernet),
              AUI (external transceiver) and so on.  The special  medium  type
              of  auto can be used to tell the driver to auto-sense the media.
              Again, not all drivers can do this.

Résultats:

jjcojax@ubuntu-7:~$ sudo ifconfig -s eth0 media 10base2
port: SIOCSIFMAP: Opération non supportée
jjcojax@ubuntu-7:~$

et mii-diag me donne:

jjcojax@ubuntu-7:~$ sudo mii-diag eth0
Basic registers of MII PHY #0:  0000 ffff 0000 ffff 0000 ffff 0000 ffff.
 The autonegotiated capability is 0000.
No common media type was autonegotiated!
This is extremely unusual and typically indicates a configuration error.
Perhaps the advertised capability set was intentionally limited.
 Basic mode control register 0x0000: Auto-negotiation disabled, with
 Speed fixed at 10 mbps, half-duplex.
 Basic mode status register 0xffff ... ffff.
   Link status: established.
 Remote fault detected!
   *** Link Jabber! ***
 Your link partner advertised ffff: Flow-control 100baseT4 100baseTx-FD 100baseTx 10baseT-FD 10baseT, w/ 802.3X flow control.
   End of basic transceiver information.

Est-ce le pilote 3c59x qui ne convient pas (c'est l'install de Ubuntu qui l'a choisis)

Sur un ancien Pentium3, je peux faire fonctionner un carte ISA PNP du même genre (3c509 également COAX / RJ45) (merci à ZERGY)

La 3c900 est plus récente et en PCI (car il n'y a plus de slot ISA sur les pentium 4)

Merci de n'indiquer ce que je peux faire. (ou m'envoyer sur un autre forum neutral )

Dernière modification par jjcojax (Le 04/04/2008, à 10:24)

Hors ligne

#4 Le 11/02/2008, à 12:02

jjcojax

Re : Faire fonctionner le réseau avec Ubuntu

Bonjour,

Je fais encore un up !

Comme les pilotes 3c59x  ne conviennent pas pour faire fonctionner une carte 3com 3c900 combo vers le coax (mais seulement en RJ45) ...

Puiis je faire quelque chose avec de tout vieux pilotes de chez 3com (par ex. créer un fichier .o = objet)
si cela peux aider, j'obtiens ces fichiers

Merci

Dernière modification par jjcojax (Le 04/04/2008, à 10:19)

Hors ligne