Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 28/10/2005, à 00:48

tichadok

ATI radeon 9800 pro fglrx : unable to acquire AGP, error "xf86_ENOMEM"

Bonjour,

Désolé de poster un sujet repris à plusieurs reprises, mais je pense avoir suivi toutes les étapes à chaque fois, sans succès.:/
j'ai vraiment tout essayé, les pilotes ATI officiels, ceux d'Ubuntu, les forums ubuntu france et ubuntu en anglais,et même google, et rien n'y fait: toujours la même erreur
(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENOMEM"
(EE) fglrx(0): cannot init AGP
au démarrage du serveur Xorg 6.8
Je me résigne à poster aprés avoir lu ce que les autres personnes ont déjà posté.;)

J'ai une carte mère SiS:
$ lspci | grep bridge

0000:00:00.0 Host bridge: Silicon Integrated Systems [SiS] 760/M760 Host (rev 02)
0000:00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SG86C202
0000:00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS964 [MuTIOL Media IO] (rev 36)

donc comme indiqué sur les forums, j'ai rajouté les lignes:
contenu de /etc/modules:

agpgart
sis-agp
fglrx

et après démarrage les modules sont bien lancés:
$ lsmod | grep agp

sis_agp                 8452  1
agpgart                32328  2 fglrx,sis_agp

Bien sûr, dans le fichier xorg.conf je n'ai pas oublié Option "UseInternalAGPGART" "no"

contenu de /etc/X11/xorg.conf:

Section "Device"
    Identifier    "ATI Technologies, Inc. Radeon 9800 Pro (R350 NH)"
    Driver        "fglrx"
    Option "UseInternalAGPGART" "no"
    BusID        "PCI:1:0:0"
EndSection

voilà ce que retourne la commande
$dmesg | grep agp

[4294690.530000] Linux agpgart interface v0.101 (c) Dave Jones
[4294690.550000] agpgart: Detected SiS 760 chipset
[4294690.574000] agpgart: AGP aperture is 4M @ 0xe0000000
[4294717.174000] [fglrx] Kernel AGP support doesn't provide agplock functionality.

et enfin l'erreur qui ne veut pas partir, erreur quand tu nous tiens ....
$cat /var/log/Xorg.0.log

(II) fglrx(0): [drm] DRM interface version 1.0
(II) fglrx(0): [drm] created "fglrx" driver at busid "PCI:1:0:0"
(II) fglrx(0): [drm] added 8192 byte SAREA at 0xf0efd000
(II) fglrx(0): [drm] mapped SAREA 0xf0efd000 to 0xb7b17000
(II) fglrx(0): [drm] framebuffer handle = 0xd0000000
(II) fglrx(0): [drm] added 1 reserved context for kernel
(II) fglrx(0): DRIScreenInit done
(II) fglrx(0): Kernel Module Version Information:
(II) fglrx(0):     Name: fglrx
(II) fglrx(0):     Version: 8.16.20
(II) fglrx(0):     Date: Aug 16 2005
(II) fglrx(0):     Desc: ATI FireGL DRM kernel module
(II) fglrx(0): Kernel Module version matches driver.
(II) fglrx(0): Kernel Module Build Time Information:
(II) fglrx(0):     Build-Kernel UTS_RELEASE:        2.6.12-9-386
(II) fglrx(0):     Build-Kernel MODVERSIONS:        no
(II) fglrx(0):     Build-Kernel __SMP__:            no
(II) fglrx(0):     Build-Kernel PAGE_SIZE:          0x1000
(II) fglrx(0): [drm] register handle = 0xe5000000
(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENOMEM"
(EE) fglrx(0): cannot init AGP
(II) fglrx(0): [drm] removed 1 reserved context for kernel
(II) fglrx(0): [drm] unmapping 8192 bytes of SAREA 0xf0efd000 at 0xb7b17000
(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed!                  *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO)             *
(WW) fglrx(0): * no 3D acceleration available                *
(WW) fglrx(0): ********************************************* *
(II) fglrx(0): FBADPhys: 0xd0000000 FBMappedSize: 0x08000000
( == ) fglrx(0): Write-combining range (0xd0000000,0x8000000)

Je pense avoir donné toutes les clés, deux questions donc:
1/ comment éviter cette erreur?
2/ Comment se fait-il que "agpgart: AGP aperture is 4M @ 0xe0000000" alors que ma carte a  128Mo et que dans le BIOS je ne trouve vraiment rien pour changer cet aperture size ?

Merci beaucoup !:P

Hors ligne

#2 Le 16/12/2005, à 15:27

kris14

Re : ATI radeon 9800 pro fglrx : unable to acquire AGP, error "xf86_ENOMEM"

Salut,

J'ai exactement le même problème, les mêmes erreurs, ... J'ai aussi essayé de plusieurs manières, toujours aucun résultat.
As-tu  réussi à le régler et si oui, comment?
Si vous avez des idées au problème, n'hésitez pas.

Merci

#3 Le 03/06/2006, à 03:40

tichadok

Re : ATI radeon 9800 pro fglrx : unable to acquire AGP, error "xf86_ENOMEM"

Toujours la même erreur sous Dapper Drake ...

Pourquoi personne PERSONNE ne peut nous aider ?? ça va bientôt faire 1 an que je traine avec cette erreur et toujours pas de solution !

Merci pour votre aide !

Je rajoute une info supplémentaire :

dmesg | grep fglrx
[4294699.487000] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[4294699.489000] [fglrx] Maximum main memory to use for locked dma buffers: 680 MBytes.
[4294699.489000] [fglrx] module loaded - fglrx 8.25.18 [May 18 2006] on minor 0
[4294700.828000] [fglrx] AGP detected, AgpState   = 0x1f004e0b (hardware caps of chipset)
[4294700.828000] [fglrx:firegl_unlock] *ERROR* Process 4626 using kernel context 0

et toujours :

cat /var/log/Xorg.0.log | grep EE
Current Operating System: Linux sam 2.6.15-23-386 #1 PREEMPT Tue May 23 13:49:40 UTC 2006 i686
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
(EE) fglrx(0): [agp] unable to acquire AGP, error "xf86_ENOMEM"
(EE) fglrx(0): cannot init AGP
(EE) fglrx(0): === [R200DALSetDisplayConfig] === CWDDC DisplaySetConfig failed: 6
(EE) xf86OpenSerial: Cannot open device /dev/wacom

J'ai essayé ces solutions sans succès:

Question 4.3: When I try to start X, it fails with a message saying it was 'unable to acquire AGP, error "xf86_ENOMEM"'
This error is generally more difficult to diagnose and fix than the "xf86_ENODEV" error. Some things to try:

    * If you are using the kernel AGP support (ie "UseInternalAGPGART" is set to "no"), ensure that you have the necessary modules (agpgart + chipset-specific module) loaded BEFORE loading the fglrx module. For example, if you have a VIA motherboard, load the "agpgart" and "via-agp" modules, then load the fglrx module (on 2.4 kernels, you only have to load the "agpgart" module). If you had an nForce board, you would load "agpgart" and "nvidia-agp", followed by fglrx, and so on for the other chipset types.
    * Increase your AGP aperture size in the BIOS (particularly for nForce2 boards)
    * If you have an nForce2 board, try disabling the "AGP 8x Support" option in the BIOS.
    * Check that you haven't set "UseInternalAGPGART" to "yes" and have your kernel AGP settings compiled in (this won't work)
    * Set "UseFastTLS" to "2" in your XF86Config/xorg.conf file.
    * Try adding the line
      Option "KernelModuleParm" "agplock=0"
      to your xorg.conf file (in the same place as the other ATI-specific options).
    * Check the output of the "dmesg" command for errors.
    * Check that your kernel configuration is correct.
    * Try a newer kernel version.

You need some support for your AGP chipset. You have two choices: the ATI driver's built-in AGP support or the kernel agpgart driver. It's difficult to say in advance which one is better or will work at all, because it depends on the exact driver and kernel versions you're using, but the kernel driver should be your preferred choice if it works for you. To use the kernel driver, add the following line to the "Device" section of your X server config file:

Option "UseInternalAGPGART" "no"

The X server configuration is discussed in more detail below, but the AGP configuration is important so I'm mentioning this detail early because I'd like to make sure that it sticks in your memory somewhere.

The error unable to acquire AGP, error "xf86_ENOMEM" in your X server log usually means that you are using the built-in AGP support with an unsupported chipset. Set "UseInternalAGPGART" to "no" and load the kernel driver (see below for details) which will hopefully support your AGP chipset.
If you want to use the ATI driver's built-in AGP support instead, set "UseInternalAGPGART" to "yes" (it's the default setting, so you can just omit it) and make sure that the kernel driver is not compiled into your kernel: either compile it as a module or disable it entirely. Beware that discover (and possibly other hardware detection tools) might try to load the kernel driver automatically during startup. If that happens to you, you can tweak discover's configuration or you can simply move the agpgart.* files away from /lib/modules.

If neither one supports your chipset, try using the kernel driver with the agp_try_unsupported=1 option on the kernel command line or as a parameter when you load the module.

Note that in the 2.6 kernel the AGP chipset drivers are separate from the agpgart driver itself, so if you build them as modules you will need to load the agpgart module and a chipset module such as via-agp, nvidia-agp, etc.

Dernière modification par tichadok (Le 03/06/2006, à 16:01)

Hors ligne