Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 17/09/2014, à 15:12

maxire

Re : [Bug] polkit-gnome-authentication-agent-1[Résolu]

Cela valait le coup de vérifier, polkit et l'agent d'identification utilisateur polkit sont bien lancés....

Donc pkexec renvoie un message d'erreur, synaptic démarre mais peux-tu travailler avec?


Maxire
Archlinux/Mate + Ubuntu 18.04 + Lubuntu 18.04 + Archlinux/Gnome + Windows 10 Familial sur portable -- Archlinux/Mate sur poste de travail

Hors ligne

#27 Le 17/09/2014, à 16:12

maxire

Re : [Bug] polkit-gnome-authentication-agent-1[Résolu]

Bon, ce n'est sans doute pas polkit le problème puisque la configuration est bonne, mais plutôt pam (Pluggable Authentication Modules for Linux).
En bref la base des mots de passe/groupe ,,, est corrompue, c'est du moins ce qui semble être expliqué dans au moins 2 des résultats de cette recherche:
https://duckduckgo.com/?q=pkexec+Error+ … +dismissed
Comment le réparer?
Aucune idée.

Dernière modification par maxire (Le 17/09/2014, à 16:13)


Maxire
Archlinux/Mate + Ubuntu 18.04 + Lubuntu 18.04 + Archlinux/Gnome + Windows 10 Familial sur portable -- Archlinux/Mate sur poste de travail

Hors ligne

#28 Le 18/09/2014, à 11:23

WanaXub

Re : [Bug] polkit-gnome-authentication-agent-1[Résolu]

maxire a écrit :

1/Cela valait le coup de vérifier, polkit et l'agent d'identification utilisateur polkit sont bien lancés....
2/ Donc pkexec renvoie un message d'erreur, synaptic démarre mais peux-tu travailler avec?

Ok merci.
Oui je peux travailler avec synaptic.

maxire a écrit :

Bon, ce n'est sans doute pas polkit le problème puisque la configuration est bonne, mais plutôt pam (Pluggable Authentication Modules for Linux).
En bref la base des mots de passe/groupe ,,, est corrompue, c'est du moins ce qui semble être expliqué dans au moins 2 des résultats de cette recherche:
https://duckduckgo.com/?q=pkexec+Error+ … +dismissed
Comment le réparer?
Aucune idée.

Encore merci de ton temps et de ton aide.

Pam ne serait corrompue que pour cet utilisateur mon_user.
Parce que ceux que j' ai créés après (avec droits d'admin par exemple) ne subissent pas de bug.

Il me resterait donc à supprimer le compte en question, puis à le recréer.
Ainsi les reliquats de l' ancienne install 10.04 dans le dossier utilisateur seraient virés.
Mais peut il en rester ailleurs ?

Dernière modification par WanaXub (Le 18/09/2014, à 11:40)

Hors ligne

#29 Le 18/09/2014, à 12:35

WanaXub

Re : [Bug] polkit-gnome-authentication-agent-1[Résolu]

Bon, j'ai fait une erreur en relevant les données. Il me semble...
Car dans le terminal je n'ai pas retrouvé les commandes ps -aux | grep polkit et suivantes...

J'étais sur une autre install (sda4) qui possède les mêmes logins et cela m'a "confusionné"
Voici le bon log.
Il semble que tout n'est pas OK. ce serait bien là le gros souci.

Ici il me manque la ligne
0:00 /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1

ps -aux | grep polkit
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
root      1086  0.1  0.1  25236  3684 ?        Sl   12:11   0:00 /usr/lib/policykit-1/polkitd --no-debug
r51       3222  0.0  0.0   4412   820 pts/0    S+   12:15   0:00 grep --color=auto polkit

à comparer avec:

root      1139  0.0  0.1  27396  3812 ?        Sl   11:26   0:01 /usr/lib/policykit-1/polkitd --no-debug
r51       8085  0.0  0.0   4412   816 pts/0    S+   14:46   0:00 grep --color=auto polkit
r51      15997  0.0  0.3  40244  7848 ?        Sl   11:52   0:00 /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
ls /etc/xdg/autostart
at-spi-dbus-bus.desktop                gnome-screensaver.desktop                      polkit-gnome-authentication-agent-1.desktop
at-spi-registryd.desktop               gnome-settings-daemon.desktop                  polkit-kde-authentication-agent-1.desktop
bluetooth-applet.desktop               gnome-settings-daemon-helper.desktop.dpkg-bak  print-applet.desktop
bluetooth-applet-unity.desktop         gnome-sound-applet.desktop                     pulseaudio.desktop
deja-dup-monitor.desktop               gnome-user-share.desktop                       pulseaudio-kde.desktop
gdu-notification-daemon.desktop        gsettings-data-convert.desktop                 smart-notifier.desktop
gnome-fallback-mount-helper.desktop    gwibber.desktop                                telepathy-indicator.desktop
gnome-keyring-daemon.desktop.dpkg-bak  jockey-gtk.desktop                             ubuntuone-launch.desktop
gnome-keyring-gpg.desktop              nautilus-autostart.desktop                     update-notifier.desktop
gnome-keyring-pkcs11.desktop           nm-applet.desktop                              user-dirs-update-gtk.desktop
gnome-keyring-secrets.desktop          onboard-autostart.desktop                      vino-server.desktop
gnome-keyring-ssh.desktop              orca-autostart.desktop                         zeitgeist-datahub.desktop

Par contre, il y a un grand nombre de services utilisateurs pour cet user buggé comparé à l' autre user sur l' autre partoche sda4...

ls $HOME/.config/autostart
at-spi-registryd.desktop        gnome-screensaver.desktop             jockey-gtk.desktop                           update-notifier.desktop
bluetooth-applet.desktop        gnome-settings-daemon-helper.desktop  libcanberra-login-sound.desktop              user-dirs-update-gtk.desktop
dropbox.desktop                 gnome-user-share.desktop              polkit-gnome-authentication-agent-1.desktop  vino-server.desktop
evolution-alarm-notify.desktop  gnome-volume-control-applet.desktop   print-applet.desktop
gnome-at-session.desktop        hplip-systray.desktop                 seahorse-daemon.desktop
gnome-power-manager.desktop     indicator-applet.desktop              ubuntuone-client-applet.desktop
synaptic-pkexec

==== AUTHENTICATING FOR com.ubuntu.pkexec.synaptic ===
Authentication is required to run the Synaptic Package Manager
Multiple identities can be used for authentication:
 1.  R51,,,, (r51)
 2.  ,,, (toto)
Choose identity to authenticate as (1-2): 

Password: 
==== AUTHENTICATION COMPLETE ===

Dernière modification par WanaXub (Le 18/09/2014, à 12:49)

Hors ligne

#30 Le 18/09/2014, à 13:05

maxire

Re : [Bug] polkit-gnome-authentication-agent-1[Résolu]

Voilà quelque chose d'un peu plus cohérent:

- Le service polkit-gnome-authentication-agent-1 est désactivé (présence du fichier .desktop dans .config/autostart)
- La commande pkexec a bien le comportement qu'elle doit suivre par défaut lorsque aucun agent d'identification polkit n'est actif soit proposer un choix d'utilisateur.
Extrait page man de pkexec:

AUTHENTICATION AGENT
       pkexec, like any other polkit application, will use the authentication
       agent registered for the calling process or session. However, if no
       authentication agent is available, then pkexec will register its own
       textual authentication agent. This behavior can be turned off by
       passing the --disable-internal-agent option.

Il faudrait activer le service utilisateur polkit-gnome-authentication-agent-1, sous Unity je ne sais pas comment faire, il devrait exister une option  du style «Applications au démarrage» dans le menu.

Je pense qu'en supprimant polkit-gnome-authentication-agent-1.desktop dans .config/autostart cela devrait activer le service.
Ensuite une déconnexion/reconnexion de l'utilisateur va lancer l'agent d'identification et peut-être que tout devrait fonctionner.


Maxire
Archlinux/Mate + Ubuntu 18.04 + Lubuntu 18.04 + Archlinux/Gnome + Windows 10 Familial sur portable -- Archlinux/Mate sur poste de travail

Hors ligne

#31 Le 18/09/2014, à 13:46

WanaXub

Re : [Bug] polkit-gnome-authentication-agent-1[Résolu]

maxire a écrit :

1/Il faudrait activer le service utilisateur polkit-gnome-authentication-agent-1, sous Unity je ne sais pas comment faire, il devrait exister une option  du style «Applications au démarrage» dans le menu.

2/Je pense qu'en supprimant polkit-gnome-authentication-agent-1.desktop dans .config/autostart cela devrait activer le service.
Ensuite une déconnexion/reconnexion de l'utilisateur va lancer l'agent d'identification et peut-être que tout devrait fonctionner.

1/ Je n'ai rien vu, plutôt si, mais il faut connaître le nom de la commande...donc testons
le 2/

sudo rm .config/autostart/polkit-gnome-authentication-agent-1.desktop

déconnexion/reconnexion

Et ça marche --> la fenêtre de demande d'identification pour les tâches admin s'exécute de nouveau.

Super !! Encore merci. J'ai appris aussi des trucs !

Qu'est ce qui a pu causer ce bug lors de la mise à niveau ?

Cependant il faut changer le titre pour le rendre plus signifiant. 
polkit-gnome-authentication-agent-1 désactivé
ou Bug polkit-gnome-authentication-agent-1

Hors ligne

#32 Le 18/09/2014, à 14:09

F50

Re : [Bug] polkit-gnome-authentication-agent-1[Résolu]

Salut,

@ maxire : Toi qui connais bien policykit, t'as une idée de la raison de ceci :

http://forum.xubuntu-fr.org/viewtopic.php?id=906701

Désolé, je voulais pas poluer le fil.


O. Wilde: Il me semble parfois que Dieu, en créant l’homme, ait quelque peu surestimé ses capacités.
U. Eco: "Internet? Ha dato diritto di parola agli imbecilli: ............... È l'invasione degli imbecilli"

Hors ligne

#33 Le 18/09/2014, à 19:11

maxire

Re : [Bug] polkit-gnome-authentication-agent-1[Résolu]

Bon, c'est réglé, cela aurait pu être plus rapide si je t'avais demandé tout de suite de vérifier l'état des services policykit.

Un chose me chiffonne tout de même: 

WanaXub a écrit :

Message #1
Autre bizarrerie: En console la commande  sudo apt-get install synaptic s'exécute sans me demander de mot de passe.

Ceci n'a rien à voir avec policykit et a été réglé en ajoutant l'utilisateur au groupe sudo.
Cela reste quand même anormal, bug de sudo?
Je n'ai rien vu dans /etc/sudoers autorisant les membres du groupe admin à utiliser sudo sans donner leur mot de passe.
À moins que tu n'aies donné le contenu d'un /etc/sudoers d'une autre partition?

Bonne continuation.


Maxire
Archlinux/Mate + Ubuntu 18.04 + Lubuntu 18.04 + Archlinux/Gnome + Windows 10 Familial sur portable -- Archlinux/Mate sur poste de travail

Hors ligne

#34 Le 19/09/2014, à 20:01

WanaXub

Re : [Bug] polkit-gnome-authentication-agent-1[Résolu]

A/ Message #1
Autre bizarrerie: En console la commande  sudo apt-get install synaptic s'exécute sans me demander de mot de passe.

Ceci est également corrigé. je ne sais plus où ni quand cela s 'est fait, mais c'est fait.

B/
/etc/sudoers est le bon ( je n'ai commis l' erreur qu'une seule fois)...

C/
vérif faite sur une fresh install de 12.04, les utilisateurs premiers (installeurs du système) appartiennent au groupe  admin mais pas au groupe sudo.

Ceci n' a pas été modifié par moi. Ceci dit, mon install de la 10.04 tourne depuis des années, et je l'ai pas mal "torturée" au gré de divers tutos d' optim.
J'ai cloné le dd de 40 vers un 160 (PATA).
J'ai ajouté des partitions et souvent la 12.04 sur la dernière dispo.
J'ai parfois partagé les home et toujours les swap.
J'ai utilisé divers gestionnaires de montages.

Il faudrait que je fasse du ménage et que je travaille avec les versions récentes de FF et de TB...

Firefox consomme pas mal de ressouces sur un Pentium M 1,6 ou 1,7 Mhz, et les 2 Go de ram au lieu des 500 M initiaux donnent un peu de marge, sans faire de miracles.
L'utilisation du thinkpad R 51 reste correcte (même avec FF, Libreoffice, Nautilus, Thunderbird lancés en même temps).
Evince sur des pdf est souvent à la peine.

Bonne continuation aussi.
PS: content de voir quelqu'un qui utilise encore la 10.04 :-;

Hors ligne