Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 23/10/2014, à 18:02

Babdu89

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

Bonsoir.
Juste au sujet du drapeau boot et Grub ,et du Bios.

Sur un de mes disques de tests.
Deux Linux basés sur 14.04 installés pour bricoler. version de Grub  v2.02~beta2-9ubuntu1

La première partition principale à du être supprimée, pour cause de test.  À l'époque ... Savoir si oui ou non ,on pouvait installer comme ceci
Première partition ; partition étendue, contenant les partitions logiques pour installer les Linux.

Donc sur ce disque. Le drapeau boot à été mis sur la partition étendu par l'installation du premier Linux.  C'était resté en l'état depuis.
Suite à cette discutions,  j'ai viré le drapeau boot ... Grub n'en a cure... Le Bios aussi d'ailleurs.
Ma machine bootant sur ce hdd. Mes deux Os démarrent depuis l'affichage du menu Grub .

1414079856.png

bernard@bernard-System-Product-Name:~$ sudo fdisk -l
[sudo] password for bernard: 

Disk /dev/sdd: 40.0 GB, 40020664320 bytes
255 têtes, 63 secteurs/piste, 4865 cylindres, total 78165360 secteurs
Unités = secteurs de 1 * 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Identifiant de disque : 0x000cb55a

Périphérique Amorçage  Début         Fin      Blocs    Id. Système
/dev/sdd2              61    78163967    39081953+   5  Étendue
/dev/sdd5              63    21334047    10666992+  83  Linux
/dev/sdd6        73209856    78163967     2477056   82  partition d'échange Linux / Solaris
/dev/sdd7        21336064    73207157    25935547   83  Linux

Les entrées de la table de partitions ne sont pas dans l'ordre du disque

Je suis bien certain que mon W$ installé sur un autre hdd et démarrant directe, n'aimerait pas le même traitement.

Édit;
J'ai un Xp installé sur deux autres hdd, clonage de l'original.
Le drapeau boot est sur leur partition respective.
Les deux sont en multi boot avec des Linux, donc démarrés depuis un menu Grub.
Sur un j'ai viré le drapeau boot. Redémarrage de mon XP depuis le menu Grub du hdd d'installation.

Confirmation le drapeau boot n'est pas nécessaire à un W$ démarré depuis Grub.

Je vais restaurer le MBR du hdd (je lai mis de coté) donc mon XP va démarrer directe . (MBR + fichiers de boot de XP). Et voir si en virant le drapeau boot il est content. Je ne pense pas .

Alors, voila. sans drapeau boot mon XP ne boot pas.

J'ai remis ma config en état comme avant çà marche .

@+.  Babdu89  .

Dernière modification par Babdu89 (Le 23/10/2014, à 21:18)


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#27 Le 23/10/2014, à 19:08

Rufus T. Firefly

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

L'expérience à faire est d'installer grub dans la partition linux. Et ensuite de restaurer le mbr microsoft. A partir de là, voir ce qui se passe... Selon que le flag boot est sur la partition xp ou sur la partition linux.
Parce qu'évidemment, tant que grub est dans le mbr, on s'en fout du flag boot... Parce que grub fonctionne autrement...


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#28 Le 23/10/2014, à 21:45

Babdu89

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

Bonsoir .

@Rufus T.Firefly.

A partir de là, voir ce qui se passe... Selon que le flag boot est sur la partition xp ou sur la partition linux.


Alors config du hdd de test.
hdd ; /dev/sda
XP; /dev/sda1 avec flag boot
12.04 ;/dev/sda12
Première partie de grub dans le secteur de boot du hdd /dev/sda
C'est le Grub de la 12.04 qui permet le démarrage des OS.

Je veux bien tenté la manip, mais tu me dis pour la réinstallation de Grub dans la 12.04, en mettant la première partie de Grub dans le secteur de boot de la partition /sda12 , si j'ai bon?.

sudo os-prober

sudo update-grub

sudo grub-install /dev/sda12

Pour le MBR, je restaure la sauvegarde,comme tout à l'heure.

@+.   Babdu89  .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#29 Le 23/10/2014, à 22:08

Rufus T. Firefly

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

Moi je mettrais ça en sens inverse (install puis update), mais bon, on s'en fiche, là,.ce qui compte, c'est ça

sudo grub-install /dev/sda12

et ensuite ça : le mbr microsoft
Edit : ça ne fonctionnera pas : ton linux n'est pas sur une partition primaire ! Donc flag boot, tintin !

Dernière modification par Rufus T. Firefly (Le 23/10/2014, à 22:10)


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#30 Le 23/10/2014, à 22:22

Babdu89

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

Rufus T.Firefly a écrit;

Edit : ça ne fonctionnera pas : ton linux n'est pas sur une partition primaire ! Donc flag boot, tintin !

Ha!!!  zut!!!. pas de chance, mes W$ XP sont tous deux suivi d'une partition étendue. Avec les Linux dedans.

Pour les tests. Obligé d'en resté là .

@+.   Babdu89  .

Dernière modification par Babdu89 (Le 23/10/2014, à 22:23)


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#31 Le 24/10/2014, à 13:22

Rufus T. Firefly

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

Merci de confirmer, mais je l'avais déjà fait x fois, à l'époque où il y avait ces histoires de mbr tatoué. Et j'avais trouvé que c'était la meilleure solution. On laisse tout comme c'est, puis lors de l'install de linux, on met grub sur la partition linux (seule condition : cette partition doit être primaire), et on change le flag boot. Comme ça tout le monde est content. Si on veut enlever linux, on remet le flag boot sur la partition windows, et on détruit la partition linux... Et le contraire, d'ailleurs. On peut virer la partition w$... On peut même la refaire et ré-installer w$, sans que ça change rien à grub. Il y a juste les menus à mettre à jour. Tout ça sans toucher au mbr, qui reste un mbr microsoft...

Mais, les gens te sortent des trucs faux, et ensuite ils te disent ça :

Arbiel a écrit :

je n'en sais pas plus, ni n'éprouve le besoin d'en savoir plus.

Arbiel

C'est très post-moderne. Il n'y a pas de vérité, chacun a ses idées et elles se valent... Et puis les faits, on s'en fout...

Dernière modification par Rufus T. Firefly (Le 24/10/2014, à 13:39)


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#32 Le 24/10/2014, à 14:36

Babdu89

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

Bonjour.

@kalunux.

Remarque importante. Tout ce qui suit ne concerne que les installations d'OS en mode Bios ,Pas les installation en mode UEFI.

Tu dis;

Je précise que j'ai fait ces manipulations ce Matin depuis Boot-Repair.

Stp, veux tu bien préciser les manips faites avec Boot-Repair? Surtout si tu as réinstallé Grub sur /dev/sda4 avec?.

Le pourquoi de cette question?
Boot-Repair ne sait pas réinstaller Grub, en mettant Grub première partie dans le secteur de boot d'une partition d'installation de l'OS Linux.
Il réinstalle Grub dans les fichiers systèmes de l'Os concerné par la réparation.
Mais il ne peut mettre Grub première partie que dans le secteur de boot des disques dur présents dans la config, hdd usb compris.

On utilise le champ "Placer Grub dans: " pour ce faire.

Voila ce qu'il se passe chez moi:

1414152617.png

L'option qui détermine le secteur de boot utilisé pour réinstallé Grub première partie, ne propose que les secteurs de boot des hdd. Pas celui des partitions.

Loption "Placer grub dans tous les disques...." fait de même , mais en mettant Grub première partie dans les secteurs de boot de tous les hdd où sont installé des OS.
Ceci afin que les "bricoleurs du Dimanche"  qui ne savent même pas aller dans leur Bios changer l'ordre de boot de leur machine, puissent redémarrer sur un menu Grub .
Boot-Repair est prévu pour fonctionner comme çà, ceci afin d'éviter les soucis de ce que l'on voyait trop souvent pendant les installations, des utilisateurs qui installaient Grub dans le secteur de boot des partitions Système au moment de l'installation de leur OS.  Ubiquity, l'installateur de Ubuntu le permettait, et le permet toujours je crois.

Mettre Grub première partie dans le secteur de boot des partitions système, c'est pour un but bien déterminé.
Protection d'un mbr (machine tatouée ou pas)
Utilisation d'un autre chargeur d'amorçage que Grub, pour permettre le chaînage.
Utilisation d'un programme de boot installé dans un W$ . Pour pouvoir chaîner sur l'OS Linux.
&&&&.

Donc dans les tests que je me proposais de faire. C'est pour cela que je demandais confirmation des commandes pour la réinstallation de Grub avec pour dernière commande;

sudo grub-install /dev/sda12

Partition /sda12 , pour y mettre Grub première partie, car je savais que Boot-Repair ne peut pas le faire .

@+.  Babdu89 .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#33 Le 24/10/2014, à 15:43

cpcp01

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

Bonjour,
J'ai vaguement l'impression que la discussion est partie vers d'autres préoccupations ...
Enfin je vais tenter de continuer à exposer mes difficultés qui ne sont pas résolues.
Dans l'installation d'UBUNTU j'ai créé des répertoires /usr sur /dev/sda3 et /home sur /dev/sdb1

cpcp01@maison:~$ sudo lsblk --output NAME,FSTYPE,SIZE,LABEL,MOuNTPOINT
NAME   FSTYPE   SIZE LABEL MOUNTPOINT
sda    ufs    465,8G       
├─sda1 swap     9,3G       [SWAP]
├─sda2 ext4    18,6G       /
└─sda3 ext4   158,3G       /usr
sdb    ufs    465,8G       
└─sdb1 ext4   372,5G       /home
sr0            1024M

Par contre je ne retrouve pas ces partitions dans les fichiers, et les répertoires /usr et /home créés par défaut sont bien dans la racine /.
Est-ce normal?
Dois-je monter ces 2 répertoires à la main?
J'ai bien l'impression que le type "ufs" de sda et sdb pose toujours des problèmes.
Cordialement.

Hors ligne

#34 Le 24/10/2014, à 16:07

Rufus T. Firefly

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

Je ne sais pas ce que c'est, ce ufs. Chez moi, la même commande n'indique rien du tout pour les disques.
Si ton système fonctionne...

A part ça, tes partitions sont montées automatiquement au démarrage du système. Les instructions de montage sont enregistrées dans le fichier /etc/fstab dont tu peux avoir un aperçu rapide par :

cat /etc/fstab

L'idée du montage, c'est de créer une sorte de tuyau entre une partition et un répertoire. Et quand tu regardes dans le répertoire en question (le point de montage), tu vois évidemment ce qu'il y a à l'autre bout du tuyau. De même, quand tu enregistres quelque chose dans ce répertoire, ça atterrit physiquement à l'autre bout du tuyau, donc sur la partition qui est montée sur ce répertoire.
C'est vrai pour les partitions, mais en fait, c'est vrai pour n'importe quel périphérique (sauf que ça ne se passe pas dans /etc/fstab). Ainsi, par exemple, tu as un fichier /dev/input/mouse0. C'est un fichier parce que la souris ce n'est pas du stockage, ça ne fait qu'envoyer des infos sur ses déplacements. Tu peux intercepter la souris en suivant ce qui passe dans ce fichier, qui est une sorte de point de montage, en réalité...

Dernière modification par Rufus T. Firefly (Le 24/10/2014, à 16:11)


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#35 Le 24/10/2014, à 17:42

Babdu89

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

Oui!!! Excuses nous, on s'éparpille un peu. Mais çà concerne quand même ton sujet...


Post#1 on peut lire...

Ce sont mes premiers pas sur Linux.

J'ai deux disques de 500 Go que j'ai partitionné ainsi :
Sda1 primaire Ext4 180 Go pour /
Sda2 Swap 20 Go
Sda3 primaire Ext4 100 Go pour /usr le reste non alloué
Sdb1 primaire Ext4 50 Go pour /Var Sdb2 primaire Ext4 50 Go pour /Opt
Sdb3 primaire Ext4 200 Go pour /home
Le reste non alloué
Il n'y a pas d'autre OS d'installé et je ne veux que Linux donc pas de problème de Dualboot.]

Post#6 ,on peut lire...

Ouf! J'ai réussi à installer Ubuntu et Grub.

Je me demandais ,pourquoi une telle installation???...
Une recherche; voila les lien du tuto en question .

Pour l'installation j'ai suivi "Installer Ubuntu 14.04 pas à pas" de Léa-Linux. Il ne dise rien sur cette information qui est pourtant importante.

http://lea-linux.org/documentations/Ins … untu_14.04

Jusqu'a "Autre chose" rien d'anormal... Mais ensuite on voit  "partitionnement"  un lien , j'ouvre...

http://lea-linux.org/documentations/Partitionnement

On explique comment faire un partitionnement en séparant les dossiers;  /  /usr; / &&&bref des répertoires séparés, mais sur le même disque.

Heuu, notre ami  cpcp01 ajoute de la difficulté en choisissant d'installer sur deux disques, au lieux d'un...

Pour un débutant;

Ce sont mes premiers pas sur Linux.

C'est pas mal... Mais je me demande toujours pourquoi une telle installation ?? ...

Bon on continue.
Post#9 ,on peut lire...

Avec l'aide des uns et des autres je vais pouvoir répondre plus précisément.
J'ai donc refais mon installation en tenant compte de vos remarques.
1) j'opte pour         supprimer UBUNTU 14.04 LTS et réinstaller
2) je choisis           sélectionner le disque SCSI1 (0,0,0) (sda) - 500,1 Go
3) je sélectionne   l'outil de partitionnement avancé
     partitions retenues :
        /dev/sda1 ext4   /           20 Go
       /dev/sda2  swap             10  Go  ( j'ai 8 Go de RAM)
       /dev/sda3  ext4   /home 470 Go
    /dev/sdb
      espace libre (pour le futur)
périphérique où sera installé le programme de démarrage :
    /dev/sda

Ha!!! On revient à des choses plus raisonnables.

Post#11, il prévoit de compliquer les choses ...

Post#19, on voit la confirmation de la nouvelle installation ...

Ha!!!...  Post#22 ,on a comme l'impression que la dernière installation, ne ressemble pas à celle du post#19 ...

Post#39, j'ai l'impression qu'on revient au point de départ...

Pourquoi faire simple ;
Partition ext4 pour tout le système /
ou
Partition ext4 pour le système /    .
Partition ext4 pour un /home     séparé.
Partition swap
Tout çà sur le même disque /dev/sda

Quand on peut faire compliqué;

cpcp01@maison:~$ sudo lsblk --output NAME,FSTYPE,SIZE,LABEL,MOuNTPOINT
NAME   FSTYPE   SIZE LABEL MOUNTPOINT
sda    ufs    465,8G       
├─sda1 swap     9,3G       [SWAP]
├─sda2 ext4    18,6G       /
└─sda3 ext4   158,3G       /usr
sdb    ufs    465,8G       
└─sdb1 ext4   372,5G       /home
sr0            1024M

Je ne sais pas si vous arrivez à suivre, vous, mais moi j'ai bien du mal...

@+.   Babdu89   .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#36 Le 24/10/2014, à 17:50

cpcp01

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

Je pense que mon installation fonctionne les répertoires /home et /usr  sont bien montées.

Voici le fstab

cpcp01@maison:~$ sudo cat /etc/fstab
[sudo] password for cpcp01: 
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=8b9fea17-e027-4693-8e27-57ef499f8378 /               ext4    errors=remount-ro 0       1
# /home was on /dev/sdb1 during installation
UUID=aecd97ea-2da2-4bf0-ab31-5f619180a23f /home           ext4    defaults        0       2
# /usr was on /dev/sda3 during installation
UUID=c3082792-4058-4697-9b8a-a15c36af5767 /usr            ext4    defaults        0       2
# swap was on /dev/sda1 during installation
UUID=9665ecde-c94f-4c48-bd14-7a47e0db5404 none            swap    sw              0       0

Je ne sais pas si tout est propre, que signifie la mention " errors=remount-ro" pour la racine /

Hors ligne

#37 Le 24/10/2014, à 18:00

Rufus T. Firefly

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

En cas de pépin sur la partition, elle est montée en lecture seule (si elle est encore montable, bien sûr). Ce qui permet au système de démarrer mais sans écritures sur le disque. Le temps de réparer...


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#38 Le 24/10/2014, à 18:30

cpcp01

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

Babdu89
Oui!!! Excuses nous, on s'éparpille un peu. Mais çà concerne quand même ton sujet...
....
Je ne sais pas si vous arrivez à suivre, vous, mais moi j'ai bien du mal...

Effectivement j'ai tenté plusieurs plusieurs installations, c'est un peu brouillon.
Je pense que je vais m'en tenir à la dernière installation.

J'ai acheté en 2014 une tour qui date de 2011, c'est un ancien serveur qui avait 2 disques de 500 Go (l'OS du serveur était Debian). Je veux utiliser au mieux l'espace disque.
J'ai souvent vu qu'il était intéressant de mettre /home sur un disque séparé en cas de crash du disque système.
Pour /usr j'ai vu que ça pouvait être intéressant si on installe beaucoup de logiciels.
En fait ça me fait mal au coeur d'utiliser une vingtaine de Go sur les 1000 disponibles.
Pour l'instant je n'ai rien de personnel d'installé.
Je vous remercie de suivre le sujet.
Cordialement.

Hors ligne

#39 Le 24/10/2014, à 18:45

Babdu89

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

lol lol lol  wink

Tu veux que je te dise ...
Au bout de quelque temps, tu vas peut-être, je pense même certainement, te diriger vers une situation comme celle -ci,la mienne actuellement.
4 hdd internes + 1 usb en ce moment.

bernard@bernard-GA-7VAX:~$ sudo lsblk --output NAME,FSTYPE,SIZE,LABEL,MOuNTPOINT
[sudo] password for bernard: 
NAME    FSTYPE   SIZE LABEL                   MOUNTPOINT
sda             37,3G                         
├─sda2             1K                         
├─sda5  ext4    10,2G ma-h-14.04-test         
├─sda6  swap     2,4G                         
└─sda7  ext4    24,8G ma-hyb-14.04            
sdb            931,5G                         
├─sdb1  ntfs    52,2G XP_SATA_1               
├─sdb2             1K                         
├─sdb5  ntfs   701,4G DONNEES_SATA_1_         
├─sdb6  ntfs    10,2G Natty-Wubi              
├─sdb7  swap     4,1G                         
├─sdb8  ext4    15,5G syst_clone              
├─sdb9  ext4    83,8G home_clone              
├─sdb10 ext4    11,9G ubunt-11.10-cust        
├─sdb11 ext4    16,9G UBUN-11.10              
├─sdb12 ext4    12,4G sata1-fus12.04-s        
└─sdb13 ext4    23,2G sata1-fus12.04-h        
sdc            232,9G                         
├─sdc1  ntfs   181,4G SATA                    
├─sdc2             1K                         
├─sdc5  swap     2,4G                         
├─sdc6  ext4    10,2G sata-xub-12.04-s        
└─sdc7  ext4      39G sata-xub-12.04-h        
sdd            931,5G                         
├─sdd1  ntfs    52,2G SATA3-COPY-XP           
├─sdd2             1K                         
├─sdd5  swap     5,1G                         
├─sdd6  ext4      96G sata3-xub14.04h         
├─sdd7  ext4      21G sata3-xub14.04s         
├─sdd8  ext4   102,6G fusion-13.04            
├─sdd9  ext4    23,1G 12.04_inst_alter        
├─sdd10 ext4    25,3G test-u12.04.2-32        
├─sdd11 ext4    23,9G u-12.04-2_magic         
├─sdd12 ext4    54,5G clon-xub-hom14          
├─sdd13 ext4      20G clon-xub-sys14          
├─sdd14 ext4      22G hyb-evol-altern         
├─sdd15 ext4      11G xub-12.10-syst          
├─sdd16 ext4    51,1G xub-12.10-home          
├─sdd17 ext4      33G sata3-fusion            
├─sdd18 ext4    10,3G sata3-13.04-syst        
├─sdd19 ext4    20,1G sata3-13.04-hom         
├─sdd20 ext4    20,9G sata3-xub-13.04         
├─sdd21 ext4    24,8G fusion-test             
├─sdd22 ext4    21,6G raring-reserve          
├─sdd23 ext4    15,1G xu12.04-s-hydv1         
├─sdd24 ext4    68,4G xu12.04-h-hydv1         
├─sdd25 ext4    20,9G s3-fusion-12-s          
├─sdd26 ext4    42,2G s3-fusion-12-h          
├─sdd27 ext4    22,2G s3-xub-14-s             
├─sdd28 ext4    44,9G s3-xub-14-h             
├─sdd29 ext4    31,6G kubuntu-14.04           
├─sdd30 vfat     1,3G HP_RECOVERY             
└─sdd31 ext4    46,1G hybryde-14.04           
sde            931,5G                         
├─sde1  ntfs     4,9G Seagate Expansion Drive /media/bernard/Seagate Expansion Drive
├─sde2             1K                         
├─sde5  ntfs   500,4G DONNEES-SEAG-USB        /media/bernard/DONNEES-SEAG-USB
├─sde6  swap     4,3G                         [SWAP]
├─sde7  ext4    15,2G xub-syst-10-seag        /media/bernard/xub-syst-10-seag
├─sde8  ext4    50,5G xub-hom-10-seag         /media/bernard/xub-hom-10-seag
├─sde9  ext4    10,7G xub-syst-12-seag        /media/bernard/xub-syst-12-seag
├─sde10 ext4    53,2G xub-hom-12-seag         /media/bernard/xub-hom-12-seag
├─sde11 ext4    10,5G hyb-12-syst-seag        /media/bernard/hyb-12-syst-seag
├─sde12 ext4    51,3G hyb-12-hom-seag         /media/bernard/hyb-12-hom-seag
├─sde13 ext4    31,2G fusion13.04-seag        /media/bernard/fusion13.04-seag
├─sde14 ext4    10,2G emmabuntu-sys           /media/bernard/emmabuntu-sys
├─sde15 ext4    21,2G emmabuntu-hom           /media/bernard/emmabuntu-hom
├─sde16 ext4    19,9G fus-12.04-s-seag        /media/bernard/fus-12.04-s-seag
├─sde17 ext4    40,8G fus-12.04-h-seag        /media/bernard/fus-12.04-h-seag
├─sde18 ext4    33,3G hydv1-xub12.04-h        /media/bernard/hydv1-xub12.04-h
├─sde19 ext4    14,7G hydv1-xub12.04-s        /media/bernard/hydv1-xub12.04-s
├─sde20 ext4    24,8G xub-14.04-seag          /media/bernard/xub-14.04-seag
├─sde21 ext4    19,6G                         /media/bernard/e141ed2f-4e31-4ae1-a7b4-2247d9b40cc2
└─sde22 ext4    14,9G 14.04-unity-8           /
sr0             1024M                         
sr1             1024M                         
bernard@bernard-GA-7VAX:~$ 

Et tu vas regretter d'avoir éparpillé ton installation sur plusieurs hdd... tongue

@+.   Babdu89   .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#40 Le 24/10/2014, à 19:37

Rufus T. Firefly

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

cpcp01 a écrit :

J'ai souvent vu qu'il était intéressant de mettre /home sur un disque séparé en cas de crash du disque système.

Ça, d'accord, à la rigueur. Mais si tu regardes comment c'est chez moi, /home n'est même pas séparé. En revanche, mes données sont éparpillées sur plusieurs partitions et même sur plusieurs disques. Avec les montages adéquats (dans /etc/fstab) tout ça est complètement transparent :

ls -l
total 56
drwxr-xr-x  2 firefly firefly  4096 oct.   9 23:12 Desktop
drwxr-xr-x 16 firefly firefly  4096 oct.  13 18:02 Documents
drwxr-xr-x 17 firefly firefly 20480 oct.  23 23:19 Films
drwxrwxr-x 11 firefly firefly  4096 oct.  21 15:48 Images
drwxr-xr-x  2 firefly firefly  4096 sept. 21 13:08 Modèles
drwxr-xr-x  6 firefly firefly  4096 août   9 14:27 Musique
drwxr-xr-x  2 firefly firefly  4096 août  18 14:29 Scripts
drwxr-xr-x 12 firefly firefly 12288 oct.  24 02:31 Téléchargements

Et voilà les montages correspondants :

cat /etc/fstab
UUID=8510309b-6eb3-4cd0-b830-950eec5f31d2 /data/documents  ext3   defaults           0       2
/data/documents /home/firefly/Documents none bind
/data/documents/images /home/firefly/Images none bind

UUID=e4fd4939-7293-4a92-a0e1-11c2a4345629 /data/musique    ext4   defaults           0       2
/data/musique/classique /home/firefly/Musique/classique     none   bind
/data/musique/jazz /home/firefly/Musique/jazz               none   bind
/data/musique/chansonette /home/firefly/Musique/chansonette none   bind
/data/musique/blues /home/firefly/Musique/blues             none   bind

UUID=a04a3e2b-4259-40e0-bd00-53e071a07954 /data/films      ext4   defaults           0       2
/data/films/Films /home/firefly/Films none bind
/data/films/Téléchargements /home/firefly/Téléchargements none bind

Tu vois qu'ils sont tous sur le même modèle :
1) un répertoire /data
2) les sous-répertoires /data/documents, /data/musique, /data/films comme points de montage pour les partitions correspondantes
3) des bind (liens sous forme de montages) entre les sous-répertoires des partitions et leur homologue dans mon répertoire
Par exemple : sur la partition dédiée à la musique, montée en /data/musique, il y a 4 répertoires, classique, jazz, chansonette et blues qui sont liés au sous-répertoires correspondants de /home/firefly/Musique:

firefly@sid:~$ cd Musique/
firefly@sid:~/Musique$ ls
blues  chansonette  classique  jazz

Ce genre de choses, - ce n'est pas facile à comprendre au début -, tu peux le faire et le défaire comme tu veux. Je mets un # devant une ligne, - marque de commentaire -, dans /etc/fstab (ou je supprime la ligne) et le montage ne se fait plus.

# UUID=e4fd4939-7293-4a92-a0e1-11c2a4345629 /data/musique    ext4   defaults           0       2

Au prochain démarrage, mon répertoire Musique est vide (en fait les répertoires classique, jazz, etc. sont toujours là, mais ils sont vides puisque plus rien n'est monté dessus, ce sont redevenus des répertoires ordinaires et non plus des points de montage comme avant) ! Mais les données sont évidemment toujours sur la partition. Il suffit d'enlever le # pour restaurer la situation antérieure !
(ne le tente pas dans ton fstab : les partitions /, /home et /usr sont indispensables au fonctionnement, mais même si ça arrivait, il suffirait de corriger le fichier en démarrant sur un live-cd...).

cpcp01 a écrit :

Pour /usr j'ai vu que ça pouvait être intéressant si on installe beaucoup de logiciels.

Ça c'était vrai quand les disques faisaient 120 Mo (méga-octets, pas giga) ! Mais regarde ce qu'il y a actuellement sur ton /usr et l'ensemble des logiciels déjà installés. Avec la place dont tu disposes, tu pourrais installer tout ce qu'il y a dans les dépôts (plus de 40000 paquets !). Que ferais-tu avec 5 suites bureautiques complètes, 25 lecteurs multi-médias, autant de navigateurs internet, des logiciels pour visualiser la structure 3D des protéines, de quoi calculer les pistes d'un circuit imprimé, plusieurs jeux d'échec, à peu près tous les langages de programmation existants... ?
Tu oublies que tu es sur linux (ou plutôt tu n'en as pas encore pris pleinement la mesure). Si tu as besoin de quelque chose, tu fais :

sudo apt-get install le_paquet

Quelques secondes plus tard c'est installé !
Et si tu vois que ça ne te conviens pas :

sudo apt-get purge le_paquet

Ce n'est vraiment pas la peine de remplir ton /usr avec des trucs que tu n'utilises pas...

Dernière modification par Rufus T. Firefly (Le 24/10/2014, à 19:45)


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#41 Le 24/10/2014, à 22:27

cpcp01

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

Bonsoir,
Je comprends ce que tu me dis mais je ne l'ai pas encore assimilé.
Tu ranges tes données dans un répertoire nommé "data" , tu as :
/data/musique
/data/films
/data/documents
Pourquoi ne pas le faire directement dans le répertoire /home, pour ma part j'aurais sur le disque sdb:
/home/musique
/home/films
/home/documents
En terme d'organisation des données je ne vois pas de différence.
Par contre ce que je ne connais c'est la notion du bind, c'est sur ce point que je bloque.
Bon il me faut un peu de temps.

Il n'en reste pas moins que si je prends l'installation de base, je consomme 15 Go et il me  reste 985 Go de disponible. C'est un peu ballot.
Cordialement.

Hors ligne

#42 Le 24/10/2014, à 22:51

Rufus T. Firefly

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

cpcp01 a écrit :

Bonsoir,
Je comprends ce que tu me dis mais je ne l'ai pas encore assimilé.
Tu ranges tes données dans un répertoire nommé "data" , tu as :
/data/musique
/data/films
/data/documents
Pourquoi ne pas le faire directement dans le répertoire /home, pour ma part j'aurais sur le disque sdb:

Ne pas faire quoi ? Les montages directement sur /home/user ? Ça ne pose pas de problèmes. Mais tu vois que Films et Téléchargements sont sur la même partition.

UUID=a04a3e2b-4259-40e0-bd00-53e071a07954 /data/films      ext4   defaults           0       2
/data/films/Films /home/firefly/Films none bind
/data/films/Téléchargements /home/firefly/Téléchargements none bind

Pour les séparer, je monte la partition ailleurs (/data) puis je crée un bind de /data/films/Films vers /home/user/Films et un autre bind de /data/films/Téléchargements vers /home/user/Téléchargements. Donc sur mon /home, j'ai 2 répertoires bien séparés, même si, en fin de compte les données sont sur la même partition.
Un truc de ce genre ne fonctionnerait pas. Ce n'est pas autorisé.

UUID=a04a3e2b-4259-40e0-bd00-53e071a07954/Films /home/firefly/Films      ext4   defaults           0       2

Il n'en reste pas moins que si je prends l'installation de base, je consomme 15 Go et il me  reste 985 Go de disponible. C'est un peu ballot.

Ce n'est pas exact. Ta partition /usr appartient à root et tu ne peux pas écrire dedans en tant qu'utilisateur. En plus, ce serait une très très mauvaise idée d'y mettre n'importe quoi. Donc tu peux considérer qu'il y a là environ 150 Go de perdus !
Ensuite tu m'étonnes avec les 15 Go ! En sortie d'installation, ça ne dépasse pas 4-5 Go.

Dernière modification par Rufus T. Firefly (Le 24/10/2014, à 22:54)


La provocation est une façon de remettre la réalité sur ses pieds. (Bertolt Brecht)
Il n'y a pas de route royale pour la science et ceux-là seulement ont chance d'arriver à ses sommets lumineux qui ne craignent pas de se fatiguer à gravir ses sentiers escarpés. (Karl Marx)
Il est devenu plus facile de penser la fin du monde que la fin du capitalisme

Hors ligne

#43 Le 25/10/2014, à 16:55

cpcp01

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

Bonsoir à tous,
Je vais m'absenter une quinzaine de jours, je ne pourrais donc pas participer à la discussion.
Là où je vais je ne dispose pas d'internet.
Pour mes premiers pas sur Linux ce fut une excellente formation car de nombreux sujets ont été abordés même si je n'ai pas tout compris.
Merci à tous les participants qui ont bien voulu me consacrer de leur temps et de leur compétence.
Pour ma part je considère mon problème RESOLU.
Cordialement.

Hors ligne

#44 Le 29/10/2014, à 12:24

missicbc

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

pas transférer les résultats dans ma réponse dans le forum. Pouvez-vous me renseigner sur ce point?   

___________________

Fifa 15 Coins

Hors ligne

#45 Le 03/11/2014, à 23:33

Arbiel

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

Bonsoir

J'ai désiré poursuivre la discussion sur le BIOS, Grub et le drapeau "boot" en en ouvrant une nouvelle ici.

Arbiel


Arbiel Perlacremaz
Dell Vostro Ubuntu 18.04 64 bits, LDLC Aurore NK3S-8-S4 Ubuntu 20.04
Abandon d'azerty au profit de bépo, de google au profit de Lilo et de la messagerie électronique violable au profit de Protonmail, une messagerie chiffrée de poste de travail à poste de travail.

Hors ligne

#46 Le 08/12/2015, à 14:17

mr-pingouin

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

Bonjour smile

Nouvel utilisateur linux, j'ai le même souci que la personne qui a créé ce topic.

J'ai suivi les mêmes instructions et voici ce que me donne la commande dans le terminal

Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1  3907029167  1953514583+  ee  GPT
Partition 1 does not start on physical sector boundary.
/dev/sda1: UUID="02E2-C6B7" TYPE="vfat" 
/dev/sda3: UUID="06ECE752ECE73B17" TYPE="ntfs" 
/dev/sdb1: LABEL="Geekland" UUID="384821B7482174B2" TYPE="ntfs" 
/dev/sdb3: UUID="26EE8C8CEE8C5649" TYPE="ntfs" 
/dev/sdb5: UUID="f1c638f3-8c73-4ca8-8968-6487556657c1" TYPE="ext4" 
/dev/sdb4: UUID="b0a7cbcf-c644-41ac-ab13-5e3c3f20da68" TYPE="swap" 
/dev/loop0: TYPE="squashfs" 
/dev/sr0: LABEL="Ubuntu 14.04.3 LTS amd64" TYPE="iso9660" 
[1]+  Done                    sudo fdisk -lu

J'ai l'intention d'avoir un dual boot Windows 7 / Ubuntu. J'ai deux disques durs à disposition, un disque sur lequel j'ai installé windows et un autre sur lequel j'ai créé une partition supplémentaire afin d'installer Ubuntu.

Pourriez vous m'aider ? smile

Hors ligne

#47 Le 08/12/2015, à 23:02

Babdu89

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

Bonsoir.
mr-pingouin.
Stp, veux tu bien créer un autre sujet. Faire un boot info

https://doc.ubuntu-fr.org/tutoriel/boot-info

Donner l'URL du boot info dans la nouvelle discutions .

Donner ici l'URL du nouveau sujet.

Rappel, tu interviens dans un sujet marqué comme résolu, et ton souci n'est pas forcement le même. On va voir çà dans le boot info.

Merci.

@+.  Babdu89  .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#48 Le 09/12/2015, à 14:09

mr-pingouin

Re : [RESOLU] execution de "grub-install /dev/sda ... " a échoué

Bonjour Babdu89

Voici le lien du sujet que j'ai créé.

https://forum.ubuntu-fr.org/viewtopic.php?id=1956851

J'ai suivi les indications données par Arbiel.

Voilà où j'en suis wink

@+

Hors ligne