Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#126 Le 11/11/2007, à 23:08

misteraph

Re : Enemy Territory : Quake Wars

Bon sinon, je n'arrive pas non plus à  afficher la console. La seule chose qui fonctionne dans mon autoexec.cfg, c'est l'affichage des fps.

Hors ligne

#127 Le 12/11/2007, à 17:44

zephilo0o

Re : Enemy Territory : Quake Wars

Petite question :

J'arrives pas a affichier mes peripheriques sons dans la page settings (pour la voip) , quelqu'un a le meme soucis ?

-- sinon teamspeak / googletalk / etc fonctionne donc ca devrait venir de la cfg de ETQW ---


OS: Ubuntu 7.10  64 bit
Processeur: AMD Athlon64 3200+
Carte graphique: NVidia GeForce76600GT
Mémoire vive: 1 Go RAM

Hors ligne

#128 Le 12/11/2007, à 18:22

lawl

Re : Enemy Territory : Quake Wars

oui le voip n'est pas encore integrer au client linux.

Hors ligne

#129 Le 12/11/2007, à 18:30

Lowa

Re : Enemy Territory : Quake Wars

misteraph a écrit :

Bon sinon, je n'arrive pas non plus à  afficher la console. La seule chose qui fonctionne dans mon autoexec.cfg, c'est l'affichage des fps.

Pareil pour moi, impossible d'ouvrir la console (sur une gutsy fraichement installée), j'ai essayé toutes les combinaisons de touches (², ~, alt, shift, ctrl, ...) mais rien n'y fait... problème de clavier ou paramètres spécial à  définir dans l'autoexec ?

Merci de vos réponses !

Lowa

#130 Le 12/11/2007, à 18:52

pop2010

Re : Enemy Territory : Quake Wars

Il faut passer le clavier en us. Comme ça en plus les touches alphanumériques fonctionnent pour le changement d'armes et les voix.

A ce moment là  tu fait ctrl-alt-² pour afficher la console. Et si tu as la flemme, tu tapes dans la console "com_allowConsole 1", ce qui permet de l'afficher en appuyant uniquement sur ². Le paramètre est enregistré pour chaque démarrage.

Alors comme le jeu déconne si on laisse compiz-fusion et qu'il vaut mieux jouer avec un clavier us (évidemment il faut taper en qwerty malheureusement), l'idéal c'est de créer un fichier bash (etqw.sh par exemple) qui contient le code suivant

#! /bin/sh

metacity --replace &

setxkbmap -layout us

/usr/local/games/etqw/etqw.x86

setxkbmap -layout be

compiz --replace &

Il faut bien sûr penser à  changer le be en fr ou autre selon le clavier. Et aussi changer metacity par euh... je sais plus pour kde si c'est votre cas.

Ensuite on crée un lanceur vers ce fichier, et on est tranquille. Pour ma part j'ai placé ce fichier dans ~/.etqwcl/.

Hors ligne

#131 Le 12/11/2007, à 19:04

Lowa

Re : Enemy Territory : Quake Wars

pop2010 a écrit :

Il faut passer le clavier en us. Comme ça en plus les touches alphanumériques fonctionnent pour le changement d'armes et les voix.

A ce moment là tu fait ctrl-alt-² pour afficher la console. Et si tu as la flemme, tu tapes dans la console "com_allowConsole 1", ce qui permet de l'afficher en appuyant uniquement sur ². Le paramètre est enregistré pour chaque démarrage.

Alors comme le jeu déconne si on laisse compiz-fusion et qu'il vaut mieux jouer avec un clavier us (évidemment il faut taper en qwerty malheureusement), l'idéal c'est de créer un fichier bash (etqw.sh par exemple) qui contient le code suivant

#! /bin/sh

metacity --replace &

setxkbmap -layout us

/usr/local/games/etqw/etqw.x86

setxkbmap -layout be

compiz --replace &

Il faut bien sûr penser à changer le be en fr ou autre selon le clavier. Et aussi changer metacity par euh... je sais plus pour kde si c'est votre cas.

Ensuite on crée un lanceur vers ce fichier, et on est tranquille. Pour ma part j'ai placé ce fichier dans ~/.etqwcl/.

Je m'étais effectivement déjà fait un script pour désactiver compiz (et avant-window-navigator), mais je n'avais pas du tout pensé à passer le clavier en "us", merci !

Je vais tester ça dès ce soir wink

Par contre l'un de vous a-t-il essayé le kernel "real-time" de la gutsy ? est-ce un kernel "low-latency" pour desktop, ou un véritable kernel "real-time" destiné plutôt à l'embarqué ? Le kernel standard de la gusty n'étant pas compilé avec l'option CONFIG_HZ=1000 ...

#132 Le 12/11/2007, à 19:11

pop2010

Re : Enemy Territory : Quake Wars

Je ne savais pas pour la configuration du kernel de gutsy, mais je n'ai aucun soucis dans le jeu, il tourne nickel avec des pings à ~20 ms donc je ne m'en inquiète pas.

Hors ligne

#133 Le 12/11/2007, à 21:43

Lowa

Re : Enemy Territory : Quake Wars

pop2010 a écrit :

Je ne savais pas pour la configuration du kernel de gutsy, mais je n'ai aucun soucis dans le jeu, il tourne nickel avec des pings à  ~20 ms donc je ne m'en inquiète pas.

Tu as quoi comme config ?

Je m'étonne quand même d'une chose, j'ai beau passer de 1680x1050 a 800x600, je ne constate pas de différence notable au niveau des FPS à  règlages égaux (ça oscille entre 30 et 50 en permanence), et le processeur n'est même pas utilisé à  fond (60%) alors que ce jeu est réputé pour être gourmand en CPU...

Je pensais que ça pouvait venir de l'histoire du kernel "low-latency", mais j'ai un doute maintenant... alors qu'est-ce qui coince ?

#134 Le 12/11/2007, à 22:03

pop2010

Re : Enemy Territory : Quake Wars

J'ai un portable avec Core 2 Duo T7300 et 8600m GT DDR2.  Pour moi si je monte en 1680 ça fait baisser les fps vers les 25 et ce n'est plus suffisamment jouable. Pour ce qui est des fps c'est normal, le jeu est normalement prévu pour les bloquer à 30, mais sous linux ça oscille. Il existe une commande pour les débloquer, mais je ne vois vraiment pas de quoi tu t'inquiètes si le jeu est suffisamment fluide et qu'il répond bien.

Hors ligne

#135 Le 13/11/2007, à 00:09

Lowa

Re : Enemy Territory : Quake Wars

pop2010 a écrit :

J'ai un portable avec Core 2 Duo T7300 et 8600m GT DDR2.  Pour moi si je monte en 1680 ça fait baisser les fps vers les 25 et ce n'est plus suffisamment jouable. Pour ce qui est des fps c'est normal, le jeu est normalement prévu pour les bloquer à  30, mais sous linux ça oscille. Il existe une commande pour les débloquer, mais je ne vois vraiment pas de quoi tu t'inquiètes si le jeu est suffisamment fluide et qu'il répond bien.

Oui j'ai déjà  débloqué les fps pour essayer d'atteindre les 60, mais rien n'y fait, même en low bien tuné.

En fait ça oscille entre 30 et 50 tant que je me ballade, mais dès que ça fight un peu ça baisse et c'est très saccadé, autant en 800x600 qu'en 1680x1050, c'est vraiment étrange.

Je sais que j'ai une petite config (AMD64 3500+, 1Go DDR, 7600 GT), mais au moins les perfs devraient être différentes entre ces 2 résolutions non ?

#136 Le 13/11/2007, à 00:30

pop2010

Re : Enemy Territory : Quake Wars

Oui a priori il devrait y avoir une différence. C'est difficile à  dire vraiment car de mon cà´té je suis bridé par la mémoire de la carte graphique qui a une trop petite bande passante, du coup augmenter la résolution se ressent. Le fait que les performances ne change pas chez toi à  mon avis est plutà´t significatif d'un bridage cà´té processeur, mais c'est contradictoire avec le fait qu'il ne tourne jamais à  fond.

Hors ligne

#137 Le 13/11/2007, à 01:43

Lord Northam

Re : Enemy Territory : Quake Wars

ErickH a écrit :

J'ai regardé dans mes fichiers de config sous .etqwcl (j'ai pas de .etqw) et je ne vois pas ce qui pourrais clocher dans ces fichiers.... Les fichiers de configurations ressemblent à  ceux sur les sites ETQW...

Pour info : /.etqw = démo et /.etqwcl = jeu complet

Ensuite dans le script/raccourcis, on peut lui indiquer de charger automatiquement notre profile en ajoutant l'option suivante :
./etqw.x86 +set net_accountName NomDuProfile

Pour la console j'ai essayé divers bind "'" "toggleconsole" mais rien ne fonctionne (en restant en clavier BE)

Hors ligne

#138 Le 13/11/2007, à 10:53

mangoo

Re : Enemy Territory : Quake Wars

je rencontre un décalage de l'ecran et il ne veux pas changer ma résolution  et la prise en charge de l'antialiasing déconne, j'ai une 6800 avec 256 DDR 3 sur une X2 4800 avec 2 Go de DDR en dual

#139 Le 28/01/2008, à 23:47

forficule

Re : Enemy Territory : Quake Wars

Bonjour à  tous... Juste une petite question en passant, comment faites-vous pour avoir les fps pendant le jeu ?
Je suis en clavier français, donc j'ai pas la console facilement... y a moyen de mettre la commande dans un autoexe.cfg ?
merci.
J'édite, je joue aussi à  quake et et de temps à  autre et pour le clavier y avait ça qu'était pas mal, c'est adapté pour marcher avec etqw...

#!/bin/sh
cd `dirname $0`
export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:."
#charge le fichier kdb
xmodmap ./kdb_etqw
#lance le jeu
exec ./etqw.x86 "$@"
#revient au clavier francais
setxkbmap fr

à  mettre dans le fichier etqw qui se trouve dans le répertoire du jeu...
En cas de soucis avec le clavier (genre la touche 2 qui ne veut pas faire é... sad) au retour sur votre bureau, vous pouvez lancer setxkbmap fr dans un terminal, ça règle tout... Par contre toujours pas de console avec ² ? j'ai cru comprendre qu'il fallait faire une combi ctrl+alt+² ? Et dans la console, si j'arrive à  l'avoir... je tape quoi pour voir les fps ? merci...

Dernière modification par forficule (Le 29/01/2008, à 22:31)

Hors ligne

#140 Le 06/02/2010, à 21:07

NaKroTeK

Re : Enemy Territory : Quake Wars

Yop Yop !!

Bon je poste sans grand espoir de réponse,
Au pire j'irai voir ailleurs

J'ai un souci sur ETQW,
je viens de l'acheter l'install se passe bien...

MAIS !!!
Pendant les phases de jeu en ligne ou non,
Lorsque j'appuie sur une touche quelconque(souvent non assigné a une action) le jeu plante en affichant
"erreur de segmentation"

et me renvoie sur le bureau que le clavier soit en français ou en anglais !
avec ou sans l'utilisation des script qui bloquent compiz.

Une idée? la je bloque a mort !

je suis sous karmic et j'utilise une nvidia8600 512 mo

voila
bonne soirée !

Hors ligne

#141 Le 07/02/2010, à 08:41

forficule

Re : Enemy Territory : Quake Wars

Bon, d'abord les vérif d'usage :
glxinfo | grep rendering dans un terminal doit retourner direct rendering yes.
Ensuite il faut vérifier les pilotes proprios de la carte 3d avec le menu  système > administration > pilotes de périphériques. Normalement tu dois voir ton driver proprio nvidia en vert dedans (chez moi c'est la version 185, je ne sais pas trop si c'est à jour...)
Quand tout ça est ok, d'autres plus costaud pourront sans doute t'aider.

Hors ligne

#142 Le 08/02/2010, à 02:02

NaKroTeK

Re : Enemy Territory : Quake Wars

J'ai bien un

direct rendering: Yes

est tout est bon du coté des drivers !!

Néanmoins après moult  exploration j'ai vu que
seul les touches étant non assigné dans les paramètres à une action dans le jeu
réponde à une "erreur de segmentation" en soit ça paraît bien logique.....
Une solution possible serait de crée une valeur "null" sur les touches ayant aucun assignement.

N.B : ce qui est bizarre c'est que l'erreur ne se produit pas sur la démo...

Hors ligne

#143 Le 08/02/2010, à 02:08

NaKroTeK

Re : Enemy Territory : Quake Wars

Rectification

Il y a erreur quand je demande le "fireteam chat" !

Dernière modification par NaKroTeK (Le 08/02/2010, à 02:44)

Hors ligne

#144 Le 08/02/2010, à 02:43

NaKroTeK

Re : Enemy Territory : Quake Wars

Bon ben finalment la lumière fut !!

Chose qui a mon avis n'est pas nouvelle,
Le système son linux (pulseaudio et ou alsa)
ne gère pas le voip du logiciel (chez moi en tout cas)

2 solutions :
*Soit rendre non assigné sur toutes les commandes pour le chat vocal

*Soit rentré la valeur 1 à la ligne 143 du fichier de conf (no_mic)
qui est dans :

/home/[user]/.etqwcl/base/etqwconfig.cfg

La seconde me parait plus propre.

Pour la suite des activité il semble que l'on peut définir manuellement le driver à utiliser un peu plus bas dans le fichier de config.

Je ne connais pas l'adresse sous alsa des entrées (encore moins avec pulseaudio)
Si certains sont branchés la dessus ! faites signe ! a savoir que le jeu rentre comme sortie sous alsa: /dev/dsp (ce n'est pas la même sous oss?)

N.B: mon écran gère pas le jeu au delà de 1024x768 or il peu monter a 1360x768 mais à cette résolution, l'image est décalé...

Hors ligne

#145 Le 08/02/2010, à 09:35

forficule

Re : Enemy Territory : Quake Wars

Pour le voip par-dessus un jeu mumble marche très bien (mieux que teamspeak pour mon expérience perso : multi starcraft winxp (eux) ubuntu (moi), y a peut-être même eu un mac...) Bref pas de soucis pulse/mumble, c'est dans les dépôts, et c'est multiplateforme wink

Hors ligne

#146 Le 05/05/2010, à 21:20

sabjiseq

Re : Enemy Territory : Quake Wars

Yop !

J'ai un petit problème...
Je voulais tester le jeu, j'ai donc téléchargé la demo et je l'ai installé. Le jeu en lui même marche bien j'ai juste un problème de son.

En effet j'ai l'impression que le son que j'entend correspond à celui d'un autre joueur.

Personnelement il n'y a pas de son lorsque je tir ou que je conduit un véhicule (peut importe ce que je fait).
J'entend par contre les bruitage d'un autre joueur...( qu'il tiren qu'il marche ou qu'il conduise un vehicule etc ...)

Je sais pas si j'arrive à me faire comprendre ... hmm Pour essayer de faire simple j'ai l'image, mais le son vient d'une autre chaine ... sad

Bref si une personne à compris est-ce qu'elle aurait une idée d'où ça peut venir ? neutral

Hors ligne

#147 Le 31/10/2010, à 13:49

casselinux

Re : Enemy Territory : Quake Wars

sabjiseq a écrit :

Yop !

J'ai un petit problème...
Je voulais tester le jeu, j'ai donc téléchargé la demo et je l'ai installé. Le jeu en lui même marche bien j'ai juste un problème de son.

En effet j'ai l'impression que le son que j'entend correspond à celui d'un autre joueur.

Personnelement il n'y a pas de son lorsque je tir ou que je conduit un véhicule (peut importe ce que je fait).
J'entend par contre les bruitage d'un autre joueur...( qu'il tiren qu'il marche ou qu'il conduise un vehicule etc ...)

Je sais pas si j'arrive à me faire comprendre ... hmm Pour essayer de faire simple j'ai l'image, mais le son vient d'une autre chaine ... sad

Bref si une personne à compris est-ce qu'elle aurait une idée d'où ça peut venir ? neutral

J'ai exactement le même problème que toi! Au fait, ce n'est pas le son d'un autre joueur, c'est bien toi, le soucis c'est que le son arrive au moins 20 secondes après ton action, bien sur 20 sec ce n'est qu'une estimation mais c'est quasiment ça.
PS: C'est bien la demo que je jou mais ce bug ne me donne franchement pas envi de l'acheter :s

Je cherche encore pourquoi ça bug comme ça, Alsa qui merdouille? Ou un bug propre à la demo (corrigé sur la version achetable via un patch)?


Utilisateur d'Ubuntu depuis 2008, partisan du libre mais anti-extrémiste... Bein quoi? Je n'aime pas les sectes... :paf:
Blog de Claqueur - Le blog qui donne des claques! :3

Hors ligne

#148 Le 01/11/2010, à 12:26

sabjiseq

Re : Enemy Territory : Quake Wars

Effectivement, le décalage est tellement important que j'ai cru que le son ne venait pas de moi. J'avais finalement acheté le jeu complet (vu le prix ridicule) pour tester mais le problème est le même comme je m'y attendais... Je joue donc sur windows mais j'aimerai bien pouvoir le faire fonctionner correctement sous ubuntu (10.10).

J'ai également essayé de corriger le problème en appliquant la méthode donnée dans la doc ubuntu pour les versions 64 bits (bien que je fonctionne en 32bits). A savoir mettre la ligne seta s_driver "pulseaudio" dans un autoexec.cfg. Mais là j'ai plus de son du tout.

voir : http://doc.ubuntu-fr.org/quake_wars

En bref après avoir cherché des solutions toute une après-midi jai abandonné... J'ai lu quelque chose comme quoi ça pourrai venir d'un problème dans les paramétrages de la carte son, il faudrai l'utiliser en full duplex ou quelque chose comme ça. Mais j'ai pas trouvé l'option pour ma carte.

Hors ligne

#149 Le 01/11/2010, à 16:32

casselinux

Re : Enemy Territory : Quake Wars

Je me suis commandé le jeu sur Amazon... Euh, je vais être comme déçu!
Je pensais que c'étais un bug propre à demo du jeu... Et pourtant c'est le seul et unique jeu qui a un tel comportements sur mon PC!
Il a été codé avec les pieds ou quoi? yikes

Sinon comme ça tu a installé tous les patch?
http://www.clubic.com/patch-jeux-video- … -wars.html

Dernière modification par casselinux (Le 01/11/2010, à 16:33)


Utilisateur d'Ubuntu depuis 2008, partisan du libre mais anti-extrémiste... Bein quoi? Je n'aime pas les sectes... :paf:
Blog de Claqueur - Le blog qui donne des claques! :3

Hors ligne

#150 Le 01/11/2010, à 18:56

sabjiseq

Re : Enemy Territory : Quake Wars

J'ai pas l'impression que ce soit un problème qui concerne uniquement ce jeu... j'ai voulu tester "savage 2" la semaine dernière et j'ai été confronté au même problème...
Sinon par rapport aux patch il est vrai que je ne les ai pas appliqué... Mais ceux que tu télécharge depuis clubic sont des .exe et vont donc chercher à s'installer avec wine ... comment tu les installe sur linux ? il faut retélécharger un client comme pour installer le jeu ?

Hors ligne